Update to 3.18.0
- Backport a few upstream fixes - Rebase the translations
This commit is contained in:
parent
b9fd94585a
commit
feb88792ad
@ -0,0 +1,43 @@
|
||||
From ece6bbee10191c60674669c810915ae741ee6d7c Mon Sep 17 00:00:00 2001
|
||||
From: Christian Persch <chpe@gnome.org>
|
||||
Date: Sat, 19 Sep 2015 16:56:15 +0200
|
||||
Subject: [PATCH] notebook: Don't change show-tabs when going to empty notebook
|
||||
|
||||
The window will close anyway, so the change is unnecessary. This fixes
|
||||
a crash in terminal-window's show-tabs change handler.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=755240
|
||||
(cherry picked from commit 7b7c38d01b198c9e2b32e2e6161472178f7492fa)
|
||||
---
|
||||
src/terminal-notebook.c | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/terminal-notebook.c b/src/terminal-notebook.c
|
||||
index d6c9dd101c94..34236f9e7a43 100644
|
||||
--- a/src/terminal-notebook.c
|
||||
+++ b/src/terminal-notebook.c
|
||||
@@ -58,14 +58,20 @@ update_tab_visibility (TerminalNotebook *notebook,
|
||||
{
|
||||
TerminalNotebookPrivate *priv = notebook->priv;
|
||||
GtkNotebook *gtk_notebook = GTK_NOTEBOOK (notebook);
|
||||
+ int new_n_pages;
|
||||
gboolean show_tabs;
|
||||
|
||||
+ new_n_pages = gtk_notebook_get_n_pages (gtk_notebook) + change;
|
||||
+ /* Don't do anything if we're going to have zero pages (and thus close the window) */
|
||||
+ if (new_n_pages == 0)
|
||||
+ return;
|
||||
+
|
||||
switch (priv->policy) {
|
||||
case GTK_POLICY_ALWAYS:
|
||||
show_tabs = TRUE;
|
||||
break;
|
||||
case GTK_POLICY_AUTOMATIC:
|
||||
- show_tabs = (gtk_notebook_get_n_pages (gtk_notebook) + change) > 1;
|
||||
+ show_tabs = new_n_pages > 1;
|
||||
break;
|
||||
case GTK_POLICY_NEVER:
|
||||
#if GTK_CHECK_VERSION (3, 16, 0)
|
||||
--
|
||||
2.1.0
|
||||
|
@ -0,0 +1,62 @@
|
||||
From 44c6df308a2e5c331b44797c8537da430bb92df7 Mon Sep 17 00:00:00 2001
|
||||
From: Christian Persch <chpe@gnome.org>
|
||||
Date: Sat, 19 Sep 2015 16:58:34 +0200
|
||||
Subject: [PATCH] window: Exit early from screen-removed handler for now empty
|
||||
notebook
|
||||
|
||||
When the notebook is now empty, it's not necessary to change anything else
|
||||
since the window will be closed right away. Since GtkNotebook doesn't send
|
||||
the switch-page signal when removing the last and only screen in the notebook,
|
||||
priv->active_tab will point to an already freed object, which causes a
|
||||
crash when the window tries to update itself for the new active tab.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=755240
|
||||
(cherry picked from commit c8704ba3fef98d4acd59ec061566ff540b77c528)
|
||||
---
|
||||
src/terminal-window.c | 20 +++++++++++++++-----
|
||||
1 file changed, 15 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/terminal-window.c b/src/terminal-window.c
|
||||
index e065ac1de49d..91279663fb50 100644
|
||||
--- a/src/terminal-window.c
|
||||
+++ b/src/terminal-window.c
|
||||
@@ -3468,10 +3468,24 @@ mdi_screen_removed_cb (TerminalMdiContainer *container,
|
||||
G_CALLBACK (screen_close_cb),
|
||||
window);
|
||||
|
||||
+ /* We already got a switch-page signal whose handler sets the active tab to the
|
||||
+ * new active tab, unless this screen was the only one in the notebook, so
|
||||
+ * priv->active_tab is valid here.
|
||||
+ */
|
||||
+
|
||||
+ pages = terminal_mdi_container_get_n_screens (container);
|
||||
+ if (pages == 0)
|
||||
+ {
|
||||
+ priv->active_screen = NULL;
|
||||
+
|
||||
+ /* That was the last tab in the window; close it. */
|
||||
+ gtk_widget_destroy (GTK_WIDGET (window));
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
terminal_window_update_tabs_menu_sensitivity (window);
|
||||
terminal_window_update_search_sensitivity (screen, window);
|
||||
|
||||
- pages = terminal_mdi_container_get_n_screens (container);
|
||||
if (pages == 1)
|
||||
{
|
||||
TerminalScreen *active_screen = terminal_mdi_container_get_active_screen (container);
|
||||
@@ -3479,10 +3493,6 @@ mdi_screen_removed_cb (TerminalMdiContainer *container,
|
||||
|
||||
terminal_window_update_size (window);
|
||||
}
|
||||
- else if (pages == 0)
|
||||
- {
|
||||
- gtk_widget_destroy (GTK_WIDGET (window));
|
||||
- }
|
||||
}
|
||||
|
||||
gboolean
|
||||
--
|
||||
2.1.0
|
||||
|
@ -0,0 +1,39 @@
|
||||
From 448cb610ed7c9f243275050b4b3a530561f0f8ab Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Mon, 5 Oct 2015 20:13:05 +0200
|
||||
Subject: [PATCH] window: Pass tab switching keys to the terminal for tabless
|
||||
windows
|
||||
|
||||
This was removed as a side effect of
|
||||
a319aeb66f36e728af1b4929ddd69574df838702
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=730128
|
||||
---
|
||||
src/terminal-window.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/terminal-window.c b/src/terminal-window.c
|
||||
index 91279663fb50..618425c0e4d5 100644
|
||||
--- a/src/terminal-window.c
|
||||
+++ b/src/terminal-window.c
|
||||
@@ -1820,6 +1820,7 @@ static void
|
||||
terminal_window_update_tabs_menu_sensitivity (TerminalWindow *window)
|
||||
{
|
||||
TerminalWindowPrivate *priv = window->priv;
|
||||
+ GAction *gaction;
|
||||
GtkActionGroup *action_group = priv->action_group;
|
||||
GtkAction *action;
|
||||
int num_pages, page_num;
|
||||
@@ -1856,6 +1857,9 @@ terminal_window_update_tabs_menu_sensitivity (TerminalWindow *window)
|
||||
gtk_action_set_sensitive (action, not_last);
|
||||
#endif
|
||||
|
||||
+ gaction = g_action_map_lookup_action (G_ACTION_MAP (window), "switch-tab");
|
||||
+ g_simple_action_set_enabled (G_SIMPLE_ACTION (gaction), num_pages > 1);
|
||||
+
|
||||
action = gtk_action_group_get_action (action_group, "TabsMoveLeft");
|
||||
gtk_action_set_sensitive (action, not_first);
|
||||
action = gtk_action_group_get_action (action_group, "TabsMoveRight");
|
||||
--
|
||||
2.1.0
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 3f4b0ca3b72fbb495f684af0b03433e83dd0d847 Mon Sep 17 00:00:00 2001
|
||||
From 6794273920bc690c2403938c101d1ed2ae33359b Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Tue, 27 Jan 2015 18:40:13 +0100
|
||||
Subject: [PATCH 1/3] Support desktop notifications from OSC 777
|
||||
@ -320,7 +320,7 @@ index 20cfbceb36b0..a987025e0524 100644
|
||||
2.1.0
|
||||
|
||||
|
||||
From 4bf9c87627eca47b2c2721ea69bbec45e16a8040 Mon Sep 17 00:00:00 2001
|
||||
From 684f71a0548579304ec8283e17d073be243cba44 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Tue, 27 Jan 2015 19:04:19 +0100
|
||||
Subject: [PATCH 2/3] Make notifications based on org.gtk.Notification work
|
||||
@ -367,7 +367,7 @@ index f6f41a6e2c73..3aa8677ed587 100644
|
||||
@INTLTOOL_XML_RULE@
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f1bc9023eb1b..839a7347b3ff 100644
|
||||
index fcaf3df73ce7..0f04df152015 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -353,7 +353,7 @@ AC_DEFINE_UNQUOTED([GDK_VERSION_MAX_ALLOWED],[GDK_VERSION_[]AS_TR_SH([$GTK_MAX_A
|
||||
@ -553,7 +553,7 @@ index b6506f299f1d..1b9f81c10fcf 100644
|
||||
2.1.0
|
||||
|
||||
|
||||
From 28838b7ba5da1f5ee9f7f60d4f604a74cc273506 Mon Sep 17 00:00:00 2001
|
||||
From ac22ab8ab4d12d051f0e371c8a405d7568db50dd Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Thu, 29 Jan 2015 11:47:21 +0100
|
||||
Subject: [PATCH 3/3] Sprinkle debug messages for notifications
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a63d59c288545a8199334e78f1ed1e99d9c58d57 Mon Sep 17 00:00:00 2001
|
||||
From 0a97a742fc4153caa76548e075cb731e96376a67 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Mon, 12 May 2014 14:57:18 +0200
|
||||
Subject: [PATCH 1/5] Restore transparency
|
||||
@ -269,7 +269,7 @@ index e065ac1de49d..a146a62fb098 100644
|
||||
2.1.0
|
||||
|
||||
|
||||
From 3343f7710e0cdbb6c5b8fbed5316e176becb09e8 Mon Sep 17 00:00:00 2001
|
||||
From 9461b958aaf6bf40afa389850fc56cd087320a43 Mon Sep 17 00:00:00 2001
|
||||
From: Lars Uebernickel <lars.uebernickel@canonical.com>
|
||||
Date: Wed, 28 May 2014 14:11:02 +0200
|
||||
Subject: [PATCH 2/5] window: Make the drawing robust across all themes
|
||||
@ -331,7 +331,7 @@ index a146a62fb098..5117c06653c0 100644
|
||||
2.1.0
|
||||
|
||||
|
||||
From 7e4d713503e5105a4bb8149c5e73a444b5726303 Mon Sep 17 00:00:00 2001
|
||||
From c1efbc4c8a1d018f3724a2ca494ea5b543130612 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Tue, 17 Feb 2015 13:22:11 +0100
|
||||
Subject: [PATCH 3/5] Revert "prefs: Remove dark theme pref"
|
||||
@ -453,7 +453,7 @@ index e35990d728dc..d4f44d2f538e 100644
|
||||
2.1.0
|
||||
|
||||
|
||||
From b68a180427249e040ec1ced6461b5ce5dfab5d04 Mon Sep 17 00:00:00 2001
|
||||
From 4e92b51530a182aaf87a7b3ca8e1292078c86093 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Tue, 17 Feb 2015 13:22:21 +0100
|
||||
Subject: [PATCH 4/5] Revert "help: Remove dark theme pref"
|
||||
@ -528,7 +528,7 @@ index e3ca62732cf6..4bacc91265de 100644
|
||||
2.1.0
|
||||
|
||||
|
||||
From 46fee8a5c659a36867cd97c80de9d4a257ed5c6b Mon Sep 17 00:00:00 2001
|
||||
From 59a5e9751c868bfedd1ca19994760d3cf3768487 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Tue, 17 Feb 2015 17:06:17 +0100
|
||||
Subject: [PATCH 5/5] Restore translations for dark terminals and transparency
|
||||
@ -580,7 +580,7 @@ Subject: [PATCH 5/5] Restore translations for dark terminals and transparency
|
||||
po/ko.po | 11 +++++++----
|
||||
po/ku.po | 4 ++--
|
||||
po/lt.po | 11 +++++++----
|
||||
po/lv.po | 4 ++--
|
||||
po/lv.po | 3 +++
|
||||
po/mai.po | 4 ++--
|
||||
po/mg.po | 4 ++--
|
||||
po/mk.po | 4 ++--
|
||||
@ -623,7 +623,7 @@ Subject: [PATCH 5/5] Restore translations for dark terminals and transparency
|
||||
po/zh_CN.po | 11 +++++++----
|
||||
po/zh_HK.po | 3 +++
|
||||
po/zh_TW.po | 11 +++++++----
|
||||
89 files changed, 327 insertions(+), 216 deletions(-)
|
||||
89 files changed, 328 insertions(+), 214 deletions(-)
|
||||
|
||||
diff --git a/po/am.po b/po/am.po
|
||||
index 27a7e9640668..04a8ad9f36a3 100644
|
||||
@ -838,10 +838,10 @@ index 0739e201f83b..8b1ff006857a 100644
|
||||
#: ../src/profile-preferences.glade.h:74
|
||||
msgid "_Update login records when command is launched"
|
||||
diff --git a/po/da.po b/po/da.po
|
||||
index 74b7d0beee7d..ec1b391c2a7a 100644
|
||||
index f420e1cdbbff..217b176092a9 100644
|
||||
--- a/po/da.po
|
||||
+++ b/po/da.po
|
||||
@@ -2083,11 +2083,11 @@ msgstr "_Luk vindue"
|
||||
@@ -2094,11 +2094,11 @@ msgstr "_Luk vindue"
|
||||
#~ msgid "Missing command"
|
||||
#~ msgstr "Manglende kommando"
|
||||
|
||||
@ -857,7 +857,7 @@ index 74b7d0beee7d..ec1b391c2a7a 100644
|
||||
|
||||
#~ msgid "COMMAND"
|
||||
#~ msgstr "KOMMANDO"
|
||||
@@ -2987,8 +2987,8 @@ msgstr "_Luk vindue"
|
||||
@@ -2999,8 +2999,8 @@ msgstr "_Luk vindue"
|
||||
#~ msgid "_Solid color"
|
||||
#~ msgstr "_Ensfarvet"
|
||||
|
||||
@ -869,10 +869,10 @@ index 74b7d0beee7d..ec1b391c2a7a 100644
|
||||
#~ msgid ""
|
||||
#~ "You already have a profile called “%s”. Do you want to create another "
|
||||
diff --git a/po/de.po b/po/de.po
|
||||
index 0d46e223c669..4101ba2c6eef 100644
|
||||
index 7fbad63bb009..9d376b53eec9 100644
|
||||
--- a/po/de.po
|
||||
+++ b/po/de.po
|
||||
@@ -2125,11 +2125,11 @@ msgstr "Fenster _schließen"
|
||||
@@ -2134,11 +2134,11 @@ msgstr "Fenster _schließen"
|
||||
#~ msgid "Missing command"
|
||||
#~ msgstr "Fehlender Befehl"
|
||||
|
||||
@ -888,7 +888,7 @@ index 0d46e223c669..4101ba2c6eef 100644
|
||||
|
||||
#~ msgid "Set the terminal title"
|
||||
#~ msgstr "Den Titel des Terminals festlegen"
|
||||
@@ -3057,8 +3057,8 @@ msgstr "Fenster _schließen"
|
||||
@@ -3066,8 +3066,8 @@ msgstr "Fenster _schließen"
|
||||
#~ msgid "Background image _scrolls"
|
||||
#~ msgstr "Hintergrundbild _folgt Bildlauf"
|
||||
|
||||
@ -915,10 +915,10 @@ index ecb8fd59329c..290934ad3e0f 100644
|
||||
#: ../src/profile-preferences.glade.h:78
|
||||
#, fuzzy
|
||||
diff --git a/po/el.po b/po/el.po
|
||||
index b81802c913a5..573a99bb52ef 100644
|
||||
index 587527cb7a99..b0dbdd2a60a7 100644
|
||||
--- a/po/el.po
|
||||
+++ b/po/el.po
|
||||
@@ -2121,11 +2121,11 @@ msgstr "Κ_λείσιμο παραθύρου"
|
||||
@@ -2128,11 +2128,11 @@ msgstr "Κ_λείσιμο παραθύρου"
|
||||
#~ msgid "Missing command"
|
||||
#~ msgstr "Λείπει εντολή"
|
||||
|
||||
@ -934,7 +934,7 @@ index b81802c913a5..573a99bb52ef 100644
|
||||
|
||||
#~ msgid "_Use the system fixed width font"
|
||||
#~ msgstr "_Χρήση της γραμματοσειράς σταθερού πλάτους του συστήματος"
|
||||
@@ -2289,3 +2289,6 @@ msgstr "Κ_λείσιμο παραθύρου"
|
||||
@@ -2296,3 +2296,6 @@ msgstr "Κ_λείσιμο παραθύρου"
|
||||
|
||||
#~ msgid "_Input Methods"
|
||||
#~ msgstr "_Μέθοδοι εισαγωγής"
|
||||
@ -1060,13 +1060,13 @@ index 97bb9762528f..9e32fb740c57 100644
|
||||
#~ msgid ""
|
||||
#~ "You already have a profile called “%s”. Do you want to create another "
|
||||
diff --git a/po/fa.po b/po/fa.po
|
||||
index 2090863eddaf..b9a05af5c969 100644
|
||||
index 882aae98a939..93007dc7450c 100644
|
||||
--- a/po/fa.po
|
||||
+++ b/po/fa.po
|
||||
@@ -2027,3 +2027,6 @@ msgstr "ذخیره به نام..."
|
||||
#: ../src/terminal-window.c:3456
|
||||
msgid "_Title:"
|
||||
msgstr "_عنوان:"
|
||||
@@ -2239,3 +2239,6 @@ msgstr "_بستن پنجره"
|
||||
|
||||
#~ msgid "_Title:"
|
||||
#~ msgstr "_عنوان:"
|
||||
+
|
||||
+msgid "Transparent background"
|
||||
+msgstr "پسزمینهی شفاف"
|
||||
@ -1163,10 +1163,10 @@ index 04a76e1de96a..4af1d80ececc 100644
|
||||
+msgid "Use _dark theme variant"
|
||||
+msgstr "Cleachd tionndadh _dorcha dhen ùrlar"
|
||||
diff --git a/po/gl.po b/po/gl.po
|
||||
index 1429c66bcaa5..584072278739 100644
|
||||
index ad9af1ba5ddc..bdbfa91fcf13 100644
|
||||
--- a/po/gl.po
|
||||
+++ b/po/gl.po
|
||||
@@ -2101,11 +2101,11 @@ msgstr "P_echar a xanela"
|
||||
@@ -2106,11 +2106,11 @@ msgstr "P_echar a xanela"
|
||||
#~ msgid "Missing command"
|
||||
#~ msgstr "Falta a orde"
|
||||
|
||||
@ -1182,7 +1182,7 @@ index 1429c66bcaa5..584072278739 100644
|
||||
|
||||
#~ msgid "_Use the system fixed width font"
|
||||
#~ msgstr "_Usar o tipo de letra de largura fixa do sistema"
|
||||
@@ -3055,8 +3055,8 @@ msgstr "P_echar a xanela"
|
||||
@@ -3060,8 +3060,8 @@ msgstr "P_echar a xanela"
|
||||
#~ msgid "Background image _scrolls"
|
||||
#~ msgstr "A imaxe de fondo _desprázase"
|
||||
|
||||
@ -1312,35 +1312,35 @@ index 558490157ada..caadbba37c5d 100644
|
||||
#: ../src/profile-preferences.glade.h:74
|
||||
msgid "_Update login records when command is launched"
|
||||
diff --git a/po/id.po b/po/id.po
|
||||
index 346b5d815552..244844430503 100644
|
||||
index 595a325a574d..99c29b6d855b 100644
|
||||
--- a/po/id.po
|
||||
+++ b/po/id.po
|
||||
@@ -2068,3 +2068,6 @@ msgstr ""
|
||||
#: ../src/terminal-window.c:3652
|
||||
@@ -2058,3 +2058,6 @@ msgstr ""
|
||||
#: ../src/terminal-window.c:3694
|
||||
msgid "C_lose Window"
|
||||
msgstr "Tutup Jende_la"
|
||||
+
|
||||
+msgid "Transparent background"
|
||||
+msgstr "Latar belakang transparan"
|
||||
diff --git a/po/it.po b/po/it.po
|
||||
index 5a1847f3a108..2eb1d621e662 100644
|
||||
index 491303dfe349..af13ad9ca310 100644
|
||||
--- a/po/it.po
|
||||
+++ b/po/it.po
|
||||
@@ -2093,3 +2093,6 @@ msgstr ""
|
||||
#: ../src/terminal-window.c:3652
|
||||
msgid "C_lose Window"
|
||||
msgstr "Chiudi _finestra"
|
||||
@@ -2105,3 +2105,6 @@ msgstr "Chiudi _finestra"
|
||||
|
||||
#~ msgid "_Update login records when command is launched"
|
||||
#~ msgstr "_Aggiornare i record di login quando il comando viene eseguito"
|
||||
+
|
||||
+msgid "Transparent background"
|
||||
+msgstr "Sfondo trasparente"
|
||||
diff --git a/po/ja.po b/po/ja.po
|
||||
index 4f8f4dec0bb0..ce2ec952ca76 100644
|
||||
index f7235d9f4a0b..63d7fd7bb943 100644
|
||||
--- a/po/ja.po
|
||||
+++ b/po/ja.po
|
||||
@@ -1902,3 +1902,6 @@ msgstr "この端末には未だ実行中のプロセスが存在しています
|
||||
#: ../src/terminal-window.c:3652
|
||||
msgid "C_lose Window"
|
||||
msgstr "ウィンドウを閉じる(_L)"
|
||||
@@ -1907,3 +1907,6 @@ msgstr "ウィンドウを閉じる(_L)"
|
||||
|
||||
#~ msgid "_Update login records when command is launched"
|
||||
#~ msgstr "コマンドを実行した時にログイン記録を更新する(_U)"
|
||||
+
|
||||
+msgid "Transparent background"
|
||||
+msgstr "透過な画像にする"
|
||||
@ -1358,10 +1358,10 @@ index 8415e88f94ff..3717b7e75dcd 100644
|
||||
|
||||
#: ../src/gnome-terminal.glade2.h:87
|
||||
diff --git a/po/kk.po b/po/kk.po
|
||||
index dba7503c4286..2961b87f3b2a 100644
|
||||
index ed86f1b70460..639411cfce86 100644
|
||||
--- a/po/kk.po
|
||||
+++ b/po/kk.po
|
||||
@@ -2019,14 +2019,17 @@ msgstr "Терезені жа_бу"
|
||||
@@ -2024,14 +2024,17 @@ msgstr "Терезені жа_бу"
|
||||
#~ msgid "Missing command"
|
||||
#~ msgstr "Команда жоқ болып тұр"
|
||||
|
||||
@ -1395,10 +1395,10 @@ index c887f88a2c87..e899ef3ca8c1 100644
|
||||
+msgid "Transparent background"
|
||||
+msgstr "ಪಾರದರ್ಶಕ ಹಿನ್ನಲೆ"
|
||||
diff --git a/po/ko.po b/po/ko.po
|
||||
index 0700e25f9ec8..32914679e998 100644
|
||||
index 57c120389ac9..a41296a7fb0a 100644
|
||||
--- a/po/ko.po
|
||||
+++ b/po/ko.po
|
||||
@@ -2073,8 +2073,11 @@ msgstr "창 닫기(_L)"
|
||||
@@ -2079,8 +2079,11 @@ msgstr "창 닫기(_L)"
|
||||
#~ msgid "Missing command"
|
||||
#~ msgstr "명령어 없음"
|
||||
|
||||
@ -1430,10 +1430,10 @@ index 221825b29cd9..96e35811337b 100644
|
||||
#: ../src/gnome-terminal.glade2.h:87
|
||||
msgid "_Update login records when command is launched"
|
||||
diff --git a/po/lt.po b/po/lt.po
|
||||
index c906132e1a9e..dbe03e9abc8d 100644
|
||||
index 8c9c9e660d28..71411ab7cf5b 100644
|
||||
--- a/po/lt.po
|
||||
+++ b/po/lt.po
|
||||
@@ -2078,8 +2078,11 @@ msgstr "_Užverti langą"
|
||||
@@ -2085,8 +2085,11 @@ msgstr "_Užverti langą"
|
||||
#~ msgid "Missing command"
|
||||
#~ msgstr "Trūksta komandos"
|
||||
|
||||
@ -1450,20 +1450,16 @@ index c906132e1a9e..dbe03e9abc8d 100644
|
||||
+msgid "Transparent background"
|
||||
+msgstr "Permatomas fonas"
|
||||
diff --git a/po/lv.po b/po/lv.po
|
||||
index a50f529c31b8..b29541fceb45 100644
|
||||
index 80a13ab6cac9..0360452e7b61 100644
|
||||
--- a/po/lv.po
|
||||
+++ b/po/lv.po
|
||||
@@ -3016,8 +3016,8 @@ msgstr "Aizvērt _logu"
|
||||
#~ msgid "Background image _scrolls"
|
||||
#~ msgstr "Fona attēla ritināšanā_s"
|
||||
|
||||
-#~ msgid "_Transparent background"
|
||||
-#~ msgstr "_Caurspīdīgs fons"
|
||||
@@ -2048,3 +2048,6 @@ msgstr ""
|
||||
#: ../src/terminal-window.c:3694
|
||||
msgid "C_lose Window"
|
||||
msgstr "Aizvērt _logu"
|
||||
+
|
||||
+msgid "Transparent background"
|
||||
+msgstr "Caurspīdīgs fons"
|
||||
|
||||
#~ msgid "S_hade transparent or image background:"
|
||||
#~ msgstr "_Aizēnot caurspīdīgo vai attēla fonu:"
|
||||
diff --git a/po/mai.po b/po/mai.po
|
||||
index 9b984a068fda..a3c0e178ae67 100644
|
||||
--- a/po/mai.po
|
||||
@ -1698,10 +1694,10 @@ index 9c95b66e7185..5e5b8ba4f104 100644
|
||||
#~ msgid "S/Key Challenge Response"
|
||||
#~ msgstr "S/ਸਵਿੱਚ ਚੈਲੰਜ਼ ਜਵਾਬ"
|
||||
diff --git a/po/pl.po b/po/pl.po
|
||||
index deb91b7d10bc..f7721713a0ca 100644
|
||||
index 609ffc36b5a4..f50b535b80fd 100644
|
||||
--- a/po/pl.po
|
||||
+++ b/po/pl.po
|
||||
@@ -2116,3 +2116,6 @@ msgid ""
|
||||
@@ -2106,3 +2106,6 @@ msgid ""
|
||||
msgstr ""
|
||||
"Wartość między 0 a 100, gdzie 0 oznacza nieprzezroczystość, a 100 oznacza "
|
||||
"całkowitą przezroczystość."
|
||||
@ -1797,11 +1793,11 @@ index 179dd77fd166..f7fc7ae070cf 100644
|
||||
#: ../src/profile-preferences.glade.h:78
|
||||
msgid "_Underline color:"
|
||||
diff --git a/po/ru.po b/po/ru.po
|
||||
index cf87d021e781..7db31b8af3f1 100644
|
||||
index 1a6fbd95b4ba..4551e12f255b 100644
|
||||
--- a/po/ru.po
|
||||
+++ b/po/ru.po
|
||||
@@ -2056,3 +2056,6 @@ msgstr ""
|
||||
#: ../src/terminal-window.c:3656
|
||||
@@ -2065,3 +2065,6 @@ msgstr ""
|
||||
#: ../src/terminal-window.c:3694
|
||||
msgid "C_lose Window"
|
||||
msgstr "_Закрыть окно"
|
||||
+
|
||||
@ -1863,10 +1859,10 @@ index 3a8ede3b61f4..b9744bc7c14c 100644
|
||||
+msgid "Transparent background"
|
||||
+msgstr "Priehľadné pozadie"
|
||||
diff --git a/po/sl.po b/po/sl.po
|
||||
index 782fd76c3563..247b87b021e4 100644
|
||||
index 72baf7b1e8ad..d7ff33ccfe8e 100644
|
||||
--- a/po/sl.po
|
||||
+++ b/po/sl.po
|
||||
@@ -2058,11 +2058,11 @@ msgstr "_Zapri okno"
|
||||
@@ -2066,11 +2066,11 @@ msgstr "_Zapri okno"
|
||||
#~ msgid "Missing command"
|
||||
#~ msgstr "Manjka ukaz"
|
||||
|
||||
@ -1882,7 +1878,7 @@ index 782fd76c3563..247b87b021e4 100644
|
||||
|
||||
#~ msgid "Set the terminal title"
|
||||
#~ msgstr "Nastavi naziv terminala"
|
||||
@@ -2314,3 +2314,6 @@ msgstr "_Zapri okno"
|
||||
@@ -2322,3 +2322,6 @@ msgstr "_Zapri okno"
|
||||
|
||||
#~ msgid "_Profile Preferences…"
|
||||
#~ msgstr "Možnosti _profila ..."
|
||||
@ -1959,7 +1955,7 @@ index c82646ca4451..4ba3d9588643 100644
|
||||
+msgid "Transparent background"
|
||||
+msgstr "Providna pozadina"
|
||||
diff --git a/po/sv.po b/po/sv.po
|
||||
index ae8410940fce..eaae659d9ef3 100644
|
||||
index 745f7d985494..2cfce8bc6254 100644
|
||||
--- a/po/sv.po
|
||||
+++ b/po/sv.po
|
||||
@@ -2073,5 +2073,8 @@ msgstr "Stän_g fönster"
|
||||
@ -2053,11 +2049,11 @@ index f7a8d674657e..b0cc3a6014c2 100644
|
||||
#~ msgid ""
|
||||
#~ "You already have a profile called “%s”. Do you want to create another "
|
||||
diff --git a/po/tr.po b/po/tr.po
|
||||
index 02a704a93d49..78f26ba59dd7 100644
|
||||
index f7c68e62d9da..316587c0a7b2 100644
|
||||
--- a/po/tr.po
|
||||
+++ b/po/tr.po
|
||||
@@ -1968,3 +1968,6 @@ msgstr "Hala bir süreç bu uçbirimde çalışıyor. Uçbirimi kapatmak onu son
|
||||
#: ../src/terminal-window.c:3652
|
||||
@@ -1963,3 +1963,6 @@ msgstr "Hala bir süreç bu uçbirimde çalışıyor. Uçbirimi kapatmak onu son
|
||||
#: ../src/terminal-window.c:3694
|
||||
msgid "C_lose Window"
|
||||
msgstr "_Pencereyi Kapat"
|
||||
+
|
||||
@ -2205,10 +2201,10 @@ index eb0ede77e889..aceb184b2440 100644
|
||||
+msgid "Transparent background"
|
||||
+msgstr "透明背景"
|
||||
diff --git a/po/zh_TW.po b/po/zh_TW.po
|
||||
index a32a53906a99..5d0ffa77f19f 100644
|
||||
index 8326ad3b0171..a9062135a180 100644
|
||||
--- a/po/zh_TW.po
|
||||
+++ b/po/zh_TW.po
|
||||
@@ -2029,11 +2029,11 @@ msgstr "關閉視窗(_L)"
|
||||
@@ -2034,11 +2034,11 @@ msgstr "關閉視窗(_L)"
|
||||
#~ msgid "Missing command"
|
||||
#~ msgstr "遺失指令"
|
||||
|
||||
@ -2224,7 +2220,7 @@ index a32a53906a99..5d0ffa77f19f 100644
|
||||
|
||||
#~ msgid "_Use the system fixed width font"
|
||||
#~ msgstr "使用系統的固定寬度字型(_U)"
|
||||
@@ -2379,3 +2379,6 @@ msgstr "關閉視窗(_L)"
|
||||
@@ -2383,3 +2383,6 @@ msgstr "關閉視窗(_L)"
|
||||
|
||||
#~ msgid "Show session management options"
|
||||
#~ msgstr "顯示作業階段管理選項"
|
||||
|
@ -7,8 +7,8 @@
|
||||
|
||||
Summary: Terminal emulator for GNOME
|
||||
Name: gnome-terminal
|
||||
Version: 3.17.91
|
||||
Release: 2%{?dist}
|
||||
Version: 3.18.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+ and GFDL
|
||||
Group: User Interface/Desktops
|
||||
URL: http://www.gnome.org/
|
||||
@ -19,6 +19,12 @@ Source1: org.gnome.Terminal.gschema.override
|
||||
Patch0: 0001-build-Don-t-treat-warnings-as-errors.patch
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=755825
|
||||
Patch1: gnome-terminal-symbolic-new-tab-icon.patch
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=755240
|
||||
Patch2: 0001-notebook-Don-t-change-show-tabs-when-going-to-empty-.patch
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=755240
|
||||
Patch3: 0001-window-Exit-early-from-screen-removed-handler-for-no.patch
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=730128
|
||||
Patch4: 0001-window-Pass-tab-switching-keys-to-the-terminal-for-t.patch
|
||||
|
||||
Patch100: gnome-terminal-restore-dark-transparency.patch
|
||||
Patch101: gnome-terminal-command-notify.patch
|
||||
@ -64,6 +70,9 @@ option to the right-click context menu in Nautilus.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .warnings
|
||||
%patch1 -p1 -b .new-tab-icon
|
||||
%patch2 -p1 -b .dont-change-show-tabs
|
||||
%patch3 -p1 -b .exit-early-from-screen
|
||||
%patch4 -p1 -b .pass-tab-switching-keys
|
||||
%patch100 -p1 -b .dark-transparency
|
||||
%patch101 -p1 -b .command-notify
|
||||
|
||||
@ -111,6 +120,11 @@ fi
|
||||
%{_libdir}/nautilus/extensions-3.0/libterminal-nautilus.so
|
||||
|
||||
%changelog
|
||||
* Wed Oct 07 2015 Debarshi Ray <rishi@fedoraproject.org> - 3.18.0-1
|
||||
- Update to 3.18.0
|
||||
- Backport a few upstream fixes
|
||||
- Rebase the translations
|
||||
|
||||
* Thu Oct 01 2015 Michael Catanzaro <mcatanzaro@gnome.org> - 3.17.91-2
|
||||
- Use a symbolic new tab icon
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user