Dropped unused patches
This commit is contained in:
parent
72f3c05ab9
commit
ae165ef29d
@ -1,22 +0,0 @@
|
||||
Index: gnome-terminal-2.15.0/src/terminal-window.c
|
||||
===================================================================
|
||||
RCS file: /cvs/gnome/gnome-terminal/src/terminal-window.c,v
|
||||
retrieving revision 1.124
|
||||
diff -u -p -d -r1.124 terminal-window.c
|
||||
--- gnome-terminal-2.15.0/src/terminal-window.c 4 Mar 2006 06:21:01 -0000 1.124
|
||||
+++ gnome-terminal-2.15.0/src/terminal-window.c 1 Apr 2006 03:11:46 -0000
|
||||
@@ -1536,6 +1536,14 @@ terminal_window_set_size_force_grid (Ter
|
||||
app = gtk_widget_get_toplevel (widget);
|
||||
g_assert (app != NULL);
|
||||
|
||||
+ /* This set_size_request hack is because the extra size above base
|
||||
+ * size should only include the width of widgets that intersect the
|
||||
+ * term vertically and the height of widgets that intersect the term
|
||||
+ * horizontally. It works around a GTK bug, GTK should handle
|
||||
+ * this case. The size request can be huge without hosing
|
||||
+ * anything because we set the MIN_SIZE geometry hint.
|
||||
+ */
|
||||
+ gtk_widget_set_size_request (widget, 2000, 2000);
|
||||
gtk_widget_size_request (app, &toplevel_request);
|
||||
gtk_widget_size_request (widget, &widget_request);
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff -up gnome-terminal-2.33.3/configure.ac.builder gnome-terminal-2.33.3/configure.ac
|
||||
--- gnome-terminal-2.33.3/configure.ac.builder 2011-01-07 17:37:33.449993002 -0500
|
||||
+++ gnome-terminal-2.33.3/configure.ac 2011-01-07 17:37:49.942992152 -0500
|
||||
@@ -130,10 +130,7 @@ AC_SUBST([GLIB_GENMARSHAL])
|
||||
GLIB_MKENUMS="$($PKG_CONFIG --variable=glib_mkenums glib-2.0)"
|
||||
AC_SUBST([GLIB_MKENUMS])
|
||||
|
||||
-case "$with_gtk" in
|
||||
- 2.0) AC_PATH_PROG([GTK_BUILDER_CONVERT],[gtk-builder-convert],[false]) ;;
|
||||
- 3.0) AC_PATH_PROG([GTK_BUILDER_CONVERT],[gtk-builder-convert-3.0],[false]) ;;
|
||||
-esac
|
||||
+AC_PATH_PROG([GTK_BUILDER_CONVERT],[gtk-builder-convert],[false])
|
||||
|
||||
if test "$GTK_BUILDER_CONVERT" = "false"; then
|
||||
AC_MSG_ERROR([gtk-builder-convert not found])
|
@ -1,13 +0,0 @@
|
||||
diff -up gnome-terminal-2.33.3/src/Makefile.am.libs gnome-terminal-2.33.3/src/Makefile.am
|
||||
--- gnome-terminal-2.33.3/src/Makefile.am.libs 2011-01-07 22:19:10.168992663 -0500
|
||||
+++ gnome-terminal-2.33.3/src/Makefile.am 2011-01-07 22:19:47.375993276 -0500
|
||||
@@ -75,7 +75,8 @@ gnome_terminal_CFLAGS = \
|
||||
gnome_terminal_LDFLAGS =
|
||||
|
||||
gnome_terminal_LDADD = \
|
||||
- $(TERM_LIBS)
|
||||
+ $(TERM_LIBS) \
|
||||
+ -lX11
|
||||
|
||||
if WITH_SMCLIENT
|
||||
gnome_terminal_SOURCES += \
|
@ -1,12 +0,0 @@
|
||||
diff -up gnome-terminal-2.31.1/po/POTFILES.in.potfiles gnome-terminal-2.31.1/po/POTFILES.in
|
||||
--- gnome-terminal-2.31.1/po/POTFILES.in.potfiles 2010-05-04 00:41:15.490932905 -0400
|
||||
+++ gnome-terminal-2.31.1/po/POTFILES.in 2010-05-04 00:41:26.265182941 -0400
|
||||
@@ -17,8 +17,6 @@ src/terminal-accels.c
|
||||
src/terminal-app.c
|
||||
src/terminal.c
|
||||
src/terminal-encoding.c
|
||||
-src/terminal-find.c
|
||||
-src/terminal-find.glade
|
||||
src/terminal-options.c
|
||||
src/terminal-profile.c
|
||||
src/terminal-screen.c
|
@ -15,8 +15,6 @@ Group: User Interface/Desktops
|
||||
URL: http://www.gnome.org/
|
||||
#VCS: git:git://git.gnome.org/gnome-terminal
|
||||
Source0: http://download.gnome.org/sources/gnome-terminal/3.4/gnome-terminal-%{version}.tar.xz
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=588732
|
||||
Source1: profile-new-dialog.ui
|
||||
|
||||
# gconftool-2
|
||||
Requires(pre): GConf2 >= %{gconf_version}
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up gnome-terminal-2.33.0/configure.ac.gtk3-build gnome-terminal-2.33.0/configure.ac
|
||||
--- gnome-terminal-2.33.0/configure.ac.gtk3-build 2010-10-07 13:02:12.307779002 -0400
|
||||
+++ gnome-terminal-2.33.0/configure.ac 2010-10-07 13:05:13.335779007 -0400
|
||||
@@ -129,7 +129,7 @@ AC_SUBST([GLIB_GENMARSHAL])
|
||||
GLIB_MKENUMS="$($PKG_CONFIG --variable=glib_mkenums glib-2.0)"
|
||||
AC_SUBST([GLIB_MKENUMS])
|
||||
|
||||
-AC_PATH_PROG([GTK_BUILDER_CONVERT],[gtk-builder-convert],[false])
|
||||
+AC_PATH_PROGS([GTK_BUILDER_CONVERT],[gtk-builder-convert] [gtk-builder-convert-3.0],[false])
|
||||
if test "$GTK_BUILDER_CONVERT" = "false"; then
|
||||
AC_MSG_ERROR([gtk-builder-convert not found])
|
||||
fi
|
@ -1,196 +0,0 @@
|
||||
<?xml version="1.0"?>
|
||||
<!--*- mode: xml -*-->
|
||||
<interface>
|
||||
<object class="GtkImage" id="icon-1212">
|
||||
<property name="visible">True</property>
|
||||
<property name="stock">gtk-apply</property>
|
||||
<property name="icon_size">4</property>
|
||||
<property name="xalign">0.5</property>
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
</object>
|
||||
<object class="GtkDialog" id="new-profile-dialog">
|
||||
<property name="border_width">5</property>
|
||||
<property name="title" translatable="yes">New Profile</property>
|
||||
<property name="type">GTK_WINDOW_TOPLEVEL</property>
|
||||
<property name="window_position">GTK_WIN_POS_NONE</property>
|
||||
<property name="modal">False</property>
|
||||
<property name="resizable">False</property>
|
||||
<property name="destroy_with_parent">False</property>
|
||||
<property name="decorated">True</property>
|
||||
<property name="skip_taskbar_hint">False</property>
|
||||
<property name="skip_pager_hint">False</property>
|
||||
<property name="type_hint">GDK_WINDOW_TYPE_HINT_DIALOG</property>
|
||||
<property name="gravity">GDK_GRAVITY_NORTH_WEST</property>
|
||||
<property name="focus_on_map">True</property>
|
||||
<property name="urgency_hint">False</property>
|
||||
<property name="has_separator">False</property>
|
||||
<child internal-child="vbox">
|
||||
<object class="GtkVBox" id="dialog-vbox5">
|
||||
<property name="visible">True</property>
|
||||
<property name="homogeneous">False</property>
|
||||
<property name="spacing">2</property>
|
||||
<child internal-child="action_area">
|
||||
<object class="GtkHButtonBox" id="dialog-action_area5">
|
||||
<property name="visible">True</property>
|
||||
<property name="layout_style">GTK_BUTTONBOX_END</property>
|
||||
<child>
|
||||
<object class="GtkButton" id="new-profile-cancel-button">
|
||||
<property name="visible">True</property>
|
||||
<property name="can_default">True</property>
|
||||
<property name="can_focus">True</property>
|
||||
<property name="label">gtk-cancel</property>
|
||||
<property name="use_stock">True</property>
|
||||
<property name="relief">GTK_RELIEF_NORMAL</property>
|
||||
<property name="focus_on_click">True</property>
|
||||
</object>
|
||||
</child>
|
||||
<child>
|
||||
<object class="GtkButton" id="new-profile-create-button">
|
||||
<property name="visible">True</property>
|
||||
<property name="sensitive">False</property>
|
||||
<property name="image">icon-1212</property>
|
||||
<property name="label" translatable="yes">C_reate</property>
|
||||
<property name="use_underline">True</property>
|
||||
<property name="can_default">True</property>
|
||||
<property name="can_focus">True</property>
|
||||
<property name="relief">GTK_RELIEF_NORMAL</property>
|
||||
<property name="focus_on_click">True</property>
|
||||
</object>
|
||||
</child>
|
||||
</object>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
<property name="expand">False</property>
|
||||
<property name="fill">True</property>
|
||||
<property name="pack_type">GTK_PACK_END</property>
|
||||
</packing>
|
||||
</child>
|
||||
<child>
|
||||
<object class="GtkVBox" id="vbox7">
|
||||
<property name="border_width">5</property>
|
||||
<property name="visible">True</property>
|
||||
<property name="homogeneous">False</property>
|
||||
<property name="spacing">0</property>
|
||||
<child>
|
||||
<object class="GtkTable" id="new-profile-table">
|
||||
<property name="visible">True</property>
|
||||
<property name="n_rows">2</property>
|
||||
<property name="n_columns">2</property>
|
||||
<property name="homogeneous">False</property>
|
||||
<property name="row_spacing">6</property>
|
||||
<property name="column_spacing">12</property>
|
||||
<child>
|
||||
<object class="GtkVBox" id="vbox77">
|
||||
<property name="visible">True</property>
|
||||
<property name="homogeneous">False</property>
|
||||
<property name="spacing">6</property>
|
||||
<child>
|
||||
<placeholder/>
|
||||
</child>
|
||||
</object>
|
||||
<packing>
|
||||
<property name="left_attach">1</property>
|
||||
<property name="right_attach">2</property>
|
||||
<property name="top_attach">1</property>
|
||||
<property name="bottom_attach">2</property>
|
||||
</packing>
|
||||
</child>
|
||||
<child>
|
||||
<object class="GtkLabel" id="new-profile-name-label">
|
||||
<property name="visible">True</property>
|
||||
<property name="label" translatable="yes">Profile _name:</property>
|
||||
<property name="use_underline">True</property>
|
||||
<property name="use_markup">False</property>
|
||||
<property name="justify">GTK_JUSTIFY_LEFT</property>
|
||||
<property name="wrap">False</property>
|
||||
<property name="selectable">False</property>
|
||||
<property name="xalign">0</property>
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
<property name="mnemonic_widget">new-profile-name-entry</property>
|
||||
<property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
<property name="width_chars">-1</property>
|
||||
<property name="single_line_mode">False</property>
|
||||
<property name="angle">0</property>
|
||||
</object>
|
||||
<packing>
|
||||
<property name="left_attach">0</property>
|
||||
<property name="right_attach">1</property>
|
||||
<property name="top_attach">0</property>
|
||||
<property name="bottom_attach">1</property>
|
||||
<property name="x_options">fill</property>
|
||||
<property name="y_options"/>
|
||||
</packing>
|
||||
</child>
|
||||
<child>
|
||||
<object class="GtkEntry" id="new-profile-name-entry">
|
||||
<property name="visible">True</property>
|
||||
<property name="can_focus">True</property>
|
||||
<property name="editable">True</property>
|
||||
<property name="visibility">True</property>
|
||||
<property name="max_length">0</property>
|
||||
<property name="text" translatable="yes"/>
|
||||
<property name="has_frame">True</property>
|
||||
<property name="activates_default">False</property>
|
||||
<property name="width_chars">14</property>
|
||||
</object>
|
||||
<packing>
|
||||
<property name="left_attach">1</property>
|
||||
<property name="right_attach">2</property>
|
||||
<property name="top_attach">0</property>
|
||||
<property name="bottom_attach">1</property>
|
||||
<property name="y_options"/>
|
||||
</packing>
|
||||
</child>
|
||||
<child>
|
||||
<object class="GtkLabel" id="new-profile-base-label">
|
||||
<property name="visible">True</property>
|
||||
<property name="label" translatable="yes">_Base on:</property>
|
||||
<property name="use_underline">True</property>
|
||||
<property name="use_markup">False</property>
|
||||
<property name="justify">GTK_JUSTIFY_LEFT</property>
|
||||
<property name="wrap">False</property>
|
||||
<property name="selectable">False</property>
|
||||
<property name="xalign">0</property>
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
<property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
<property name="width_chars">-1</property>
|
||||
<property name="single_line_mode">False</property>
|
||||
<property name="angle">0</property>
|
||||
</object>
|
||||
<packing>
|
||||
<property name="left_attach">0</property>
|
||||
<property name="right_attach">1</property>
|
||||
<property name="top_attach">1</property>
|
||||
<property name="bottom_attach">2</property>
|
||||
<property name="x_options">fill</property>
|
||||
<property name="y_options"/>
|
||||
</packing>
|
||||
</child>
|
||||
</object>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
<property name="expand">True</property>
|
||||
<property name="fill">True</property>
|
||||
</packing>
|
||||
</child>
|
||||
</object>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
<property name="expand">True</property>
|
||||
<property name="fill">True</property>
|
||||
</packing>
|
||||
</child>
|
||||
</object>
|
||||
</child>
|
||||
<action-widgets>
|
||||
<action-widget response="-6">new-profile-cancel-button</action-widget>
|
||||
<action-widget response="-3">new-profile-create-button</action-widget>
|
||||
</action-widgets>
|
||||
</object>
|
||||
</interface>
|
@ -1,16 +0,0 @@
|
||||
diff --git a/src/terminal-search-dialog.c b/src/terminal-search-dialog.c
|
||||
index 81e3317..e299ae9 100644
|
||||
--- a/src/terminal-search-dialog.c
|
||||
+++ b/src/terminal-search-dialog.c
|
||||
@@ -108,7 +108,11 @@ terminal_search_dialog_new (GtkWindow *parent)
|
||||
priv->store = store = gtk_list_store_new (1, G_TYPE_STRING);
|
||||
g_object_set (G_OBJECT (priv->search_entry),
|
||||
"model", store,
|
||||
+#if GTK_CHECK_VERSION (2, 91, 0)
|
||||
+ "entry-text-column", 0,
|
||||
+#else
|
||||
"text-column", 0,
|
||||
+#endif
|
||||
NULL);
|
||||
|
||||
priv->completion = completion = gtk_entry_completion_new ();
|
Loading…
Reference in New Issue
Block a user