import gnome-terminal-3.28.3-2.el8
This commit is contained in:
parent
87224958b9
commit
723b586eb3
470
SOURCES/0001-Add-a-manual.patch
Normal file
470
SOURCES/0001-Add-a-manual.patch
Normal file
@ -0,0 +1,470 @@
|
|||||||
|
From 33c56bac4d5592e845a824f3273de5af5eee0ae4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Debarshi Ray <debarshir@gnome.org>
|
||||||
|
Date: Wed, 17 Jun 2020 12:59:48 +0200
|
||||||
|
Subject: [PATCH] Add a manual
|
||||||
|
|
||||||
|
https://gitlab.gnome.org/GNOME/gnome-terminal/-/issues/277
|
||||||
|
---
|
||||||
|
Makefile.am | 2 +-
|
||||||
|
configure.ac | 9 +
|
||||||
|
man/Makefile.am | 18 ++
|
||||||
|
man/gnome-terminal.xml | 385 +++++++++++++++++++++++++++++++++++++++++
|
||||||
|
4 files changed, 413 insertions(+), 1 deletion(-)
|
||||||
|
create mode 100644 man/Makefile.am
|
||||||
|
create mode 100644 man/gnome-terminal.xml
|
||||||
|
|
||||||
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
|
index 14b59bac43b9..52dd7265d715 100644
|
||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-SUBDIRS = src po help
|
||||||
|
+SUBDIRS = man src po help
|
||||||
|
|
||||||
|
NULL =
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index c5f40c07884a..00028858c654 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -192,6 +192,14 @@ if test -z "$DESKTOP_FILE_VALIDATE"; then
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
|
||||||
|
+AC_ARG_VAR([XSLTPROC],[the xsltproc programme])
|
||||||
|
+if test -z "$XSLTPROC"; then
|
||||||
|
+ AC_PATH_PROG([XSLTPROC],[xsltproc],[])
|
||||||
|
+ if test -z "$XSLTPROC"; then
|
||||||
|
+ AC_MSG_ERROR([xsltproc not found])
|
||||||
|
+ fi
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
# ***************************
|
||||||
|
# GNOME Shell search provider
|
||||||
|
# ***************************
|
||||||
|
@@ -327,6 +335,7 @@ AC_DEFINE_UNQUOTED([GDK_VERSION_MAX_ALLOWED],[G_ENCODE_VERSION($(echo $GTK_MAX_A
|
||||||
|
AC_CONFIG_FILES([
|
||||||
|
Makefile
|
||||||
|
org.gnome.Terminal.desktop.in
|
||||||
|
+man/Makefile
|
||||||
|
src/Makefile
|
||||||
|
src/terminal-version.h
|
||||||
|
help/Makefile
|
||||||
|
diff --git a/man/Makefile.am b/man/Makefile.am
|
||||||
|
new file mode 100644
|
||||||
|
index 000000000000..ecce224d455d
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/man/Makefile.am
|
||||||
|
@@ -0,0 +1,18 @@
|
||||||
|
+XSLTPROC_FLAGS = \
|
||||||
|
+ --nonet \
|
||||||
|
+ --stringparam man.output.quietly 1 \
|
||||||
|
+ --stringparam funcsynopsis.style ansi \
|
||||||
|
+ --stringparam man.authors.section.enabled 0 \
|
||||||
|
+ --stringparam man.copyright.section.enabled 0
|
||||||
|
+
|
||||||
|
+.xml.1:
|
||||||
|
+ $(AM_V_GEN) $(XSLTPROC) $(XSLTPROC_FLAGS) http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
|
||||||
|
+
|
||||||
|
+man_MANS = \
|
||||||
|
+ gnome-terminal.1
|
||||||
|
+
|
||||||
|
+xml_files = $(man_MANS:.1=.xml)
|
||||||
|
+
|
||||||
|
+EXTRA_DIST = $(xml_files)
|
||||||
|
+
|
||||||
|
+CLEANFILES = $(man_MANS)
|
||||||
|
diff --git a/man/gnome-terminal.xml b/man/gnome-terminal.xml
|
||||||
|
new file mode 100644
|
||||||
|
index 000000000000..abdac002c8ae
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/man/gnome-terminal.xml
|
||||||
|
@@ -0,0 +1,385 @@
|
||||||
|
+<?xml version="1.0" encoding="UTF-8"?>
|
||||||
|
+<!--
|
||||||
|
+ Copyright © 2020 Red Hat, Inc.
|
||||||
|
+
|
||||||
|
+ This program is free software; you can redistribute it and/or modify
|
||||||
|
+ it under the terms of either:
|
||||||
|
+
|
||||||
|
+ * the GNU General Public License as published by the Free
|
||||||
|
+ Software Foundation; either version 3 of the License, or (at your
|
||||||
|
+ option) any later version.
|
||||||
|
+
|
||||||
|
+ or
|
||||||
|
+
|
||||||
|
+ * the GNU Free Documentation License version 1.3 as published by the
|
||||||
|
+ Free Software Foundation; with no Invariant Sections, no Front-Cover
|
||||||
|
+ Texts, and no Back-Cover Texts.
|
||||||
|
+
|
||||||
|
+ or both in parallel, as here.
|
||||||
|
+
|
||||||
|
+ This program is distributed in the hope that it will be useful,
|
||||||
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+ GNU General Public License and the GNU Free Documentation License
|
||||||
|
+ for more details.
|
||||||
|
+
|
||||||
|
+ You should have received a copy of the GNU General Public License and
|
||||||
|
+ of the GNU Free Documentation License along with this program.
|
||||||
|
+ If not, see <https://www.gnu.org/licenses/>.
|
||||||
|
+-->
|
||||||
|
+<refentry id="gnome-terminal.1">
|
||||||
|
+ <refentryinfo>
|
||||||
|
+ <title>gnome-terminal</title>
|
||||||
|
+ <date>June 2020</date>
|
||||||
|
+ <productname>GNOME</productname>
|
||||||
|
+ </refentryinfo>
|
||||||
|
+
|
||||||
|
+ <refmeta>
|
||||||
|
+ <refentrytitle>gnome-terminal</refentrytitle>
|
||||||
|
+ <manvolnum>1</manvolnum>
|
||||||
|
+ <refmiscinfo class="manual">User Commands</refmiscinfo>
|
||||||
|
+ </refmeta>
|
||||||
|
+
|
||||||
|
+ <refnamediv>
|
||||||
|
+ <refname>gnome-terminal</refname>
|
||||||
|
+ <refpurpose>A terminal emulator for GNOME</refpurpose>
|
||||||
|
+ </refnamediv>
|
||||||
|
+
|
||||||
|
+ <refsynopsisdiv>
|
||||||
|
+ <cmdsynopsis>
|
||||||
|
+ <command>gnome-terminal</command>
|
||||||
|
+ </cmdsynopsis>
|
||||||
|
+ </refsynopsisdiv>
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
+ <title>DESCRIPTION</title>
|
||||||
|
+ <para>
|
||||||
|
+ <command>gnome-terminal</command> is a terminal emulator application for
|
||||||
|
+ accessing a UNIX shell environment which can be used to run programs
|
||||||
|
+ available on your system. It supports several profiles, multiple tabs and
|
||||||
|
+ implements several keyboard shortcuts.
|
||||||
|
+ </para>
|
||||||
|
+ </refsect1>
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
+ <title>OPTIONS</title>
|
||||||
|
+ <variablelist>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--help, -h</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Show a brief overview of all the options.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--help-all</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Show all the options in detail.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--help-gtk</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Show all the GTK options.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--help-terminal</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Show all the options to select between new terminal tabs or
|
||||||
|
+ windows.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--help-terminal-options</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Show all the options to change the attributes of terminals
|
||||||
|
+ regardless of whether they are in separate tabs or windows.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--help-window-options</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Show all the options to change the attributes of windows
|
||||||
|
+ containing terminals.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--load-config=FILE</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Restore the application to a previously saved state by loading it
|
||||||
|
+ from a configuration file.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--preferences</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Show the preferences window.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--print-environment, -p</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Print the environment variables to interact with newly created
|
||||||
|
+ terminals.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--quiet, -q</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Suppress diagnostics.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--verbose, -v</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Increase diagnostic verbosity.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--tab</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Open a new tab containing a terminal in the last-opened window with
|
||||||
|
+ the default profile.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--window</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Open a new window with a tab containing a terminal with the default
|
||||||
|
+ profile.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--command, -e=COMMAND</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Execute the argument to this option inside the terminal.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--fd=FD</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Forward file descriptor.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--profile=PROFILE-NAME</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Use the given profile instead of the default profile.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--title, -t=TITLE</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Set the initial terminal title.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--wait</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Wait until the terminal's child exits.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--working-directory=DIRNAME</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Set the terminal's working directory.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--zoom=ZOOM</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Set the terminal's zoom factor. 1.0 is normal size.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--active</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Set the last specified tab as the active one in its window.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--full-screen</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Full-screen the window.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--geometry=GEOMETRY</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Set the window size as COLSxROWS+X+Y. For example, 80x24 or
|
||||||
|
+ 80x24+200+200.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--hide-menubar</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Turn off the menubar for the window.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--show-menubar</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Turn on the menubar for the window.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--maximize</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Maximize the window.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--role=ROLE</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Set the X window role.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--class=CLASS</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Program class as used by the window manager.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--display=DISPLAY</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ X display to use.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--g-fatal-warnings</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Make all warnings fatal.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--gdk-debug=FLAGS</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ GDK debugging flags to set.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--gdk-no-debug=FLAGS</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ GDK debugging flags to unset.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--gtk-debug=FLAGS</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ GTK debugging flags to set.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--gtk-no-debug=FLAGS</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ GTK debugging flags to unset.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--gtk-module=MODULES</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Load additional GTK modules.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>--name=NAME</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>
|
||||||
|
+ Program name as used by the window manager.
|
||||||
|
+ </para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+ </variablelist>
|
||||||
|
+ </refsect1>
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
+ <title>BUGS</title>
|
||||||
|
+ <para>
|
||||||
|
+ Please read
|
||||||
|
+ <ulink url="https://wiki.gnome.org/Apps/Terminal/ReportingBugs"></ulink>
|
||||||
|
+ on how to report bugs.
|
||||||
|
+ </para>
|
||||||
|
+ </refsect1>
|
||||||
|
+
|
||||||
|
+ <refsect1>
|
||||||
|
+ <title>SEE ALSO</title>
|
||||||
|
+ <para>
|
||||||
|
+ For further information, visit the website
|
||||||
|
+ <ulink url="https://wiki.gnome.org/Apps/Terminal"></ulink>. There's a
|
||||||
|
+ list of frequently asked questions at
|
||||||
|
+ <ulink url="https://wiki.gnome.org/Apps/Terminal/FAQ"></ulink>.
|
||||||
|
+ </para>
|
||||||
|
+ </refsect1>
|
||||||
|
+</refentry>
|
||||||
|
--
|
||||||
|
2.25.4
|
||||||
|
|
@ -7,7 +7,7 @@
|
|||||||
|
|
||||||
Name: gnome-terminal
|
Name: gnome-terminal
|
||||||
Version: 3.28.3
|
Version: 3.28.3
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Terminal emulator for GNOME
|
Summary: Terminal emulator for GNOME
|
||||||
|
|
||||||
License: GPLv3+ and GFDL and LGPLv2+
|
License: GPLv3+ and GFDL and LGPLv2+
|
||||||
@ -18,6 +18,10 @@ Source1: org.gnome.Terminal.gschema.override
|
|||||||
Patch100: gnome-terminal-notify-open-title-transparency.patch
|
Patch100: gnome-terminal-notify-open-title-transparency.patch
|
||||||
Patch101: 0001-build-Don-t-treat-warnings-as-errors.patch
|
Patch101: 0001-build-Don-t-treat-warnings-as-errors.patch
|
||||||
|
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1612688
|
||||||
|
Patch102: 0001-Add-a-manual.patch
|
||||||
|
|
||||||
|
BuildRequires: docbook-style-xsl
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
BuildRequires: gtk3-devel >= %{gtk3_version}
|
BuildRequires: gtk3-devel >= %{gtk3_version}
|
||||||
BuildRequires: gsettings-desktop-schemas-devel
|
BuildRequires: gsettings-desktop-schemas-devel
|
||||||
@ -29,6 +33,7 @@ BuildRequires: gnome-common
|
|||||||
BuildRequires: autoconf automake libtool
|
BuildRequires: autoconf automake libtool
|
||||||
BuildRequires: itstool
|
BuildRequires: itstool
|
||||||
BuildRequires: dconf-devel
|
BuildRequires: dconf-devel
|
||||||
|
BuildRequires: libxslt
|
||||||
BuildRequires: libuuid-devel
|
BuildRequires: libuuid-devel
|
||||||
BuildRequires: nautilus-devel
|
BuildRequires: nautilus-devel
|
||||||
BuildRequires: gnome-shell
|
BuildRequires: gnome-shell
|
||||||
@ -61,6 +66,7 @@ option to the right-click context menu in Nautilus.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch100 -p1 -b .notify-open-title-transparency
|
%patch100 -p1 -b .notify-open-title-transparency
|
||||||
%patch101 -p1 -b .warnings
|
%patch101 -p1 -b .warnings
|
||||||
|
%patch102 -p1 -b .manual
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -f -i
|
autoreconf -f -i
|
||||||
@ -93,6 +99,7 @@ make check
|
|||||||
%{_datadir}/glib-2.0/schemas/org.gnome.Terminal.gschema.xml
|
%{_datadir}/glib-2.0/schemas/org.gnome.Terminal.gschema.xml
|
||||||
%{_datadir}/glib-2.0/schemas/org.gnome.Terminal.gschema.override
|
%{_datadir}/glib-2.0/schemas/org.gnome.Terminal.gschema.override
|
||||||
%{_datadir}/gnome-shell
|
%{_datadir}/gnome-shell
|
||||||
|
%{_datadir}/man/man1/gnome-terminal.1*
|
||||||
%{_userunitdir}/gnome-terminal-server.service
|
%{_userunitdir}/gnome-terminal-server.service
|
||||||
|
|
||||||
%files nautilus
|
%files nautilus
|
||||||
@ -100,6 +107,10 @@ make check
|
|||||||
%{_datadir}/metainfo/org.gnome.Terminal.Nautilus.metainfo.xml
|
%{_datadir}/metainfo/org.gnome.Terminal.Nautilus.metainfo.xml
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 19 2020 Debarshi Ray <rishi@fedoraproject.org> - 3.28.3-2
|
||||||
|
- Add a manual
|
||||||
|
- Resolves: #1612688
|
||||||
|
|
||||||
* Wed Dec 11 2019 Debarshi Ray <rishi@fedoraproject.org> - 3.28.3-1
|
* Wed Dec 11 2019 Debarshi Ray <rishi@fedoraproject.org> - 3.28.3-1
|
||||||
- Update to 3.28.3
|
- Update to 3.28.3
|
||||||
- Resolves: #1642427
|
- Resolves: #1642427
|
||||||
|
Loading…
Reference in New Issue
Block a user