Update to 3.27.1
Rebase transparency, command-notify and translation patches.
This commit is contained in:
parent
be835919aa
commit
4ec8ea1db3
1
.gitignore
vendored
1
.gitignore
vendored
@ -74,3 +74,4 @@ gnome-terminal-2.31.3.tar.bz2
|
||||
/gnome-terminal-3.26.0.tar.xz
|
||||
/gnome-terminal-3.26.1.tar.xz
|
||||
/gnome-terminal-3.26.2.tar.xz
|
||||
/gnome-terminal-3.27.1.tar.xz
|
||||
|
@ -1,28 +1,26 @@
|
||||
From 5ecf7b1d3ccc7b196803e48d3bfce7caefe82416 Mon Sep 17 00:00:00 2001
|
||||
From 91247dcb61cae4fbf36123e745193b7ad041f319 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Mon, 23 Feb 2015 18:54:36 +0100
|
||||
Subject: [PATCH] build: Don't treat warnings as errors
|
||||
|
||||
---
|
||||
configure.ac | 14 +++++++-------
|
||||
1 file changed, 7 insertions(+), 7 deletions(-)
|
||||
configure.ac | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 523a0da..f055dfe 100644
|
||||
index fcdd52c83980..b3a57a693e64 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -270,13 +270,13 @@ CC_CHECK_FLAGS_APPEND([WARN_CFLAGS],[CFLAGS],[ \
|
||||
@@ -271,12 +271,12 @@ CC_CHECK_FLAGS_APPEND([WARN_CFLAGS],[CFLAGS],[ \
|
||||
-Wall \
|
||||
-Wcast-align \
|
||||
-Wendif-labels \
|
||||
- -Werror=declaration-after-statement \
|
||||
- "-Werror=format=2 -Werror=format-nonliteral -Werror=format-security" \
|
||||
- -Werror=implicit-function-declaration \
|
||||
- -Werror=init-self \
|
||||
- -Werror=missing-include-dirs \
|
||||
- -Werror=missing-prototypes \
|
||||
- -Werror=pointer-arith \
|
||||
+ -Wdeclaration-after-statement \
|
||||
+ "-Wformat=2 -Wformat-nonliteral -Wformat-security" \
|
||||
+ -Wimplicit-function-declaration \
|
||||
+ -Winit-self \
|
||||
@ -33,5 +31,5 @@ index 523a0da..f055dfe 100644
|
||||
-Wfloat-equal \
|
||||
-Wimplicit \
|
||||
--
|
||||
2.1.0
|
||||
2.14.3
|
||||
|
||||
|
105
gnome-terminal-dont-misplace-the-notebook-popup-on-wayland.patch
Normal file
105
gnome-terminal-dont-misplace-the-notebook-popup-on-wayland.patch
Normal file
@ -0,0 +1,105 @@
|
||||
From 42b10bb35c1615e4fb0164200ff65535b8e7f29a Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Tue, 3 Apr 2018 18:51:30 +0200
|
||||
Subject: [PATCH] window: Don't misplace the notebook popup on Wayland
|
||||
|
||||
Fallout from 0820b3853a3b7c629a93fa820d5372eac1760686
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=794935
|
||||
---
|
||||
src/terminal-window.c | 65 +--------------------------------------------------
|
||||
1 file changed, 1 insertion(+), 64 deletions(-)
|
||||
|
||||
diff --git a/src/terminal-window.c b/src/terminal-window.c
|
||||
index 663f7f335650..46625c514956 100644
|
||||
--- a/src/terminal-window.c
|
||||
+++ b/src/terminal-window.c
|
||||
@@ -1449,60 +1449,6 @@ find_tab_num_at_pos (GtkNotebook *notebook,
|
||||
return -1;
|
||||
}
|
||||
|
||||
-static void
|
||||
-position_menu_under_widget (GtkMenu *menu,
|
||||
- int *x,
|
||||
- int *y,
|
||||
- gboolean *push_in,
|
||||
- gpointer user_data)
|
||||
-{
|
||||
- /* Adapted from gtktoolbar.c */
|
||||
- GtkWidget *widget = GTK_WIDGET (user_data);
|
||||
- GdkWindow *widget_window;
|
||||
- GtkWidget *container;
|
||||
- GtkRequisition req;
|
||||
- GtkRequisition menu_req;
|
||||
- GdkRectangle monitor;
|
||||
- int monitor_num;
|
||||
- GdkScreen *screen;
|
||||
- GtkAllocation widget_allocation;
|
||||
-
|
||||
- widget_window = gtk_widget_get_window (widget);
|
||||
- gtk_widget_get_allocation (widget, &widget_allocation);
|
||||
- container = gtk_widget_get_ancestor (widget, GTK_TYPE_CONTAINER);
|
||||
-
|
||||
- gtk_widget_get_preferred_size (widget, NULL, &req);
|
||||
- gtk_widget_get_preferred_size (GTK_WIDGET (menu), NULL, &menu_req);
|
||||
-
|
||||
- screen = gtk_widget_get_screen (GTK_WIDGET (menu));
|
||||
- monitor_num = gdk_screen_get_monitor_at_window (screen, widget_window);
|
||||
- if (monitor_num < 0)
|
||||
- monitor_num = 0;
|
||||
- gdk_screen_get_monitor_geometry (screen, monitor_num, &monitor);
|
||||
-
|
||||
- gdk_window_get_origin (widget_window, x, y);
|
||||
- if (!gtk_widget_get_has_window (widget))
|
||||
- {
|
||||
- *x += widget_allocation.x;
|
||||
- *y += widget_allocation.y;
|
||||
- }
|
||||
- if (gtk_widget_get_direction (container) == GTK_TEXT_DIR_LTR)
|
||||
- *x += widget_allocation.width - req.width;
|
||||
- else
|
||||
- *x += req.width - menu_req.width;
|
||||
-
|
||||
- if ((*y + widget_allocation.height + menu_req.height) <= monitor.y + monitor.height)
|
||||
- *y += widget_allocation.height;
|
||||
- else if ((*y - menu_req.height) >= monitor.y)
|
||||
- *y -= menu_req.height;
|
||||
- else if (monitor.y + monitor.height - (*y + widget_allocation.height) > *y)
|
||||
- *y += widget_allocation.height;
|
||||
- else
|
||||
- *y -= menu_req.height;
|
||||
-
|
||||
- *push_in = FALSE;
|
||||
-}
|
||||
-
|
||||
static void
|
||||
terminal_window_update_set_profile_menu_active_profile (TerminalWindow *window)
|
||||
{
|
||||
@@ -2762,15 +2708,6 @@ notebook_show_context_menu (TerminalWindow *window,
|
||||
guint button,
|
||||
guint32 timestamp)
|
||||
{
|
||||
- TerminalWindowPrivate *priv = window->priv;
|
||||
- GtkNotebook *notebook = GTK_NOTEBOOK (priv->mdi_container);
|
||||
- int page_num;
|
||||
- GtkWidget *tab, *tab_label;
|
||||
-
|
||||
- page_num = gtk_notebook_get_current_page (notebook);
|
||||
- tab = gtk_notebook_get_nth_page (notebook, page_num);
|
||||
- tab_label = gtk_notebook_get_tab_label (notebook, tab);
|
||||
-
|
||||
/* Load the UI */
|
||||
gs_unref_object GMenu *menu;
|
||||
terminal_util_load_objects_resource ("/org/gnome/terminal/ui/notebook-menu.ui",
|
||||
@@ -2781,7 +2718,7 @@ notebook_show_context_menu (TerminalWindow *window,
|
||||
|
||||
gtk_widget_set_halign (popup_menu, GTK_ALIGN_START);
|
||||
gtk_menu_popup (GTK_MENU (popup_menu), NULL, NULL,
|
||||
- position_menu_under_widget, tab_label,
|
||||
+ NULL, NULL,
|
||||
button, timestamp);
|
||||
|
||||
if (button == 0)
|
||||
--
|
||||
2.14.3
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -2,21 +2,24 @@
|
||||
|
||||
%define glib2_version 2.42.0
|
||||
%define gtk3_version 3.20.0
|
||||
%define vte_version 0.50.2
|
||||
%define vte_version 0.51.1
|
||||
%define desktop_file_utils_version 0.2.90
|
||||
|
||||
Name: gnome-terminal
|
||||
Version: 3.26.2
|
||||
Release: 3%{?dist}
|
||||
Version: 3.27.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Terminal emulator for GNOME
|
||||
|
||||
License: GPLv3+ and GFDL
|
||||
URL: http://www.gnome.org/
|
||||
Source0: http://download.gnome.org/sources/gnome-terminal/3.26/gnome-terminal-%{version}.tar.xz
|
||||
Source0: http://download.gnome.org/sources/gnome-terminal/3.27/gnome-terminal-%{version}.tar.xz
|
||||
Source1: org.gnome.Terminal.gschema.override
|
||||
|
||||
Patch0: 0001-build-Don-t-treat-warnings-as-errors.patch
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=794935
|
||||
Patch1: gnome-terminal-dont-misplace-the-notebook-popup-on-wayland.patch
|
||||
|
||||
Patch100: gnome-terminal-notify-open-title-transparency.patch
|
||||
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
@ -62,11 +65,12 @@ option to the right-click context menu in Nautilus.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .warnings
|
||||
%patch1 -p1 -b .notebook-popup
|
||||
%patch100 -p1 -b .notify-open-title-transparency
|
||||
|
||||
%build
|
||||
autoreconf -f -i
|
||||
%configure --disable-static --disable-gterminal --disable-migration --with-gtk=3.0 --with-nautilus-extension
|
||||
%configure --disable-static --disable-migration --with-gtk=3.0 --with-nautilus-extension
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -102,6 +106,10 @@ make check
|
||||
%{_datadir}/metainfo/org.gnome.Terminal.Nautilus.metainfo.xml
|
||||
|
||||
%changelog
|
||||
* Tue Apr 03 2018 Debarshi Ray <rishi@fedoraproject.org> - 3.27.1-1
|
||||
- Update to 3.27.1
|
||||
- Rebase transparency, command-notify and translation patches
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.26.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gnome-terminal-3.26.2.tar.xz) = a5f91d68e729695126e1fe0ab81cea994c8fb1dc3de33fdd63ada2592c6c60b16613d1a01a317a83fedc3caf656106955d3a33ef7cdbff01680eb7f30069e555
|
||||
SHA512 (gnome-terminal-3.27.1.tar.xz) = 32f1a3e9a3eaffbf4a04e30f8a80217e3afb96ddf68747d9ca8a5cdfe34c3d3cffe974b95096462354b614498c50b56450b131092bb98f861945348c30ee6ded
|
||||
|
Loading…
Reference in New Issue
Block a user