Don't treat warnings as errors

This commit is contained in:
Debarshi Ray 2015-02-23 18:55:58 +01:00
parent 5e80d24cd6
commit 323e59cf1d
2 changed files with 39 additions and 0 deletions

View File

@ -0,0 +1,37 @@
From 5ecf7b1d3ccc7b196803e48d3bfce7caefe82416 Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Mon, 23 Feb 2015 18:54:36 +0100
Subject: [PATCH] build: Don't treat warnings as errors
---
configure.ac | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/configure.ac b/configure.ac
index 523a0da..f055dfe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -270,13 +270,13 @@ CC_CHECK_FLAGS_APPEND([WARN_CFLAGS],[CFLAGS],[ \
-Wall \
-Wcast-align \
-Wendif-labels \
- -Werror=declaration-after-statement \
- "-Werror=format=2 -Werror=format-nonliteral -Werror=format-security" \
- -Werror=implicit-function-declaration \
- -Werror=init-self \
- -Werror=missing-include-dirs \
- -Werror=missing-prototypes \
- -Werror=pointer-arith \
+ -Wdeclaration-after-statement \
+ "-Wformat=2 -Wformat-nonliteral -Wformat-security" \
+ -Wimplicit-function-declaration \
+ -Winit-self \
+ -Wmissing-include-dirs \
+ -Wmissing-prototypes \
+ -Wpointer-arith \
-Wextra \
-Wfloat-equal \
-Wimplicit \
--
2.1.0

View File

@ -17,6 +17,7 @@ Source0: http://download.gnome.org/sources/gnome-terminal/3.15/gnome-terminal-%{
Source1: org.gnome.Terminal.gschema.override
Patch0: 0001-all-Fix-various-format-specifiers-for-Wformat-signed.patch
Patch1: 0001-build-Don-t-treat-warnings-as-errors.patch
Patch100: gnome-terminal-restore-transparency.patch
Patch101: gnome-terminal-restore-dark.patch
@ -60,6 +61,7 @@ option to the right-click context menu in Nautilus.
%prep
%setup -q
%patch0 -p1 -b .format
%patch1 -p1 -b .warnings
%patch100 -p1 -b .transparency
%patch101 -p1 -b .dark
%patch102 -p1 -b .command-notify