Update to 3.30.2

- Rebase transparency, command-notify, custom title and translation patches
This commit is contained in:
Kalev Lember 2018-10-26 09:06:33 +02:00
parent 248649a295
commit 1951e9e18f
5 changed files with 76 additions and 124 deletions

1
.gitignore vendored
View File

@ -83,3 +83,4 @@ gnome-terminal-2.31.3.tar.bz2
/gnome-terminal-3.29.92.tar.xz
/gnome-terminal-3.30.0.tar.xz
/gnome-terminal-3.30.1.tar.xz
/gnome-terminal-3.30.2.tar.xz

View File

@ -1,4 +1,4 @@
From 91247dcb61cae4fbf36123e745193b7ad041f319 Mon Sep 17 00:00:00 2001
From 8709588cc5ec11e7b1007e7d67aa4df74faf5c68 Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Mon, 23 Feb 2015 18:54:36 +0100
Subject: [PATCH] build: Don't treat warnings as errors
@ -8,10 +8,10 @@ Subject: [PATCH] build: Don't treat warnings as errors
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/configure.ac b/configure.ac
index fcdd52c83980..b3a57a693e64 100644
index f22050d6a2e3..d6d936eb0a96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -271,12 +271,12 @@ CC_CHECK_FLAGS_APPEND([WARN_CFLAGS],[CFLAGS],[ \
@@ -225,12 +225,12 @@ CC_CHECK_FLAGS_APPEND([WARN_CFLAGS],[CFLAGS],[ \
-Wall \
-Wcast-align \
-Wendif-labels \
@ -31,5 +31,5 @@ index fcdd52c83980..b3a57a693e64 100644
-Wfloat-equal \
-Wimplicit \
--
2.14.3
2.19.1

View File

@ -1,7 +1,7 @@
From 5a7a968a84cdf1cbd053bb5ad1d0f47657a74600 Mon Sep 17 00:00:00 2001
From c9a5c9630248efe0bc34dfbd4f54c8d4f68d4ee6 Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Mon, 12 May 2014 14:57:18 +0200
Subject: [PATCH 01/15] Restore transparency
Subject: [PATCH 01/14] Restore transparency
The transparency settings were removed as a side effect of
2bff4b63ed3ceef6055e35563e9b0b33ad57349d
@ -16,12 +16,12 @@ restore the translations of the string.
Some changes by Peter Weber <peter.weber@mailbox.org>
---
src/org.gnome.Terminal.gschema.xml | 10 ++++++++
src/preferences.ui | 47 ++++++++++++++++++++++++++++++++++++++
src/profile-editor.c | 16 +++++++++++++
src/terminal-schemas.h | 3 +++
src/terminal-screen.c | 22 +++++++++++++++++-
src/terminal-window.c | 7 ++++++
src/org.gnome.Terminal.gschema.xml | 10 +++++++
src/preferences.ui | 47 ++++++++++++++++++++++++++++++
src/profile-editor.c | 16 ++++++++++
src/terminal-schemas.h | 3 ++
src/terminal-screen.c | 22 +++++++++++++-
src/terminal-window.c | 7 +++++
6 files changed, 104 insertions(+), 1 deletion(-)
diff --git a/src/org.gnome.Terminal.gschema.xml b/src/org.gnome.Terminal.gschema.xml
@ -231,13 +231,13 @@ index 4ed3647498b2..8fc70ce74252 100644
uuid_unparse (u, uuidstr);
priv->uuid = g_strdup (uuidstr);
--
2.14.4
2.19.1
From a5e63c8ebb436f08a25ee0b107ef0abe8977d3f2 Mon Sep 17 00:00:00 2001
From f10a426375c392add4ad9ce28bdfc17c27b2da23 Mon Sep 17 00:00:00 2001
From: Lars Uebernickel <lars.uebernickel@canonical.com>
Date: Wed, 28 May 2014 14:11:02 +0200
Subject: [PATCH 02/15] window: Make the drawing robust across all themes
Subject: [PATCH 02/14] window: Make the drawing robust across all themes
There are lots of themes out there in the wild that do not specify a
background-color for all widgets and the default is transparent. This
@ -293,13 +293,13 @@ index 8fc70ce74252..1707ada83ce8 100644
widget_class->screen_changed = terminal_window_screen_changed;
widget_class->style_updated = terminal_window_style_updated;
--
2.14.4
2.19.1
From a7d2159896b0409c61089e17696b2653a88aaf66 Mon Sep 17 00:00:00 2001
From ab579d89948777e2e0267376d64cca79af6684d9 Mon Sep 17 00:00:00 2001
From: "Owen W. Taylor" <otaylor@fishsoup.net>
Date: Fri, 13 Nov 2015 15:16:42 +0100
Subject: [PATCH 03/15] screen, window: Extra padding around transparent
Subject: [PATCH 03/14] screen, window: Extra padding around transparent
terminals in Wayland
https://bugzilla.redhat.com/show_bug.cgi?id=1207943
@ -420,13 +420,13 @@ index 1707ada83ce8..a3c5a7fc2f46 100644
return GTK_WIDGET_CLASS (terminal_window_parent_class)->draw (widget, cr);
--
2.14.4
2.19.1
From 0db67508ccbe961a0424f012afdb9e2ae6403139 Mon Sep 17 00:00:00 2001
From aa31c5189de74fba379426792f5d48c64515ba48 Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Mon, 27 Feb 2017 16:53:51 +0100
Subject: [PATCH 04/15] screen: Silence -Wunused variable
Subject: [PATCH 04/14] screen: Silence -Wunused variable
https://bugzilla.redhat.com/show_bug.cgi?id=1207943
---
@ -446,19 +446,19 @@ index c0ce8a89126c..1b763a3890dd 100644
gboolean use_theme_colors;
--
2.14.4
2.19.1
From 92f0f2e6ff0ae529cb9526082e50f6ecd027a8b4 Mon Sep 17 00:00:00 2001
From dde5c4452134cef537120c70a0d6749329736b7b Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Tue, 27 Jan 2015 18:40:13 +0100
Subject: [PATCH 05/15] Support desktop notifications from OSC 777
Subject: [PATCH 05/14] Support desktop notifications from OSC 777
https://bugzilla.gnome.org/show_bug.cgi?id=711059
---
src/terminal-app.c | 32 ++++++++++++++
src/terminal-screen.c | 108 +++++++++++++++++++++++++++++++++++++++++++++++
src/terminal-tab-label.c | 28 +++++++++++-
src/terminal-app.c | 32 ++++++++++++
src/terminal-screen.c | 108 +++++++++++++++++++++++++++++++++++++++
src/terminal-tab-label.c | 28 +++++++++-
src/terminal-tab-label.h | 4 ++
4 files changed, 171 insertions(+), 1 deletion(-)
@ -768,13 +768,13 @@ index 20cfbceb36b0..a987025e0524 100644
G_END_DECLS
--
2.14.4
2.19.1
From cad92b3f80f69e39c42777813449059c48c0798b Mon Sep 17 00:00:00 2001
From 0dd2a301dfc5b23d62595d901312c2a627f39f1e Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Thu, 29 Jan 2015 11:47:21 +0100
Subject: [PATCH 06/15] Sprinkle debug messages for notifications
Subject: [PATCH 06/14] Sprinkle debug messages for notifications
This can be useful for finding out whether the escape sequence wasn't
emitted or the filtering was faulty.
@ -851,73 +851,20 @@ index ced2cdfe8a30..36a9afa3ded9 100644
}
--
2.14.4
2.19.1
From b99cbf89328d978c57a69413d76e1670316615ab Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Wed, 28 Mar 2018 18:50:16 +0200
Subject: [PATCH 07/15] prefs: Fix the visibility of the new-terminal-mode
GSetting UI
... when the new-terminal menus are disunified.
Since it's not possible to use DISUNIFY_NEW_TERMINAL_SECTION, it
should check the unified-menu GSetting instead.
Fallout from 30efce621ad04276771aa311f52731b468c4adfd
https://gitlab.gnome.org/GNOME/gnome-terminal/issues/37
---
src/terminal-prefs.c | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/src/terminal-prefs.c b/src/terminal-prefs.c
index 5bc7718632f2..1cccfa923dd3 100644
--- a/src/terminal-prefs.c
+++ b/src/terminal-prefs.c
@@ -849,16 +849,16 @@ terminal_prefs_show_preferences (GSettings *profile, const char *widget_name)
gtk_widget_set_visible (theme_variant_combo, FALSE);
#endif /* GTK+ 3.19 */
-#ifndef DISUNIFY_NEW_TERMINAL_SECTION
- g_settings_bind (settings,
- TERMINAL_SETTING_NEW_TERMINAL_MODE_KEY,
- new_terminal_mode_combo,
- "active-id",
- G_SETTINGS_BIND_GET | G_SETTINGS_BIND_SET);
-#else
- gtk_widget_set_visible (new_terminal_mode_label, FALSE);
- gtk_widget_set_visible (new_terminal_mode_combo, FALSE);
-#endif
+ if (terminal_app_get_menu_unified (app)) {
+ g_settings_bind (settings,
+ TERMINAL_SETTING_NEW_TERMINAL_MODE_KEY,
+ new_terminal_mode_combo,
+ "active-id",
+ G_SETTINGS_BIND_GET | G_SETTINGS_BIND_SET);
+ } else {
+ gtk_widget_set_visible (new_terminal_mode_label, FALSE);
+ gtk_widget_set_visible (new_terminal_mode_combo, FALSE);
+ }
if (shell_shows_menubar) {
gtk_widget_set_visible (disable_mnemonics_button, FALSE);
--
2.14.4
From d3234cf0cbcdbfc24e524a7f3194e04e6fbe6cae Mon Sep 17 00:00:00 2001
From 0c11608721e2e522ef4315c710b0f2763346d862 Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Tue, 10 Apr 2018 15:39:35 +0200
Subject: [PATCH 08/15] profile: Split the Command tab into two nested GtkGrids
Subject: [PATCH 07/14] profile: Split the Command tab into two nested GtkGrids
This will let the subsequent patch add a "Command" sub-heading to keep
the command settings separate from the to-be-restored title settings.
https://bugzilla.redhat.com/show_bug.cgi?id=1296110
---
src/preferences.ui | 173 ++++++++++++++++++++++++++++-------------------------
src/preferences.ui | 173 +++++++++++++++++++++++----------------------
1 file changed, 90 insertions(+), 83 deletions(-)
diff --git a/src/preferences.ui b/src/preferences.ui
@ -1111,19 +1058,19 @@ index f5c366f14e10..edd924689d35 100644
</object>
<packing>
--
2.14.4
2.19.1
From 6d6480aa54c00df7121b888b63fa56fb8ba4b0c8 Mon Sep 17 00:00:00 2001
From 75b2fcb3e9ec7518327fef96f79a3e9bbc427c73 Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Tue, 10 Apr 2018 16:01:51 +0200
Subject: [PATCH 09/15] Revert "profile: Remove the "Command" sub-heading"
Subject: [PATCH 08/14] Revert "profile: Remove the "Command" sub-heading"
This reverts commit 8e27479299d075df0a52d0e8e7baeab344dcaa6c.
https://bugzilla.redhat.com/show_bug.cgi?id=1296110
---
src/preferences.ui | 179 ++++++++++++++++++++++++++++++++---------------------
src/preferences.ui | 179 +++++++++++++++++++++++++++------------------
1 file changed, 109 insertions(+), 70 deletions(-)
diff --git a/src/preferences.ui b/src/preferences.ui
@ -1335,20 +1282,20 @@ index edd924689d35..11a283064996 100644
</object>
<packing>
--
2.14.4
2.19.1
From 6c103036b31c3ce394d47315162c38c87a1a2b87 Mon Sep 17 00:00:00 2001
From ae37843fd6ec1d6e901228da912dfdfdbe9f7ed2 Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Thu, 30 Jun 2016 16:02:13 +0200
Subject: [PATCH 10/15] Revert "screen: Remove unused description and
Subject: [PATCH 09/14] Revert "screen: Remove unused description and
user_title API"
This reverts commit 3bb41272b7509a16ec2a5cd93e44f73d5743b626.
https://bugzilla.redhat.com/show_bug.cgi?id=1296110
---
src/terminal-screen.c | 63 +++++++++++++++++++++++++++++++++++++++++++++++++++
src/terminal-screen.c | 63 +++++++++++++++++++++++++++++++++++++++++++
src/terminal-screen.h | 5 ++++
2 files changed, 68 insertions(+)
@ -1514,13 +1461,13 @@ index ff77fcf78947..af9583e7cbaf 100644
char *terminal_screen_get_current_dir (TerminalScreen *screen);
--
2.14.4
2.19.1
From 865f41677e3430b78fbccce0b674a9fc99f4ebf2 Mon Sep 17 00:00:00 2001
From be017f0b1885796a02da2fdc247071b03ed4f998 Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Thu, 30 Jun 2016 17:39:48 +0200
Subject: [PATCH 11/15] Revert "Remove the static title setting from profile
Subject: [PATCH 10/14] Revert "Remove the static title setting from profile
preferences"
This reverts commit e9cb8fea14a849704074c5d69f173bcf4dc2fb27.
@ -1528,10 +1475,10 @@ This reverts commit e9cb8fea14a849704074c5d69f173bcf4dc2fb27.
https://bugzilla.redhat.com/show_bug.cgi?id=1296110
---
src/org.gnome.Terminal.gschema.xml | 5 +++
src/preferences.ui | 71 ++++++++++++++++++++++++++++++++++++++
src/preferences.ui | 71 ++++++++++++++++++++++++++++++
src/profile-editor.c | 5 +++
src/terminal-schemas.h | 1 +
src/terminal-screen.c | 9 +++++
src/terminal-screen.c | 9 ++++
5 files changed, 91 insertions(+)
diff --git a/src/org.gnome.Terminal.gschema.xml b/src/org.gnome.Terminal.gschema.xml
@ -1693,13 +1640,13 @@ index 8e6f2e935ba4..bf3618cb41b0 100644
(!prop_name ||
prop_name == I_(TERMINAL_PROFILE_USE_SYSTEM_FONT_KEY) ||
--
2.14.4
2.19.1
From 0eeb6d9f05a13b6922b642e23666e180c9af964a Mon Sep 17 00:00:00 2001
From b3c8ba6bd276defab38d05406d225f56b170db08 Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Tue, 17 Feb 2015 17:06:17 +0100
Subject: [PATCH 12/15] Restore translations for setting a title and
Subject: [PATCH 11/14] Restore translations for setting a title and
transparency
---
@ -3360,11 +3307,11 @@ index f2ebd4851d3b..f3d44c9c6294 100644
#: ../src/gnome-terminal.glade2.h:103
msgid "_Update login records when command is launched"
diff --git a/po/nb.po b/po/nb.po
index 53da54ab54e0..c5aa509f7003 100644
index 683acfe5221e..3dc97ee17fec 100644
--- a/po/nb.po
+++ b/po/nb.po
@@ -2183,3 +2183,15 @@ msgstr ""
#: ../src/terminal-window.c:3346
@@ -2261,3 +2261,15 @@ msgstr ""
#: ../src/terminal-window.c:3210
msgid "C_lose Window"
msgstr "_Lukk vindu"
+
@ -4515,13 +4462,13 @@ index b9890ad91bdc..18e55e2e945c 100644
+msgid "Transparent background"
+msgstr "透明背景"
--
2.14.4
2.19.1
From 8d309ffd19b0ed50ab55042cf6d7b249c2395328 Mon Sep 17 00:00:00 2001
From 617748abc5c22e094c764c3a4da5258f86ed19a8 Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Wed, 25 May 2016 13:47:36 +0200
Subject: [PATCH 13/15] Restore the action and shortcut to set a static title
Subject: [PATCH 12/14] Restore the action and shortcut to set a static title
from the menus
This reverts 9bbe19e98f62aa3c9020913a3a5a8080a5177505 with various
@ -4531,7 +4478,7 @@ https://bugzilla.redhat.com/show_bug.cgi?id=1296110
---
src/org.gnome.Terminal.gschema.xml | 4 ++
src/terminal-accels.c | 2 +
src/terminal-window.c | 75 ++++++++++++++++++++++++++++++++++++++
src/terminal-window.c | 75 ++++++++++++++++++++++++++++++
3 files changed, 81 insertions(+)
diff --git a/src/org.gnome.Terminal.gschema.xml b/src/org.gnome.Terminal.gschema.xml
@ -4663,13 +4610,13 @@ index a3c5a7fc2f46..8df7707ab77f 100644
{ "tab-detach", action_tab_detach_cb, NULL, NULL, NULL },
{ "tab-move-left", action_tab_move_left_cb, NULL, NULL, NULL },
--
2.14.4
2.19.1
From 157d04e4f3897a8383f867818ff88c805299b0c5 Mon Sep 17 00:00:00 2001
From 810666d52c2d373c62d25e68f8f1a91e1597a744 Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Thu, 30 Jun 2016 18:14:36 +0200
Subject: [PATCH 14/15] screen: Style fix
Subject: [PATCH 13/14] screen: Style fix
This brings the code in line with how it was before
de0dc7c2649c42e2aa02a66e4be27d262b34452d
@ -4693,13 +4640,13 @@ index bf3618cb41b0..6caa002ddece 100644
const char *p;
--
2.14.4
2.19.1
From dd28d5a586befa6a8137202aa9cac5eeb81ae4d5 Mon Sep 17 00:00:00 2001
From 93e37d374dde902662c2240b0d6c50b19b76a77b Mon Sep 17 00:00:00 2001
From: Debarshi Ray <debarshir@gnome.org>
Date: Thu, 30 Jun 2016 16:58:15 +0200
Subject: [PATCH 15/15] Restore the rest of the title handling options and make
Subject: [PATCH 14/14] Restore the rest of the title handling options and make
it all work
This reverts commit f27bf0135a2d18ba22158d28bf1f8c5f6ec066c8 and makes
@ -4708,11 +4655,11 @@ it use the user_title API instead of sending an escape sequence.
https://bugzilla.redhat.com/show_bug.cgi?id=1296110
---
src/org.gnome.Terminal.gschema.xml | 12 ++
src/preferences.ui | 33 ++++-
src/profile-editor.c | 9 ++
src/terminal-enums.h | 8 ++
src/preferences.ui | 33 +++-
src/profile-editor.c | 9 +
src/terminal-enums.h | 8 +
src/terminal-schemas.h | 1 +
src/terminal-screen.c | 261 +++++++++++++++++++++++++++----------
src/terminal-screen.c | 261 +++++++++++++++++++++--------
src/terminal-screen.h | 8 +-
src/terminal-window.c | 11 +-
8 files changed, 265 insertions(+), 78 deletions(-)
@ -5328,5 +5275,5 @@ index 8df7707ab77f..37bbcca35580 100644
static void
--
2.14.4
2.19.1

View File

@ -6,8 +6,8 @@
%define desktop_file_utils_version 0.2.90
Name: gnome-terminal
Version: 3.30.1
Release: 2%{?dist}
Version: 3.30.2
Release: 1%{?dist}
Summary: Terminal emulator for GNOME
License: GPLv3+ and GFDL and LGPLv2+
@ -104,6 +104,10 @@ make check
%{_datadir}/metainfo/org.gnome.Terminal.Nautilus.metainfo.xml
%changelog
* Fri Oct 26 2018 Kalev Lember <klember@redhat.com> - 3.30.2-1
- Update to 3.30.2
- Rebase transparency, command-notify, custom title and translation patches
* Thu Oct 11 2018 David Herrmann <dh.herrmann@gmail.com> - 3.30.1-2
- Reduce 'dbus-x11' dependency to 'dbus'. The xinit script are no longer the
canonical way to start dbus, but the 'dbus' package is nowadays required to

View File

@ -1 +1 @@
SHA512 (gnome-terminal-3.30.1.tar.xz) = 486fe7a9841114d49428208fdea195f1ce6a27ecfc66e2c77632385a7b106a28d3e6a0f1a198bd08f3e2a89d201ac49dafa376c002eab6470ff9d64cf30194ec
SHA512 (gnome-terminal-3.30.2.tar.xz) = acbc854271b8dd8c60e04277228d5e0d2dbfaff42bc9c002d4bc42bb97052e2e3ab03da130c31c3cc1452644adfafcddd5103a6d79a10a659b4fe20d6063c61e