fix patch

This commit is contained in:
Matthias Clasen 2008-02-26 05:29:43 +00:00
parent d484a1d342
commit ff4643ecca

View File

@ -1,6 +1,6 @@
diff -up gnome-system-monitor-2.21.92/po/POTFILES.in.polkit gnome-system-monitor-2.21.92/po/POTFILES.in
--- gnome-system-monitor-2.21.92/po/POTFILES.in.polkit 2008-02-25 10:15:16.000000000 -0500
+++ gnome-system-monitor-2.21.92/po/POTFILES.in 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/po/POTFILES.in 2008-02-26 00:13:35.000000000 -0500
@@ -6,6 +6,7 @@ src/callbacks.cpp
src/defaulttable.h
src/disks.cpp
@ -11,19 +11,18 @@ diff -up gnome-system-monitor-2.21.92/po/POTFILES.in.polkit gnome-system-monitor
src/interface.cpp
diff -up gnome-system-monitor-2.21.92/configure.in.polkit gnome-system-monitor-2.21.92/configure.in
--- gnome-system-monitor-2.21.92/configure.in.polkit 2008-02-25 10:01:45.000000000 -0500
+++ gnome-system-monitor-2.21.92/configure.in 2008-02-26 00:07:57.000000000 -0500
+++ gnome-system-monitor-2.21.92/configure.in 2008-02-26 00:29:05.000000000 -0500
@@ -33,11 +33,45 @@ GNOME_ICON_THEME_REQUIRED=2.15.3
GTKMM_REQUIRED=2.8
GLIBMM_REQUIRED=2.14
LIBXML_REQUIRED=2.0
-RSVG_REQUIRED=2.12
+POLKIT_GNOME_REQUIRED=0.7
+POLKIT_DBUS_REQUIRED=0.7
+DBUS_GLIB_REQUIRED=0.71
+DBUS_REQUIRED=1.1.2
+SVG_REQUIRED=2.12
+
RSVG_REQUIRED=2.12
+
PKG_CHECK_MODULES(PROCMAN, glib-2.0 >= $GLIB_REQUIRED gconf-2.0 >= $GCONF_REQUIRED libgtop-2.0 >= $LIBGTOP_REQUIRED libwnck-1.0 >= $LIBWNCK_REQUIRED gtk+-2.0 >= $GTK_REQUIRED gnome-vfs-2.0 >= $GNOME_VFS_REQUIRED gnome-icon-theme >= $GNOME_ICON_THEME_REQUIRED gtkmm-2.4 >= $GTKMM_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED librsvg-2.0 >= $RSVG_REQUIRED glibmm-2.4 >= $GLIBMM_REQUIRED)
@ -69,7 +68,7 @@ diff -up gnome-system-monitor-2.21.92/configure.in.polkit gnome-system-monitor-2
"
diff -up gnome-system-monitor-2.21.92/src/Makefile.am.polkit gnome-system-monitor-2.21.92/src/Makefile.am
--- gnome-system-monitor-2.21.92/src/Makefile.am.polkit 2008-02-20 14:58:48.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/Makefile.am 2008-02-26 00:10:49.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/Makefile.am 2008-02-26 00:13:35.000000000 -0500
@@ -4,7 +4,9 @@ INCLUDES = \
-DPROCMAN_DATADIR=\""$(datadir)/procman/"\" \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
@ -142,7 +141,7 @@ diff -up gnome-system-monitor-2.21.92/src/Makefile.am.polkit gnome-system-monito
$(schema_DATA)
diff -up /dev/null gnome-system-monitor-2.21.92/src/gnome-system-monitor-mechanism.c
--- /dev/null 2008-02-25 20:11:08.647008951 -0500
+++ gnome-system-monitor-2.21.92/src/gnome-system-monitor-mechanism.c 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/gnome-system-monitor-mechanism.c 2008-02-26 00:13:35.000000000 -0500
@@ -0,0 +1,640 @@
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 8 -*-
+ *
@ -786,7 +785,7 @@ diff -up /dev/null gnome-system-monitor-2.21.92/src/gnome-system-monitor-mechani
+}
diff -up /dev/null gnome-system-monitor-2.21.92/src/gnome-system-monitor-mechanism.xml
--- /dev/null 2008-02-25 20:11:08.647008951 -0500
+++ gnome-system-monitor-2.21.92/src/gnome-system-monitor-mechanism.xml 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/gnome-system-monitor-mechanism.xml 2008-02-26 00:13:35.000000000 -0500
@@ -0,0 +1,15 @@
+<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
+<node name="/">
@ -805,7 +804,7 @@ diff -up /dev/null gnome-system-monitor-2.21.92/src/gnome-system-monitor-mechani
+</node>
diff -up /dev/null gnome-system-monitor-2.21.92/src/org.gnome.SystemMonitor.Mechanism.service.in
--- /dev/null 2008-02-25 20:11:08.647008951 -0500
+++ gnome-system-monitor-2.21.92/src/org.gnome.SystemMonitor.Mechanism.service.in 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/org.gnome.SystemMonitor.Mechanism.service.in 2008-02-26 00:13:35.000000000 -0500
@@ -0,0 +1,4 @@
+[D-BUS Service]
+Name=org.gnome.SystemMonitor.Mechanism
@ -813,7 +812,7 @@ diff -up /dev/null gnome-system-monitor-2.21.92/src/org.gnome.SystemMonitor.Mech
+User=root
diff -up /dev/null gnome-system-monitor-2.21.92/src/org.gnome.system-monitor.policy.in
--- /dev/null 2008-02-25 20:11:08.647008951 -0500
+++ gnome-system-monitor-2.21.92/src/org.gnome.system-monitor.policy.in 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/org.gnome.system-monitor.policy.in 2008-02-26 00:13:35.000000000 -0500
@@ -0,0 +1,50 @@
+<?xml version="1.0" encoding="utf-8"?>
+
@ -867,7 +866,7 @@ diff -up /dev/null gnome-system-monitor-2.21.92/src/org.gnome.system-monitor.pol
+</policyconfig>
diff -up gnome-system-monitor-2.21.92/src/procactions.cpp.polkit gnome-system-monitor-2.21.92/src/procactions.cpp
--- gnome-system-monitor-2.21.92/src/procactions.cpp.polkit 2007-12-22 10:03:34.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/procactions.cpp 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/procactions.cpp 2008-02-26 00:13:35.000000000 -0500
@@ -31,6 +31,10 @@
#include "procdialogs.h"
#include "callbacks.h"
@ -982,7 +981,7 @@ diff -up gnome-system-monitor-2.21.92/src/procactions.cpp.polkit gnome-system-mo
+
diff -up gnome-system-monitor-2.21.92/src/callbacks.cpp.polkit gnome-system-monitor-2.21.92/src/callbacks.cpp
--- gnome-system-monitor-2.21.92/src/callbacks.cpp.polkit 2008-02-22 15:50:07.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/callbacks.cpp 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/callbacks.cpp 2008-02-26 00:13:35.000000000 -0500
@@ -36,25 +36,21 @@
#include "disks.h"
#include "lsof.h"
@ -1027,7 +1026,7 @@ diff -up gnome-system-monitor-2.21.92/src/callbacks.cpp.polkit gnome-system-moni
static void change_gconf_color(GConfClient *client, const char *key,
diff -up gnome-system-monitor-2.21.92/src/procman.cpp.polkit gnome-system-monitor-2.21.92/src/procman.cpp
--- gnome-system-monitor-2.21.92/src/procman.cpp.polkit 2008-02-24 05:06:57.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/procman.cpp 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/procman.cpp 2008-02-26 00:13:35.000000000 -0500
@@ -33,6 +33,10 @@
#include <glibtop/close.h>
#include <glibtop/loadavg.h>
@ -1077,7 +1076,7 @@ diff -up gnome-system-monitor-2.21.92/src/procman.cpp.polkit gnome-system-monito
ProcData* ProcData::get_instance()
diff -up gnome-system-monitor-2.21.92/src/procman.h.polkit gnome-system-monitor-2.21.92/src/procman.h
--- gnome-system-monitor-2.21.92/src/procman.h.polkit 2008-01-14 13:14:34.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/procman.h 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/procman.h 2008-02-26 00:13:35.000000000 -0500
@@ -32,6 +32,11 @@
#include <map>
@ -1111,7 +1110,7 @@ diff -up gnome-system-monitor-2.21.92/src/procman.h.polkit gnome-system-monitor-
GStringChunk *users;
diff -up /dev/null gnome-system-monitor-2.21.92/src/org.gnome.SystemMonitor.Mechanism.conf
--- /dev/null 2008-02-25 20:11:08.647008951 -0500
+++ gnome-system-monitor-2.21.92/src/org.gnome.SystemMonitor.Mechanism.conf 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/org.gnome.SystemMonitor.Mechanism.conf 2008-02-26 00:13:35.000000000 -0500
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->
+
@ -1126,7 +1125,7 @@ diff -up /dev/null gnome-system-monitor-2.21.92/src/org.gnome.SystemMonitor.Mech
+</busconfig>
diff -up gnome-system-monitor-2.21.92/src/procdialogs.cpp.polkit gnome-system-monitor-2.21.92/src/procdialogs.cpp
--- gnome-system-monitor-2.21.92/src/procdialogs.cpp.polkit 2007-12-22 10:03:34.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/procdialogs.cpp 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/procdialogs.cpp 2008-02-26 00:13:35.000000000 -0500
@@ -35,6 +35,11 @@
#include "procman_gnomesu.h"
#include "procman_gksu.h"
@ -1322,7 +1321,7 @@ diff -up gnome-system-monitor-2.21.92/src/procdialogs.cpp.polkit gnome-system-mo
static void
diff -up gnome-system-monitor-2.21.92/src/interface.cpp.polkit gnome-system-monitor-2.21.92/src/interface.cpp
--- gnome-system-monitor-2.21.92/src/interface.cpp.polkit 2008-02-20 15:40:44.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/interface.cpp 2008-02-26 00:04:30.000000000 -0500
+++ gnome-system-monitor-2.21.92/src/interface.cpp 2008-02-26 00:13:35.000000000 -0500
@@ -30,6 +30,10 @@
#include <gdk/gdkkeysyms.h>
#include <math.h>