fix a typo
This commit is contained in:
parent
aca6759145
commit
f5a4f9fa37
45
polkit.patch
45
polkit.patch
@ -1,6 +1,6 @@
|
||||
diff -up gnome-system-monitor-2.28.2/configure.in.polkit gnome-system-monitor-2.28.2/configure.in
|
||||
--- gnome-system-monitor-2.28.2/configure.in.polkit 2010-09-27 19:13:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.28.2/configure.in 2010-09-30 13:05:41.132603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/configure.in 2010-09-30 14:27:14.731603002 -0400
|
||||
@@ -35,10 +35,35 @@ GIOMM_REQUIRED=2.16.0
|
||||
GLIBMM_REQUIRED=2.14
|
||||
LIBXML_REQUIRED=2.0
|
||||
@ -49,7 +49,7 @@ diff -up gnome-system-monitor-2.28.2/configure.in.polkit gnome-system-monitor-2.
|
||||
"
|
||||
diff -up gnome-system-monitor-2.28.2/po/POTFILES.in.polkit gnome-system-monitor-2.28.2/po/POTFILES.in
|
||||
--- gnome-system-monitor-2.28.2/po/POTFILES.in.polkit 2010-02-09 08:23:26.000000000 -0500
|
||||
+++ gnome-system-monitor-2.28.2/po/POTFILES.in 2010-09-30 13:05:41.132603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/po/POTFILES.in 2010-09-30 14:27:14.732603002 -0400
|
||||
@@ -8,6 +8,7 @@ src/callbacks.cpp
|
||||
src/defaulttable.h
|
||||
src/disks.cpp
|
||||
@ -59,8 +59,8 @@ diff -up gnome-system-monitor-2.28.2/po/POTFILES.in.polkit gnome-system-monitor-
|
||||
src/gsm_color_button.c
|
||||
src/interface.cpp
|
||||
diff -up gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.c.polkit gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.c
|
||||
--- gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.c.polkit 2010-09-30 13:05:41.148603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.c 2010-09-30 13:05:41.148603002 -0400
|
||||
--- gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.c.polkit 2010-09-30 14:27:14.734603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.c 2010-09-30 14:27:14.734603002 -0400
|
||||
@@ -0,0 +1,592 @@
|
||||
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 8 -*-
|
||||
+ *
|
||||
@ -655,8 +655,8 @@ diff -up gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.c.polkit
|
||||
+ return ret;
|
||||
+}
|
||||
diff -up gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.xml.polkit gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.xml
|
||||
--- gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.xml.polkit 2010-09-30 13:05:41.149603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.xml 2010-09-30 13:05:41.149603002 -0400
|
||||
--- gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.xml.polkit 2010-09-30 14:27:14.735603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.xml 2010-09-30 14:27:14.735603002 -0400
|
||||
@@ -0,0 +1,15 @@
|
||||
+<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
|
||||
+<node name="/">
|
||||
@ -675,7 +675,7 @@ diff -up gnome-system-monitor-2.28.2/src/gnome-system-monitor-mechanism.xml.polk
|
||||
+</node>
|
||||
diff -up gnome-system-monitor-2.28.2/src/interface.cpp.polkit gnome-system-monitor-2.28.2/src/interface.cpp
|
||||
--- gnome-system-monitor-2.28.2/src/interface.cpp.polkit 2010-02-09 08:23:26.000000000 -0500
|
||||
+++ gnome-system-monitor-2.28.2/src/interface.cpp 2010-09-30 13:05:41.151603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/interface.cpp 2010-09-30 14:27:14.737603002 -0400
|
||||
@@ -30,6 +30,10 @@
|
||||
#include <gdk/gdkkeysyms.h>
|
||||
#include <math.h>
|
||||
@ -802,7 +802,7 @@ diff -up gnome-system-monitor-2.28.2/src/interface.cpp.polkit gnome-system-monit
|
||||
static void
|
||||
diff -up gnome-system-monitor-2.28.2/src/Makefile.am.polkit gnome-system-monitor-2.28.2/src/Makefile.am
|
||||
--- gnome-system-monitor-2.28.2/src/Makefile.am.polkit 2010-02-09 08:23:26.000000000 -0500
|
||||
+++ gnome-system-monitor-2.28.2/src/Makefile.am 2010-09-30 13:05:41.153603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/Makefile.am 2010-09-30 14:27:14.739603002 -0400
|
||||
@@ -4,7 +4,9 @@ INCLUDES = \
|
||||
-DPROCMAN_DATADIR=\""$(datadir)/procman/"\" \
|
||||
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
|
||||
@ -874,8 +874,8 @@ diff -up gnome-system-monitor-2.28.2/src/Makefile.am.polkit gnome-system-monitor
|
||||
CLEANFILES = \
|
||||
$(schema_DATA)
|
||||
diff -up gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.conf.polkit gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.conf
|
||||
--- gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.conf.polkit 2010-09-30 13:05:41.154603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.conf 2010-09-30 13:05:41.154603002 -0400
|
||||
--- gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.conf.polkit 2010-09-30 14:27:14.740603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.conf 2010-09-30 14:27:14.740603002 -0400
|
||||
@@ -0,0 +1,15 @@
|
||||
+<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->
|
||||
+
|
||||
@ -893,16 +893,16 @@ diff -up gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.conf.
|
||||
+ </policy>
|
||||
+</busconfig>
|
||||
diff -up gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.service.in.polkit gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.service.in
|
||||
--- gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.service.in.polkit 2010-09-30 13:05:41.155603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.service.in 2010-09-30 13:05:41.155603002 -0400
|
||||
--- gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.service.in.polkit 2010-09-30 14:27:14.741603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/org.gnome.SystemMonitor.Mechanism.service.in 2010-09-30 14:27:14.741603002 -0400
|
||||
@@ -0,0 +1,4 @@
|
||||
+[D-BUS Service]
|
||||
+Name=org.gnome.SystemMonitor.Mechanism
|
||||
+Exec=libexecdir/gnome-system-monitor-mechanism
|
||||
+User=root
|
||||
diff -up gnome-system-monitor-2.28.2/src/org.gnome.system-monitor.policy.in.polkit gnome-system-monitor-2.28.2/src/org.gnome.system-monitor.policy.in
|
||||
--- gnome-system-monitor-2.28.2/src/org.gnome.system-monitor.policy.in.polkit 2010-09-30 13:05:41.156603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/org.gnome.system-monitor.policy.in 2010-09-30 13:05:41.156603002 -0400
|
||||
--- gnome-system-monitor-2.28.2/src/org.gnome.system-monitor.policy.in.polkit 2010-09-30 14:27:14.742603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/org.gnome.system-monitor.policy.in 2010-09-30 14:27:14.743603002 -0400
|
||||
@@ -0,0 +1,50 @@
|
||||
+<?xml version="1.0" encoding="utf-8"?>
|
||||
+
|
||||
@ -956,7 +956,7 @@ diff -up gnome-system-monitor-2.28.2/src/org.gnome.system-monitor.policy.in.polk
|
||||
+</policyconfig>
|
||||
diff -up gnome-system-monitor-2.28.2/src/procactions.cpp.polkit gnome-system-monitor-2.28.2/src/procactions.cpp
|
||||
--- gnome-system-monitor-2.28.2/src/procactions.cpp.polkit 2010-02-09 08:23:26.000000000 -0500
|
||||
+++ gnome-system-monitor-2.28.2/src/procactions.cpp 2010-09-30 13:05:41.157603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/procactions.cpp 2010-09-30 14:27:14.744603002 -0400
|
||||
@@ -31,6 +31,10 @@
|
||||
#include "procdialogs.h"
|
||||
#include "callbacks.h"
|
||||
@ -1071,7 +1071,7 @@ diff -up gnome-system-monitor-2.28.2/src/procactions.cpp.polkit gnome-system-mon
|
||||
+
|
||||
diff -up gnome-system-monitor-2.28.2/src/procdialogs.cpp.polkit gnome-system-monitor-2.28.2/src/procdialogs.cpp
|
||||
--- gnome-system-monitor-2.28.2/src/procdialogs.cpp.polkit 2010-09-27 19:13:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/procdialogs.cpp 2010-09-30 13:06:52.942602972 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/procdialogs.cpp 2010-09-30 14:27:49.183603015 -0400
|
||||
@@ -123,29 +123,34 @@ get_nice_level (gint nice)
|
||||
return _("(Very Low Priority)");
|
||||
}
|
||||
@ -1086,12 +1086,13 @@ diff -up gnome-system-monitor-2.28.2/src/procdialogs.cpp.polkit gnome-system-mon
|
||||
{
|
||||
- GtkWidget *label = GTK_WIDGET (data);
|
||||
-
|
||||
+ ReniceClosure *rc = (ReniceClosure *) data;
|
||||
+
|
||||
new_nice_value = int(gtk_adjustment_get_value (adj));
|
||||
- new_nice_value = int(gtk_adjustment_get_value (adj));
|
||||
- gtk_label_set_text (GTK_LABEL (label), get_nice_level (new_nice_value));
|
||||
-
|
||||
+‣‧‧‧‧‧‧gtk_label_set_text (GTK_LABEL (rc->priority_label), get_nice_level (new_nice_value));‣‧‧‣‧‧‧‧‧‧‧
|
||||
+ ReniceClosure *rc = (ReniceClosure *) data;
|
||||
+
|
||||
+ new_nice_value = int(gtk_adjustment_get_value (adj));
|
||||
+ gtk_label_set_text (GTK_LABEL (rc->priority_label), get_nice_level (new_nice_value));
|
||||
}
|
||||
|
||||
static void
|
||||
@ -1194,7 +1195,7 @@ diff -up gnome-system-monitor-2.28.2/src/procdialogs.cpp.polkit gnome-system-mon
|
||||
static void
|
||||
diff -up gnome-system-monitor-2.28.2/src/procman.cpp.polkit gnome-system-monitor-2.28.2/src/procman.cpp
|
||||
--- gnome-system-monitor-2.28.2/src/procman.cpp.polkit 2010-09-27 19:13:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/procman.cpp 2010-09-30 13:05:41.161603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/procman.cpp 2010-09-30 14:27:14.747603002 -0400
|
||||
@@ -36,6 +36,10 @@
|
||||
#include <glibtop/close.h>
|
||||
#include <glibtop/loadavg.h>
|
||||
@ -1235,7 +1236,7 @@ diff -up gnome-system-monitor-2.28.2/src/procman.cpp.polkit gnome-system-monitor
|
||||
ProcData* ProcData::get_instance()
|
||||
diff -up gnome-system-monitor-2.28.2/src/procman.h.polkit gnome-system-monitor-2.28.2/src/procman.h
|
||||
--- gnome-system-monitor-2.28.2/src/procman.h.polkit 2010-02-09 08:23:26.000000000 -0500
|
||||
+++ gnome-system-monitor-2.28.2/src/procman.h 2010-09-30 13:05:41.162603002 -0400
|
||||
+++ gnome-system-monitor-2.28.2/src/procman.h 2010-09-30 14:27:14.748603002 -0400
|
||||
@@ -33,6 +33,10 @@
|
||||
#include <map>
|
||||
#include <string>
|
||||
|
Loading…
Reference in New Issue
Block a user