fix patch
This commit is contained in:
parent
e3413953f5
commit
e9af21a4f1
@ -1,19 +1,21 @@
|
||||
diff -up gnome-system-monitor-2.23.90/configure.in.polkit gnome-system-monitor-2.23.90/configure.in
|
||||
--- gnome-system-monitor-2.23.90/configure.in.polkit 2008-08-18 11:25:22.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/configure.in 2008-08-22 23:24:58.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/configure.in 2008-08-22 23:58:35.000000000 -0400
|
||||
@@ -35,10 +35,41 @@ GIOMM_REQUIRED=2.16.0
|
||||
GLIBMM_REQUIRED=2.14
|
||||
LIBXML_REQUIRED=2.0
|
||||
RSVG_REQUIRED=2.12
|
||||
-DBUS_REQUIRED=0.7
|
||||
-
|
||||
-PKG_CHECK_MODULES(PROCMAN, glib-2.0 >= $GLIB_REQUIRED gconf-2.0 >= $GCONF_REQUIRED libgtop-2.0 >= $LIBGTOP_REQUIRED libwnck-1.0 >= $LIBWNCK_REQUIRED gtk+-2.0 >= $GTK_REQUIRED gnome-icon-theme >= $GNOME_ICON_THEME_REQUIRED gtkmm-2.4 >= $GTKMM_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED librsvg-2.0 >= $RSVG_REQUIRED glibmm-2.4 >= $GLIBMM_REQUIRED giomm-2.4 >= $GIOMM_REQUIRED dbus-glib-1 >= $DBUS_REQUIRED)
|
||||
+POLKIT_GNOME_REQUIRED=0.7
|
||||
+POLKIT_DBUS_REQUIRED=0.7
|
||||
+DBUS_GLIB_REQUIRED=0.71
|
||||
+DBUS_REQUIRED=1.1.2
|
||||
+
|
||||
|
||||
PKG_CHECK_MODULES(PROCMAN, glib-2.0 >= $GLIB_REQUIRED gconf-2.0 >= $GCONF_REQUIRED libgtop-2.0 >= $LIBGTOP_REQUIRED libwnck-1.0 >= $LIBWNCK_REQUIRED gtk+-2.0 >= $GTK_REQUIRED gnome-icon-theme >= $GNOME_ICON_THEME_REQUIRED gtkmm-2.4 >= $GTKMM_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED librsvg-2.0 >= $RSVG_REQUIRED glibmm-2.4 >= $GLIBMM_REQUIRED giomm-2.4 >= $GIOMM_REQUIRED dbus-glib-1 >= $DBUS_REQUIRED)
|
||||
|
||||
+
|
||||
+PKG_CHECK_MODULES(PROCMAN, glib-2.0 >= $GLIB_REQUIRED gconf-2.0 >= $GCONF_REQUIRED libgtop-2.0 >= $LIBGTOP_REQUIRED libwnck-1.0 >= $LIBWNCK_REQUIRED gtk+-2.0 >= $GTK_REQUIRED gnome-icon-theme >= $GNOME_ICON_THEME_REQUIRED gtkmm-2.4 >= $GTKMM_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED librsvg-2.0 >= $RSVG_REQUIRED glibmm-2.4 >= $GLIBMM_REQUIRED giomm-2.4 >= $GIOMM_REQUIRED dbus-glib-1 >= $DBUS_GLIB_REQUIRED)
|
||||
+
|
||||
+# PolicyKit detection; defaults to 'auto' (use it if it's available)
|
||||
+#
|
||||
+POLKIT_GNOME_CFLAGS=
|
||||
@ -26,7 +28,7 @@ diff -up gnome-system-monitor-2.23.90/configure.in.polkit gnome-system-monitor-2
|
||||
+else
|
||||
+ HAVE_POLKIT=no
|
||||
+ PKG_CHECK_MODULES(POLKIT_GNOME, polkit-gnome >= $POLKIT_GNOME_REQUIRED dbus-1 >= $DBUS_REQUIRED, HAVE_POLKIT=yes, HAVE_POLKIT=no)
|
||||
+
|
||||
|
||||
+ if test "x$enable_polkit" = "xyes" -a "x$HAVE_POLKIT" = "xno" ; then
|
||||
+ AC_MSG_ERROR(PolicyKit support explicity enabled but not available)
|
||||
+ fi
|
||||
@ -54,7 +56,7 @@ diff -up gnome-system-monitor-2.23.90/configure.in.polkit gnome-system-monitor-2
|
||||
"
|
||||
diff -up gnome-system-monitor-2.23.90/po/POTFILES.in.polkit gnome-system-monitor-2.23.90/po/POTFILES.in
|
||||
--- gnome-system-monitor-2.23.90/po/POTFILES.in.polkit 2008-08-18 12:15:12.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/po/POTFILES.in 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/po/POTFILES.in 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -8,6 +8,7 @@ src/callbacks.cpp
|
||||
src/defaulttable.h
|
||||
src/disks.cpp
|
||||
@ -65,7 +67,7 @@ diff -up gnome-system-monitor-2.23.90/po/POTFILES.in.polkit gnome-system-monitor
|
||||
src/interface.cpp
|
||||
diff -up gnome-system-monitor-2.23.90/src/callbacks.cpp.polkit gnome-system-monitor-2.23.90/src/callbacks.cpp
|
||||
--- gnome-system-monitor-2.23.90/src/callbacks.cpp.polkit 2008-04-22 17:55:31.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/callbacks.cpp 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/callbacks.cpp 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -37,25 +37,21 @@
|
||||
#include "disks.h"
|
||||
#include "lsof.h"
|
||||
@ -110,7 +112,7 @@ diff -up gnome-system-monitor-2.23.90/src/callbacks.cpp.polkit gnome-system-moni
|
||||
static void change_gconf_color(GConfClient *client, const char *key,
|
||||
diff -up /dev/null gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechanism.c
|
||||
--- /dev/null 2008-08-22 21:13:59.064267460 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechanism.c 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechanism.c 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -0,0 +1,640 @@
|
||||
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 8 -*-
|
||||
+ *
|
||||
@ -754,7 +756,7 @@ diff -up /dev/null gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechani
|
||||
+}
|
||||
diff -up /dev/null gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechanism.xml
|
||||
--- /dev/null 2008-08-22 21:13:59.064267460 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechanism.xml 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechanism.xml 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -0,0 +1,15 @@
|
||||
+<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
|
||||
+<node name="/">
|
||||
@ -773,7 +775,7 @@ diff -up /dev/null gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechani
|
||||
+</node>
|
||||
diff -up gnome-system-monitor-2.23.90/src/interface.cpp.polkit gnome-system-monitor-2.23.90/src/interface.cpp
|
||||
--- gnome-system-monitor-2.23.90/src/interface.cpp.polkit 2008-02-25 14:30:29.000000000 -0500
|
||||
+++ gnome-system-monitor-2.23.90/src/interface.cpp 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/interface.cpp 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -30,6 +30,10 @@
|
||||
#include <gdk/gdkkeysyms.h>
|
||||
#include <math.h>
|
||||
@ -929,7 +931,7 @@ diff -up gnome-system-monitor-2.23.90/src/interface.cpp.polkit gnome-system-moni
|
||||
static void
|
||||
diff -up gnome-system-monitor-2.23.90/src/Makefile.am.polkit gnome-system-monitor-2.23.90/src/Makefile.am
|
||||
--- gnome-system-monitor-2.23.90/src/Makefile.am.polkit 2008-08-08 15:55:59.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/Makefile.am 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/Makefile.am 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -4,7 +4,9 @@ INCLUDES = \
|
||||
-DPROCMAN_DATADIR=\""$(datadir)/procman/"\" \
|
||||
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
|
||||
@ -941,9 +943,13 @@ diff -up gnome-system-monitor-2.23.90/src/Makefile.am.polkit gnome-system-monito
|
||||
|
||||
bin_PROGRAMS = gnome-system-monitor
|
||||
|
||||
@@ -35,8 +37,11 @@ gnome_system_monitor_SOURCES = \
|
||||
@@ -33,10 +35,14 @@ gnome_system_monitor_SOURCES = \
|
||||
gconf-keys.cpp gconf-keys.h \
|
||||
iconthemewrapper.cpp iconthemewrapper.h \
|
||||
e_date.c e_date.h \
|
||||
gsm_color_button.c gsm_color_button.h
|
||||
- gsm_color_button.c gsm_color_button.h
|
||||
+ gsm_color_button.c gsm_color_button.h \
|
||||
+ gsm-session-manager.c gsm-session-manager.h
|
||||
|
||||
+if HAVE_POLKIT
|
||||
+gnome_system_monitor_SOURCES += gnome-system-monitor-mechanism-client-glue.h
|
||||
@ -954,7 +960,7 @@ diff -up gnome-system-monitor-2.23.90/src/Makefile.am.polkit gnome-system-monito
|
||||
|
||||
|
||||
noinst_LTLIBRARIES = libbacon.la
|
||||
@@ -52,8 +57,44 @@ schema_ins = gnome-system-monitor.schem
|
||||
@@ -52,8 +58,44 @@ schema_ins = gnome-system-monitor.schem
|
||||
schema_DATA = $(schema_ins:.schemas.in=.schemas)
|
||||
@INTLTOOL_SCHEMAS_RULE@
|
||||
|
||||
@ -1002,7 +1008,7 @@ diff -up gnome-system-monitor-2.23.90/src/Makefile.am.polkit gnome-system-monito
|
||||
$(schema_DATA)
|
||||
diff -up /dev/null gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mechanism.conf
|
||||
--- /dev/null 2008-08-22 21:13:59.064267460 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mechanism.conf 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mechanism.conf 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -0,0 +1,11 @@
|
||||
+<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->
|
||||
+
|
||||
@ -1017,7 +1023,7 @@ diff -up /dev/null gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mech
|
||||
+</busconfig>
|
||||
diff -up /dev/null gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mechanism.service.in
|
||||
--- /dev/null 2008-08-22 21:13:59.064267460 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mechanism.service.in 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mechanism.service.in 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -0,0 +1,4 @@
|
||||
+[D-BUS Service]
|
||||
+Name=org.gnome.SystemMonitor.Mechanism
|
||||
@ -1025,7 +1031,7 @@ diff -up /dev/null gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mech
|
||||
+User=root
|
||||
diff -up /dev/null gnome-system-monitor-2.23.90/src/org.gnome.system-monitor.policy.in
|
||||
--- /dev/null 2008-08-22 21:13:59.064267460 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/org.gnome.system-monitor.policy.in 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/org.gnome.system-monitor.policy.in 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -0,0 +1,50 @@
|
||||
+<?xml version="1.0" encoding="utf-8"?>
|
||||
+
|
||||
@ -1079,7 +1085,7 @@ diff -up /dev/null gnome-system-monitor-2.23.90/src/org.gnome.system-monitor.pol
|
||||
+</policyconfig>
|
||||
diff -up gnome-system-monitor-2.23.90/src/procactions.cpp.polkit gnome-system-monitor-2.23.90/src/procactions.cpp
|
||||
--- gnome-system-monitor-2.23.90/src/procactions.cpp.polkit 2007-01-02 17:15:36.000000000 -0500
|
||||
+++ gnome-system-monitor-2.23.90/src/procactions.cpp 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/procactions.cpp 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -31,6 +31,10 @@
|
||||
#include "procdialogs.h"
|
||||
#include "callbacks.h"
|
||||
@ -1194,7 +1200,7 @@ diff -up gnome-system-monitor-2.23.90/src/procactions.cpp.polkit gnome-system-mo
|
||||
+
|
||||
diff -up gnome-system-monitor-2.23.90/src/procdialogs.cpp.polkit gnome-system-monitor-2.23.90/src/procdialogs.cpp
|
||||
--- gnome-system-monitor-2.23.90/src/procdialogs.cpp.polkit 2008-05-23 17:44:00.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/procdialogs.cpp 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/procdialogs.cpp 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -35,6 +35,11 @@
|
||||
#include "procman_gnomesu.h"
|
||||
#include "procman_gksu.h"
|
||||
@ -1390,7 +1396,7 @@ diff -up gnome-system-monitor-2.23.90/src/procdialogs.cpp.polkit gnome-system-mo
|
||||
static void
|
||||
diff -up gnome-system-monitor-2.23.90/src/procman.cpp.polkit gnome-system-monitor-2.23.90/src/procman.cpp
|
||||
--- gnome-system-monitor-2.23.90/src/procman.cpp.polkit 2008-07-21 12:18:47.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/procman.cpp 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/procman.cpp 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -34,6 +34,10 @@
|
||||
#include <glibtop/close.h>
|
||||
#include <glibtop/loadavg.h>
|
||||
@ -1440,7 +1446,7 @@ diff -up gnome-system-monitor-2.23.90/src/procman.cpp.polkit gnome-system-monito
|
||||
ProcData* ProcData::get_instance()
|
||||
diff -up gnome-system-monitor-2.23.90/src/procman.h.polkit gnome-system-monitor-2.23.90/src/procman.h
|
||||
--- gnome-system-monitor-2.23.90/src/procman.h.polkit 2008-05-24 17:58:27.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/procman.h 2008-08-22 23:22:17.000000000 -0400
|
||||
+++ gnome-system-monitor-2.23.90/src/procman.h 2008-08-22 23:57:57.000000000 -0400
|
||||
@@ -33,6 +33,11 @@
|
||||
#include <map>
|
||||
#include <string>
|
||||
|
Loading…
Reference in New Issue
Block a user