Update to 44.beta
This commit is contained in:
parent
9ee7c87606
commit
7bb96b4745
1
.gitignore
vendored
1
.gitignore
vendored
@ -124,3 +124,4 @@ gnome-system-monitor-2.28.1.tar.bz2
|
||||
/gnome-system-monitor-42.alpha.tar.xz
|
||||
/gnome-system-monitor-42.rc.tar.xz
|
||||
/gnome-system-monitor-42.0.tar.xz
|
||||
/gnome-system-monitor-44.beta.tar.xz
|
||||
|
@ -1,19 +1,19 @@
|
||||
Submitted upstream:
|
||||
From 3be21b4cd1b70e184375061f2d944f6f73e9a3a7 Mon Sep 17 00:00:00 2001
|
||||
From: Florian Weimer <fweimer@redhat.com>
|
||||
Date: Mon, 6 Feb 2023 08:36:22 +0100
|
||||
Subject: [PATCH] meson: Remove unused ctime_r check
|
||||
|
||||
<https://gitlab.gnome.org/GNOME/gnome-system-monitor/-/merge_requests/67>
|
||||
|
||||
Author: Florian Weimer <fweimer@redhat.com>
|
||||
Date: Mon Feb 6 08:36:22 2023 +0100
|
||||
|
||||
meson: Remove unused ctime_r check
|
||||
|
||||
It did not work because of an implicit function declaration
|
||||
(<time.h> does not declare ctime_r due to -std=c11, which disables
|
||||
GNU extensions). The only use of CTIME_R_THREE_ARGS was #if'ed out,
|
||||
so remove that as well.
|
||||
It did not work because of an implicit function declaration
|
||||
(<time.h> does not declare ctime_r due to -std=c11, which disables
|
||||
GNU extensions). The only use of CTIME_R_THREE_ARGS was #if'ed out,
|
||||
so remove that as well.
|
||||
---
|
||||
meson.build | 10 ----------
|
||||
src/legacy/e_date.c | 7 -------
|
||||
2 files changed, 17 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index a314a684b2a9ceb4..985a361a60b08240 100644
|
||||
index d5d221e3..ab4c7944 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -105,16 +105,6 @@ add_project_arguments(cx.get_supported_arguments(cxxflags),
|
||||
@ -34,20 +34,23 @@ index a314a684b2a9ceb4..985a361a60b08240 100644
|
||||
output: 'config.h',
|
||||
configuration: conf,
|
||||
diff --git a/src/legacy/e_date.c b/src/legacy/e_date.c
|
||||
index 2697e892c7463357..71d0b5214b6d15cf 100644
|
||||
index 19f6d631..2fdaa1c7 100644
|
||||
--- a/src/legacy/e_date.c
|
||||
+++ b/src/legacy/e_date.c
|
||||
@@ -194,13 +194,6 @@ filter_date (time_t date)
|
||||
e_utf8_strftime_fix_am_pm (buf, 26, _("%b %d %Y"), &then);
|
||||
}
|
||||
@@ -220,13 +220,6 @@ filter_date (time_t date)
|
||||
else
|
||||
e_utf8_strftime_fix_am_pm (buf, 26, _("%b %d %Y"), &then);
|
||||
}
|
||||
-#if 0
|
||||
-#ifdef CTIME_R_THREE_ARGS
|
||||
- ctime_r (&date, buf, 26);
|
||||
- ctime_r (&date, buf, 26);
|
||||
-#else
|
||||
- ctime_r (&date, buf);
|
||||
- ctime_r (&date, buf);
|
||||
-#endif
|
||||
-#endif
|
||||
|
||||
return g_strdup (buf);
|
||||
return g_strdup (buf);
|
||||
}
|
||||
--
|
||||
GitLab
|
||||
|
||||
|
@ -4,13 +4,13 @@
|
||||
%global tarball_version %%(echo %{version} | tr '~' '.')
|
||||
|
||||
Name: gnome-system-monitor
|
||||
Version: 42.0
|
||||
Release: 4%{?dist}
|
||||
Version: 44~beta
|
||||
Release: 1%{?dist}
|
||||
Summary: Process and resource monitor
|
||||
|
||||
License: GPLv2+
|
||||
License: GPL-2.0-or-later
|
||||
URL: https://wiki.gnome.org/Apps/SystemMonitor
|
||||
Source0: https://download.gnome.org/sources/%{name}/42/%{name}-%{tarball_version}.tar.xz
|
||||
Source0: https://download.gnome.org/sources/%{name}/44/%{name}-%{tarball_version}.tar.xz
|
||||
Patch0: gnome-system-monitor-c99.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
@ -64,11 +64,14 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/gnome-system-monit
|
||||
%{_datadir}/icons/hicolor/scalable/apps/org.gnome.SystemMonitor*.svg
|
||||
%{_datadir}/icons/hicolor/symbolic/apps/org.gnome.SystemMonitor-symbolic.svg
|
||||
%{_datadir}/icons/hicolor/symbolic/apps/speedometer-symbolic.svg
|
||||
%{_datadir}/metainfo/gnome-system-monitor.appdata.xml
|
||||
%{_metainfodir}/gnome-system-monitor.appdata.xml
|
||||
%{_datadir}/polkit-1/actions/org.gnome.gnome-system-monitor.policy
|
||||
%{_libexecdir}/gnome-system-monitor/
|
||||
|
||||
%changelog
|
||||
* Thu Feb 16 2023 David King <amigadave@amigadave.com> - 44~beta-1
|
||||
- Update to 44.beta
|
||||
|
||||
* Mon Feb 06 2023 Florian Weimer <fweimer@redhat.com> - 42.0-4
|
||||
- Fix C99 compatibility issue
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gnome-system-monitor-42.0.tar.xz) = 880093fd75a87993ff8def1db9f6f090edaad43c6dc08564f61b9dbfa8c10df5e6d6a9a9072737d802503b34ba70de7bf7ef5aab2bf055ea68e795ec11a48bdd
|
||||
SHA512 (gnome-system-monitor-44.beta.tar.xz) = 4d30cf1a8c9c464a5a24d023c31c9f8c1a751a663d3d4752c2ce642c01abbce0924027cc9d0355a7d3d7d73158d188e55aa3854106ac40a72adbe4f3a15921e9
|
||||
|
Loading…
Reference in New Issue
Block a user