update patch
This commit is contained in:
parent
61a05134dd
commit
6c7957e94f
@ -1,6 +1,6 @@
|
|||||||
diff -up gnome-system-monitor-2.23.90/configure.in.polkit gnome-system-monitor-2.23.90/configure.in
|
diff -up gnome-system-monitor-2.25.91/configure.in.polkit gnome-system-monitor-2.25.91/configure.in
|
||||||
--- gnome-system-monitor-2.23.90/configure.in.polkit 2008-08-18 11:25:22.000000000 -0400
|
--- gnome-system-monitor-2.25.91/configure.in.polkit 2009-02-16 13:07:36.000000000 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/configure.in 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/configure.in 2009-02-19 01:04:23.775985963 -0500
|
||||||
@@ -35,10 +35,41 @@ GIOMM_REQUIRED=2.16.0
|
@@ -35,10 +35,41 @@ GIOMM_REQUIRED=2.16.0
|
||||||
GLIBMM_REQUIRED=2.14
|
GLIBMM_REQUIRED=2.14
|
||||||
LIBXML_REQUIRED=2.0
|
LIBXML_REQUIRED=2.0
|
||||||
@ -54,9 +54,9 @@ diff -up gnome-system-monitor-2.23.90/configure.in.polkit gnome-system-monitor-2
|
|||||||
Maintainer mode: ${USER_MAINTAINER_MODE}
|
Maintainer mode: ${USER_MAINTAINER_MODE}
|
||||||
Languages: ${ALL_LINGUAS}
|
Languages: ${ALL_LINGUAS}
|
||||||
"
|
"
|
||||||
diff -up gnome-system-monitor-2.23.90/po/POTFILES.in.polkit gnome-system-monitor-2.23.90/po/POTFILES.in
|
diff -up gnome-system-monitor-2.25.91/po/POTFILES.in.polkit gnome-system-monitor-2.25.91/po/POTFILES.in
|
||||||
--- gnome-system-monitor-2.23.90/po/POTFILES.in.polkit 2008-08-18 12:15:12.000000000 -0400
|
--- gnome-system-monitor-2.25.91/po/POTFILES.in.polkit 2009-02-16 13:36:20.000000000 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/po/POTFILES.in 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/po/POTFILES.in 2009-02-19 01:04:23.777985747 -0500
|
||||||
@@ -8,6 +8,7 @@ src/callbacks.cpp
|
@@ -8,6 +8,7 @@ src/callbacks.cpp
|
||||||
src/defaulttable.h
|
src/defaulttable.h
|
||||||
src/disks.cpp
|
src/disks.cpp
|
||||||
@ -65,38 +65,10 @@ diff -up gnome-system-monitor-2.23.90/po/POTFILES.in.polkit gnome-system-monitor
|
|||||||
src/gnome-system-monitor.schemas.in
|
src/gnome-system-monitor.schemas.in
|
||||||
src/gsm_color_button.c
|
src/gsm_color_button.c
|
||||||
src/interface.cpp
|
src/interface.cpp
|
||||||
diff -up gnome-system-monitor-2.23.90/src/callbacks.cpp.polkit gnome-system-monitor-2.23.90/src/callbacks.cpp
|
diff -up gnome-system-monitor-2.25.91/src/callbacks.cpp.polkit gnome-system-monitor-2.25.91/src/callbacks.cpp
|
||||||
--- gnome-system-monitor-2.23.90/src/callbacks.cpp.polkit 2008-04-22 17:55:31.000000000 -0400
|
--- gnome-system-monitor-2.25.91/src/callbacks.cpp.polkit 2009-01-20 16:00:27.000000000 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/src/callbacks.cpp 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/callbacks.cpp 2009-02-19 01:04:23.779986089 -0500
|
||||||
@@ -37,25 +37,21 @@
|
@@ -210,11 +210,13 @@ cb_app_delete (GtkWidget *window, GdkEve
|
||||||
#include "disks.h"
|
|
||||||
#include "lsof.h"
|
|
||||||
|
|
||||||
-
|
|
||||||
void
|
|
||||||
cb_kill_sigstop(GtkAction *action, gpointer data)
|
|
||||||
{
|
|
||||||
ProcData * const procdata = static_cast<ProcData*>(data);
|
|
||||||
|
|
||||||
- /* no confirmation */
|
|
||||||
+ /* no confirmation */
|
|
||||||
kill_process (procdata, SIGSTOP);
|
|
||||||
}
|
|
||||||
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-
|
|
||||||
void
|
|
||||||
cb_kill_sigcont(GtkAction *action, gpointer data)
|
|
||||||
{
|
|
||||||
ProcData * const procdata = static_cast<ProcData*>(data);
|
|
||||||
|
|
||||||
- /* no confirmation */
|
|
||||||
+ /* no confirmation */
|
|
||||||
kill_process (procdata, SIGCONT);
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -210,11 +206,13 @@ cb_app_delete (GtkWidget *window, GdkEve
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
@ -110,9 +82,9 @@ diff -up gnome-system-monitor-2.23.90/src/callbacks.cpp.polkit gnome-system-moni
|
|||||||
|
|
||||||
|
|
||||||
static void change_gconf_color(GConfClient *client, const char *key,
|
static void change_gconf_color(GConfClient *client, const char *key,
|
||||||
diff -up /dev/null gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechanism.c
|
diff -up /dev/null gnome-system-monitor-2.25.91/src/gnome-system-monitor-mechanism.c
|
||||||
--- /dev/null 2008-08-23 00:44:06.022255656 -0400
|
--- /dev/null 2009-02-18 21:36:54.364015287 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechanism.c 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/gnome-system-monitor-mechanism.c 2009-02-19 01:04:23.785987256 -0500
|
||||||
@@ -0,0 +1,640 @@
|
@@ -0,0 +1,640 @@
|
||||||
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 8 -*-
|
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 8 -*-
|
||||||
+ *
|
+ *
|
||||||
@ -754,9 +726,9 @@ diff -up /dev/null gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechani
|
|||||||
+out:
|
+out:
|
||||||
+ return ret;
|
+ return ret;
|
||||||
+}
|
+}
|
||||||
diff -up /dev/null gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechanism.xml
|
diff -up /dev/null gnome-system-monitor-2.25.91/src/gnome-system-monitor-mechanism.xml
|
||||||
--- /dev/null 2008-08-23 00:44:06.022255656 -0400
|
--- /dev/null 2009-02-18 21:36:54.364015287 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechanism.xml 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/gnome-system-monitor-mechanism.xml 2009-02-19 01:04:23.788989062 -0500
|
||||||
@@ -0,0 +1,15 @@
|
@@ -0,0 +1,15 @@
|
||||||
+<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
|
+<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
|
||||||
+<node name="/">
|
+<node name="/">
|
||||||
@ -773,9 +745,9 @@ diff -up /dev/null gnome-system-monitor-2.23.90/src/gnome-system-monitor-mechani
|
|||||||
+ </method>
|
+ </method>
|
||||||
+ </interface>
|
+ </interface>
|
||||||
+</node>
|
+</node>
|
||||||
diff -up gnome-system-monitor-2.23.90/src/interface.cpp.polkit gnome-system-monitor-2.23.90/src/interface.cpp
|
diff -up gnome-system-monitor-2.25.91/src/interface.cpp.polkit gnome-system-monitor-2.25.91/src/interface.cpp
|
||||||
--- gnome-system-monitor-2.23.90/src/interface.cpp.polkit 2008-02-25 14:30:29.000000000 -0500
|
--- gnome-system-monitor-2.25.91/src/interface.cpp.polkit 2009-01-24 05:37:45.000000000 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/src/interface.cpp 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/interface.cpp 2009-02-19 01:04:23.792990166 -0500
|
||||||
@@ -30,6 +30,10 @@
|
@@ -30,6 +30,10 @@
|
||||||
#include <gdk/gdkkeysyms.h>
|
#include <gdk/gdkkeysyms.h>
|
||||||
#include <math.h>
|
#include <math.h>
|
||||||
@ -929,9 +901,9 @@ diff -up gnome-system-monitor-2.23.90/src/interface.cpp.polkit gnome-system-moni
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void
|
static void
|
||||||
diff -up gnome-system-monitor-2.23.90/src/Makefile.am.polkit gnome-system-monitor-2.23.90/src/Makefile.am
|
diff -up gnome-system-monitor-2.25.91/src/Makefile.am.polkit gnome-system-monitor-2.25.91/src/Makefile.am
|
||||||
--- gnome-system-monitor-2.23.90/src/Makefile.am.polkit 2008-08-08 15:55:59.000000000 -0400
|
--- gnome-system-monitor-2.25.91/src/Makefile.am.polkit 2008-08-08 15:55:59.000000000 -0400
|
||||||
+++ gnome-system-monitor-2.23.90/src/Makefile.am 2008-08-23 01:19:51.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/Makefile.am 2009-02-19 01:04:23.800988043 -0500
|
||||||
@@ -4,7 +4,9 @@ INCLUDES = \
|
@@ -4,7 +4,9 @@ INCLUDES = \
|
||||||
-DPROCMAN_DATADIR=\""$(datadir)/procman/"\" \
|
-DPROCMAN_DATADIR=\""$(datadir)/procman/"\" \
|
||||||
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
|
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
|
||||||
@ -1002,9 +974,9 @@ diff -up gnome-system-monitor-2.23.90/src/Makefile.am.polkit gnome-system-monito
|
|||||||
|
|
||||||
CLEANFILES = \
|
CLEANFILES = \
|
||||||
$(schema_DATA)
|
$(schema_DATA)
|
||||||
diff -up /dev/null gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mechanism.conf
|
diff -up /dev/null gnome-system-monitor-2.25.91/src/org.gnome.SystemMonitor.Mechanism.conf
|
||||||
--- /dev/null 2008-08-23 00:44:06.022255656 -0400
|
--- /dev/null 2009-02-18 21:36:54.364015287 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mechanism.conf 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/org.gnome.SystemMonitor.Mechanism.conf 2009-02-19 01:04:23.801989995 -0500
|
||||||
@@ -0,0 +1,11 @@
|
@@ -0,0 +1,11 @@
|
||||||
+<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->
|
+<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->
|
||||||
+
|
+
|
||||||
@ -1017,17 +989,17 @@ diff -up /dev/null gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mech
|
|||||||
+ <allow own="org.gnome.SystemMonitor.Mechanism"/>
|
+ <allow own="org.gnome.SystemMonitor.Mechanism"/>
|
||||||
+ </policy>
|
+ </policy>
|
||||||
+</busconfig>
|
+</busconfig>
|
||||||
diff -up /dev/null gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mechanism.service.in
|
diff -up /dev/null gnome-system-monitor-2.25.91/src/org.gnome.SystemMonitor.Mechanism.service.in
|
||||||
--- /dev/null 2008-08-23 00:44:06.022255656 -0400
|
--- /dev/null 2009-02-18 21:36:54.364015287 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/src/org.gnome.SystemMonitor.Mechanism.service.in 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/org.gnome.SystemMonitor.Mechanism.service.in 2009-02-19 01:04:23.802984823 -0500
|
||||||
@@ -0,0 +1,4 @@
|
@@ -0,0 +1,4 @@
|
||||||
+[D-BUS Service]
|
+[D-BUS Service]
|
||||||
+Name=org.gnome.SystemMonitor.Mechanism
|
+Name=org.gnome.SystemMonitor.Mechanism
|
||||||
+Exec=libexecdir/gnome-system-monitor-mechanism
|
+Exec=libexecdir/gnome-system-monitor-mechanism
|
||||||
+User=root
|
+User=root
|
||||||
diff -up /dev/null gnome-system-monitor-2.23.90/src/org.gnome.system-monitor.policy.in
|
diff -up /dev/null gnome-system-monitor-2.25.91/src/org.gnome.system-monitor.policy.in
|
||||||
--- /dev/null 2008-08-23 00:44:06.022255656 -0400
|
--- /dev/null 2009-02-18 21:36:54.364015287 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/src/org.gnome.system-monitor.policy.in 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/org.gnome.system-monitor.policy.in 2009-02-19 01:04:23.803984610 -0500
|
||||||
@@ -0,0 +1,50 @@
|
@@ -0,0 +1,50 @@
|
||||||
+<?xml version="1.0" encoding="utf-8"?>
|
+<?xml version="1.0" encoding="utf-8"?>
|
||||||
+
|
+
|
||||||
@ -1079,9 +1051,9 @@ diff -up /dev/null gnome-system-monitor-2.23.90/src/org.gnome.system-monitor.pol
|
|||||||
+ </action>
|
+ </action>
|
||||||
+
|
+
|
||||||
+</policyconfig>
|
+</policyconfig>
|
||||||
diff -up gnome-system-monitor-2.23.90/src/procactions.cpp.polkit gnome-system-monitor-2.23.90/src/procactions.cpp
|
diff -up gnome-system-monitor-2.25.91/src/procactions.cpp.polkit gnome-system-monitor-2.25.91/src/procactions.cpp
|
||||||
--- gnome-system-monitor-2.23.90/src/procactions.cpp.polkit 2007-01-02 17:15:36.000000000 -0500
|
--- gnome-system-monitor-2.25.91/src/procactions.cpp.polkit 2007-01-02 17:15:36.000000000 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/src/procactions.cpp 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/procactions.cpp 2009-02-19 01:04:23.804984817 -0500
|
||||||
@@ -31,6 +31,10 @@
|
@@ -31,6 +31,10 @@
|
||||||
#include "procdialogs.h"
|
#include "procdialogs.h"
|
||||||
#include "callbacks.h"
|
#include "callbacks.h"
|
||||||
@ -1194,9 +1166,9 @@ diff -up gnome-system-monitor-2.23.90/src/procactions.cpp.polkit gnome-system-mo
|
|||||||
proctable_update_all (procdata);
|
proctable_update_all (procdata);
|
||||||
}
|
}
|
||||||
+
|
+
|
||||||
diff -up gnome-system-monitor-2.23.90/src/procdialogs.cpp.polkit gnome-system-monitor-2.23.90/src/procdialogs.cpp
|
diff -up gnome-system-monitor-2.25.91/src/procdialogs.cpp.polkit gnome-system-monitor-2.25.91/src/procdialogs.cpp
|
||||||
--- gnome-system-monitor-2.23.90/src/procdialogs.cpp.polkit 2008-05-23 17:44:00.000000000 -0400
|
--- gnome-system-monitor-2.25.91/src/procdialogs.cpp.polkit 2008-05-23 17:44:00.000000000 -0400
|
||||||
+++ gnome-system-monitor-2.23.90/src/procdialogs.cpp 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/procdialogs.cpp 2009-02-19 01:04:23.805984464 -0500
|
||||||
@@ -35,6 +35,11 @@
|
@@ -35,6 +35,11 @@
|
||||||
#include "procman_gnomesu.h"
|
#include "procman_gnomesu.h"
|
||||||
#include "procman_gksu.h"
|
#include "procman_gksu.h"
|
||||||
@ -1390,10 +1362,10 @@ diff -up gnome-system-monitor-2.23.90/src/procdialogs.cpp.polkit gnome-system-mo
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void
|
static void
|
||||||
diff -up gnome-system-monitor-2.23.90/src/procman.cpp.polkit gnome-system-monitor-2.23.90/src/procman.cpp
|
diff -up gnome-system-monitor-2.25.91/src/procman.cpp.polkit gnome-system-monitor-2.25.91/src/procman.cpp
|
||||||
--- gnome-system-monitor-2.23.90/src/procman.cpp.polkit 2008-07-21 12:18:47.000000000 -0400
|
--- gnome-system-monitor-2.25.91/src/procman.cpp.polkit 2009-01-03 07:06:10.000000000 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/src/procman.cpp 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/procman.cpp 2009-02-19 01:04:23.807984667 -0500
|
||||||
@@ -34,6 +34,10 @@
|
@@ -36,6 +36,10 @@
|
||||||
#include <glibtop/close.h>
|
#include <glibtop/close.h>
|
||||||
#include <glibtop/loadavg.h>
|
#include <glibtop/loadavg.h>
|
||||||
|
|
||||||
@ -1404,7 +1376,7 @@ diff -up gnome-system-monitor-2.23.90/src/procman.cpp.polkit gnome-system-monito
|
|||||||
#include "load-graph.h"
|
#include "load-graph.h"
|
||||||
#include "procman.h"
|
#include "procman.h"
|
||||||
#include "interface.h"
|
#include "interface.h"
|
||||||
@@ -56,7 +60,34 @@ ProcData::ProcData()
|
@@ -58,7 +62,34 @@ ProcData::ProcData()
|
||||||
disk_timeout(0),
|
disk_timeout(0),
|
||||||
cpu_total_time(1),
|
cpu_total_time(1),
|
||||||
cpu_total_time_last(1)
|
cpu_total_time_last(1)
|
||||||
@ -1440,9 +1412,9 @@ diff -up gnome-system-monitor-2.23.90/src/procman.cpp.polkit gnome-system-monito
|
|||||||
|
|
||||||
|
|
||||||
ProcData* ProcData::get_instance()
|
ProcData* ProcData::get_instance()
|
||||||
diff -up gnome-system-monitor-2.23.90/src/procman.h.polkit gnome-system-monitor-2.23.90/src/procman.h
|
diff -up gnome-system-monitor-2.25.91/src/procman.h.polkit gnome-system-monitor-2.25.91/src/procman.h
|
||||||
--- gnome-system-monitor-2.23.90/src/procman.h.polkit 2008-05-24 17:58:27.000000000 -0400
|
--- gnome-system-monitor-2.25.91/src/procman.h.polkit 2009-01-20 15:53:35.000000000 -0500
|
||||||
+++ gnome-system-monitor-2.23.90/src/procman.h 2008-08-23 01:19:36.000000000 -0400
|
+++ gnome-system-monitor-2.25.91/src/procman.h 2009-02-19 01:04:23.808984593 -0500
|
||||||
@@ -33,6 +33,11 @@
|
@@ -33,6 +33,11 @@
|
||||||
#include <map>
|
#include <map>
|
||||||
#include <string>
|
#include <string>
|
Loading…
Reference in New Issue
Block a user