Update to 45.alpha

This commit is contained in:
Kalev Lember 2023-07-03 13:54:07 +02:00
parent a46c8654b7
commit 62b1500d6a
4 changed files with 7 additions and 60 deletions

1
.gitignore vendored
View File

@ -127,3 +127,4 @@ gnome-system-monitor-2.28.1.tar.bz2
/gnome-system-monitor-44.beta.tar.xz
/gnome-system-monitor-44.rc.tar.xz
/gnome-system-monitor-44.0.tar.xz
/gnome-system-monitor-45.alpha.tar.xz

View File

@ -1,56 +0,0 @@
From 3be21b4cd1b70e184375061f2d944f6f73e9a3a7 Mon Sep 17 00:00:00 2001
From: Florian Weimer <fweimer@redhat.com>
Date: Mon, 6 Feb 2023 08:36:22 +0100
Subject: [PATCH] meson: Remove unused ctime_r check
It did not work because of an implicit function declaration
(<time.h> does not declare ctime_r due to -std=c11, which disables
GNU extensions). The only use of CTIME_R_THREE_ARGS was #if'ed out,
so remove that as well.
---
meson.build | 10 ----------
src/legacy/e_date.c | 7 -------
2 files changed, 17 deletions(-)
diff --git a/meson.build b/meson.build
index d5d221e3..ab4c7944 100644
--- a/meson.build
+++ b/meson.build
@@ -105,16 +105,6 @@ add_project_arguments(cx.get_supported_arguments(cxxflags),
conf.set('HAVE_LKSTRFTIME', cc.has_function('strftime'))
-conf.set('CTIME_R_THREE_ARGS', cc.compiles('''
-#include <time.h>
-int main() {
- char *buf;
- time_t date;
- ctime_r (&date, buf, 100);
-}
-'''))
-
-
configure_file(
output: 'config.h',
configuration: conf,
diff --git a/src/legacy/e_date.c b/src/legacy/e_date.c
index 19f6d631..2fdaa1c7 100644
--- a/src/legacy/e_date.c
+++ b/src/legacy/e_date.c
@@ -220,13 +220,6 @@ filter_date (time_t date)
else
e_utf8_strftime_fix_am_pm (buf, 26, _("%b %d %Y"), &then);
}
-#if 0
-#ifdef CTIME_R_THREE_ARGS
- ctime_r (&date, buf, 26);
-#else
- ctime_r (&date, buf);
-#endif
-#endif
return g_strdup (buf);
}
--
GitLab

View File

@ -4,14 +4,13 @@
%global tarball_version %%(echo %{version} | tr '~' '.')
Name: gnome-system-monitor
Version: 44.0
Version: 45~alpha
Release: 1%{?dist}
Summary: Process and resource monitor
License: GPL-2.0-or-later
URL: https://wiki.gnome.org/Apps/SystemMonitor
Source0: https://download.gnome.org/sources/%{name}/44/%{name}-%{tarball_version}.tar.xz
Patch0: gnome-system-monitor-c99.patch
Source0: https://download.gnome.org/sources/%{name}/45/%{name}-%{tarball_version}.tar.xz
BuildRequires: gcc
BuildRequires: gcc-c++
@ -69,6 +68,9 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/gnome-system-monit
%{_libexecdir}/gnome-system-monitor/
%changelog
* Mon Jul 03 2023 Kalev Lember <klember@redhat.com> - 45~alpha-1
- Update to 45.alpha
* Sat Mar 18 2023 David King <amigadave@amigadave.com> - 44.0-1
- Update to 44.0

View File

@ -1 +1 @@
SHA512 (gnome-system-monitor-44.0.tar.xz) = 052dcdc927ad53ea601f1f3da6a921fe21b04f69aaa8b75a5096fdcdac5706391180c476b5c87a98012fa7b5dc6c5c43b8c88c30a38b12868c4188020e8ec3b8
SHA512 (gnome-system-monitor-45.alpha.tar.xz) = 7bf4f37ac207d2c04f66eb54d6ef36c971d8667bf1cded9e34aa46f203acd7516e4406b4d100a3aa99ddb39d52a17be88e8d4463355b72e2a36a9459f87c7b75