Build against newer GConf/intltool
This commit is contained in:
parent
c773c24c45
commit
5f4d8866e6
@ -1,6 +1,6 @@
|
|||||||
diff -up gnome-system-monitor-2.25.91/configure.in.polkit gnome-system-monitor-2.25.91/configure.in
|
diff -up gnome-system-monitor-2.26.1/configure.in.polkit gnome-system-monitor-2.26.1/configure.in
|
||||||
--- gnome-system-monitor-2.25.91/configure.in.polkit 2009-02-16 13:07:36.000000000 -0500
|
--- gnome-system-monitor-2.26.1/configure.in.polkit 2009-04-10 18:33:14.000000000 -0400
|
||||||
+++ gnome-system-monitor-2.25.91/configure.in 2009-02-19 01:04:23.775985963 -0500
|
+++ gnome-system-monitor-2.26.1/configure.in 2009-04-23 15:01:02.779508852 -0400
|
||||||
@@ -35,10 +35,41 @@ GIOMM_REQUIRED=2.16.0
|
@@ -35,10 +35,41 @@ GIOMM_REQUIRED=2.16.0
|
||||||
GLIBMM_REQUIRED=2.14
|
GLIBMM_REQUIRED=2.14
|
||||||
LIBXML_REQUIRED=2.0
|
LIBXML_REQUIRED=2.0
|
||||||
@ -54,9 +54,9 @@ diff -up gnome-system-monitor-2.25.91/configure.in.polkit gnome-system-monitor-2
|
|||||||
Maintainer mode: ${USER_MAINTAINER_MODE}
|
Maintainer mode: ${USER_MAINTAINER_MODE}
|
||||||
Languages: ${ALL_LINGUAS}
|
Languages: ${ALL_LINGUAS}
|
||||||
"
|
"
|
||||||
diff -up gnome-system-monitor-2.25.91/po/POTFILES.in.polkit gnome-system-monitor-2.25.91/po/POTFILES.in
|
diff -up gnome-system-monitor-2.26.1/po/POTFILES.in.polkit gnome-system-monitor-2.26.1/po/POTFILES.in
|
||||||
--- gnome-system-monitor-2.25.91/po/POTFILES.in.polkit 2009-02-16 13:36:20.000000000 -0500
|
--- gnome-system-monitor-2.26.1/po/POTFILES.in.polkit 2009-04-13 15:36:22.000000000 -0400
|
||||||
+++ gnome-system-monitor-2.25.91/po/POTFILES.in 2009-02-19 01:04:23.777985747 -0500
|
+++ gnome-system-monitor-2.26.1/po/POTFILES.in 2009-04-23 15:01:02.779508852 -0400
|
||||||
@@ -8,6 +8,7 @@ src/callbacks.cpp
|
@@ -8,6 +8,7 @@ src/callbacks.cpp
|
||||||
src/defaulttable.h
|
src/defaulttable.h
|
||||||
src/disks.cpp
|
src/disks.cpp
|
||||||
@ -65,9 +65,9 @@ diff -up gnome-system-monitor-2.25.91/po/POTFILES.in.polkit gnome-system-monitor
|
|||||||
src/gnome-system-monitor.schemas.in
|
src/gnome-system-monitor.schemas.in
|
||||||
src/gsm_color_button.c
|
src/gsm_color_button.c
|
||||||
src/interface.cpp
|
src/interface.cpp
|
||||||
diff -up gnome-system-monitor-2.25.91/src/callbacks.cpp.polkit gnome-system-monitor-2.25.91/src/callbacks.cpp
|
diff -up gnome-system-monitor-2.26.1/src/callbacks.cpp.polkit gnome-system-monitor-2.26.1/src/callbacks.cpp
|
||||||
--- gnome-system-monitor-2.25.91/src/callbacks.cpp.polkit 2009-01-20 16:00:27.000000000 -0500
|
--- gnome-system-monitor-2.26.1/src/callbacks.cpp.polkit 2009-01-20 16:00:27.000000000 -0500
|
||||||
+++ gnome-system-monitor-2.25.91/src/callbacks.cpp 2009-02-19 01:04:23.779986089 -0500
|
+++ gnome-system-monitor-2.26.1/src/callbacks.cpp 2009-04-23 15:01:24.243745907 -0400
|
||||||
@@ -210,11 +210,13 @@ cb_app_delete (GtkWidget *window, GdkEve
|
@@ -210,11 +210,13 @@ cb_app_delete (GtkWidget *window, GdkEve
|
||||||
|
|
||||||
|
|
||||||
@ -82,9 +82,17 @@ diff -up gnome-system-monitor-2.25.91/src/callbacks.cpp.polkit gnome-system-moni
|
|||||||
|
|
||||||
|
|
||||||
static void change_gconf_color(GConfClient *client, const char *key,
|
static void change_gconf_color(GConfClient *client, const char *key,
|
||||||
diff -up /dev/null gnome-system-monitor-2.25.91/src/gnome-system-monitor-mechanism.c
|
@@ -286,6 +288,7 @@ cb_row_selected (GtkTreeSelection *selec
|
||||||
--- /dev/null 2009-02-18 21:36:54.364015287 -0500
|
ProcData * const procdata = static_cast<ProcData*>(data);
|
||||||
+++ gnome-system-monitor-2.25.91/src/gnome-system-monitor-mechanism.c 2009-02-19 01:04:23.785987256 -0500
|
|
||||||
|
procdata->selection = selection;
|
||||||
|
+ procdata->selected_process = NULL;
|
||||||
|
|
||||||
|
/* get the most recent selected process and determine if there are
|
||||||
|
** no selected processes
|
||||||
|
diff -up /dev/null gnome-system-monitor-2.26.1/src/gnome-system-monitor-mechanism.c
|
||||||
|
--- /dev/null 2009-04-23 10:50:49.279044520 -0400
|
||||||
|
+++ gnome-system-monitor-2.26.1/src/gnome-system-monitor-mechanism.c 2009-04-23 15:01:02.782492856 -0400
|
||||||
@@ -0,0 +1,640 @@
|
@@ -0,0 +1,640 @@
|
||||||
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 8 -*-
|
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 8 -*-
|
||||||
+ *
|
+ *
|
||||||
@ -726,9 +734,9 @@ diff -up /dev/null gnome-system-monitor-2.25.91/src/gnome-system-monitor-mechani
|
|||||||
+out:
|
+out:
|
||||||
+ return ret;
|
+ return ret;
|
||||||
+}
|
+}
|
||||||
diff -up /dev/null gnome-system-monitor-2.25.91/src/gnome-system-monitor-mechanism.xml
|
diff -up /dev/null gnome-system-monitor-2.26.1/src/gnome-system-monitor-mechanism.xml
|
||||||
--- /dev/null 2009-02-18 21:36:54.364015287 -0500
|
--- /dev/null 2009-04-23 10:50:49.279044520 -0400
|
||||||
+++ gnome-system-monitor-2.25.91/src/gnome-system-monitor-mechanism.xml 2009-02-19 01:04:23.788989062 -0500
|
+++ gnome-system-monitor-2.26.1/src/gnome-system-monitor-mechanism.xml 2009-04-23 15:01:02.782492856 -0400
|
||||||
@@ -0,0 +1,15 @@
|
@@ -0,0 +1,15 @@
|
||||||
+<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
|
+<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
|
||||||
+<node name="/">
|
+<node name="/">
|
||||||
@ -745,9 +753,9 @@ diff -up /dev/null gnome-system-monitor-2.25.91/src/gnome-system-monitor-mechani
|
|||||||
+ </method>
|
+ </method>
|
||||||
+ </interface>
|
+ </interface>
|
||||||
+</node>
|
+</node>
|
||||||
diff -up gnome-system-monitor-2.25.91/src/interface.cpp.polkit gnome-system-monitor-2.25.91/src/interface.cpp
|
diff -up gnome-system-monitor-2.26.1/src/interface.cpp.polkit gnome-system-monitor-2.26.1/src/interface.cpp
|
||||||
--- gnome-system-monitor-2.25.91/src/interface.cpp.polkit 2009-01-24 05:37:45.000000000 -0500
|
--- gnome-system-monitor-2.26.1/src/interface.cpp.polkit 2009-04-10 18:33:14.000000000 -0400
|
||||||
+++ gnome-system-monitor-2.25.91/src/interface.cpp 2009-02-19 01:04:23.792990166 -0500
|
+++ gnome-system-monitor-2.26.1/src/interface.cpp 2009-04-23 15:02:01.567746154 -0400
|
||||||
@@ -30,6 +30,10 @@
|
@@ -30,6 +30,10 @@
|
||||||
#include <gdk/gdkkeysyms.h>
|
#include <gdk/gdkkeysyms.h>
|
||||||
#include <math.h>
|
#include <math.h>
|
||||||
@ -867,15 +875,14 @@ diff -up gnome-system-monitor-2.25.91/src/interface.cpp.polkit gnome-system-moni
|
|||||||
for (i = 0; i != G_N_ELEMENTS(selected_actions); ++i) {
|
for (i = 0; i != G_N_ELEMENTS(selected_actions); ++i) {
|
||||||
action = gtk_action_group_get_action(data->action_group,
|
action = gtk_action_group_get_action(data->action_group,
|
||||||
selected_actions[i]);
|
selected_actions[i]);
|
||||||
- gtk_action_set_sensitive(action, selected_sensitivity);
|
|
||||||
+#ifdef HAVE_POLKIT
|
+#ifdef HAVE_POLKIT
|
||||||
+ if (POLKIT_GNOME_IS_ACTION (action)) {
|
+ if (POLKIT_GNOME_IS_ACTION (action)) {
|
||||||
+ polkit_gnome_action_set_sensitive (POLKIT_GNOME_ACTION (action), processes_sensitivity);
|
+ polkit_gnome_action_set_sensitive (POLKIT_GNOME_ACTION (action), selected_sensitivity);
|
||||||
+ } else {
|
+ } else {
|
||||||
+ gtk_action_set_sensitive(action, processes_sensitivity);
|
+ gtk_action_set_sensitive(action, selected_sensitivity);
|
||||||
+ }
|
+ }
|
||||||
+#else
|
+#else
|
||||||
+ gtk_action_set_sensitive(action, processes_sensitivity);
|
gtk_action_set_sensitive(action, selected_sensitivity);
|
||||||
+#endif
|
+#endif
|
||||||
}
|
}
|
||||||
+
|
+
|
||||||
@ -901,9 +908,9 @@ diff -up gnome-system-monitor-2.25.91/src/interface.cpp.polkit gnome-system-moni
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void
|
static void
|
||||||
diff -up gnome-system-monitor-2.25.91/src/Makefile.am.polkit gnome-system-monitor-2.25.91/src/Makefile.am
|
diff -up gnome-system-monitor-2.26.1/src/Makefile.am.polkit gnome-system-monitor-2.26.1/src/Makefile.am
|
||||||
--- gnome-system-monitor-2.25.91/src/Makefile.am.polkit 2008-08-08 15:55:59.000000000 -0400
|
--- gnome-system-monitor-2.26.1/src/Makefile.am.polkit 2008-08-08 15:55:59.000000000 -0400
|
||||||
+++ gnome-system-monitor-2.25.91/src/Makefile.am 2009-02-19 01:04:23.800988043 -0500
|
+++ gnome-system-monitor-2.26.1/src/Makefile.am 2009-04-23 15:01:02.784504169 -0400
|
||||||
@@ -4,7 +4,9 @@ INCLUDES = \
|
@@ -4,7 +4,9 @@ INCLUDES = \
|
||||||
-DPROCMAN_DATADIR=\""$(datadir)/procman/"\" \
|
-DPROCMAN_DATADIR=\""$(datadir)/procman/"\" \
|
||||||
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
|
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
|
||||||
@ -974,9 +981,9 @@ diff -up gnome-system-monitor-2.25.91/src/Makefile.am.polkit gnome-system-monito
|
|||||||
|
|
||||||
CLEANFILES = \
|
CLEANFILES = \
|
||||||
$(schema_DATA)
|
$(schema_DATA)
|
||||||
diff -up /dev/null gnome-system-monitor-2.25.91/src/org.gnome.SystemMonitor.Mechanism.conf
|
diff -up /dev/null gnome-system-monitor-2.26.1/src/org.gnome.SystemMonitor.Mechanism.conf
|
||||||
--- /dev/null 2009-02-18 21:36:54.364015287 -0500
|
--- /dev/null 2009-04-23 10:50:49.279044520 -0400
|
||||||
+++ gnome-system-monitor-2.25.91/src/org.gnome.SystemMonitor.Mechanism.conf 2009-02-19 01:04:23.801989995 -0500
|
+++ gnome-system-monitor-2.26.1/src/org.gnome.SystemMonitor.Mechanism.conf 2009-04-23 15:01:02.786494180 -0400
|
||||||
@@ -0,0 +1,11 @@
|
@@ -0,0 +1,11 @@
|
||||||
+<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->
|
+<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->
|
||||||
+
|
+
|
||||||
@ -989,17 +996,17 @@ diff -up /dev/null gnome-system-monitor-2.25.91/src/org.gnome.SystemMonitor.Mech
|
|||||||
+ <allow own="org.gnome.SystemMonitor.Mechanism"/>
|
+ <allow own="org.gnome.SystemMonitor.Mechanism"/>
|
||||||
+ </policy>
|
+ </policy>
|
||||||
+</busconfig>
|
+</busconfig>
|
||||||
diff -up /dev/null gnome-system-monitor-2.25.91/src/org.gnome.SystemMonitor.Mechanism.service.in
|
diff -up /dev/null gnome-system-monitor-2.26.1/src/org.gnome.SystemMonitor.Mechanism.service.in
|
||||||
--- /dev/null 2009-02-18 21:36:54.364015287 -0500
|
--- /dev/null 2009-04-23 10:50:49.279044520 -0400
|
||||||
+++ gnome-system-monitor-2.25.91/src/org.gnome.SystemMonitor.Mechanism.service.in 2009-02-19 01:04:23.802984823 -0500
|
+++ gnome-system-monitor-2.26.1/src/org.gnome.SystemMonitor.Mechanism.service.in 2009-04-23 15:01:02.786494180 -0400
|
||||||
@@ -0,0 +1,4 @@
|
@@ -0,0 +1,4 @@
|
||||||
+[D-BUS Service]
|
+[D-BUS Service]
|
||||||
+Name=org.gnome.SystemMonitor.Mechanism
|
+Name=org.gnome.SystemMonitor.Mechanism
|
||||||
+Exec=libexecdir/gnome-system-monitor-mechanism
|
+Exec=libexecdir/gnome-system-monitor-mechanism
|
||||||
+User=root
|
+User=root
|
||||||
diff -up /dev/null gnome-system-monitor-2.25.91/src/org.gnome.system-monitor.policy.in
|
diff -up /dev/null gnome-system-monitor-2.26.1/src/org.gnome.system-monitor.policy.in
|
||||||
--- /dev/null 2009-02-18 21:36:54.364015287 -0500
|
--- /dev/null 2009-04-23 10:50:49.279044520 -0400
|
||||||
+++ gnome-system-monitor-2.25.91/src/org.gnome.system-monitor.policy.in 2009-02-19 01:04:23.803984610 -0500
|
+++ gnome-system-monitor-2.26.1/src/org.gnome.system-monitor.policy.in 2009-04-23 15:01:02.787520999 -0400
|
||||||
@@ -0,0 +1,50 @@
|
@@ -0,0 +1,50 @@
|
||||||
+<?xml version="1.0" encoding="utf-8"?>
|
+<?xml version="1.0" encoding="utf-8"?>
|
||||||
+
|
+
|
||||||
@ -1051,9 +1058,9 @@ diff -up /dev/null gnome-system-monitor-2.25.91/src/org.gnome.system-monitor.pol
|
|||||||
+ </action>
|
+ </action>
|
||||||
+
|
+
|
||||||
+</policyconfig>
|
+</policyconfig>
|
||||||
diff -up gnome-system-monitor-2.25.91/src/procactions.cpp.polkit gnome-system-monitor-2.25.91/src/procactions.cpp
|
diff -up gnome-system-monitor-2.26.1/src/procactions.cpp.polkit gnome-system-monitor-2.26.1/src/procactions.cpp
|
||||||
--- gnome-system-monitor-2.25.91/src/procactions.cpp.polkit 2007-01-02 17:15:36.000000000 -0500
|
--- gnome-system-monitor-2.26.1/src/procactions.cpp.polkit 2007-01-02 17:15:36.000000000 -0500
|
||||||
+++ gnome-system-monitor-2.25.91/src/procactions.cpp 2009-02-19 01:04:23.804984817 -0500
|
+++ gnome-system-monitor-2.26.1/src/procactions.cpp 2009-04-23 15:01:02.788493760 -0400
|
||||||
@@ -31,6 +31,10 @@
|
@@ -31,6 +31,10 @@
|
||||||
#include "procdialogs.h"
|
#include "procdialogs.h"
|
||||||
#include "callbacks.h"
|
#include "callbacks.h"
|
||||||
@ -1166,9 +1173,9 @@ diff -up gnome-system-monitor-2.25.91/src/procactions.cpp.polkit gnome-system-mo
|
|||||||
proctable_update_all (procdata);
|
proctable_update_all (procdata);
|
||||||
}
|
}
|
||||||
+
|
+
|
||||||
diff -up gnome-system-monitor-2.25.91/src/procdialogs.cpp.polkit gnome-system-monitor-2.25.91/src/procdialogs.cpp
|
diff -up gnome-system-monitor-2.26.1/src/procdialogs.cpp.polkit gnome-system-monitor-2.26.1/src/procdialogs.cpp
|
||||||
--- gnome-system-monitor-2.25.91/src/procdialogs.cpp.polkit 2008-05-23 17:44:00.000000000 -0400
|
--- gnome-system-monitor-2.26.1/src/procdialogs.cpp.polkit 2008-05-23 17:44:00.000000000 -0400
|
||||||
+++ gnome-system-monitor-2.25.91/src/procdialogs.cpp 2009-02-19 01:04:23.805984464 -0500
|
+++ gnome-system-monitor-2.26.1/src/procdialogs.cpp 2009-04-23 15:01:02.789493899 -0400
|
||||||
@@ -35,6 +35,11 @@
|
@@ -35,6 +35,11 @@
|
||||||
#include "procman_gnomesu.h"
|
#include "procman_gnomesu.h"
|
||||||
#include "procman_gksu.h"
|
#include "procman_gksu.h"
|
||||||
@ -1362,9 +1369,9 @@ diff -up gnome-system-monitor-2.25.91/src/procdialogs.cpp.polkit gnome-system-mo
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void
|
static void
|
||||||
diff -up gnome-system-monitor-2.25.91/src/procman.cpp.polkit gnome-system-monitor-2.25.91/src/procman.cpp
|
diff -up gnome-system-monitor-2.26.1/src/procman.cpp.polkit gnome-system-monitor-2.26.1/src/procman.cpp
|
||||||
--- gnome-system-monitor-2.25.91/src/procman.cpp.polkit 2009-01-03 07:06:10.000000000 -0500
|
--- gnome-system-monitor-2.26.1/src/procman.cpp.polkit 2009-03-31 17:57:18.000000000 -0400
|
||||||
+++ gnome-system-monitor-2.25.91/src/procman.cpp 2009-02-19 01:04:23.807984667 -0500
|
+++ gnome-system-monitor-2.26.1/src/procman.cpp 2009-04-23 15:01:02.790494038 -0400
|
||||||
@@ -36,6 +36,10 @@
|
@@ -36,6 +36,10 @@
|
||||||
#include <glibtop/close.h>
|
#include <glibtop/close.h>
|
||||||
#include <glibtop/loadavg.h>
|
#include <glibtop/loadavg.h>
|
||||||
@ -1412,9 +1419,9 @@ diff -up gnome-system-monitor-2.25.91/src/procman.cpp.polkit gnome-system-monito
|
|||||||
|
|
||||||
|
|
||||||
ProcData* ProcData::get_instance()
|
ProcData* ProcData::get_instance()
|
||||||
diff -up gnome-system-monitor-2.25.91/src/procman.h.polkit gnome-system-monitor-2.25.91/src/procman.h
|
diff -up gnome-system-monitor-2.26.1/src/procman.h.polkit gnome-system-monitor-2.26.1/src/procman.h
|
||||||
--- gnome-system-monitor-2.25.91/src/procman.h.polkit 2009-01-20 15:53:35.000000000 -0500
|
--- gnome-system-monitor-2.26.1/src/procman.h.polkit 2009-01-20 15:53:35.000000000 -0500
|
||||||
+++ gnome-system-monitor-2.25.91/src/procman.h 2009-02-19 01:04:23.808984593 -0500
|
+++ gnome-system-monitor-2.26.1/src/procman.h 2009-04-23 15:01:02.791493688 -0400
|
||||||
@@ -33,6 +33,11 @@
|
@@ -33,6 +33,11 @@
|
||||||
#include <map>
|
#include <map>
|
||||||
#include <string>
|
#include <string>
|
||||||
|
@ -13,7 +13,7 @@
|
|||||||
Summary: Process and resource monitor
|
Summary: Process and resource monitor
|
||||||
Name: gnome-system-monitor
|
Name: gnome-system-monitor
|
||||||
Version: 2.26.1
|
Version: 2.26.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://www.gnome.org/
|
URL: http://www.gnome.org/
|
||||||
@ -144,6 +144,10 @@ scrollkeeper-update -q
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 27 2009 Matthias Clasen <mclasen@redhat.com> - 2.26.1-2
|
||||||
|
- Rebuild against newer GConf/intltool
|
||||||
|
- Pick up fixes from F-11
|
||||||
|
|
||||||
* Mon Apr 13 2009 Matthias Clasen <mclasen@redhat.com> - 2.26.1-1
|
* Mon Apr 13 2009 Matthias Clasen <mclasen@redhat.com> - 2.26.1-1
|
||||||
- Update to 2.26.1
|
- Update to 2.26.1
|
||||||
- See http://download.gnome.org/sources/gnome-system-monitor/2.26/gnome-system-monitor-2.26.1.news
|
- See http://download.gnome.org/sources/gnome-system-monitor/2.26/gnome-system-monitor-2.26.1.news
|
||||||
|
Loading…
Reference in New Issue
Block a user