Resolves: RHEL-58962 (Rebase to 47.0)

This also includes a gnome-app-list appstream file from the version 1.0 of it.
This commit is contained in:
Milan Crha 2024-09-16 13:33:45 +02:00
parent ec2cfe6840
commit ea7112e8c8
5 changed files with 1508 additions and 41 deletions

View File

@ -0,0 +1,123 @@
diff -up gnome-software-47.0/meson.build.without-help gnome-software-47.0/meson.build
--- gnome-software-47.0/meson.build.without-help 2024-09-16 12:08:30.314978903 +0200
+++ gnome-software-47.0/meson.build 2024-09-16 12:08:44.681170496 +0200
@@ -314,7 +314,6 @@ if get_option('external_appstream')
endif
subdir('po')
subdir('doc')
-subdir('help')
# FIXME: remove when https://github.com/mesonbuild/meson/issues/837 fixed
meson.add_install_script('meson_post_install.sh')
diff -up gnome-software-47.0/plugins/epiphany/gs-plugin-epiphany.c.without-help gnome-software-47.0/plugins/epiphany/gs-plugin-epiphany.c
--- gnome-software-47.0/plugins/epiphany/gs-plugin-epiphany.c.without-help 2024-09-16 12:11:54.253698750 +0200
+++ gnome-software-47.0/plugins/epiphany/gs-plugin-epiphany.c 2024-09-16 12:12:11.827933131 +0200
@@ -413,8 +413,6 @@ gs_epiphany_refine_app_state (GsPlugin *
gs_app_set_state (app, GS_APP_STATE_AVAILABLE);
else {
gs_app_set_state (app, GS_APP_STATE_UNAVAILABLE);
- gs_app_set_url_missing (app,
- "help:gnome-software/how-to-reinstall-a-web-app");
}
}
}
diff -up gnome-software-47.0/src/gs-age-rating-context-dialog.ui.without-help gnome-software-47.0/src/gs-age-rating-context-dialog.ui
--- gnome-software-47.0/src/gs-age-rating-context-dialog.ui.without-help 2024-09-16 12:13:52.655277823 +0200
+++ gnome-software-47.0/src/gs-age-rating-context-dialog.ui 2024-09-16 12:13:56.668331343 +0200
@@ -56,6 +56,8 @@
</child>
<child>
<object class="AdwPreferencesGroup">
+ <property name="visible">False</property>
+ <property name="sensitive">False</property>
<child>
<object class="AdwButtonRow">
<property name="title" translatable="yes">_How to contribute missing information</property>
diff -up gnome-software-47.0/src/gs-details-page.c.without-help gnome-software-47.0/src/gs-details-page.c
--- gnome-software-47.0/src/gs-details-page.c.without-help 2024-09-16 12:22:07.020871002 +0200
+++ gnome-software-47.0/src/gs-details-page.c 2024-09-16 12:22:56.795534829 +0200
@@ -626,27 +626,18 @@ gs_details_page_license_tile_get_involve
uri = gs_app_get_url (self->app, AS_URL_KIND_HOMEPAGE);
} else {
if (gs_app_get_license (self->app) == NULL) {
- uri = "help:gnome-software/software-metadata#license";
+ /* would show help URI */
} else {
license_url = as_get_license_url (gs_app_get_license (self->app));
if (license_url != NULL && *license_url != '\0') {
uri = license_url;
- } else {
- /* Page to explain the differences between FOSS and proprietary
- * software. This is a page on the gnome-software wiki for now,
- * so that we can update the content independently of the release
- * cycle. Likely, we will link to a more authoritative source
- * to explain the differences.
- * Ultimately, we could ship a user manual page to explain the
- * differences (so that its available offline), but thats too
- * much work for right now. */
- uri = "help:gnome-software/software-licensing";
}
}
}
- gs_shell_show_uri (self->shell, uri);
+ if (uri != NULL)
+ gs_shell_show_uri (self->shell, uri);
}
static void
diff -up gnome-software-47.0/src/gs-hardware-support-context-dialog.ui.without-help gnome-software-47.0/src/gs-hardware-support-context-dialog.ui
--- gnome-software-47.0/src/gs-hardware-support-context-dialog.ui.without-help 2024-09-16 12:23:52.542278301 +0200
+++ gnome-software-47.0/src/gs-hardware-support-context-dialog.ui 2024-09-16 12:24:00.332382197 +0200
@@ -58,6 +58,8 @@
</child>
<child>
<object class="AdwPreferencesGroup">
+ <property name="visible">False</property>
+ <property name="sensitive">False</property>
<child>
<object class="AdwButtonRow">
<property name="title" translatable="yes">_How to contribute missing information</property>
diff -up gnome-software-47.0/src/gs-license-tile.c.without-help gnome-software-47.0/src/gs-license-tile.c
--- gnome-software-47.0/src/gs-license-tile.c.without-help 2024-09-16 12:19:52.028070653 +0200
+++ gnome-software-47.0/src/gs-license-tile.c 2024-09-16 12:20:58.089951698 +0200
@@ -150,7 +150,7 @@ gs_license_tile_refresh (GsLicenseTile *
lozenge_icon_names[0] = "community-blocked-symbolic";
lozenge_icon_names[1] = "dialog-warning-symbolic";
lozenge_icon_names[2] = "software-license-symbolic";
- get_involved_visible = TRUE;
+ get_involved_visible = FALSE;
get_involved_label = _("_Learn More");
if (is_application) {
@@ -168,7 +168,7 @@ gs_license_tile_refresh (GsLicenseTile *
lozenge_icon_names[0] = "community-blocked-symbolic";
lozenge_icon_names[1] = "proprietary-code-symbolic";
lozenge_icon_names[2] = "software-license-symbolic";
- get_involved_visible = TRUE;
+ get_involved_visible = FALSE;
get_involved_label = _("_Learn More");
if (is_application) {
@@ -218,7 +218,7 @@ gs_license_tile_refresh (GsLicenseTile *
license_url,
license_spdx);
} else {
- get_involved_visible = TRUE;
+ get_involved_visible = FALSE;
/* Translators: The placeholder here is the name of a software license. */
description = g_strdup_printf (_("This software is developed under the special license “%s”."
"\n\n"
diff -up gnome-software-47.0/src/gs-safety-context-dialog.ui.without-help gnome-software-47.0/src/gs-safety-context-dialog.ui
--- gnome-software-47.0/src/gs-safety-context-dialog.ui.without-help 2024-09-16 12:24:27.198740507 +0200
+++ gnome-software-47.0/src/gs-safety-context-dialog.ui 2024-09-16 12:25:48.974831126 +0200
@@ -121,6 +121,8 @@
<child>
<object class="AdwPreferencesGroup">
+ <property name="visible">False</property>
+ <property name="sensitive">False</property>
<child>
<object class="AdwButtonRow">
<property name="title" translatable="yes">_How to contribute missing information</property>

View File

@ -1,15 +0,0 @@
diff --git a/plugins/fedora-langpacks/gs-plugin-fedora-langpacks.c b/plugins/fedora-langpacks/gs-plugin-fedora-langpacks.c
index ae91005bed..39780cc061 100644
--- a/plugins/fedora-langpacks/gs-plugin-fedora-langpacks.c
+++ b/plugins/fedora-langpacks/gs-plugin-fedora-langpacks.c
@@ -30,7 +30,8 @@ gs_plugin_fedora_langpacks_init (GsPluginFedoraLangpacks *self)
GsPlugin *plugin = GS_PLUGIN (self);
/* this plugin should be fedora specific */
- if (!gs_plugin_check_distro_id (plugin, "fedora")) {
+ if (!gs_plugin_check_distro_id (plugin, "fedora") &&
+ !gs_plugin_check_distro_id (plugin, "rhel")) {
gs_plugin_set_enabled (plugin, FALSE);
return;
}

View File

@ -2,9 +2,9 @@
%global flatpak_version 1.9.1
%global fwupd_version 1.5.6
%global glib2_version 2.70.0
%global gtk4_version 4.10.0
%global gtk4_version 4.14.0
%global json_glib_version 1.6.0
%global libadwaita_version 1.3.alpha
%global libadwaita_version 1.6~alpha
%global libxmlb_version 0.1.7
%global packagekit_version 1.2.5
@ -14,30 +14,31 @@
%bcond malcontent %[!0%{?rhel}]
# Disable rpm-ostree support for RHEL builds
%bcond rpmostree %[!0%{?rhel}]
# this is to be able to disable fedora-langpacks subpackage build
%bcond langpacks %[1]
# Disable DKMS/akmods support for RHEL builds
%bcond dkms %[!0%{?rhel}]
# this is not a library version
%define gs_plugin_version 20
%define gs_plugin_version 21
%global tarball_version %%(echo %{version} | tr '~' '.')
%global __provides_exclude_from ^%{_libdir}/%{name}/plugins-%{gs_plugin_version}/.*\\.so.*$
Name: gnome-software
Version: 46.4
Version: 47.0
Release: 1%{?dist}
Summary: A software center for GNOME
License: GPL-2.0-or-later
URL: https://apps.gnome.org/Software
Source0: https://download.gnome.org/sources/gnome-software/46/%{name}-%{tarball_version}.tar.xz
Source0: https://download.gnome.org/sources/gnome-software/47/%{name}-%{tarball_version}.tar.xz
Source1: org.gnome.App-list-1.0.xml
Patch: 0001-fedora-langpacks-for-rhel.patch
Patch: 0001-Disable-build-and-use-of-help-files.patch
# ostree and flatpak not on i686 for RHEL 10
# ostree and flatpak not on i686 for Fedora and RHEL 10
# https://github.com/containers/composefs/pull/229#issuecomment-1838735764
%if 0%{?rhel} >= 10
%if 0%{?fedora} || 0%{?rhel} >= 10
ExcludeArch: %{ix86}
%endif
@ -46,6 +47,9 @@ BuildRequires: desktop-file-utils
BuildRequires: gcc
BuildRequires: gettext
BuildRequires: gtk-doc
%if !0%{?rhel}
BuildRequires: itstool
%endif
BuildRequires: libxslt
BuildRequires: meson
BuildRequires: pkgconfig(appstream) >= %{appstream_version}
@ -84,6 +88,9 @@ Requires: flatpak%{?_isa} >= %{flatpak_version}
Requires: flatpak-libs%{?_isa} >= %{flatpak_version}
Requires: fwupd%{?_isa} >= %{fwupd_version}
Requires: glib2%{?_isa} >= %{glib2_version}
%if !0%{?rhel}
Requires: gnome-app-list
%endif
# gnome-menus is needed for app folder .directory entries
Requires: gnome-menus%{?_isa}
Requires: gsettings-desktop-schemas%{?_isa}
@ -94,9 +101,7 @@ Requires: librsvg2%{?_isa}
Requires: libxmlb%{?_isa} >= %{libxmlb_version}
Recommends: PackageKit%{?_isa} >= %{packagekit_version}
%if %{with langpacks}
Recommends: %{name}-fedora-langpacks
%endif
Obsoletes: gnome-software-snap < 3.33.1
Obsoletes: gnome-software-editor < 3.35.1
@ -113,7 +118,6 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
These development files are for building gnome-software plugins outside
the source tree. Most users do not need this subpackage installed.
%if %{with langpacks}
%package fedora-langpacks
Summary: Contains fedora-langpacks plugin
Requires: %{name}%{?_isa} = %{version}-%{release}
@ -121,7 +125,6 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
%description fedora-langpacks
The fedora-langpacks plugin ensures langpacks packages are installed
for the current locale.
%endif
%if %{with rpmostree}
%package rpm-ostree
@ -166,6 +169,11 @@ This package includes the rpm-ostree backend.
-Dwebapps=false \
-Dhardcoded_foss_webapps=false \
-Dhardcoded_proprietary_webapps=false \
%endif
%if %{with dkms}
-Ddkms=true \
%else
-Ddkms=false \
%endif
-Dtests=false
%meson_build
@ -173,12 +181,9 @@ This package includes the rpm-ostree backend.
%install
%meson_install
# remove unneeded dpkg plugin
# remove unneeded dpkg and dummy plugins
rm %{buildroot}%{_libdir}/gnome-software/plugins-%{gs_plugin_version}/libgs_plugin_dpkg.so
%if !%{with langpacks}
rm %{buildroot}%{_libdir}/gnome-software/plugins-%{gs_plugin_version}/libgs_plugin_fedora-langpacks.so
%endif
rm %{buildroot}%{_libdir}/gnome-software/plugins-%{gs_plugin_version}/libgs_plugin_dummy.so
# make the software center load faster
desktop-file-edit %{buildroot}%{_datadir}/applications/org.gnome.Software.desktop \
@ -196,6 +201,12 @@ packaging-format-preference = [ 'flatpak:fedora-testing', 'flatpak:fedora', 'rpm
%endif
FOE
%if 0%{?rhel}
# install gnome-app-list appstream data
mkdir -p %{buildroot}%{_datadir}/swcatalog/xml 2>/dev/null
cp %{S:1} %{buildroot}%{_datadir}/swcatalog/xml/
%endif
%find_lang %name --with-gnome
%check
@ -213,7 +224,15 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
%{_mandir}/man1/gnome-software.1*
%{_datadir}/icons/hicolor/*/apps/org.gnome.Software.svg
%{_datadir}/icons/hicolor/symbolic/apps/org.gnome.Software-symbolic.svg
%{_datadir}/icons/hicolor/scalable/actions/app-remove-symbolic.svg
%{_datadir}/icons/hicolor/scalable/categories/system-component-addon.svg
%{_datadir}/icons/hicolor/scalable/categories/system-component-application.svg
%{_datadir}/icons/hicolor/scalable/categories/system-component-codecs.svg
%{_datadir}/icons/hicolor/scalable/categories/system-component-driver.svg
%{_datadir}/icons/hicolor/scalable/categories/system-component-firmware.svg
%{_datadir}/icons/hicolor/scalable/categories/system-component-input-sources.svg
%{_datadir}/icons/hicolor/scalable/categories/system-component-language.svg
%{_datadir}/icons/hicolor/scalable/categories/system-component-os-updates.svg
%{_datadir}/icons/hicolor/scalable/categories/system-component-runtime.svg
%{_datadir}/metainfo/org.gnome.Software.metainfo.xml
%if %{with webapps}
%{_datadir}/metainfo/org.gnome.Software.Plugin.Epiphany.metainfo.xml
@ -223,7 +242,6 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
%dir %{_libdir}/gnome-software/plugins-%{gs_plugin_version}
%{_libdir}/gnome-software/libgnomesoftware.so.%{gs_plugin_version}
%{_libdir}/gnome-software/plugins-%{gs_plugin_version}/libgs_plugin_appstream.so
%{_libdir}/gnome-software/plugins-%{gs_plugin_version}/libgs_plugin_dummy.so
%if %{with webapps}
%{_libdir}/gnome-software/plugins-%{gs_plugin_version}/libgs_plugin_epiphany.so
%endif
@ -248,8 +266,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
%if %{with webapps}
%{_datadir}/swcatalog/xml/gnome-pwa-list-foss.xml
%endif
%{_datadir}/swcatalog/xml/org.gnome.Software.Curated.xml
%{_datadir}/swcatalog/xml/org.gnome.Software.Featured.xml
%if 0%{?rhel}
%{_datadir}/swcatalog/xml/org.gnome.App-list-1.0.xml
%endif
%{_datadir}/dbus-1/services/org.freedesktop.PackageKit.service
%{_datadir}/dbus-1/services/org.gnome.Software.service
%{_datadir}/gnome-shell/search-providers/org.gnome.Software-search-provider.ini
@ -258,10 +277,14 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
%{_libexecdir}/gnome-software-cmd
%{_libexecdir}/gnome-software-restarter
%if %{with langpacks}
%if %{with dkms}
%{_datadir}/polkit-1/actions/org.gnome.software.dkms-helper.policy
%{_libdir}/gnome-software/plugins-%{gs_plugin_version}/libgs_plugin_dkms.so
%{_libexecdir}/gnome-software-dkms-helper
%endif
%files fedora-langpacks
%{_libdir}/gnome-software/plugins-%{gs_plugin_version}/libgs_plugin_fedora-langpacks.so
%endif
%if %{with rpmostree}
%files rpm-ostree
@ -278,6 +301,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
%{_datadir}/gtk-doc/html/gnome-software/
%changelog
* Mon Sep 16 2024 Milan Crha <mcrha@redhat.com> - 47.0-1
- Resolves: RHEL-58962 (Rebase to 47.0)
* Mon Aug 19 2024 Milan Crha <mcrha@redhat.com> - 46.4-1
- Resolves: RHEL-52807 (Update to 46.4)

1333
org.gnome.App-list-1.0.xml Normal file

File diff suppressed because it is too large Load Diff

View File

@ -1 +1 @@
SHA512 (gnome-software-46.4.tar.xz) = 148cdb3d3b3b0d74e00adcc066cf85fc20f86d9196def5132dfbb7b579464abe12c199d7f45b289d980ea634ddbce677be7588e2600a5f08ccd4630276a78799
SHA512 (gnome-software-47.0.tar.xz) = 0aac8e2f9803fbdef9e07c798d3171eb6267090fc1ffcbe1e4888e2499a50c28ec4a817ec82205f1eeb4e3220f11920ff045b817b692c8b1f8e5edbdbd82b6b9