Update to 47.alpha

Resolves: https://issues.redhat.com/browse/RHEL-49583
This commit is contained in:
Florian Müllner 2024-07-23 10:13:02 -06:00
parent 4a276ed986
commit ecab994da7
No known key found for this signature in database
18 changed files with 84 additions and 84 deletions

1
.gitignore vendored
View File

@ -228,3 +228,4 @@ gnome-shell-2.31.5.tar.bz2
/gnome-shell-46.1.tar.xz
/gnome-shell-46.2.tar.xz
/gnome-shell-46.3.1.tar.xz
/gnome-shell-47.alpha.tar.xz

View File

@ -1,4 +1,4 @@
From 45ffbb8caf46465608fb4de883114e94f1128b12 Mon Sep 17 00:00:00 2001
From 55c1dfed04084e9dbaf034263172bc745f905718 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 20 May 2015 16:44:00 +0200
Subject: [PATCH] app: Fall back to window title instead of WM_CLASS
@ -11,10 +11,10 @@ a .desktop file ...
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/shell-app.c b/src/shell-app.c
index 3b5df0aabb..b36a7c4e01 100644
index 04d0ab508b..4a55daf809 100644
--- a/src/shell-app.c
+++ b/src/shell-app.c
@@ -248,7 +248,7 @@ shell_app_get_name (ShellApp *app)
@@ -247,7 +247,7 @@ shell_app_get_name (ShellApp *app)
const char *name = NULL;
if (window)
@ -24,5 +24,5 @@ index 3b5df0aabb..b36a7c4e01 100644
name = C_("program", "Unknown");
return name;
--
2.44.0
2.45.2

View File

@ -1,4 +1,4 @@
From 9d63a3910637dacf412e0418bea3baf1b90e96a6 Mon Sep 17 00:00:00 2001
From 170ccbd3d237bf980f46ae87e3da8238df9f8a3c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Tue, 16 Apr 2024 20:49:40 +0200
Subject: [PATCH] data: Update generated stylesheets
@ -10,10 +10,10 @@ Subject: [PATCH] data: Update generated stylesheets
3 files changed, 9 insertions(+)
diff --git a/data/theme/gnome-shell-dark.css b/data/theme/gnome-shell-dark.css
index e57c4394ec..ebf3a58d31 100644
index 339adf7e7b..5dd7d29a3a 100644
--- a/data/theme/gnome-shell-dark.css
+++ b/data/theme/gnome-shell-dark.css
@@ -1686,6 +1686,9 @@ StScrollBar {
@@ -1720,6 +1720,9 @@ StScrollBar {
min-width: 0.5455em;
min-height: 0.5455em;
background-color: #ffffff; }
@ -24,10 +24,10 @@ index e57c4394ec..ebf3a58d31 100644
spacing: 0.409em; }
#panel .panel-button.screen-recording-indicator StIcon, #panel .panel-button.screen-sharing-indicator StIcon {
diff --git a/data/theme/gnome-shell-high-contrast.css b/data/theme/gnome-shell-high-contrast.css
index 32b18d5629..165cd2438e 100644
index 4bb622aa26..8f94fa4101 100644
--- a/data/theme/gnome-shell-high-contrast.css
+++ b/data/theme/gnome-shell-high-contrast.css
@@ -1863,6 +1863,9 @@ StScrollBar {
@@ -1897,6 +1897,9 @@ StScrollBar {
min-width: 0.5455em;
min-height: 0.5455em;
background-color: #ffffff; }
@ -38,10 +38,10 @@ index 32b18d5629..165cd2438e 100644
spacing: 0.409em; }
#panel .panel-button.screen-recording-indicator StIcon, #panel .panel-button.screen-sharing-indicator StIcon {
diff --git a/data/theme/gnome-shell-light.css b/data/theme/gnome-shell-light.css
index db4169399a..234f109a74 100644
index 82a5b0bc18..128aa93dea 100644
--- a/data/theme/gnome-shell-light.css
+++ b/data/theme/gnome-shell-light.css
@@ -1686,6 +1686,9 @@ StScrollBar {
@@ -1720,6 +1720,9 @@ StScrollBar {
min-width: 0.5455em;
min-height: 0.5455em;
background-color: #282828; }
@ -52,5 +52,5 @@ index db4169399a..234f109a74 100644
spacing: 0.409em; }
#panel .panel-button.screen-recording-indicator StIcon, #panel .panel-button.screen-sharing-indicator StIcon {
--
2.44.0
2.45.2

View File

@ -1,4 +1,4 @@
From 26ad129561209ce62ebe2f43db5536840fcc34b0 Mon Sep 17 00:00:00 2001
From 7e82f0a73a1d1576e94b17e21d07fd3978ba7c33 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Mon, 1 Feb 2021 18:26:00 +0100
Subject: [PATCH] extensionDownloader: Refuse to override system extensions
@ -33,5 +33,5 @@ index 0366c5dfa8..5b27543aa6 100644
uuid,
shell_version: Config.PACKAGE_VERSION,
--
2.44.0
2.45.2

View File

@ -1,4 +1,4 @@
From 4c9b458862942ed8dafc13d6475a476843894977 Mon Sep 17 00:00:00 2001
From 2060b040f91c3751861a1c1b985c5fe8cc891d58 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Thu, 29 Oct 2020 18:21:06 +0100
Subject: [PATCH] main: Dump stack on segfaults by default
@ -8,7 +8,7 @@ Subject: [PATCH] main: Dump stack on segfaults by default
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/src/main.c b/src/main.c
index 10b5f6eb0f..51b0f8d41b 100644
index 4be47258eb..b324b6b96a 100644
--- a/src/main.c
+++ b/src/main.c
@@ -47,6 +47,7 @@ static char *script_path = NULL;
@ -34,5 +34,5 @@ index 10b5f6eb0f..51b0f8d41b 100644
static GLogWriterOutput
--
2.44.0
2.45.2

View File

@ -1,4 +1,4 @@
From 376722b0500dcceb04785838b0bb4508da4f1944 Mon Sep 17 00:00:00 2001
From c0b2f60108e7b8cffa10306ef54c620fe71a6735 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 22 May 2024 18:42:06 +0200
Subject: [PATCH] panel: Use branding in activities button

View File

@ -1,4 +1,4 @@
From 9ed103334c211058e039dd1ad76351bfc5d9866e Mon Sep 17 00:00:00 2001
From 17e77f1729b8542c46d5020d55edce4daf7ab24a Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Fri, 3 Jul 2015 13:54:36 -0400
Subject: [PATCH] screenShield: unblank when inserting smartcard
@ -29,5 +29,5 @@ index d2236fb900..b62440dff6 100644
this._credentialManagers = {};
--
2.44.0
2.45.2

View File

@ -1,4 +1,4 @@
From 458413d859549b12c6be5c263d3f9a66adf2e929 Mon Sep 17 00:00:00 2001
From 5ddabd342d8016b5b1c8a56ecca7de21e91feb3c Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Tue, 15 Jan 2019 12:54:32 -0500
Subject: [PATCH] st-texture-cache: purge on resume
@ -12,7 +12,7 @@ so the texture cache needs to evict all textures in that situation.
3 files changed, 16 insertions(+), 1 deletion(-)
diff --git a/js/ui/main.js b/js/ui/main.js
index 9f1697df2b..8cb2963d34 100644
index ad0ea962f1..d9646fea52 100644
--- a/js/ui/main.js
+++ b/js/ui/main.js
@@ -265,7 +265,11 @@ async function _initializeUI() {
@ -29,7 +29,7 @@ index 9f1697df2b..8cb2963d34 100644
global.context.connect('notify::unsafe-mode', () => {
if (!global.context.unsafe_mode)
diff --git a/src/st/st-texture-cache.c b/src/st/st-texture-cache.c
index b93db94b5a..07ce0e00bc 100644
index a137480ad1..2e5c6c689a 100644
--- a/src/st/st-texture-cache.c
+++ b/src/st/st-texture-cache.c
@@ -129,6 +129,16 @@ st_texture_cache_class_init (StTextureCacheClass *klass)
@ -62,5 +62,5 @@ index 1c5be957c4..1a4bfde73f 100644
ClutterActor *
st_texture_cache_load_sliced_image (StTextureCache *cache,
--
2.44.0
2.45.2

View File

@ -1,4 +1,4 @@
From 5eaadd46539a9f6154bc32e87a6c50b420349768 Mon Sep 17 00:00:00 2001
From 15df1086028087e5a81830323137a8730d2c5888 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Tue, 14 Mar 2017 17:04:36 +0100
Subject: [PATCH] windowMenu: Bring back workspaces submenu for static
@ -13,10 +13,10 @@ are used.
1 file changed, 17 insertions(+)
diff --git a/js/ui/windowMenu.js b/js/ui/windowMenu.js
index 571a193580..76d630911a 100644
index c69c183d7c..2db3962012 100644
--- a/js/ui/windowMenu.js
+++ b/js/ui/windowMenu.js
@@ -159,6 +159,23 @@ export class WindowMenu extends PopupMenu.PopupMenu {
@@ -153,6 +153,23 @@ export class WindowMenu extends PopupMenu.PopupMenu {
window.change_workspace(workspace.get_neighbor(dir));
});
}
@ -41,5 +41,5 @@ index 571a193580..76d630911a 100644
}
--
2.44.0
2.45.2

View File

@ -1,4 +1,4 @@
From 508b6605da15da476a492f0364d66a031ce15bbb Mon Sep 17 00:00:00 2001
From 8a4efef39a0f48371c632d449688f29d06b9eed7 Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Wed, 30 Sep 2015 12:51:24 -0400
Subject: [PATCH 1/3] authPrompt: don't fade out auth messages if user types
@ -25,10 +25,10 @@ index 8a46559d90..9309f60886 100644
});
--
2.45.1
2.45.2
From b8802f770ae641125fdafe6b3eadcb2d9bc33860 Mon Sep 17 00:00:00 2001
From 007bbb694d4f30175caecbc9ada91515634bfd0b Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Wed, 30 Sep 2015 14:36:33 -0400
Subject: [PATCH 2/3] authPrompt: don't spin unless answering question
@ -61,10 +61,10 @@ index 9309f60886..3e72668967 100644
this.emit('next');
}
--
2.45.1
2.45.2
From 4618962582f7f2ce1d76daca4ce3ee34e4c07f55 Mon Sep 17 00:00:00 2001
From 92f66a5ff91e47d46a48d7ee51c0808f7ce1eaf9 Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Mon, 5 Oct 2015 15:26:18 -0400
Subject: [PATCH 3/3] authPrompt: stop accepting preemptive answer if user
@ -166,5 +166,5 @@ index 3e72668967..254b4dbb88 100644
this._userVerifier.cancel();
--
2.45.1
2.45.2

View File

@ -1,4 +1,4 @@
From 066e4346a13a667f318e4334020cc1ac4a03ba9a Mon Sep 17 00:00:00 2001
From eaa7217db15a28e88ce0b5a84827c306148561ca Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Mon, 28 Sep 2015 10:57:02 -0400
Subject: [PATCH 1/3] smartcardManager: add way to detect if user logged using
@ -32,10 +32,10 @@ index 32573cd384..6c48c80a19 100644
+ }
}
--
2.44.0
2.45.2
From dba5cdb1cd96d8f5e99280135e88df4f0487c4ed Mon Sep 17 00:00:00 2001
From d7ef26d7b9d352232c9e0a24a04bcfcf6eee7d9a Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Mon, 28 Sep 2015 19:56:53 -0400
Subject: [PATCH 2/3] gdm: only unlock with smartcard, if smartcard used for
@ -48,10 +48,10 @@ gets used for unlock, too.
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/js/gdm/util.js b/js/gdm/util.js
index 97df6d687e..8a05758bb8 100644
index c9c040beb7..c0d8852880 100644
--- a/js/gdm/util.js
+++ b/js/gdm/util.js
@@ -463,6 +463,8 @@ export class ShellUserVerifier extends Signals.EventEmitter {
@@ -465,6 +465,8 @@ export class ShellUserVerifier extends Signals.EventEmitter {
this.smartcardDetected = false;
this._checkForSmartcard();
@ -60,7 +60,7 @@ index 97df6d687e..8a05758bb8 100644
this._smartcardManager.connectObject(
'smartcard-inserted', () => this._checkForSmartcard(),
'smartcard-removed', () => this._checkForSmartcard(), this);
@@ -641,7 +643,9 @@ export class ShellUserVerifier extends Signals.EventEmitter {
@@ -643,7 +645,9 @@ export class ShellUserVerifier extends Signals.EventEmitter {
}
_getDetectedDefaultService() {
@ -72,10 +72,10 @@ index 97df6d687e..8a05758bb8 100644
else if (this._smartcardManager)
return SMARTCARD_SERVICE_NAME;
--
2.44.0
2.45.2
From ef8ac2256eed6bac5c002f127915c88a12bf1a58 Mon Sep 17 00:00:00 2001
From 9bff98c2757e4591035e408aa9cee703cec74bdf Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Mon, 28 Sep 2015 19:57:36 -0400
Subject: [PATCH 3/3] gdm: update default service when smartcard inserted
@ -88,10 +88,10 @@ after we get a smartcard insertion event.
1 file changed, 2 insertions(+)
diff --git a/js/gdm/util.js b/js/gdm/util.js
index 8a05758bb8..69005f7335 100644
index c0d8852880..430af4d8ef 100644
--- a/js/gdm/util.js
+++ b/js/gdm/util.js
@@ -488,6 +488,8 @@ export class ShellUserVerifier extends Signals.EventEmitter {
@@ -490,6 +490,8 @@ export class ShellUserVerifier extends Signals.EventEmitter {
else if (this._preemptingService === SMARTCARD_SERVICE_NAME)
this._preemptingService = null;
@ -101,5 +101,5 @@ index 8a05758bb8..69005f7335 100644
}
}
--
2.44.0
2.45.2

View File

@ -1,4 +1,4 @@
From 37c02e06a05170cd32acc683f745cc47bf3e52a4 Mon Sep 17 00:00:00 2001
From 04bf0729ed6ae75736e297a10603bcb0a564cb28 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Tue, 9 Jun 2020 19:42:21 +0200
Subject: [PATCH 1/2] popupMenu: Guard against non-menu-item children
@ -9,10 +9,10 @@ This avoid a harmless but annoying warning.
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/js/ui/popupMenu.js b/js/ui/popupMenu.js
index 3842d82181..2ff781a80b 100644
index b6ad545087..cbbcfea1ff 100644
--- a/js/ui/popupMenu.js
+++ b/js/ui/popupMenu.js
@@ -825,7 +825,8 @@ export class PopupMenuBase extends Signals.EventEmitter {
@@ -951,7 +951,8 @@ export class PopupMenuBase extends Signals.EventEmitter {
}
_getMenuItems() {
@ -23,10 +23,10 @@ index 3842d82181..2ff781a80b 100644
});
}
--
2.44.0
2.45.2
From a64fa15ced5e56f0b9265dc4b2482ea32e58a25b Mon Sep 17 00:00:00 2001
From cffe984d9b85494fcf34500e78875b66c1cec534 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Tue, 9 Jun 2020 19:48:06 +0200
Subject: [PATCH 2/2] st/shadow: Check pipeline when painting
@ -38,25 +38,25 @@ called before paint() or that the pipeline was created successfully.
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/src/st/st-shadow.c b/src/st/st-shadow.c
index a5a0a85d09..1072cf56a7 100644
index a406b61532..574445aeac 100644
--- a/src/st/st-shadow.c
+++ b/src/st/st-shadow.c
@@ -294,9 +294,10 @@ st_shadow_helper_paint (StShadowHelper *helper,
ClutterActorBox *actor_box,
guint8 paint_opacity)
uint8_t paint_opacity)
{
- _st_paint_shadow_with_opacity (helper->shadow,
- framebuffer,
- node,
- helper->pipeline,
- actor_box,
- paint_opacity);
+ if (helper->pipeline != NULL)
+ _st_paint_shadow_with_opacity (helper->shadow,
+ framebuffer,
+ node,
+ helper->pipeline,
+ actor_box,
+ paint_opacity);
}
--
2.44.0
2.45.2

View File

@ -1,4 +1,4 @@
From fd6c784f6142c19307952d0bc7ef832ac10790dd Mon Sep 17 00:00:00 2001
From 8fcaf1708fee86b1c16c9749dc1794be5a2a86fd Mon Sep 17 00:00:00 2001
From: rpm-build <rpm-build>
Date: Mon, 28 Feb 2022 10:27:09 -0500
Subject: [PATCH] data: Enable logo extension out of the box
@ -25,5 +25,5 @@ index 3dd9d2d86b..fe1e266f8c 100644
<description>
GNOME Shell extensions have a UUID property; this key lists extensions
--
2.44.0
2.45.2

View File

@ -1,4 +1,4 @@
From 551b8979483e127471c726fd1db1d52e063a7d81 Mon Sep 17 00:00:00 2001
From 9bb33b1c8d0dba0d5c9e98d98b1063a1d0408414 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 17 Sep 2014 07:11:12 +0200
Subject: [PATCH] Replace Web with Firefox in default favorites
@ -9,10 +9,10 @@ Subject: [PATCH] Replace Web with Firefox in default favorites
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/data/org.gnome.shell.gschema.xml.in b/data/org.gnome.shell.gschema.xml.in
index f4fa86d013..86b4bf85ee 100644
index 3cd37692a7..bd2bd5ead8 100644
--- a/data/org.gnome.shell.gschema.xml.in
+++ b/data/org.gnome.shell.gschema.xml.in
@@ -50,7 +50,7 @@
@@ -61,7 +61,7 @@
</description>
</key>
<key name="favorite-apps" type="as">
@ -22,7 +22,7 @@ index f4fa86d013..86b4bf85ee 100644
<description>
The applications corresponding to these identifiers
diff --git a/js/ui/appFavorites.js b/js/ui/appFavorites.js
index 576df3800d..1f55a3c881 100644
index 576df3800d..a1deabde37 100644
--- a/js/ui/appFavorites.js
+++ b/js/ui/appFavorites.js
@@ -51,6 +51,7 @@ const RENAMED_DESKTOP_IDS = {
@ -34,5 +34,5 @@ index 576df3800d..1f55a3c881 100644
'org.gnome.gnome-2048.desktop': 'org.gnome.TwentyFortyEight.desktop',
'org.gnome.taquin.desktop': 'org.gnome.Taquin.desktop',
--
2.43.0
2.45.2

View File

@ -1,4 +1,4 @@
From 204f14d0cac6f38c5afeb8586ee288e2773b4cb2 Mon Sep 17 00:00:00 2001
From ff6a6c1ef9063b8e7e5ae7e48f712b07e2f8100f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Thu, 9 Mar 2017 14:44:32 +0100
Subject: [PATCH] appFavorites: Add terminal
@ -21,5 +21,5 @@ index bd2bd5ead8..3dd9d2d86b 100644
<description>
The applications corresponding to these identifiers
--
2.44.0
2.45.2

View File

@ -8,7 +8,7 @@
%endif
Name: gnome-shell
Version: 46.3.1
Version: 47~alpha
Release: %autorelease
Summary: Window management and application launching for GNOME
@ -42,19 +42,18 @@ Patch: 0001-main-Dump-stack-on-segfaults-by-default.patch
Patch: 0001-st-texture-cache-purge-on-resume.patch
Patch: fix-some-js-warnings.patch
Patch: 0001-data-Update-generated-stylesheets.patch
Patch: 0001-data-App-icon-for-captive-portal.patch
Patch: portal-notify.patch
%define eds_version 3.45.1
%define gnome_desktop_version 44.0-7
%define glib2_version 2.56.0
%define glib2_version 2.79.2
%define gobject_introspection_version 1.49.1
%define gjs_version 1.73.1
%define gtk4_version 4.0.0
%define adwaita_version 1.0.0
%define mutter_version 46.0
%define adwaita_version 1.5.0
%define mutter_version 47~alpha
%define polkit_version 0.100
%define gsettings_desktop_schemas_version 46~beta
%define gsettings_desktop_schemas_version 47~alpha
%define ibus_version 1.5.2
%define gnome_bluetooth_version 1:42.3
%define gstreamer_version 1.4.5

View File

@ -1,4 +1,4 @@
From 9e43e0f7172b448d449764ab20dbe0540316f388 Mon Sep 17 00:00:00 2001
From d77ed9ad5fdadcdefcc41fecf8200bd2bf47282d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 12 Jun 2024 13:13:41 +0200
Subject: [PATCH 1/3] network: Split out CaptivePortalHandler class
@ -211,7 +211,7 @@ index 404733b74c..d34e947073 100644
2.45.2
From 44242a1a79a4d9b0311b735d484c996584bee0e2 Mon Sep 17 00:00:00 2001
From cd489e54948e3f2900a1f4e354fd4bb43c62db6d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 12 Jun 2024 13:13:41 +0200
Subject: [PATCH 2/3] status/network: Show notification when detecting captive
@ -232,7 +232,7 @@ Closes: https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/7688
1 file changed, 34 insertions(+), 4 deletions(-)
diff --git a/js/ui/status/network.js b/js/ui/status/network.js
index d34e947073..39140d0ce4 100644
index d34e947073..5d1e168fb5 100644
--- a/js/ui/status/network.js
+++ b/js/ui/status/network.js
@@ -1951,19 +1951,43 @@ class CaptivePortalHandler extends Signals.EventEmitter {
@ -250,7 +250,7 @@ index d34e947073..39140d0ce4 100644
return;
- this._launchPortalHelper(path).catch(logError);
+ const source = new MessageTray.getSystemSource();
+ const source = MessageTray.getSystemSource();
+
+ const notification = new MessageTray.Notification({
+ title: _('Sign Into WiFi Network'),
@ -308,7 +308,7 @@ index d34e947073..39140d0ce4 100644
2.45.2
From b25485ef256068b53a852070bcb5fcf4c4a62875 Mon Sep 17 00:00:00 2001
From 52b8a150dd96086a48ba2ac7668b22e6429767fd Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 12 Jun 2024 13:13:41 +0200
Subject: [PATCH 3/3] build: Add option to disable portal-helper
@ -347,7 +347,7 @@ index eff6e4b530..277df017b2 100644
+install_subdir('hicolor',
+ install_dir: icondir, exclude_files: excluded_icons)
diff --git a/data/meson.build b/data/meson.build
index 0307613e70..8b376a6d6b 100644
index 8654dfeca7..ed13b6baea 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -6,7 +6,7 @@ desktop_files = [
@ -407,7 +407,7 @@ index 5aceefac42..5fc8ca433f 100644
jsconf.set('libexecdir', libexecdir)
diff --git a/js/ui/status/network.js b/js/ui/status/network.js
index 39140d0ce4..5832d96dc6 100644
index 5d1e168fb5..cdc9ba8928 100644
--- a/js/ui/status/network.js
+++ b/js/ui/status/network.js
@@ -10,6 +10,7 @@ import Polkit from 'gi://Polkit';
@ -461,10 +461,10 @@ index 39140d0ce4..5832d96dc6 100644
this._connectivityQueue.add(path);
}
diff --git a/meson.build b/meson.build
index 923a5228ec..d554045c5b 100644
index 035f54732a..4721bd6017 100644
--- a/meson.build
+++ b/meson.build
@@ -101,6 +101,11 @@ else
@@ -107,6 +107,11 @@ else
have_networkmanager = false
endif
@ -494,10 +494,10 @@ index 6e83d92f2e..01e0d5803b 100644
type: 'boolean',
value: true,
diff --git a/src/meson.build b/src/meson.build
index c81bd1a42a..d4445743bd 100644
index 752104e120..a3bf542480 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -258,7 +258,7 @@ executable('gnome-shell', 'main.c',
@@ -286,7 +286,7 @@ executable('gnome-shell', 'main.c',
install: true
)

View File

@ -1 +1 @@
SHA512 (gnome-shell-46.3.1.tar.xz) = 7a7389fa9ad4a51e2df4c2aa3ee3e4d088342351997e8d56b7621ccefd7b7743aff4df56c1c721b9009c49c232a51b4979c2c33552104500c32613955309dcb0
SHA512 (gnome-shell-47.alpha.tar.xz) = 72fbd6be1115f7130a0eefaef526181e5bef1a26ef815f4c005606a77e0c50e001e76db588abcea625dccf0eec455e54f88afed76f60e134a3172106790d87fc