Add patch to port to gcr4
The path is upstream-ed at: https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/2386
This commit is contained in:
parent
2ba55d5179
commit
e4499adaef
110
0001-build-Port-to-gcr4.patch
Normal file
110
0001-build-Port-to-gcr4.patch
Normal file
@ -0,0 +1,110 @@
|
|||||||
|
From 82489d37d9b4f86506e5843e50d26217f8cb8508 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Milan Crha <mcrha@redhat.com>
|
||||||
|
Date: Tue, 19 Jul 2022 18:31:04 +0200
|
||||||
|
Subject: [PATCH] build: Port to gcr4
|
||||||
|
|
||||||
|
The gcr4 is going to replace gcr3. As only base functions are used,
|
||||||
|
the port to gcr4 is trivial.
|
||||||
|
---
|
||||||
|
js/ui/environment.js | 2 +-
|
||||||
|
meson.build | 4 ++--
|
||||||
|
src/meson.build | 2 +-
|
||||||
|
src/shell-keyring-prompt.c | 6 +++---
|
||||||
|
src/shell-secure-text-buffer.c | 2 +-
|
||||||
|
5 files changed, 8 insertions(+), 8 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/js/ui/environment.js b/js/ui/environment.js
|
||||||
|
index 83df7bcce..4853a83d5 100644
|
||||||
|
--- a/js/ui/environment.js
|
||||||
|
+++ b/js/ui/environment.js
|
||||||
|
@@ -8,7 +8,7 @@ imports.gi.versions.Atk = '1.0';
|
||||||
|
imports.gi.versions.Atspi = '2.0';
|
||||||
|
imports.gi.versions.Clutter = Config.LIBMUTTER_API_VERSION;
|
||||||
|
imports.gi.versions.Cogl = Config.LIBMUTTER_API_VERSION;
|
||||||
|
-imports.gi.versions.Gcr = '3';
|
||||||
|
+imports.gi.versions.Gcr = '4';
|
||||||
|
imports.gi.versions.Gdk = '3.0';
|
||||||
|
imports.gi.versions.Gdm = '1.0';
|
||||||
|
imports.gi.versions.Geoclue = '2.0';
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index bc0f62176..c3766e5e3 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -20,7 +20,7 @@ libmutter_test_pc = 'libmutter-test-' + mutter_api_version
|
||||||
|
|
||||||
|
ecal_req = '>= 3.33.1'
|
||||||
|
eds_req = '>= 3.33.1'
|
||||||
|
-gcr_req = '>= 3.7.5'
|
||||||
|
+gcr_req = '>= 3.90.0'
|
||||||
|
gio_req = '>= 2.56.0'
|
||||||
|
gi_req = '>= 1.49.1'
|
||||||
|
gjs_req = '>= 1.71.1'
|
||||||
|
@@ -71,7 +71,7 @@ endif
|
||||||
|
atk_bridge_dep = dependency('atk-bridge-2.0')
|
||||||
|
ecal_dep = dependency('libecal-2.0', version: ecal_req)
|
||||||
|
eds_dep = dependency('libedataserver-1.2', version: eds_req)
|
||||||
|
-gcr_dep = dependency('gcr-base-3', version: gcr_req)
|
||||||
|
+gcr_dep = dependency('gcr-4', version: gcr_req)
|
||||||
|
gdk_x11_dep = dependency('gdk-x11-3.0')
|
||||||
|
gdk_pixbuf_dep = dependency('gdk-pixbuf-2.0')
|
||||||
|
gi_dep = dependency('gobject-introspection-1.0', version: gi_req)
|
||||||
|
diff --git a/src/meson.build b/src/meson.build
|
||||||
|
index 112782d86..e784a5132 100644
|
||||||
|
--- a/src/meson.build
|
||||||
|
+++ b/src/meson.build
|
||||||
|
@@ -213,7 +213,7 @@ libshell_dep = declare_dependency(link_with: libshell)
|
||||||
|
libshell_gir_includes = [
|
||||||
|
'Clutter-@0@'.format(mutter_api_version),
|
||||||
|
'Meta-@0@'.format(mutter_api_version),
|
||||||
|
- 'Gcr-3',
|
||||||
|
+ 'Gcr-4',
|
||||||
|
'PolkitAgent-1.0'
|
||||||
|
]
|
||||||
|
|
||||||
|
diff --git a/src/shell-keyring-prompt.c b/src/shell-keyring-prompt.c
|
||||||
|
index 83c674638..bb0327966 100644
|
||||||
|
--- a/src/shell-keyring-prompt.c
|
||||||
|
+++ b/src/shell-keyring-prompt.c
|
||||||
|
@@ -26,7 +26,7 @@
|
||||||
|
#include "shell-secure-text-buffer.h"
|
||||||
|
|
||||||
|
#define GCR_API_SUBJECT_TO_CHANGE
|
||||||
|
-#include <gcr/gcr-base.h>
|
||||||
|
+#include <gcr/gcr.h>
|
||||||
|
|
||||||
|
#include <glib/gi18n.h>
|
||||||
|
|
||||||
|
@@ -91,7 +91,7 @@ enum {
|
||||||
|
|
||||||
|
static GParamSpec *props[N_PROPS] = { NULL, };
|
||||||
|
|
||||||
|
-static void shell_keyring_prompt_iface (GcrPromptIface *iface);
|
||||||
|
+static void shell_keyring_prompt_iface (GcrPromptInterface *iface);
|
||||||
|
|
||||||
|
G_DEFINE_TYPE_WITH_CODE (ShellKeyringPrompt, shell_keyring_prompt, G_TYPE_OBJECT,
|
||||||
|
G_IMPLEMENT_INTERFACE (GCR_TYPE_PROMPT, shell_keyring_prompt_iface);
|
||||||
|
@@ -531,7 +531,7 @@ shell_keyring_prompt_close (GcrPrompt *prompt)
|
||||||
|
}
|
||||||
|
|
||||||
|
static void
|
||||||
|
-shell_keyring_prompt_iface (GcrPromptIface *iface)
|
||||||
|
+shell_keyring_prompt_iface (GcrPromptInterface *iface)
|
||||||
|
{
|
||||||
|
iface->prompt_password_async = shell_keyring_prompt_password_async;
|
||||||
|
iface->prompt_password_finish = shell_keyring_prompt_password_finish;
|
||||||
|
diff --git a/src/shell-secure-text-buffer.c b/src/shell-secure-text-buffer.c
|
||||||
|
index 03af451ba..8271410e2 100644
|
||||||
|
--- a/src/shell-secure-text-buffer.c
|
||||||
|
+++ b/src/shell-secure-text-buffer.c
|
||||||
|
@@ -26,7 +26,7 @@
|
||||||
|
#include "shell-secure-text-buffer.h"
|
||||||
|
|
||||||
|
#define GCR_API_SUBJECT_TO_CHANGE
|
||||||
|
-#include <gcr/gcr-base.h>
|
||||||
|
+#include <gcr/gcr.h>
|
||||||
|
|
||||||
|
#include <string.h>
|
||||||
|
|
||||||
|
--
|
||||||
|
2.35.1
|
||||||
|
|
@ -19,6 +19,8 @@ Patch40001: 0001-gdm-Work-around-failing-fingerprint-auth.patch
|
|||||||
# Work around crashy tear down
|
# Work around crashy tear down
|
||||||
Patch60003: 0001-main-Leak-the-GJS-context-and-ShellGlobal.patch
|
Patch60003: 0001-main-Leak-the-GJS-context-and-ShellGlobal.patch
|
||||||
|
|
||||||
|
Patch01: 0001-build-Port-to-gcr4.patch
|
||||||
|
|
||||||
%define eds_version 3.45.1
|
%define eds_version 3.45.1
|
||||||
%define gnome_desktop_version 3.35.91
|
%define gnome_desktop_version 3.35.91
|
||||||
%define glib2_version 2.56.0
|
%define glib2_version 2.56.0
|
||||||
@ -43,7 +45,7 @@ BuildRequires: git
|
|||||||
BuildRequires: pkgconfig(ibus-1.0) >= %{ibus_version}
|
BuildRequires: pkgconfig(ibus-1.0) >= %{ibus_version}
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: pkgconfig(libedataserver-1.2) >= %{eds_version}
|
BuildRequires: pkgconfig(libedataserver-1.2) >= %{eds_version}
|
||||||
BuildRequires: pkgconfig(gcr-base-3)
|
BuildRequires: pkgconfig(gcr-4)
|
||||||
BuildRequires: pkgconfig(gjs-1.0) >= %{gjs_version}
|
BuildRequires: pkgconfig(gjs-1.0) >= %{gjs_version}
|
||||||
BuildRequires: pkgconfig(gio-2.0) >= %{glib2_version}
|
BuildRequires: pkgconfig(gio-2.0) >= %{glib2_version}
|
||||||
BuildRequires: pkgconfig(gnome-autoar-0)
|
BuildRequires: pkgconfig(gnome-autoar-0)
|
||||||
@ -234,6 +236,7 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/evolution-calendar.de
|
|||||||
%changelog
|
%changelog
|
||||||
* Tue Jul 19 2022 Milan Crha <mcrha@redhat.com> - 43~alpha-2
|
* Tue Jul 19 2022 Milan Crha <mcrha@redhat.com> - 43~alpha-2
|
||||||
- Rebuilt for evolution-data-server soname version bump
|
- Rebuilt for evolution-data-server soname version bump
|
||||||
|
- Add patch to port to gcr4
|
||||||
|
|
||||||
* Sun Jul 10 2022 Florian Müllner <fmuellner@redhat.com> - 43~alpha-1
|
* Sun Jul 10 2022 Florian Müllner <fmuellner@redhat.com> - 43~alpha-1
|
||||||
- Update to 43.alpha
|
- Update to 43.alpha
|
||||||
|
Loading…
Reference in New Issue
Block a user