Update to 43.beta

This commit is contained in:
Florian Müllner 2022-08-10 20:58:55 +02:00
parent 34eabf05a2
commit dbe889a668
4 changed files with 8 additions and 116 deletions

1
.gitignore vendored
View File

@ -205,3 +205,4 @@ gnome-shell-2.31.5.tar.bz2
/gnome-shell-42.1.tar.xz
/gnome-shell-42.2.tar.xz
/gnome-shell-43.alpha.tar.xz
/gnome-shell-43.beta.tar.xz

View File

@ -1,110 +0,0 @@
From 82489d37d9b4f86506e5843e50d26217f8cb8508 Mon Sep 17 00:00:00 2001
From: Milan Crha <mcrha@redhat.com>
Date: Tue, 19 Jul 2022 18:31:04 +0200
Subject: [PATCH] build: Port to gcr4
The gcr4 is going to replace gcr3. As only base functions are used,
the port to gcr4 is trivial.
---
js/ui/environment.js | 2 +-
meson.build | 4 ++--
src/meson.build | 2 +-
src/shell-keyring-prompt.c | 6 +++---
src/shell-secure-text-buffer.c | 2 +-
5 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/js/ui/environment.js b/js/ui/environment.js
index 83df7bcce..4853a83d5 100644
--- a/js/ui/environment.js
+++ b/js/ui/environment.js
@@ -8,7 +8,7 @@ imports.gi.versions.Atk = '1.0';
imports.gi.versions.Atspi = '2.0';
imports.gi.versions.Clutter = Config.LIBMUTTER_API_VERSION;
imports.gi.versions.Cogl = Config.LIBMUTTER_API_VERSION;
-imports.gi.versions.Gcr = '3';
+imports.gi.versions.Gcr = '4';
imports.gi.versions.Gdk = '3.0';
imports.gi.versions.Gdm = '1.0';
imports.gi.versions.Geoclue = '2.0';
diff --git a/meson.build b/meson.build
index bc0f62176..c3766e5e3 100644
--- a/meson.build
+++ b/meson.build
@@ -20,7 +20,7 @@ libmutter_test_pc = 'libmutter-test-' + mutter_api_version
ecal_req = '>= 3.33.1'
eds_req = '>= 3.33.1'
-gcr_req = '>= 3.7.5'
+gcr_req = '>= 3.90.0'
gio_req = '>= 2.56.0'
gi_req = '>= 1.49.1'
gjs_req = '>= 1.71.1'
@@ -71,7 +71,7 @@ endif
atk_bridge_dep = dependency('atk-bridge-2.0')
ecal_dep = dependency('libecal-2.0', version: ecal_req)
eds_dep = dependency('libedataserver-1.2', version: eds_req)
-gcr_dep = dependency('gcr-base-3', version: gcr_req)
+gcr_dep = dependency('gcr-4', version: gcr_req)
gdk_x11_dep = dependency('gdk-x11-3.0')
gdk_pixbuf_dep = dependency('gdk-pixbuf-2.0')
gi_dep = dependency('gobject-introspection-1.0', version: gi_req)
diff --git a/src/meson.build b/src/meson.build
index 112782d86..e784a5132 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -213,7 +213,7 @@ libshell_dep = declare_dependency(link_with: libshell)
libshell_gir_includes = [
'Clutter-@0@'.format(mutter_api_version),
'Meta-@0@'.format(mutter_api_version),
- 'Gcr-3',
+ 'Gcr-4',
'PolkitAgent-1.0'
]
diff --git a/src/shell-keyring-prompt.c b/src/shell-keyring-prompt.c
index 83c674638..bb0327966 100644
--- a/src/shell-keyring-prompt.c
+++ b/src/shell-keyring-prompt.c
@@ -26,7 +26,7 @@
#include "shell-secure-text-buffer.h"
#define GCR_API_SUBJECT_TO_CHANGE
-#include <gcr/gcr-base.h>
+#include <gcr/gcr.h>
#include <glib/gi18n.h>
@@ -91,7 +91,7 @@ enum {
static GParamSpec *props[N_PROPS] = { NULL, };
-static void shell_keyring_prompt_iface (GcrPromptIface *iface);
+static void shell_keyring_prompt_iface (GcrPromptInterface *iface);
G_DEFINE_TYPE_WITH_CODE (ShellKeyringPrompt, shell_keyring_prompt, G_TYPE_OBJECT,
G_IMPLEMENT_INTERFACE (GCR_TYPE_PROMPT, shell_keyring_prompt_iface);
@@ -531,7 +531,7 @@ shell_keyring_prompt_close (GcrPrompt *prompt)
}
static void
-shell_keyring_prompt_iface (GcrPromptIface *iface)
+shell_keyring_prompt_iface (GcrPromptInterface *iface)
{
iface->prompt_password_async = shell_keyring_prompt_password_async;
iface->prompt_password_finish = shell_keyring_prompt_password_finish;
diff --git a/src/shell-secure-text-buffer.c b/src/shell-secure-text-buffer.c
index 03af451ba..8271410e2 100644
--- a/src/shell-secure-text-buffer.c
+++ b/src/shell-secure-text-buffer.c
@@ -26,7 +26,7 @@
#include "shell-secure-text-buffer.h"
#define GCR_API_SUBJECT_TO_CHANGE
-#include <gcr/gcr-base.h>
+#include <gcr/gcr.h>
#include <string.h>
--
2.35.1

View File

@ -1,8 +1,8 @@
%global tarball_version %%(echo %{version} | tr '~' '.')
Name: gnome-shell
Version: 43~alpha
Release: 3%{?dist}
Version: 43~beta
Release: 1%{?dist}
Summary: Window management and application launching for GNOME
License: GPLv2+
@ -19,8 +19,6 @@ Patch40001: 0001-gdm-Work-around-failing-fingerprint-auth.patch
# Work around crashy tear down
Patch60003: 0001-main-Leak-the-GJS-context-and-ShellGlobal.patch
Patch01: 0001-build-Port-to-gcr4.patch
%define eds_version 3.45.1
%define gnome_desktop_version 3.35.91
%define glib2_version 2.56.0
@ -29,7 +27,7 @@ Patch01: 0001-build-Port-to-gcr4.patch
%define gtk3_version 3.15.0
%define gtk4_version 4.0.0
%define adwaita_version 1.0.0
%define mutter_version 43~alpha
%define mutter_version 43~beta
%define polkit_version 0.100
%define gsettings_desktop_schemas_version 42~beta
%define ibus_version 1.5.2
@ -234,6 +232,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/evolution-calendar.de
%{_mandir}/man1/gnome-shell.1*
%changelog
* Wed Aug 10 2022 Florian Müllner <fmuellner@redhat.com> - 43~beta-1
- Update to 43.beta
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 43~alpha-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (gnome-shell-43.alpha.tar.xz) = 5227d6762e49bb550b030e70702796f8b38316bb60d92b07314814b61a41bd06ef25ecfd00780f16d7c26c799972402b6831b03b99e6372715fa59ab40fa3a51
SHA512 (gnome-shell-43.beta.tar.xz) = 2c7c11a344975610dfb5914240397392a858544192472beebf8e62d35c5bdcb09eb5c38dde1fd39f5ea55c6819a38811cefeb68441d929d58c1dbffecdf97c5f