Fix unit file installation
This commit is contained in:
parent
5f31baffb9
commit
db2ff26bc1
30
0001-build-Don-t-use-libdir-for-systemd-unit-path.patch
Normal file
30
0001-build-Don-t-use-libdir-for-systemd-unit-path.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From 43e8dfacb45e470d02d3880ceb28a4494262f4c9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||||
|
Date: Wed, 18 Jul 2018 23:03:30 +0200
|
||||||
|
Subject: [PATCH] build: Don't use libdir for systemd unit path
|
||||||
|
|
||||||
|
Some systems define it to /usr/lib64 on 64-bit systems, which is not
|
||||||
|
where systemd looks for unit files. Just hardcode 'lib' in the install
|
||||||
|
prefix until we get to use the pkg-config file.
|
||||||
|
|
||||||
|
https://gitlab.gnome.org/GNOME/gnome-shell/issues/424
|
||||||
|
---
|
||||||
|
meson.build | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index 7e5fe3832..65f6c7f1f 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -64,7 +64,7 @@ plugindir = get_variable('BROWSER_PLUGIN_DIR', mozplugindir)
|
||||||
|
# systemduserunitdir = systemd_dep.get_pkgconfig_variable('systemduserunitdir',
|
||||||
|
# define_variable: ['prefix', prefix])
|
||||||
|
# and uncomment systemd_dep below
|
||||||
|
-systemduserunitdir = join_paths(libdir, 'systemd', 'user')
|
||||||
|
+systemduserunitdir = join_paths(prefix, 'lib', 'systemd', 'user')
|
||||||
|
|
||||||
|
keybindings_dep = dependency('gnome-keybindings', required: false)
|
||||||
|
if keybindings_dep.found()
|
||||||
|
--
|
||||||
|
2.17.1
|
||||||
|
|
@ -13,6 +13,8 @@ Source0: http://download.gnome.org/sources/gnome-shell/3.29/%{name}-%{ver
|
|||||||
# Replace Epiphany with Firefox in the default favourite apps list
|
# Replace Epiphany with Firefox in the default favourite apps list
|
||||||
Patch1: gnome-shell-favourite-apps-firefox.patch
|
Patch1: gnome-shell-favourite-apps-firefox.patch
|
||||||
|
|
||||||
|
Patch2: 0001-build-Don-t-use-libdir-for-systemd-unit-path.patch
|
||||||
|
|
||||||
%define libcroco_version 0.6.8
|
%define libcroco_version 0.6.8
|
||||||
%define eds_version 3.17.2
|
%define eds_version 3.17.2
|
||||||
%define gnome_desktop_version 3.7.90
|
%define gnome_desktop_version 3.7.90
|
||||||
@ -173,6 +175,9 @@ glib-compile-schemas --allow-any-name %{_datadir}/glib-2.0/schemas &> /dev/null
|
|||||||
%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
|
%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
|
||||||
%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
|
%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
|
||||||
%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
|
%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
|
||||||
|
%{_userunitdir}/gnome-shell.service
|
||||||
|
%{_userunitdir}/gnome-shell-wayland.target
|
||||||
|
%{_userunitdir}/gnome-shell-x11.target
|
||||||
# Co own directory instead of pulling in xdg-desktop-portal - we
|
# Co own directory instead of pulling in xdg-desktop-portal - we
|
||||||
# are providing a backend to the portal, not depending on it
|
# are providing a backend to the portal, not depending on it
|
||||||
%dir %{_datadir}/xdg-desktop-portal/portals/
|
%dir %{_datadir}/xdg-desktop-portal/portals/
|
||||||
|
Loading…
Reference in New Issue
Block a user