Update to 3.25.4
... and switch to meson, yay
This commit is contained in:
parent
05c464e75f
commit
c6f1e51e2f
1
.gitignore
vendored
1
.gitignore
vendored
@ -132,3 +132,4 @@ gnome-shell-2.31.5.tar.bz2
|
||||
/gnome-shell-3.25.1.tar.xz
|
||||
/gnome-shell-3.25.2.tar.xz
|
||||
/gnome-shell-3.25.3.tar.xz
|
||||
/gnome-shell-3.25.4.tar.xz
|
||||
|
@ -1,5 +1,5 @@
|
||||
Name: gnome-shell
|
||||
Version: 3.25.3
|
||||
Version: 3.25.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Window management and application launching for GNOME
|
||||
|
||||
@ -12,6 +12,7 @@ Source0: http://download.gnome.org/sources/gnome-shell/3.25/%{name}-%{ver
|
||||
|
||||
# Replace Epiphany with Firefox in the default favourite apps list
|
||||
Patch1: gnome-shell-favourite-apps-firefox.patch
|
||||
Patch2: meson-fixes.patch
|
||||
|
||||
%define gnome_bluetooth_version 1:3.9.0
|
||||
%define gobject_introspection_version 1.45.4
|
||||
@ -26,11 +27,7 @@ Patch1: gnome-shell-favourite-apps-firefox.patch
|
||||
%define libcroco_version 0.6.8
|
||||
%define telepathy_logger_version 0.2.6
|
||||
|
||||
## Needed when we re-autogen
|
||||
BuildRequires: autoconf >= 2.53
|
||||
BuildRequires: automake >= 1.10
|
||||
BuildRequires: gnome-common >= 2.2.0
|
||||
BuildRequires: libtool >= 1.4.3
|
||||
BuildRequires: meson
|
||||
BuildRequires: caribou-devel >= %{caribou_version}
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: dbus-glib-devel
|
||||
@ -44,6 +41,7 @@ BuildRequires: json-glib-devel >= %{json_glib_version}
|
||||
BuildRequires: upower-devel
|
||||
BuildRequires: libgnome-keyring-devel
|
||||
BuildRequires: libnm-gtk-devel
|
||||
BuildRequires: mesa-libGL-devel
|
||||
BuildRequires: NetworkManager-glib-devel
|
||||
BuildRequires: polkit-devel
|
||||
BuildRequires: startup-notification-devel
|
||||
@ -66,7 +64,7 @@ BuildRequires: gnome-bluetooth-libs-devel >= %{gnome_bluetooth_version}
|
||||
%endif
|
||||
BuildRequires: control-center
|
||||
# Bootstrap requirements
|
||||
BuildRequires: gtk-doc gnome-common
|
||||
BuildRequires: gtk-doc
|
||||
%ifnarch s390 s390x
|
||||
Requires: gnome-bluetooth%{?_isa} >= %{gnome_bluetooth_version}
|
||||
%endif
|
||||
@ -118,16 +116,14 @@ easy to use experience.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .firefox
|
||||
%patch2 -p1 -b .meson-fixes
|
||||
|
||||
%build
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi;
|
||||
%configure --disable-static --disable-compile-warnings)
|
||||
make V=1 %{?_smp_mflags}
|
||||
%meson
|
||||
%meson_build -v
|
||||
|
||||
%install
|
||||
%make_install
|
||||
|
||||
rm -rf %{buildroot}/%{_libdir}/mozilla/plugins/*.la
|
||||
%meson_install
|
||||
|
||||
# Create empty directories where other packages can drop extensions
|
||||
mkdir -p %{buildroot}%{_datadir}/gnome-shell/extensions
|
||||
@ -184,10 +180,11 @@ glib-compile-schemas --allow-any-name %{_datadir}/glib-2.0/schemas &> /dev/null
|
||||
%dir %{_datadir}/GConf/gsettings
|
||||
%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
|
||||
%{_mandir}/man1/%{name}.1.gz
|
||||
# exclude as these should be in a devel package for st etc
|
||||
%exclude %{_datadir}/gtk-doc
|
||||
|
||||
%changelog
|
||||
* Thu Jul 20 2017 Florian Müllner <fmuellner@redhat.com> - 3.25.4-1
|
||||
- Update to 3.25.4
|
||||
|
||||
* Wed Jun 21 2017 Florian Müllner <fmuellner@redhat.com> - 3.25.3-1
|
||||
- Update to 3.25.3
|
||||
|
||||
|
52
meson-fixes.patch
Normal file
52
meson-fixes.patch
Normal file
@ -0,0 +1,52 @@
|
||||
From ae0eeb0dcadcf5543d3cf2e8d2d1fa429d0af82c Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Thu, 20 Jul 2017 01:43:38 +0200
|
||||
Subject: [PATCH] build: Fix portal installation with meson
|
||||
|
||||
Gah, this fell through the cracks ...
|
||||
|
||||
diff --git a/data/meson.build b/data/meson.build
|
||||
index 0fa87fbfc..6bc5ae08a 100644
|
||||
--- a/data/meson.build
|
||||
+++ b/data/meson.build
|
||||
@@ -72,6 +72,7 @@ configure_file(
|
||||
)
|
||||
|
||||
|
||||
+install_data('gnome-shell.portal', install_dir: portaldir)
|
||||
install_data('50-gnome-shell-system.xml', install_dir: keysdir)
|
||||
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 00a541da4..5f4c74700 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -53,6 +53,7 @@ desktopdir = join_paths(datadir, 'applications')
|
||||
ifacedir = join_paths(datadir, 'dbus-1', 'interfaces')
|
||||
localedir = join_paths(datadir, 'locale')
|
||||
mozplugindir = join_paths(libdir, 'mozilla', 'plugins')
|
||||
+portaldir = join_paths(datadir, 'xdg-desktop-portal', 'portals')
|
||||
schemadir = join_paths(datadir, 'glib-2.0', 'schemas')
|
||||
servicedir = join_paths(datadir, 'dbus-1', 'services')
|
||||
|
||||
|
||||
From 2aceeac7e0e5ddd1deddb35e6bc24265ccdc1465 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Thu, 20 Jul 2017 01:28:35 +0200
|
||||
Subject: [PATCH] build: Update gvc subproject
|
||||
|
||||
|
||||
Submodule subprojects/gvc 01e1fde6e..3f71aac04:
|
||||
diff --git a/subprojects/gvc/meson.build b/subprojects/gvc/meson.build
|
||||
index 7433f6e..238f608 100644
|
||||
--- a/subprojects/gvc/meson.build
|
||||
+++ b/subprojects/gvc/meson.build
|
||||
@@ -21,7 +21,7 @@ libpulse_glib = dependency('libpulse-mainloop-glib')
|
||||
cdata = configuration_data()
|
||||
cdata.set_quoted('GETTEXT_PACKAGE', get_option('package-name'))
|
||||
cdata.set_quoted('PACKAGE_VERSION', get_option('package-version'))
|
||||
-cdata.set10('HAVE_ALSA', alsa.found())
|
||||
+cdata.set('HAVE_ALSA', alsa.found())
|
||||
|
||||
config = configure_file(
|
||||
input: 'config.h.meson',
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gnome-shell-3.25.3.tar.xz) = 0f7427d0932e22162e69107148fa39dfb69c4e598395e50c473efdd937012a82e99471b567597b60e17389d2e33bf650c8e77fa418f8a3327506630f7c40c899
|
||||
SHA512 (gnome-shell-3.25.4.tar.xz) = 8e6b5adaffa428a3af12caf43aea4bac446772fffc1c735a4430b36f80693adb36731599f25b34f4af0aceb344ff459727e3f7b68514a1269b875c2791d0b3f4
|
||||
|
Loading…
Reference in New Issue
Block a user