Update to 3.36.1
This commit is contained in:
parent
c41301197e
commit
9a1a96f839
1
.gitignore
vendored
1
.gitignore
vendored
@ -173,3 +173,4 @@ gnome-shell-2.31.5.tar.bz2
|
|||||||
/gnome-shell-3.35.91.tar.xz
|
/gnome-shell-3.35.91.tar.xz
|
||||||
/gnome-shell-3.35.92.tar.xz
|
/gnome-shell-3.35.92.tar.xz
|
||||||
/gnome-shell-3.36.0.tar.xz
|
/gnome-shell-3.36.0.tar.xz
|
||||||
|
/gnome-shell-3.36.1.tar.xz
|
||||||
|
@ -1,60 +0,0 @@
|
|||||||
From 187af8f442248b4d9481cc4189e24033607a1c81 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ray Strode <rstrode@redhat.com>
|
|
||||||
Date: Wed, 25 Mar 2020 16:30:46 -0400
|
|
||||||
Subject: [PATCH] data: ensure systemd environment is sanitized when shell
|
|
||||||
exits
|
|
||||||
|
|
||||||
When mutter is acting as a display server it sets a number of
|
|
||||||
environment variables in the user's session. These variables
|
|
||||||
tell applications where the display server's sockets are.
|
|
||||||
|
|
||||||
When the shell exits at logout time it leaves these environment
|
|
||||||
variables in the systemd --user environment, which can confuse
|
|
||||||
subsequent sessions.
|
|
||||||
|
|
||||||
This commit clears up the environment on exit.
|
|
||||||
|
|
||||||
https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1129
|
|
||||||
---
|
|
||||||
data/gnome-shell-wayland.service.in | 4 ++++
|
|
||||||
1 file changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/data/gnome-shell-wayland.service.in b/data/gnome-shell-wayland.service.in
|
|
||||||
index 04f94af2d..aab02f4f5 100644
|
|
||||||
--- a/data/gnome-shell-wayland.service.in
|
|
||||||
+++ b/data/gnome-shell-wayland.service.in
|
|
||||||
@@ -1,27 +1,31 @@
|
|
||||||
[Unit]
|
|
||||||
Description=GNOME Shell on Wayland
|
|
||||||
# On wayland, force a session shutdown
|
|
||||||
OnFailure=gnome-shell-disable-extensions.service gnome-session-shutdown.target
|
|
||||||
OnFailureJobMode=replace-irreversibly
|
|
||||||
CollectMode=inactive-or-failed
|
|
||||||
RefuseManualStart=on
|
|
||||||
RefuseManualStop=on
|
|
||||||
|
|
||||||
After=gnome-session-manager.target
|
|
||||||
|
|
||||||
Requisite=gnome-session-initialized.target
|
|
||||||
PartOf=gnome-session-initialized.target
|
|
||||||
Before=gnome-session-initialized.target
|
|
||||||
|
|
||||||
# The units already conflict because they use the same BusName
|
|
||||||
#Conflicts=gnome-shell-x11.service
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
Type=notify
|
|
||||||
ExecStart=@bindir@/gnome-shell
|
|
||||||
+
|
|
||||||
+# unset some environment variables that were set by the shell and won't work now that the shell is gone
|
|
||||||
+ExecStopPost=-systemctl --user unset-environment GNOME_SETUP_DISPLAY WAYLAND_DISPLAY DISPLAY XAUTHORITY
|
|
||||||
+
|
|
||||||
# Exit code 1 means we are probably *not* dealing with an extension failure
|
|
||||||
SuccessExitStatus=1
|
|
||||||
# On wayland we cannot restart
|
|
||||||
Restart=no
|
|
||||||
# Kill any stubborn child processes after this long
|
|
||||||
TimeoutStopSec=5
|
|
||||||
--
|
|
||||||
2.21.1
|
|
||||||
|
|
26
1080.patch
26
1080.patch
@ -1,26 +0,0 @@
|
|||||||
From 099b6694b50b9748de6309c99b65bd09e0b6ba6d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alynx Zhou <alynx.zhou@gmail.com>
|
|
||||||
Date: Mon, 9 Mar 2020 10:09:47 +0800
|
|
||||||
Subject: [PATCH] ibusManager: fix ibus launch error because of wrong method
|
|
||||||
name
|
|
||||||
|
|
||||||
---
|
|
||||||
js/misc/ibusManager.js | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/js/misc/ibusManager.js b/js/misc/ibusManager.js
|
|
||||||
index aa1f510602..e27e9f06dd 100644
|
|
||||||
--- a/js/misc/ibusManager.js
|
|
||||||
+++ b/js/misc/ibusManager.js
|
|
||||||
@@ -66,7 +66,7 @@ var IBusManager = class {
|
|
||||||
let display = GLib.getenv('GNOME_SETUP_DISPLAY');
|
|
||||||
if (display)
|
|
||||||
launcher.setenv('DISPLAY', display, true);
|
|
||||||
- launcher.launch(cmdLine);
|
|
||||||
+ launcher.spawnv(cmdLine);
|
|
||||||
} catch (e) {
|
|
||||||
log(`Failed to launch ibus-daemon: ${e.message}`);
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.24.1
|
|
||||||
|
|
60
1084.patch
60
1084.patch
@ -1,60 +0,0 @@
|
|||||||
From b18469427e5c19402111de5fe9888bceec0eaacd Mon Sep 17 00:00:00 2001
|
|
||||||
From: Carlos Garnacho <carlosg@gnome.org>
|
|
||||||
Date: Wed, 11 Mar 2020 12:32:07 +0100
|
|
||||||
Subject: [PATCH] St: Ensure to update entry hint visibility with IM preedit
|
|
||||||
|
|
||||||
Commit 88ac339774 changed StEntry behavior so the text hint would
|
|
||||||
stay visible while focused, as long as the text buffer is empty.
|
|
||||||
However, IMs that use preedit still should count as "started typing",
|
|
||||||
while the text buffer is still officially empty.
|
|
||||||
|
|
||||||
To fix this, check on st_entry_update_hint_visibility() that there's
|
|
||||||
indeed no preedit buffer before showing the hint. We can't directly
|
|
||||||
listen to internal preedit buffer changes in ClutterText, so handle
|
|
||||||
preedit buffer updates through the ::cursor-changed signal that will
|
|
||||||
be indirectly emitted.
|
|
||||||
|
|
||||||
https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1084
|
|
||||||
---
|
|
||||||
src/st/st-entry.c | 11 +++++++++++
|
|
||||||
1 file changed, 11 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/st/st-entry.c b/src/st/st-entry.c
|
|
||||||
index 24fe7434c7..28dddc0537 100644
|
|
||||||
--- a/src/st/st-entry.c
|
|
||||||
+++ b/src/st/st-entry.c
|
|
||||||
@@ -232,6 +232,7 @@ st_entry_update_hint_visibility (StEntry *self)
|
|
||||||
StEntryPrivate *priv = ST_ENTRY_PRIV (self);
|
|
||||||
gboolean hint_visible =
|
|
||||||
priv->hint_actor != NULL &&
|
|
||||||
+ !clutter_text_has_preedit (CLUTTER_TEXT (priv->entry)) &&
|
|
||||||
strcmp (clutter_text_get_text (CLUTTER_TEXT (priv->entry)), "") == 0;
|
|
||||||
|
|
||||||
if (priv->hint_actor)
|
|
||||||
@@ -530,6 +531,13 @@ clutter_text_focus_out_cb (ClutterText *text,
|
|
||||||
clutter_text_set_cursor_visible (text, FALSE);
|
|
||||||
}
|
|
||||||
|
|
||||||
+static void
|
|
||||||
+clutter_text_cursor_changed (ClutterText *text,
|
|
||||||
+ StEntry *entry)
|
|
||||||
+{
|
|
||||||
+ st_entry_update_hint_visibility (entry);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
static void
|
|
||||||
clutter_text_changed_cb (GObject *object,
|
|
||||||
GParamSpec *pspec,
|
|
||||||
@@ -980,6 +988,9 @@ st_entry_init (StEntry *entry)
|
|
||||||
g_signal_connect (priv->entry, "button-press-event",
|
|
||||||
G_CALLBACK (clutter_text_button_press_event), entry);
|
|
||||||
|
|
||||||
+ g_signal_connect (priv->entry, "cursor-changed",
|
|
||||||
+ G_CALLBACK (clutter_text_cursor_changed), entry);
|
|
||||||
+
|
|
||||||
g_signal_connect (priv->entry, "notify::text",
|
|
||||||
G_CALLBACK (clutter_text_changed_cb), entry);
|
|
||||||
|
|
||||||
--
|
|
||||||
2.24.1
|
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
Name: gnome-shell
|
Name: gnome-shell
|
||||||
Version: 3.36.0
|
Version: 3.36.1
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Window management and application launching for GNOME
|
Summary: Window management and application launching for GNOME
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -17,18 +17,6 @@ Patch1: gnome-shell-favourite-apps-firefox.patch
|
|||||||
Patch2: 0001-endSessionDialog-Immediately-add-buttons-to-the-dial.patch
|
Patch2: 0001-endSessionDialog-Immediately-add-buttons-to-the-dial.patch
|
||||||
Patch3: 0002-endSessionDialog-Support-rebooting-into-the-bootload.patch
|
Patch3: 0002-endSessionDialog-Support-rebooting-into-the-bootload.patch
|
||||||
|
|
||||||
# Fix ibus failing to launch automatically
|
|
||||||
# https://gitlab.gnome.org/GNOME/gnome-shell/issues/2341
|
|
||||||
# https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1080
|
|
||||||
Patch4: 1080.patch
|
|
||||||
|
|
||||||
# Fix input method preedit not counting as 'started typing'
|
|
||||||
# https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1084
|
|
||||||
Patch5: 1084.patch
|
|
||||||
|
|
||||||
# Clear environment on logout
|
|
||||||
Patch6: 0001-data-ensure-systemd-environment-is-sanitized-when-sh.patch
|
|
||||||
|
|
||||||
%define libcroco_version 0.6.8
|
%define libcroco_version 0.6.8
|
||||||
%define eds_version 3.33.1
|
%define eds_version 3.33.1
|
||||||
%define gnome_desktop_version 3.35.91
|
%define gnome_desktop_version 3.35.91
|
||||||
@ -152,20 +140,11 @@ advantage of the capabilities of modern graphics hardware and introduces
|
|||||||
innovative user interface concepts to provide a visually attractive and
|
innovative user interface concepts to provide a visually attractive and
|
||||||
easy to use experience.
|
easy to use experience.
|
||||||
|
|
||||||
%package -n gnome-extensions-app
|
|
||||||
Summary: Manage GNOME Shell extensions
|
|
||||||
License: GPLv2+
|
|
||||||
Requires: gnome-shell >= %{version}
|
|
||||||
|
|
||||||
%description -n gnome-extensions-app
|
|
||||||
GNOME Extensions is an application for configuring and removing
|
|
||||||
GNOME Shell extensions.
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -S git
|
%autosetup -S git
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%meson
|
%meson -Dextensions_app=false
|
||||||
%meson_build
|
%meson_build
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -179,7 +158,6 @@ mkdir -p %{buildroot}%{_datadir}/gnome-shell/search-providers
|
|||||||
|
|
||||||
%check
|
%check
|
||||||
desktop-file-validate %{buildroot}%{_datadir}/applications/org.gnome.Shell.desktop
|
desktop-file-validate %{buildroot}%{_datadir}/applications/org.gnome.Shell.desktop
|
||||||
desktop-file-validate %{buildroot}%{_datadir}/applications/org.gnome.Extensions.desktop
|
|
||||||
desktop-file-validate %{buildroot}%{_datadir}/applications/evolution-calendar.desktop
|
desktop-file-validate %{buildroot}%{_datadir}/applications/evolution-calendar.desktop
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
@ -198,7 +176,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/evolution-calendar.de
|
|||||||
%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
|
%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
|
||||||
%{_datadir}/gnome-shell/
|
%{_datadir}/gnome-shell/
|
||||||
%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
|
%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
|
||||||
|
%{_datadir}/dbus-1/services/org.gnome.Shell.Extensions.service
|
||||||
%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
|
%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
|
||||||
|
%{_datadir}/dbus-1/services/org.gnome.Shell.Notifications.service
|
||||||
%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
|
%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
|
||||||
%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
|
%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
|
||||||
%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Introspect.xml
|
%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Introspect.xml
|
||||||
@ -231,14 +211,11 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/evolution-calendar.de
|
|||||||
%{_mandir}/man1/gnome-extensions.1*
|
%{_mandir}/man1/gnome-extensions.1*
|
||||||
%{_mandir}/man1/gnome-shell.1*
|
%{_mandir}/man1/gnome-shell.1*
|
||||||
|
|
||||||
%files -n gnome-extensions-app
|
|
||||||
%{_bindir}/gnome-shell-extension-prefs
|
|
||||||
%{_datadir}/applications/org.gnome.Extensions.desktop
|
|
||||||
%{_datadir}/icons/hicolor/scalable/apps/org.gnome.Extensions.svg
|
|
||||||
%{_datadir}/icons/hicolor/scalable/apps/org.gnome.Extensions.Devel.svg
|
|
||||||
%{_datadir}/icons/hicolor/symbolic/apps/org.gnome.Extensions-symbolic.svg
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 31 2020 Florian Müllner <fmuellner@redhat.com> - 3.36.1-1
|
||||||
|
- Update to 3.36.1
|
||||||
|
- Remove gnome-extensions-app subpackage (will move to a separate .spec)
|
||||||
|
|
||||||
* Wed Mar 25 2020 Ray Strode <rstrode@redhat.com> - 3.36.0-4
|
* Wed Mar 25 2020 Ray Strode <rstrode@redhat.com> - 3.36.0-4
|
||||||
- Clear environment on logout
|
- Clear environment on logout
|
||||||
Fixes log in to Xorg right after log out from wayland
|
Fixes log in to Xorg right after log out from wayland
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gnome-shell-3.36.0.tar.xz) = 8e4b6d9e024b27696f2fe26b86582a35ddeb42341efd05c7f731255abc1661506c14d8260757d05b3ce00e6c2e96c443ea4c22c9e671e93c9e8ef6f632cd41d4
|
SHA512 (gnome-shell-3.36.1.tar.xz) = dce7a7236f9efd50148add12373664936a291e7b058c207e29f7abee5243146dac7c769ab7b0b0d5720363886748d70c9cc53fa70d1201f3c756bd9cad92fd53
|
||||||
|
Loading…
Reference in New Issue
Block a user