Backport fixup for spring animation fix

This commit is contained in:
Jonas Ådahl 2020-03-31 19:22:56 +02:00 committed by Kalev Lember
parent 9a1a96f839
commit 92612564fe
2 changed files with 45 additions and 1 deletions

View File

@ -0,0 +1,38 @@
From f49b58cf97e167dca74b902fe1bf21d296495113 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
Date: Tue, 31 Mar 2020 19:00:58 +0200
Subject: [PATCH] appDisplay: Clear animateLater callbacks when unmapping
In some situations we could end up not with lingering 'view-loaded'
handler. This could result in delayed spring animate-in being initiated,
e.g. after a minute after the activities overview was already closed.
Fix this by removing any lingering signal or later handlers when
unmapping.
Fixes: 5c33fe4a0a4eb4ed
https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1155
---
js/ui/appDisplay.js | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/js/ui/appDisplay.js b/js/ui/appDisplay.js
index 4ba4ed67c..e07769caa 100644
--- a/js/ui/appDisplay.js
+++ b/js/ui/appDisplay.js
@@ -291,6 +291,11 @@ var BaseAppView = GObject.registerClass({
}
}
+ vfunc_unmap() {
+ this._clearAnimateLater();
+ super.vfunc_unmap();
+ }
+
animateSwitch(animationDirection) {
this.remove_all_transitions();
this._grid.remove_all_transitions();
--
2.26.0

View File

@ -1,6 +1,6 @@
Name: gnome-shell
Version: 3.36.1
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Window management and application launching for GNOME
License: GPLv2+
@ -17,6 +17,9 @@ Patch1: gnome-shell-favourite-apps-firefox.patch
Patch2: 0001-endSessionDialog-Immediately-add-buttons-to-the-dial.patch
Patch3: 0002-endSessionDialog-Support-rebooting-into-the-bootload.patch
# Backported from gnome-3-36
Patch4: 0001-appDisplay-Clear-animateLater-callbacks-when-unmappi.patch
%define libcroco_version 0.6.8
%define eds_version 3.33.1
%define gnome_desktop_version 3.35.91
@ -212,6 +215,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/evolution-calendar.de
%{_mandir}/man1/gnome-shell.1*
%changelog
* Tue Mar 31 2020 Jonas Ådahl <jadahl@redhat.com> - 3.36.1-2
- Backport fixup for spring animation fix
* Tue Mar 31 2020 Florian Müllner <fmuellner@redhat.com> - 3.36.1-1
- Update to 3.36.1
- Remove gnome-extensions-app subpackage (will move to a separate .spec)