Update to 40.rc
This commit is contained in:
parent
70f07ed1cc
commit
88a62e96a8
1
.gitignore
vendored
1
.gitignore
vendored
@ -189,3 +189,4 @@ gnome-shell-2.31.5.tar.bz2
|
|||||||
/gnome-shell-40.alpha.1.1-228-g829a096ba.tar.xz
|
/gnome-shell-40.alpha.1.1-228-g829a096ba.tar.xz
|
||||||
/gnome-shell-40.beta.tar.xz
|
/gnome-shell-40.beta.tar.xz
|
||||||
/gnome-shell-40.beta-79-g7a57528bd.tar.xz
|
/gnome-shell-40.beta-79-g7a57528bd.tar.xz
|
||||||
|
/gnome-shell-40.rc.tar.xz
|
||||||
|
@ -1,25 +0,0 @@
|
|||||||
From 7649d0c93dddfa6969e432c2510379aa5cf70420 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
|
||||||
Date: Thu, 4 Mar 2021 16:36:05 +0100
|
|
||||||
Subject: [PATCH] build: Lower mutter requirement
|
|
||||||
|
|
||||||
---
|
|
||||||
meson.build | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/meson.build b/meson.build
|
|
||||||
index 66c0fc073..5654a8838 100644
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -25,7 +25,7 @@ gio_req = '>= 2.56.0'
|
|
||||||
gi_req = '>= 1.49.1'
|
|
||||||
gjs_req = '>= 1.65.1'
|
|
||||||
gtk_req = '>= 3.15.0'
|
|
||||||
-mutter_req = '>= 40.rc'
|
|
||||||
+mutter_req = '>= 40.beta'
|
|
||||||
polkit_req = '>= 0.100'
|
|
||||||
schemas_req = '>= 3.33.1'
|
|
||||||
startup_req = '>= 0.11'
|
|
||||||
--
|
|
||||||
2.30.1
|
|
||||||
|
|
@ -1,58 +0,0 @@
|
|||||||
From f9f936e71a35dd9a383ba26763cf69c696d08ed4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sebastian Keller <skeller@gnome.org>
|
|
||||||
Date: Sun, 7 Mar 2021 16:57:44 +0100
|
|
||||||
Subject: [PATCH] shell/app: Avoid adding windows with a startup workspace
|
|
||||||
twice
|
|
||||||
|
|
||||||
Changing the workspace of a window causes the window tracker to remove
|
|
||||||
and add it to the app again. If this happens from within
|
|
||||||
_shell_app_add_window() before the window has been added to the windows
|
|
||||||
list, this will cause the check that is supposed to prevent adding the
|
|
||||||
same window multiple times to fail and the window to be added twice.
|
|
||||||
The app will then be considered still running after the last window has
|
|
||||||
been closed. Then when clicking on the corresponding app icon, the shell
|
|
||||||
would attempt to switch to a NULL workspace for the closed window
|
|
||||||
instead of starting a new instance, resulting in a crash.
|
|
||||||
|
|
||||||
Changing the workspace also needs to happen after increasing the
|
|
||||||
interesting window count, because otherwise removal of the window by
|
|
||||||
the window tracker would trigger a uint underflow leading the app to be
|
|
||||||
considered running with UINT_MAX interesting windows, despite having no
|
|
||||||
windows, leading to crashes right after launching the app.
|
|
||||||
|
|
||||||
Fixes https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3833
|
|
||||||
|
|
||||||
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1745>
|
|
||||||
---
|
|
||||||
src/shell-app.c | 8 ++++----
|
|
||||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/shell-app.c b/src/shell-app.c
|
|
||||||
index 7d7b5510d..17b179cba 100644
|
|
||||||
--- a/src/shell-app.c
|
|
||||||
+++ b/src/shell-app.c
|
|
||||||
@@ -1081,10 +1081,6 @@ _shell_app_add_window (ShellApp *app,
|
|
||||||
if (!app->running_state)
|
|
||||||
create_running_state (app);
|
|
||||||
|
|
||||||
- if (app->started_on_workspace >= 0)
|
|
||||||
- meta_window_change_workspace_by_index (window, app->started_on_workspace, FALSE);
|
|
||||||
- app->started_on_workspace = -1;
|
|
||||||
-
|
|
||||||
app->running_state->window_sort_stale = TRUE;
|
|
||||||
app->running_state->windows = g_slist_prepend (app->running_state->windows, g_object_ref (window));
|
|
||||||
g_signal_connect_object (window, "unmanaged", G_CALLBACK(shell_app_on_unmanaged), app, 0);
|
|
||||||
@@ -1098,6 +1094,10 @@ _shell_app_add_window (ShellApp *app,
|
|
||||||
app->running_state->interesting_windows++;
|
|
||||||
shell_app_sync_running_state (app);
|
|
||||||
|
|
||||||
+ if (app->started_on_workspace >= 0)
|
|
||||||
+ meta_window_change_workspace_by_index (window, app->started_on_workspace, FALSE);
|
|
||||||
+ app->started_on_workspace = -1;
|
|
||||||
+
|
|
||||||
g_object_thaw_notify (G_OBJECT (app));
|
|
||||||
|
|
||||||
g_signal_emit (app, shell_app_signals[WINDOWS_CHANGED], 0);
|
|
||||||
--
|
|
||||||
2.30.1
|
|
||||||
|
|
@ -1,17 +1,14 @@
|
|||||||
Name: gnome-shell
|
Name: gnome-shell
|
||||||
Version: 40.0~beta
|
Version: 40.0~rc
|
||||||
Release: 4.20210304git7a57528bd%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Window management and application launching for GNOME
|
Summary: Window management and application launching for GNOME
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://wiki.gnome.org/Projects/GnomeShell
|
URL: https://wiki.gnome.org/Projects/GnomeShell
|
||||||
Source0: http://download.gnome.org/sources/gnome-shell/40/%{name}-40.beta-79-g7a57528bd.tar.xz
|
Source0: http://download.gnome.org/sources/gnome-shell/40/%{name}-40.rc.tar.xz
|
||||||
|
|
||||||
# Replace Epiphany with Firefox in the default favourite apps list
|
# Replace Epiphany with Firefox in the default favourite apps list
|
||||||
Patch1: gnome-shell-favourite-apps-firefox.patch
|
Patch1: gnome-shell-favourite-apps-firefox.patch
|
||||||
# Undo post-release version bump for snapshot
|
|
||||||
Patch2: 0001-build-Lower-mutter-requirement.patch
|
|
||||||
Patch3: 0001-shell-app-Avoid-adding-windows-with-a-startup-worksp.patch
|
|
||||||
|
|
||||||
%define eds_version 3.33.1
|
%define eds_version 3.33.1
|
||||||
%define gnome_desktop_version 3.35.91
|
%define gnome_desktop_version 3.35.91
|
||||||
@ -226,6 +223,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/evolution-calendar.de
|
|||||||
%{_mandir}/man1/gnome-shell.1*
|
%{_mandir}/man1/gnome-shell.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 15 2021 Florian Müllner <fmuellner@redhat.com> - 40.0~rc-1
|
||||||
|
- Update to 40.rc
|
||||||
|
|
||||||
* Thu Mar 11 2021 Kalev Lember <klember@redhat.com> - 40.0~beta-4.20210304git7a57528bd
|
* Thu Mar 11 2021 Kalev Lember <klember@redhat.com> - 40.0~beta-4.20210304git7a57528bd
|
||||||
- Recommend gnome-session-xsession rather than hard-require it
|
- Recommend gnome-session-xsession rather than hard-require it
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gnome-shell-40.beta-79-g7a57528bd.tar.xz) = 2886a18bf75fec069be00170f1f646ac0d06c8aeb0cc7f03b221c1c77490877cb2914391c0f2297a6b8b496e4fda292e89eaf65d8c660bcbe12f961d36adccb6
|
SHA512 (gnome-shell-40.rc.tar.xz) = 9646cac912f3c6e7ae61c60cfb551a1be4c09fa6e3a2db2ca4e5ce117cac0f624a0c44cfd6ab551ab1e4e9e086856dca78347bec1bff3c05ed7741d15c55afd1
|
||||||
|
Loading…
Reference in New Issue
Block a user