Fix missing key description in ssh key unlock prompt (GGO #574)

This commit is contained in:
Adam Williamson 2018-09-19 10:30:39 -07:00
parent b87281edcb
commit 4e5b246c44
2 changed files with 110 additions and 1 deletions

97
234.patch Normal file
View File

@ -0,0 +1,97 @@
From 2e863a0b7a7f0d6acaf6cac5db94162c472a0f7e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Sat, 15 Sep 2018 00:16:47 +0200
Subject: [PATCH 1/2] build: Remove obsolete soup dependency
It's unused since commit 96396163c ...
https://gitlab.gnome.org/GNOME/gnome-shell/issues/574
---
meson.build | 1 -
src/meson.build | 4 +---
src/shell-util.h | 1 -
3 files changed, 1 insertion(+), 5 deletions(-)
diff --git a/meson.build b/meson.build
index beedc84cc..18636c2f9 100644
--- a/meson.build
+++ b/meson.build
@@ -95,7 +95,6 @@ cogl_dep = dependency(cogl_pc, version: mutter_req)
cogl_pango_dep = dependency(cogl_pango_pc, version: mutter_req)
mutter_dep = dependency(libmutter_pc, version: mutter_req)
polkit_dep = dependency('polkit-agent-1', version: polkit_req)
-soup_dep = dependency('libsoup-2.4')
startup_dep = dependency('libstartup-notification-1.0', version: startup_req)
ibus_dep = dependency('ibus-1.0', version: ibus_req)
x11_dep = dependency('x11')
diff --git a/src/meson.build b/src/meson.build
index 178e05899..a67a02642 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -45,7 +45,6 @@ gnome_shell_deps = [
atk_bridge_dep,
gjs_dep,
gdk_x11_dep,
- soup_dep,
clutter_dep,
cogl_pango_dep,
startup_dep,
@@ -224,8 +223,7 @@ libshell_dep = declare_dependency(link_with: libshell)
libshell_gir_includes = [
'Clutter-@0@'.format(mutter_api_version),
'ClutterX11-@0@'.format(mutter_api_version),
- 'Meta-@0@'.format(mutter_api_version),
- 'Soup-2.4'
+ 'Meta-@0@'.format(mutter_api_version)
]
if have_networkmanager
diff --git a/src/shell-util.h b/src/shell-util.h
index 408b55f68..bbd38a8be 100644
--- a/src/shell-util.h
+++ b/src/shell-util.h
@@ -5,7 +5,6 @@
#include <gio/gio.h>
#include <clutter/clutter.h>
-#include <libsoup/soup.h>
#include <gdk-pixbuf/gdk-pixbuf.h>
#include <meta/meta-cursor-tracker.h>
#include <meta/meta-window-actor.h>
--
2.18.0
From a88f471e49d7bc6fe2188809ea74948f15bf04f3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Fri, 14 Sep 2018 23:14:33 +0200
Subject: [PATCH 2/2] shell: Fix list of GIR includes
gjs now relies entirely on introspection data to determine parent
types and implemented interfaces, so in order to have all methods
and properties resolve correctly, we must include the corresponding
GIRs of all types used.
https://gitlab.gnome.org/GNOME/gnome-shell/issues/574
---
src/meson.build | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/src/meson.build b/src/meson.build
index a67a02642..2045bab82 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -223,7 +223,9 @@ libshell_dep = declare_dependency(link_with: libshell)
libshell_gir_includes = [
'Clutter-@0@'.format(mutter_api_version),
'ClutterX11-@0@'.format(mutter_api_version),
- 'Meta-@0@'.format(mutter_api_version)
+ 'Meta-@0@'.format(mutter_api_version),
+ 'Gcr-3',
+ 'PolkitAgent-1.0'
]
if have_networkmanager
--
2.18.0

View File

@ -1,6 +1,6 @@
Name: gnome-shell
Version: 3.30.0
Release: 5%{?dist}
Release: 6%{?dist}
Summary: Window management and application launching for GNOME
Group: User Interface/Desktops
@ -20,8 +20,17 @@ Patch2: 0001-network-Don-t-assume-the-active-connection-has-been-.patch
# https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/240
Patch3: 0001-Fix-connection-to-wifi-APs-from-user-menu-RH-1628263.patch
# Fixes crash on Overview app icon drag-and-drop
# https://gitlab.gnome.org/GNOME/gnome-shell/issues/577
# https://bugzilla.redhat.com/show_bug.cgi?id=1630134
# https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/241
Patch4: 0001-dnd-don-t-try-to-access-destroyed-dragActor.patch
# Fixes lack of text identifying the key on ssh key unlock prompt
# https://gitlab.gnome.org/GNOME/gnome-shell/issues/574
# https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/234
Patch5: 234.patch
%define libcroco_version 0.6.8
%define eds_version 3.17.2
%define gnome_desktop_version 3.7.90
@ -217,6 +226,9 @@ glib-compile-schemas --allow-any-name %{_datadir}/glib-2.0/schemas &> /dev/null
%{_mandir}/man1/%{name}.1.gz
%changelog
* Wed Sep 19 2018 Adam Williamson <awilliam@redhat.com> - 3.30.0-6
- Fix missing key description in ssh key unlock prompt (GGO #574)
* Wed Sep 19 2018 Ray Strode <rstrode@redhat.com> - 3.30.0-5
- Fix lock up when dropping icon on dash
Resolves: #1630134