e6414d8afc
Re-apply rebased and updated version of the RHEL 9 downstream patches, with some exceptions: Branding is still TBD, so has been left out for now. The desktop-icons extension will be replaced by an upstreamed version of desktop-icons-ng, which is still work-in-progress. Both dash-to-dock and dash-to-panel will be moved to separate packages, based on the existing Fedora package. It was decided to drop the panel-favorites and updates-dialog extensions. Resolves: RHEL-34255
72 lines
2.4 KiB
Diff
72 lines
2.4 KiB
Diff
From 5d7cd70f55a3da9454bffaf0bbcb32dacc8e1971 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
|
Date: Wed, 21 Feb 2024 23:22:58 +0100
|
|
Subject: [PATCH 17/28] workspace-indicator: Support light style
|
|
|
|
The window-list extension already includes light styling for
|
|
its copy of the workspace indicator. Just copy that over to
|
|
support the light variant here as well.
|
|
|
|
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/307>
|
|
---
|
|
extensions/workspace-indicator/meson.build | 5 +++-
|
|
.../{stylesheet.css => stylesheet-dark.css} | 0
|
|
.../workspace-indicator/stylesheet-light.css | 25 +++++++++++++++++++
|
|
3 files changed, 29 insertions(+), 1 deletion(-)
|
|
rename extensions/workspace-indicator/{stylesheet.css => stylesheet-dark.css} (100%)
|
|
create mode 100644 extensions/workspace-indicator/stylesheet-light.css
|
|
|
|
diff --git a/extensions/workspace-indicator/meson.build b/extensions/workspace-indicator/meson.build
|
|
index 6dd08dae..dada5408 100644
|
|
--- a/extensions/workspace-indicator/meson.build
|
|
+++ b/extensions/workspace-indicator/meson.build
|
|
@@ -7,6 +7,9 @@ extension_data += configure_file(
|
|
output: metadata_name,
|
|
configuration: metadata_conf
|
|
)
|
|
-extension_data += files('stylesheet.css')
|
|
+extension_data += files(
|
|
+ 'stylesheet-dark.css',
|
|
+ 'stylesheet-light.css',
|
|
+)
|
|
|
|
extension_sources += files('prefs.js', 'workspaceIndicator.js')
|
|
diff --git a/extensions/workspace-indicator/stylesheet.css b/extensions/workspace-indicator/stylesheet-dark.css
|
|
similarity index 100%
|
|
rename from extensions/workspace-indicator/stylesheet.css
|
|
rename to extensions/workspace-indicator/stylesheet-dark.css
|
|
diff --git a/extensions/workspace-indicator/stylesheet-light.css b/extensions/workspace-indicator/stylesheet-light.css
|
|
new file mode 100644
|
|
index 00000000..049b6a38
|
|
--- /dev/null
|
|
+++ b/extensions/workspace-indicator/stylesheet-light.css
|
|
@@ -0,0 +1,25 @@
|
|
+/*
|
|
+ * SPDX-FileCopyrightText: 2013 Florian Müllner <fmuellner@gnome.org>
|
|
+ * SPDX-FileCopyrightText: 2015 Jakub Steiner <jimmac@gmail.com>
|
|
+ *
|
|
+ * SPDX-License-Identifier: GPL-2.0-or-later
|
|
+ */
|
|
+
|
|
+@import url("stylesheet-dark.css");
|
|
+
|
|
+.workspace-indicator .workspace {
|
|
+ background-color: #ccc;
|
|
+}
|
|
+
|
|
+.workspace-indicator .workspace.active {
|
|
+ border-color: #888;
|
|
+}
|
|
+
|
|
+.workspace-indicator-window-preview {
|
|
+ background-color: #ededed;
|
|
+ border: 1px solid #ccc;
|
|
+}
|
|
+
|
|
+.workspace-indicator-window-preview.active {
|
|
+ background-color: #f6f5f4;
|
|
+}
|
|
--
|
|
2.44.0
|
|
|