Update to 47.rc
This removes the "top-icons" downstream extension, as it was upstreamed under the name "status-icons". Resolves: https://issues.redhat.com/browse/RHEL-53975
This commit is contained in:
parent
3bc2de1319
commit
f74ba2d1dd
1
.gitignore
vendored
1
.gitignore
vendored
@ -178,3 +178,4 @@
|
||||
/gnome-shell-extensions-46.1.tar.xz
|
||||
/gnome-shell-extensions-46.2.tar.xz
|
||||
/gnome-shell-extensions-47.alpha.tar.xz
|
||||
/gnome-shell-extensions-47.rc.tar.xz
|
||||
|
@ -1,32 +1,32 @@
|
||||
From 8a2191519e2431a946aa1be36474bfe323a454a8 Mon Sep 17 00:00:00 2001
|
||||
From 09d8a56d61abd5aab39a54312f180ad431605a3f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Fri, 23 Feb 2018 16:56:46 +0100
|
||||
Subject: [PATCH] Include top-icons in classic session
|
||||
Subject: [PATCH] Include status-icons in classic session
|
||||
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index dce1731c..b915b68c 100644
|
||||
index 9ecd0923..e759012d 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -34,6 +34,7 @@ classic_extensions = [
|
||||
'apps-menu',
|
||||
'places-menu',
|
||||
'launch-new-instance',
|
||||
+ 'top-icons',
|
||||
+ 'status-icons',
|
||||
'window-list'
|
||||
]
|
||||
|
||||
@@ -44,7 +45,6 @@ default_extensions += [
|
||||
'heads-up-display',
|
||||
'light-style',
|
||||
'screenshot-window-sizer',
|
||||
- 'status-icons',
|
||||
'system-monitor',
|
||||
- 'top-icons',
|
||||
'windowsNavigator',
|
||||
'workspace-indicator'
|
||||
]
|
||||
--
|
||||
2.45.2
|
||||
2.46.0
|
||||
|
@ -1,51 +0,0 @@
|
||||
From 97d71d4a7ef4b1d4c9c2eab55db62173311f5366 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Tue, 2 Jul 2024 19:04:10 +0200
|
||||
Subject: [PATCH] workspace-indicator: Re-fittsify workspace previews
|
||||
|
||||
For the window-list extension, it is important that the workspace
|
||||
previews extend to the bottom edge for easier click targets.
|
||||
|
||||
That broke while merging the code with the workspace-indicator,
|
||||
fix it again by moving the padding from the parent box into the
|
||||
thumbnail children.
|
||||
---
|
||||
.../workspace-indicator/stylesheet-dark.css | 15 ++++++++++++++-
|
||||
1 file changed, 14 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/extensions/workspace-indicator/stylesheet-dark.css b/extensions/workspace-indicator/stylesheet-dark.css
|
||||
index b4a716b8..3c57c3e6 100644
|
||||
--- a/extensions/workspace-indicator/stylesheet-dark.css
|
||||
+++ b/extensions/workspace-indicator/stylesheet-dark.css
|
||||
@@ -18,7 +18,6 @@
|
||||
}
|
||||
|
||||
.workspace-indicator .workspaces-box {
|
||||
- padding: 5px;
|
||||
spacing: 3px;
|
||||
}
|
||||
|
||||
@@ -27,6 +26,20 @@
|
||||
spacing: 6px;
|
||||
}
|
||||
|
||||
+.workspace-indicator .workspace-box {
|
||||
+ padding-top: 5px;
|
||||
+ padding-bottom: 5px;
|
||||
+}
|
||||
+
|
||||
+.workspace-indicator StButton:first-child:ltr > .workspace-box,
|
||||
+.workspace-indicator StButton:last-child:rtl > .workspace-box {
|
||||
+ padding-left: 5px;
|
||||
+}
|
||||
+.workspace-indicator StButton:last-child:ltr > .workspace-box,
|
||||
+.workspace-indicator StButton:first-child:rtl > .workspace-box {
|
||||
+ padding-right: 5px;
|
||||
+}
|
||||
+
|
||||
.workspace-indicator-menu .workspace-box {
|
||||
spacing: 6px;
|
||||
}
|
||||
--
|
||||
2.45.2
|
||||
|
@ -1,7 +1,7 @@
|
||||
From ff5063cb006a3723f422017d44787cfd908bb147 Mon Sep 17 00:00:00 2001
|
||||
From cfa4c600830902bbf4027f1bbee7c6e394a84432 Mon Sep 17 00:00:00 2001
|
||||
From: Carlos Garnacho <carlosg@gnome.org>
|
||||
Date: Thu, 28 Jan 2021 00:06:12 +0100
|
||||
Subject: [PATCH 2/5] Add gesture-inhibitor extension
|
||||
Subject: [PATCH 1/5] Add gesture-inhibitor extension
|
||||
|
||||
This extension may disable default GNOME Shell gestures.
|
||||
---
|
||||
@ -165,7 +165,7 @@ index 00000000..b06d027a
|
||||
+</schemalist>
|
||||
+
|
||||
diff --git a/meson.build b/meson.build
|
||||
index a7294c18..e36d948d 100644
|
||||
index 0d458a00..49d36c46 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -51,6 +51,7 @@ default_extensions += [
|
||||
@ -177,5 +177,5 @@ index a7294c18..e36d948d 100644
|
||||
'user-theme'
|
||||
]
|
||||
--
|
||||
2.45.2
|
||||
2.46.0
|
||||
|
@ -1,158 +0,0 @@
|
||||
From 778e3f5ec9b8897af89af1919381a14e2e3494f6 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Wed, 20 May 2015 17:44:50 +0200
|
||||
Subject: [PATCH 1/5] Add top-icons extension
|
||||
|
||||
---
|
||||
extensions/top-icons/extension.js | 91 +++++++++++++++++++++++++++
|
||||
extensions/top-icons/meson.build | 9 +++
|
||||
extensions/top-icons/metadata.json.in | 10 +++
|
||||
meson.build | 1 +
|
||||
4 files changed, 111 insertions(+)
|
||||
create mode 100644 extensions/top-icons/extension.js
|
||||
create mode 100644 extensions/top-icons/meson.build
|
||||
create mode 100644 extensions/top-icons/metadata.json.in
|
||||
|
||||
diff --git a/extensions/top-icons/extension.js b/extensions/top-icons/extension.js
|
||||
new file mode 100644
|
||||
index 00000000..c28f1386
|
||||
--- /dev/null
|
||||
+++ b/extensions/top-icons/extension.js
|
||||
@@ -0,0 +1,91 @@
|
||||
+// SPDX-FileCopyrightText: 2018 Adel Gadllah <adel.gadllah@gmail.com>
|
||||
+// SPDX-FileCopyrightText: 2018 Florian Müllner <fmuellner@gnome.org>
|
||||
+//
|
||||
+// SPDX-License-Identifier: GPL-2.0-or-later
|
||||
+
|
||||
+import Clutter from 'gi://Clutter';
|
||||
+import Shell from 'gi://Shell';
|
||||
+import St from 'gi://St';
|
||||
+
|
||||
+import * as Main from 'resource:///org/gnome/shell/ui/main.js';
|
||||
+import {Button as PanelButton} from 'resource:///org/gnome/shell/ui/panelMenu.js';
|
||||
+
|
||||
+const PANEL_ICON_SIZE = 16;
|
||||
+
|
||||
+const STANDARD_TRAY_ICON_IMPLEMENTATIONS = [
|
||||
+ 'bluetooth-applet',
|
||||
+ 'gnome-sound-applet',
|
||||
+ 'nm-applet',
|
||||
+ 'gnome-power-manager',
|
||||
+ 'keyboard',
|
||||
+ 'a11y-keyboard',
|
||||
+ 'kbd-scrolllock',
|
||||
+ 'kbd-numlock',
|
||||
+ 'kbd-capslock',
|
||||
+ 'ibus-ui-gtk',
|
||||
+];
|
||||
+
|
||||
+export default class SysTray {
|
||||
+ constructor() {
|
||||
+ this._icons = new Map();
|
||||
+ this._tray = null;
|
||||
+ }
|
||||
+
|
||||
+ _onTrayIconAdded(o, icon) {
|
||||
+ let wmClass = icon.wm_class ? icon.wm_class.toLowerCase() : '';
|
||||
+ if (STANDARD_TRAY_ICON_IMPLEMENTATIONS.includes(wmClass))
|
||||
+ return;
|
||||
+
|
||||
+ let button = new PanelButton(0.5, null, true);
|
||||
+
|
||||
+ let scaleFactor = St.ThemeContext.get_for_stage(global.stage).scale_factor;
|
||||
+ let iconSize = PANEL_ICON_SIZE * scaleFactor;
|
||||
+
|
||||
+ icon.set({
|
||||
+ width: iconSize,
|
||||
+ height: iconSize,
|
||||
+ x_align: Clutter.ActorAlign.CENTER,
|
||||
+ y_align: Clutter.ActorAlign.CENTER,
|
||||
+ });
|
||||
+
|
||||
+ let iconBin = new St.Widget({
|
||||
+ layout_manager: new Clutter.BinLayout(),
|
||||
+ style_class: 'system-status-icon',
|
||||
+ });
|
||||
+ iconBin.add_child(icon);
|
||||
+ button.add_child(iconBin);
|
||||
+
|
||||
+ this._icons.set(icon, button);
|
||||
+
|
||||
+ button.connect('button-release-event',
|
||||
+ (actor, event) => icon.click(event));
|
||||
+ button.connect('key-press-event',
|
||||
+ (actor, event) => icon.click(event));
|
||||
+
|
||||
+ const role = `${icon}`;
|
||||
+ Main.panel.addToStatusArea(role, button);
|
||||
+ }
|
||||
+
|
||||
+ _onTrayIconRemoved(o, icon) {
|
||||
+ const button = this._icons.get(icon);
|
||||
+ button?.destroy();
|
||||
+ this._icons.delete(icon);
|
||||
+ }
|
||||
+
|
||||
+ enable() {
|
||||
+ this._tray = new Shell.TrayManager();
|
||||
+ this._tray.connect('tray-icon-added',
|
||||
+ this._onTrayIconAdded.bind(this));
|
||||
+ this._tray.connect('tray-icon-removed',
|
||||
+ this._onTrayIconRemoved.bind(this));
|
||||
+ this._tray.manage_screen(Main.panel);
|
||||
+ }
|
||||
+
|
||||
+ disable() {
|
||||
+ this._icons.forEach(button => button.destroy());
|
||||
+ this._icons.clear();
|
||||
+
|
||||
+ this._tray.unmanage_screen();
|
||||
+ this._tray = null;
|
||||
+ }
|
||||
+}
|
||||
diff --git a/extensions/top-icons/meson.build b/extensions/top-icons/meson.build
|
||||
new file mode 100644
|
||||
index 00000000..b30272ad
|
||||
--- /dev/null
|
||||
+++ b/extensions/top-icons/meson.build
|
||||
@@ -0,0 +1,9 @@
|
||||
+# SPDX-FileCopyrightText: 2018 Florian Müllner <fmuellner@gnome.org>
|
||||
+#
|
||||
+# SPDX-License-Identifier: GPL-2.0-or-later
|
||||
+
|
||||
+extension_data += configure_file(
|
||||
+ input: metadata_name + '.in',
|
||||
+ output: metadata_name,
|
||||
+ configuration: metadata_conf
|
||||
+)
|
||||
diff --git a/extensions/top-icons/metadata.json.in b/extensions/top-icons/metadata.json.in
|
||||
new file mode 100644
|
||||
index 00000000..1d2e0bc2
|
||||
--- /dev/null
|
||||
+++ b/extensions/top-icons/metadata.json.in
|
||||
@@ -0,0 +1,10 @@
|
||||
+{
|
||||
+"extension-id": "@extension_id@",
|
||||
+"uuid": "@uuid@",
|
||||
+"settings-schema": "@gschemaname@",
|
||||
+"gettext-domain": "@gettext_domain@",
|
||||
+"name": "Top Icons",
|
||||
+"description": "Show legacy tray icons on top",
|
||||
+"shell-version": [ "@shell_current@" ],
|
||||
+"url": "@url@"
|
||||
+}
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 536efe49..a7294c18 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -43,6 +43,7 @@ default_extensions += [
|
||||
'light-style',
|
||||
'screenshot-window-sizer',
|
||||
'system-monitor',
|
||||
+ 'top-icons',
|
||||
'windowsNavigator',
|
||||
'workspace-indicator'
|
||||
]
|
||||
--
|
||||
2.45.2
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 950f0fded26d8664bce5410db4c280674147cdd8 Mon Sep 17 00:00:00 2001
|
||||
From 83dbd799013fc52ba79ec449286434a78c04c1f8 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Thu, 2 Dec 2021 19:39:50 +0100
|
||||
Subject: [PATCH] Add classification-banner
|
||||
Subject: [PATCH 2/5] Add classification-banner
|
||||
|
||||
---
|
||||
extensions/classification-banner/extension.js | 163 +++++++++++++++
|
||||
@ -463,7 +463,7 @@ index 00000000..fb6a697e
|
||||
+.classification-message { font-weight: bold; }
|
||||
+.classification-banner { font-size: 0.9em; }
|
||||
diff --git a/meson.build b/meson.build
|
||||
index e36d948d..63bd9ee0 100644
|
||||
index 49d36c46..2e49d72f 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -51,6 +51,7 @@ default_extensions += [
|
||||
@ -475,5 +475,5 @@ index e36d948d..63bd9ee0 100644
|
||||
'native-window-placement',
|
||||
'user-theme'
|
||||
--
|
||||
2.45.2
|
||||
2.46.0
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 271cee0eab89dcbf7b6c307c55cfbbbf843e7a0e Mon Sep 17 00:00:00 2001
|
||||
From c2864f8358f3c5c317f5f5e209c9a099fbbf9b23 Mon Sep 17 00:00:00 2001
|
||||
From: Ray Strode <rstrode@redhat.com>
|
||||
Date: Tue, 24 Aug 2021 15:03:57 -0400
|
||||
Subject: [PATCH 4/5] Add heads-up-display
|
||||
Subject: [PATCH 3/5] Add heads-up-display
|
||||
|
||||
---
|
||||
extensions/heads-up-display/extension.js | 404 ++++++++++++++++++
|
||||
@ -850,7 +850,7 @@ index 00000000..a1a34e3f
|
||||
+ text-align: center;
|
||||
+}
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 63bd9ee0..82269ff5 100644
|
||||
index 2e49d72f..ab30c7a3 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -40,6 +40,7 @@ classic_extensions = [
|
||||
@ -860,7 +860,7 @@ index 63bd9ee0..82269ff5 100644
|
||||
+ 'heads-up-display',
|
||||
'light-style',
|
||||
'screenshot-window-sizer',
|
||||
'system-monitor',
|
||||
'status-icons',
|
||||
diff --git a/po/POTFILES.in b/po/POTFILES.in
|
||||
index 447465a1..b7cb8a7c 100644
|
||||
--- a/po/POTFILES.in
|
||||
@ -874,5 +874,5 @@ index 447465a1..b7cb8a7c 100644
|
||||
extensions/native-window-placement/org.gnome.shell.extensions.native-window-placement.gschema.xml
|
||||
extensions/places-menu/extension.js
|
||||
--
|
||||
2.45.2
|
||||
2.46.0
|
||||
|
@ -1,7 +1,7 @@
|
||||
From b146a94c18e9e9ddbc7f29e8d885768d19fd7d49 Mon Sep 17 00:00:00 2001
|
||||
From f8d1ecf33fa58de64023f7431cd4d3e66e1abfe8 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Thu, 12 Jan 2023 19:43:52 +0100
|
||||
Subject: [PATCH 5/5] Add custom-menu extension
|
||||
Subject: [PATCH 4/5] Add custom-menu extension
|
||||
|
||||
---
|
||||
extensions/custom-menu/config.js | 445 ++++++++++++++++++++++++
|
||||
@ -703,7 +703,7 @@ index 00000000..054f639b
|
||||
+"url": "@url@"
|
||||
+}
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 82269ff5..dce1731c 100644
|
||||
index ab30c7a3..c698dc14 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -53,6 +53,7 @@ all_extensions = default_extensions
|
||||
@ -715,5 +715,5 @@ index 82269ff5..dce1731c 100644
|
||||
'native-window-placement',
|
||||
'user-theme'
|
||||
--
|
||||
2.45.2
|
||||
2.46.0
|
||||
|
@ -12,7 +12,7 @@
|
||||
%endif
|
||||
|
||||
Name: gnome-shell-extensions
|
||||
Version: 47~alpha
|
||||
Version: 47~rc
|
||||
Release: %autorelease
|
||||
Summary: Modify and extend GNOME Shell functionality and behavior
|
||||
|
||||
@ -28,16 +28,13 @@ Requires: gnome-shell >= %{min_gs_version}
|
||||
BuildArch: noarch
|
||||
|
||||
|
||||
Patch: extra-extensions-0001-Add-top-icons-extension.patch
|
||||
Patch: extra-extensions-0002-Add-gesture-inhibitor-extension.patch
|
||||
Patch: extra-extensions-0003-Add-classification-banner.patch
|
||||
Patch: extra-extensions-0004-Add-heads-up-display.patch
|
||||
Patch: extra-extensions-0005-Add-custom-menu-extension.patch
|
||||
Patch: extra-extensions-0006-Add-desktop-icons-extension.patch
|
||||
Patch: extra-extensions-0001-Add-gesture-inhibitor-extension.patch
|
||||
Patch: extra-extensions-0002-Add-classification-banner.patch
|
||||
Patch: extra-extensions-0003-Add-heads-up-display.patch
|
||||
Patch: extra-extensions-0004-Add-custom-menu-extension.patch
|
||||
Patch: extra-extensions-0005-Add-desktop-icons-extension.patch
|
||||
|
||||
Patch: 0001-Include-top-icons-in-classic-session.patch
|
||||
|
||||
Patch: 0001-workspace-indicator-Re-fittsify-workspace-previews.patch
|
||||
Patch: 0001-Include-status-icons-in-classic-session.patch
|
||||
|
||||
%description
|
||||
GNOME Shell Extensions is a collection of extensions providing additional and
|
||||
@ -57,8 +54,8 @@ Enabled extensions:
|
||||
* native-window-placement
|
||||
* places-menu
|
||||
* screenshot-window-sizer
|
||||
* status-icons
|
||||
* system-monitor
|
||||
* top-icons
|
||||
* user-theme
|
||||
* window-list
|
||||
* windowsNavigator
|
||||
@ -236,6 +233,15 @@ This GNOME Shell extension allows to easily resize windows for GNOME Software
|
||||
screenshots.
|
||||
|
||||
|
||||
%package -n %{pkg_prefix}-status-icons
|
||||
Summary: Status icon support for GNOME Shell
|
||||
License: GPLv2+
|
||||
Requires: %{pkg_prefix}-common = %{version}-%{release}
|
||||
|
||||
%description -n %{pkg_prefix}-status-icons
|
||||
This GNOME Shell extension displays status icons in the top bar.
|
||||
|
||||
|
||||
%package -n %{pkg_prefix}-system-monitor
|
||||
Summary: System monitor for GNOME Shell
|
||||
License: GPL-2.0-or-later
|
||||
@ -245,15 +251,6 @@ Requires: %{pkg_prefix}-common = %{version}-%{release}
|
||||
This GNOME Shell extension displays system usage information in the top bar.
|
||||
|
||||
|
||||
%package -n %{pkg_prefix}-top-icons
|
||||
Summary: Show legacy icons on top
|
||||
License: GPLv2+
|
||||
Requires: %{pkg_prefix}-common = %{version}-%{release}
|
||||
|
||||
%description -n %{pkg_prefix}-top-icons
|
||||
This GNOME Shell extension moves legacy tray icons into the top bar
|
||||
|
||||
|
||||
%package -n %{pkg_prefix}-user-theme
|
||||
Summary: Support for custom themes in GNOME Shell
|
||||
License: GPL-2.0-or-later
|
||||
@ -389,15 +386,15 @@ rm -rf %{buildroot}/%{_datadir}/xsessions
|
||||
%{_datadir}/gnome-shell/extensions/screenshot-window-sizer*/
|
||||
|
||||
|
||||
%files -n %{pkg_prefix}-status-icons
|
||||
%{_datadir}/gnome-shell/extensions/status-icons*/
|
||||
|
||||
|
||||
%files -n %{pkg_prefix}-system-monitor
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.system-monitor.gschema.xml
|
||||
%{_datadir}/gnome-shell/extensions/system-monitor*/
|
||||
|
||||
|
||||
%files -n %{pkg_prefix}-top-icons
|
||||
%{_datadir}/gnome-shell/extensions/top-icons*/
|
||||
|
||||
|
||||
%files -n %{pkg_prefix}-user-theme
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.user-theme.gschema.xml
|
||||
%{_datadir}/gnome-shell/extensions/user-theme*/
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gnome-shell-extensions-47.alpha.tar.xz) = a9d464ba6c792708b348d2b7f8b0a8c5ce00eff9b0cb9645d0594989c7ff944a310c3cd3b6fbdaa4eb236770bd7659118c85fca89d56138670ee22c1b64ff41d
|
||||
SHA512 (gnome-shell-extensions-47.rc.tar.xz) = bd7ad8c06f3e1aa7282bcb28cc88536370e4b2d716ab7604afc90799a85c4aed379b8b084b2b705da68f02b1ec694e03c3a491604d7a73c13bc7bbf634cde37f
|
||||
|
Loading…
Reference in New Issue
Block a user