import gnome-shell-extensions-3.32.1-15.el8_4
This commit is contained in:
parent
df2ae2365b
commit
f2c5bb3c09
186
SOURCES/0001-Add-gesture-inhibitor-extension.patch
Normal file
186
SOURCES/0001-Add-gesture-inhibitor-extension.patch
Normal file
@ -0,0 +1,186 @@
|
|||||||
|
From 7a6819443c896ce288e420cb9bfebebaade61fdb Mon Sep 17 00:00:00 2001
|
||||||
|
From: rpm-build <rpm-build>
|
||||||
|
Date: Thu, 28 Jan 2021 00:06:12 +0100
|
||||||
|
Subject: [PATCH] Add gesture-inhibitor extension
|
||||||
|
|
||||||
|
This extension may disable default GNOME Shell gestures.
|
||||||
|
---
|
||||||
|
extensions/gesture-inhibitor/extension.js | 75 +++++++++++++++++++
|
||||||
|
extensions/gesture-inhibitor/meson.build | 8 ++
|
||||||
|
extensions/gesture-inhibitor/metadata.json.in | 12 +++
|
||||||
|
...l.extensions.gesture-inhibitor.gschema.xml | 25 +++++++
|
||||||
|
extensions/gesture-inhibitor/stylesheet.css | 1 +
|
||||||
|
meson.build | 1 +
|
||||||
|
6 files changed, 122 insertions(+)
|
||||||
|
create mode 100644 extensions/gesture-inhibitor/extension.js
|
||||||
|
create mode 100644 extensions/gesture-inhibitor/meson.build
|
||||||
|
create mode 100644 extensions/gesture-inhibitor/metadata.json.in
|
||||||
|
create mode 100644 extensions/gesture-inhibitor/org.gnome.shell.extensions.gesture-inhibitor.gschema.xml
|
||||||
|
create mode 100644 extensions/gesture-inhibitor/stylesheet.css
|
||||||
|
|
||||||
|
diff --git a/extensions/gesture-inhibitor/extension.js b/extensions/gesture-inhibitor/extension.js
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..e74ede2
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/extensions/gesture-inhibitor/extension.js
|
||||||
|
@@ -0,0 +1,75 @@
|
||||||
|
+/* extension.js
|
||||||
|
+ *
|
||||||
|
+ * This program is free software: you can redistribute it and/or modify
|
||||||
|
+ * it under the terms of the GNU General Public License as published by
|
||||||
|
+ * the Free Software Foundation, either version 2 of the License, or
|
||||||
|
+ * (at your option) any later version.
|
||||||
|
+ *
|
||||||
|
+ * This program is distributed in the hope that it will be useful,
|
||||||
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+ * GNU General Public License for more details.
|
||||||
|
+ *
|
||||||
|
+ * You should have received a copy of the GNU General Public License
|
||||||
|
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||||
|
+ *
|
||||||
|
+ * SPDX-License-Identifier: GPL-2.0-or-later
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+/* exported init */
|
||||||
|
+
|
||||||
|
+const Clutter = imports.gi.Clutter;
|
||||||
|
+const ExtensionUtils = imports.misc.extensionUtils;
|
||||||
|
+const Me = ExtensionUtils.getCurrentExtension();
|
||||||
|
+const ViewSelector = imports.ui.viewSelector;
|
||||||
|
+const EdgeDragAction = imports.ui.edgeDragAction;
|
||||||
|
+const WindowManager = imports.ui.windowManager;
|
||||||
|
+const St = imports.gi.St;
|
||||||
|
+const Gio = imports.gi.Gio;
|
||||||
|
+
|
||||||
|
+class Extension {
|
||||||
|
+ constructor() {
|
||||||
|
+ this._settings = ExtensionUtils.getSettings();
|
||||||
|
+ let actions = global.stage.get_actions();
|
||||||
|
+
|
||||||
|
+ actions.forEach(a => {
|
||||||
|
+ if (a instanceof ViewSelector.ShowOverviewAction)
|
||||||
|
+ this._showOverview = a;
|
||||||
|
+ else if (a instanceof WindowManager.AppSwitchAction)
|
||||||
|
+ this._appSwitch = a;
|
||||||
|
+ else if (a instanceof EdgeDragAction.EdgeDragAction &&
|
||||||
|
+ a._side == St.Side.BOTTOM)
|
||||||
|
+ this._showOsk = a;
|
||||||
|
+ else if (a instanceof EdgeDragAction.EdgeDragAction &&
|
||||||
|
+ a._side == St.Side.TOP)
|
||||||
|
+ this._unfullscreen = a;
|
||||||
|
+ else if (a instanceof EdgeDragAction.EdgeDragAction)
|
||||||
|
+ this._showAppGrid = a;
|
||||||
|
+ });
|
||||||
|
+
|
||||||
|
+ this._map = [
|
||||||
|
+ { setting: 'overview', action: this._showOverview },
|
||||||
|
+ { setting: 'app-switch', action: this._appSwitch },
|
||||||
|
+ { setting: 'show-osk', action: this._showOsk },
|
||||||
|
+ { setting: 'unfullscreen', action: this._unfullscreen },
|
||||||
|
+ { setting: 'show-app-grid', action: this._showAppGrid }
|
||||||
|
+ ];
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ enable() {
|
||||||
|
+ this._map.forEach(m => {
|
||||||
|
+ this._settings.bind(m.setting, m.action, 'enabled',
|
||||||
|
+ Gio.SettingsBindFlags.DEFAULT);
|
||||||
|
+ });
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ disable() {
|
||||||
|
+ this._map.forEach(m => {
|
||||||
|
+ m.action.enabled = true;
|
||||||
|
+ });
|
||||||
|
+ }
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+function init() {
|
||||||
|
+ return new Extension();
|
||||||
|
+}
|
||||||
|
diff --git a/extensions/gesture-inhibitor/meson.build b/extensions/gesture-inhibitor/meson.build
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..fdad5cc
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/extensions/gesture-inhibitor/meson.build
|
||||||
|
@@ -0,0 +1,8 @@
|
||||||
|
+extension_data += configure_file(
|
||||||
|
+ input: metadata_name + '.in',
|
||||||
|
+ output: metadata_name,
|
||||||
|
+ configuration: metadata_conf
|
||||||
|
+)
|
||||||
|
+
|
||||||
|
+# extension_sources += files('prefs.js')
|
||||||
|
+extension_schemas += files(metadata_conf.get('gschemaname') + '.gschema.xml')
|
||||||
|
diff --git a/extensions/gesture-inhibitor/metadata.json.in b/extensions/gesture-inhibitor/metadata.json.in
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..37d6a11
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/extensions/gesture-inhibitor/metadata.json.in
|
||||||
|
@@ -0,0 +1,12 @@
|
||||||
|
+{
|
||||||
|
+ "uuid": "@uuid@",
|
||||||
|
+ "extension-id": "@extension_id@",
|
||||||
|
+ "settings-schema": "@gschemaname@",
|
||||||
|
+ "gettext-domain": "@gettext_domain@",
|
||||||
|
+ "name": "Gesture Inhibitor",
|
||||||
|
+ "description": "Makes touchscreen gestures optional.",
|
||||||
|
+ "shell-version": [ "@shell_current@" ],
|
||||||
|
+ "original-authors": [ "cgarnach@redhat.com" ],
|
||||||
|
+ "url": "@url@"
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
diff --git a/extensions/gesture-inhibitor/org.gnome.shell.extensions.gesture-inhibitor.gschema.xml b/extensions/gesture-inhibitor/org.gnome.shell.extensions.gesture-inhibitor.gschema.xml
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..1d67dcc
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/extensions/gesture-inhibitor/org.gnome.shell.extensions.gesture-inhibitor.gschema.xml
|
||||||
|
@@ -0,0 +1,25 @@
|
||||||
|
+<schemalist>
|
||||||
|
+ <schema id="org.gnome.shell.extensions.gesture-inhibitor" path="/org/gnome/shell/extensions/gesture-inhibitor/">
|
||||||
|
+ <key name="show-app-grid" type="b">
|
||||||
|
+ <default>true</default>
|
||||||
|
+ <summary>Show app grid gesture</summary>
|
||||||
|
+ </key>
|
||||||
|
+ <key name="show-osk" type="b">
|
||||||
|
+ <default>true</default>
|
||||||
|
+ <summary>Show OSK gesture</summary>
|
||||||
|
+ </key>
|
||||||
|
+ <key name="overview" type="b">
|
||||||
|
+ <default>true</default>
|
||||||
|
+ <summary>Show Overview gesture</summary>
|
||||||
|
+ </key>
|
||||||
|
+ <key name="app-switch" type="b">
|
||||||
|
+ <default>true</default>
|
||||||
|
+ <summary>Application switch gesture</summary>
|
||||||
|
+ </key>
|
||||||
|
+ <key name="unfullscreen" type="b">
|
||||||
|
+ <default>true</default>
|
||||||
|
+ <summary>Unfullscreen gesture</summary>
|
||||||
|
+ </key>
|
||||||
|
+ </schema>
|
||||||
|
+</schemalist>
|
||||||
|
+
|
||||||
|
diff --git a/extensions/gesture-inhibitor/stylesheet.css b/extensions/gesture-inhibitor/stylesheet.css
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..37b93f2
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/extensions/gesture-inhibitor/stylesheet.css
|
||||||
|
@@ -0,0 +1 @@
|
||||||
|
+/* Add your custom extension styling here */
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index 23bd5ad..9e59729 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -54,6 +54,7 @@ all_extensions += [
|
||||||
|
'auto-move-windows',
|
||||||
|
'dash-to-dock',
|
||||||
|
'disable-screenshield',
|
||||||
|
+ 'gesture-inhibitor',
|
||||||
|
'native-window-placement',
|
||||||
|
'no-hot-corner',
|
||||||
|
'panel-favorites',
|
||||||
|
--
|
||||||
|
2.29.2
|
||||||
|
|
@ -6,7 +6,7 @@
|
|||||||
|
|
||||||
Name: gnome-shell-extensions
|
Name: gnome-shell-extensions
|
||||||
Version: 3.32.1
|
Version: 3.32.1
|
||||||
Release: 14%{?dist}
|
Release: 15%{?dist}
|
||||||
Summary: Modify and extend GNOME Shell functionality and behavior
|
Summary: Modify and extend GNOME Shell functionality and behavior
|
||||||
|
|
||||||
Group: User Interface/Desktops
|
Group: User Interface/Desktops
|
||||||
@ -39,6 +39,7 @@ Patch0010: 0001-window-list-Invalid-current-mode-selected-in-Prefere.pat
|
|||||||
Patch0011: 0001-Update-desktop-icons-gettext-domain.patch
|
Patch0011: 0001-Update-desktop-icons-gettext-domain.patch
|
||||||
Patch0012: 0001-desktop-icons-Update-Japanese-translation.patch
|
Patch0012: 0001-desktop-icons-Update-Japanese-translation.patch
|
||||||
Patch0013: 0001-fileItem-Ignore-double-click-distance-clicking-on-it.patch
|
Patch0013: 0001-fileItem-Ignore-double-click-distance-clicking-on-it.patch
|
||||||
|
Patch0018: 0001-Add-gesture-inhibitor-extension.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
GNOME Shell Extensions is a collection of extensions providing additional and
|
GNOME Shell Extensions is a collection of extensions providing additional and
|
||||||
@ -50,6 +51,7 @@ Enabled extensions:
|
|||||||
* dash-to-dock
|
* dash-to-dock
|
||||||
* disable-screenshield
|
* disable-screenshield
|
||||||
* desktop-icons
|
* desktop-icons
|
||||||
|
* gesture-inhibitor
|
||||||
* horizontal-workspaces
|
* horizontal-workspaces
|
||||||
* drive-menu
|
* drive-menu
|
||||||
* launch-new-instance
|
* launch-new-instance
|
||||||
@ -190,6 +192,16 @@ This GNOME Shell extension provides a panel status menu for accessing and
|
|||||||
unmounting removable devices.
|
unmounting removable devices.
|
||||||
|
|
||||||
|
|
||||||
|
%package -n %{pkg_prefix}-gesture-inhibitor
|
||||||
|
Summary: Gesture inhibitor
|
||||||
|
Group: User Interface/Desktops
|
||||||
|
License: GPLv2+
|
||||||
|
Requires: %{pkg_prefix}-common = %{version}-%{release}
|
||||||
|
|
||||||
|
%description -n %{pkg_prefix}-gesture-inhibitor
|
||||||
|
This GNOME Shell extension allows disabling the default desktop gestures.
|
||||||
|
|
||||||
|
|
||||||
%package -n %{pkg_prefix}-launch-new-instance
|
%package -n %{pkg_prefix}-launch-new-instance
|
||||||
Summary: Always launch a new application instance for GNOME Shell
|
Summary: Always launch a new application instance for GNOME Shell
|
||||||
Group: User Interface/Desktops
|
Group: User Interface/Desktops
|
||||||
@ -409,6 +421,11 @@ cp $RPM_SOURCE_DIR/gnome-classic.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions
|
|||||||
%{_datadir}/gnome-shell/extensions/drive-menu*/
|
%{_datadir}/gnome-shell/extensions/drive-menu*/
|
||||||
|
|
||||||
|
|
||||||
|
%files -n %{pkg_prefix}-gesture-inhibitor
|
||||||
|
%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.gesture-inhibitor.gschema.xml
|
||||||
|
%{_datadir}/gnome-shell/extensions/gesture-inhibitor*/
|
||||||
|
|
||||||
|
|
||||||
%files -n %{pkg_prefix}-launch-new-instance
|
%files -n %{pkg_prefix}-launch-new-instance
|
||||||
%{_datadir}/gnome-shell/extensions/launch-new-instance*/
|
%{_datadir}/gnome-shell/extensions/launch-new-instance*/
|
||||||
|
|
||||||
@ -472,6 +489,10 @@ cp $RPM_SOURCE_DIR/gnome-classic.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 30 2021 Carlos Garnacho <cgarnach@redhat.com> - 3.32.1-15
|
||||||
|
- Add gesture-inhibitor extension
|
||||||
|
Resolves: #1962169
|
||||||
|
|
||||||
* Wed Jan 27 2021 Carlos Garnacho <cgarnach@redhat.com> - 3.32.1-14
|
* Wed Jan 27 2021 Carlos Garnacho <cgarnach@redhat.com> - 3.32.1-14
|
||||||
- Use same logic than Nautilus for double click/tap in desktop-icons extension
|
- Use same logic than Nautilus for double click/tap in desktop-icons extension
|
||||||
Resolves: #1842229
|
Resolves: #1842229
|
||||||
|
Loading…
Reference in New Issue
Block a user