Update to 3.27.91

This commit is contained in:
Florian Müllner 2018-02-22 13:50:33 +01:00
parent dd49a84efa
commit d4e7199b31
4 changed files with 76 additions and 10 deletions

1
.gitignore vendored
View File

@ -99,3 +99,4 @@
/gnome-shell-extensions-3.26.0.tar.xz
/gnome-shell-extensions-3.26.1.tar.xz
/gnome-shell-extensions-3.27.1.tar.xz
/gnome-shell-extensions-3.27.91.tar.xz

View File

@ -0,0 +1,61 @@
From 3e0d8bd56f8dde70598d39a60007f4e376c4ec35 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Thu, 22 Feb 2018 14:37:52 +0100
Subject: [PATCH 1/2] build: Fix xsession installation dir
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index a87e981..8ca83a9 100644
--- a/meson.build
+++ b/meson.build
@@ -18,7 +18,7 @@ themedir = join_paths(shelldir, 'theme')
schemadir = join_paths(datadir, 'glib-2.0', 'schemas')
sessiondir = join_paths(datadir, 'gnome-session', 'sessions')
-xsessiondir = join_paths(datadir, 'xsession')
+xsessiondir = join_paths(datadir, 'xsessions')
extensionlib = files('lib/convenience.js')
--
2.14.3
From d22e603686765abc1d0ecc93f260220115cf028a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Thu, 22 Feb 2018 15:25:05 +0100
Subject: [PATCH 2/2] build: Fix classic .session definition
Session files should be installed with the .session extension, not
.desktop ...
---
data/meson.build | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/data/meson.build b/data/meson.build
index 4118d6e..a807a3d 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -1,11 +1,12 @@
sessions = [
- ['gnome-classic.session.desktop', sessiondir],
- ['gnome-classic.desktop', xsessiondir]
+ ['gnome-classic.session.desktop.in', sessiondir],
+ ['gnome-classic.desktop.in', xsessiondir]
]
foreach s : sessions
+ name_array = s[0].split('.')
i18n.merge_file('',
- input: s[0] + '.in',
- output: s[0],
+ input: s[0],
+ output: '.'.join([name_array[0], name_array[1]]),
po_dir: '../po',
install: true,
install_dir: s[1],
--
2.14.3

View File

@ -5,8 +5,8 @@
%global pkg_prefix gnome-shell-extension
Name: gnome-shell-extensions
Version: 3.27.1
Release: 3%{?dist}
Version: 3.27.91
Release: 1%{?dist}
Summary: Modify and extend GNOME Shell functionality and behavior
Group: User Interface/Desktops
@ -14,7 +14,13 @@ Group: User Interface/Desktops
License: GPLv2+ and BSD
URL: http://wiki.gnome.org/Projects/GnomeShell/Extensions
Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{major_version}/%{name}-%{version}.tar.xz
Patch0: fix-classic-session-files.patch
# BuildRequires: gnome-common
BuildRequires: meson
BuildRequires: sassc
BuildRequires: git
BuildRequires: gettext >= 0.19.6
BuildRequires: pkgconfig(gnome-desktop-3.0)
BuildRequires: pkgconfig(libgtop-2.0)
@ -221,18 +227,16 @@ workspaces.
%prep
%setup -q
%autosetup -S git
%build
# In case we build from a Git checkout
[ -x autogen.sh ] && NOCONFIGURE=1 ./autogen.sh
%configure --enable-extensions="all"
make %{?_smp_mflags}
%meson -Dextension_set="all" -Dclassic_mode=true
%meson_build
%install
%make_install
%meson_install
# Drop useless example extension
rm -r $RPM_BUILD_ROOT%{_datadir}/gnome-shell/extensions/example*/
@ -242,7 +246,7 @@ rm $RPM_BUILD_ROOT%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.exampl
%files -n %{pkg_prefix}-common -f %{name}.lang
%doc COPYING NEWS README
%doc COPYING NEWS README.md
%files -n gnome-classic-session

View File

@ -1 +1 @@
SHA512 (gnome-shell-extensions-3.27.1.tar.xz) = 6841e732c0a3734152d0af27ca68c316dfa29524f7cb59133e68c84ca4701d889ffc28fee5df609e7a8fd1c50ccdf3cce6d544e265e5ca15f7a29c76543a8589
SHA512 (gnome-shell-extensions-3.27.91.tar.xz) = eb692021c422521729e7042b982ea201ee0ec8a7e4a9bec8bc8402d737b50192753760290c2ea8e7da7d8a50be38044067b68bcf6d740b78226b76058d077040