import gnome-shell-extensions-3.32.1-13.el8
This commit is contained in:
commit
cf9da3e90c
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/gnome-shell-extensions-3.32.1.tar.xz
|
1
.gnome-shell-extensions.metadata
Normal file
1
.gnome-shell-extensions.metadata
Normal file
@ -0,0 +1 @@
|
||||
51c1c16bcd0dc9125834b32d7c539c38fa9c4f52 SOURCES/gnome-shell-extensions-3.32.1.tar.xz
|
32
SOURCES/0001-Include-top-icons-in-classic-session.patch
Normal file
32
SOURCES/0001-Include-top-icons-in-classic-session.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From a3db60786407481efbfc4875f887d03b58f0a7b7 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Fri, 23 Feb 2018 16:56:46 +0100
|
||||
Subject: [PATCH] Include top-icons in classic session
|
||||
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 6764f9a..32743ed 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -36,6 +36,7 @@ classic_extensions = [
|
||||
'desktop-icons',
|
||||
'places-menu',
|
||||
'launch-new-instance',
|
||||
+ 'top-icons',
|
||||
'window-list'
|
||||
]
|
||||
|
||||
@@ -56,7 +57,6 @@ all_extensions += [
|
||||
'no-hot-corner',
|
||||
'panel-favorites',
|
||||
'systemMonitor',
|
||||
- 'top-icons',
|
||||
'updates-dialog',
|
||||
'user-theme',
|
||||
'window-grouper'
|
||||
--
|
||||
2.21.0
|
||||
|
83
SOURCES/0001-Update-desktop-icons-gettext-domain.patch
Normal file
83
SOURCES/0001-Update-desktop-icons-gettext-domain.patch
Normal file
@ -0,0 +1,83 @@
|
||||
From f5e47cd8ca32ae433f6906b01a509c5a304894d9 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Sat, 24 Oct 2020 01:14:44 +0200
|
||||
Subject: [PATCH] Update desktop-icons gettext domain
|
||||
|
||||
---
|
||||
extensions/desktop-icons/createFolderDialog.js | 2 +-
|
||||
extensions/desktop-icons/desktopGrid.js | 2 +-
|
||||
extensions/desktop-icons/fileItem.js | 2 +-
|
||||
extensions/desktop-icons/prefs.js | 8 +++++---
|
||||
4 files changed, 8 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/extensions/desktop-icons/createFolderDialog.js b/extensions/desktop-icons/createFolderDialog.js
|
||||
index f3e40e9..5038762 100644
|
||||
--- a/extensions/desktop-icons/createFolderDialog.js
|
||||
+++ b/extensions/desktop-icons/createFolderDialog.js
|
||||
@@ -21,7 +21,7 @@ const { Clutter, GObject, GLib, Gio, St } = imports.gi;
|
||||
const Signals = imports.signals;
|
||||
|
||||
const Dialog = imports.ui.dialog;
|
||||
-const Gettext = imports.gettext.domain('desktop-icons');
|
||||
+const Gettext = imports.gettext.domain('gnome-shell-extensions');
|
||||
const ModalDialog = imports.ui.modalDialog;
|
||||
const ShellEntry = imports.ui.shellEntry;
|
||||
const Tweener = imports.ui.tweener;
|
||||
diff --git a/extensions/desktop-icons/desktopGrid.js b/extensions/desktop-icons/desktopGrid.js
|
||||
index a2d1f12..94d2dfd 100644
|
||||
--- a/extensions/desktop-icons/desktopGrid.js
|
||||
+++ b/extensions/desktop-icons/desktopGrid.js
|
||||
@@ -44,7 +44,7 @@ const Util = imports.misc.util;
|
||||
|
||||
const Clipboard = St.Clipboard.get_default();
|
||||
const CLIPBOARD_TYPE = St.ClipboardType.CLIPBOARD;
|
||||
-const Gettext = imports.gettext.domain('desktop-icons');
|
||||
+const Gettext = imports.gettext.domain('gnome-shell-extensions');
|
||||
|
||||
const _ = Gettext.gettext;
|
||||
|
||||
diff --git a/extensions/desktop-icons/fileItem.js b/extensions/desktop-icons/fileItem.js
|
||||
index 0c6a54d..d6d43c9 100644
|
||||
--- a/extensions/desktop-icons/fileItem.js
|
||||
+++ b/extensions/desktop-icons/fileItem.js
|
||||
@@ -42,7 +42,7 @@ const Prefs = Me.imports.prefs;
|
||||
const DBusUtils = Me.imports.dbusUtils;
|
||||
const DesktopIconsUtil = Me.imports.desktopIconsUtil;
|
||||
|
||||
-const Gettext = imports.gettext.domain('desktop-icons');
|
||||
+const Gettext = imports.gettext.domain('gnome-shell-extensions');
|
||||
|
||||
const _ = Gettext.gettext;
|
||||
|
||||
diff --git a/extensions/desktop-icons/prefs.js b/extensions/desktop-icons/prefs.js
|
||||
index 4b8d986..51daf15 100644
|
||||
--- a/extensions/desktop-icons/prefs.js
|
||||
+++ b/extensions/desktop-icons/prefs.js
|
||||
@@ -26,7 +26,7 @@ const Gettext = imports.gettext;
|
||||
|
||||
const Config = imports.misc.config;
|
||||
|
||||
-var _ = Gettext.domain('desktop-icons').gettext;
|
||||
+var _ = Gettext.domain('gnome-shell-extensions').gettext;
|
||||
|
||||
const SCHEMA_NAUTILUS = 'org.gnome.nautilus.preferences';
|
||||
const SCHEMA_GTK = 'org.gtk.Settings.FileChooser';
|
||||
@@ -51,11 +51,13 @@ var CLICK_POLICY_SINGLE = false;
|
||||
function initTranslations() {
|
||||
let extension = ExtensionUtils.getCurrentExtension();
|
||||
|
||||
+ let domain = extension.metadata['gettext-domain'] || 'desktop-icons';
|
||||
+
|
||||
let localedir = extension.dir.get_child('locale');
|
||||
if (localedir.query_exists(null))
|
||||
- Gettext.bindtextdomain('desktop-icons', localedir.get_path());
|
||||
+ Gettext.bindtextdomain(domain, localedir.get_path());
|
||||
else
|
||||
- Gettext.bindtextdomain('desktop-icons', Config.LOCALEDIR);
|
||||
+ Gettext.bindtextdomain(domain, Config.LOCALEDIR);
|
||||
}
|
||||
|
||||
function init() {
|
||||
--
|
||||
2.21.1
|
||||
|
98
SOURCES/0001-Update-style.patch
Normal file
98
SOURCES/0001-Update-style.patch
Normal file
@ -0,0 +1,98 @@
|
||||
From e768ad73e2d68b3f1567051675ba0539a75e3105 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Sat, 18 May 2019 19:37:05 +0200
|
||||
Subject: [PATCH] Update style
|
||||
|
||||
---
|
||||
data/gnome-shell-sass | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
Submodule data/gnome-shell-sass 1a56956..8842e57:
|
||||
diff --git a/data/gnome-shell-sass/_common.scss b/data/gnome-shell-sass/_common.scss
|
||||
index a6357ba..62d9c82 100644
|
||||
--- a/data/gnome-shell-sass/_common.scss
|
||||
+++ b/data/gnome-shell-sass/_common.scss
|
||||
@@ -571,6 +571,18 @@ StScrollBar {
|
||||
app menu inside the main app window itself rather than the top bar
|
||||
*/
|
||||
|
||||
+/*************
|
||||
+ * App Icons *
|
||||
+ *************/
|
||||
+/* Outline for low res icons */
|
||||
+.lowres-icon {
|
||||
+ icon-shadow: 0 1px 2px rgba(0,0,0,0.3);
|
||||
+}
|
||||
+
|
||||
+/* Drapshadow for large icons */
|
||||
+.icon-dropshadow {
|
||||
+ icon-shadow: 0 1px 2px rgba(0,0,0,0.4);
|
||||
+}
|
||||
|
||||
/* OSD */
|
||||
.osd-window {
|
||||
@@ -680,7 +692,8 @@ StScrollBar {
|
||||
spacing: 8px;
|
||||
}
|
||||
|
||||
- .ws-switcher-active-up, .ws-switcher-active-down {
|
||||
+ .ws-switcher-active-up, .ws-switcher-active-down,
|
||||
+ .ws-switcher-active-left, .ws-switcher-active-right {
|
||||
height: 50px;
|
||||
background-color: $selected_bg_color;
|
||||
color: $selected_fg_color;
|
||||
@@ -781,6 +794,11 @@ StScrollBar {
|
||||
color: lighten($fg_color,10%);
|
||||
}
|
||||
|
||||
+ .panel-logo-icon {
|
||||
+ padding-right: .4em;
|
||||
+ icon-size: 1em;
|
||||
+ }
|
||||
+
|
||||
.system-status-icon { icon-size: 1.09em; padding: 0 5px; }
|
||||
.unlock-screen &,
|
||||
.login-screen &,
|
||||
@@ -1406,6 +1424,14 @@ StScrollBar {
|
||||
|
||||
}
|
||||
|
||||
+ .app-well-hover-text {
|
||||
+ text-align: center;
|
||||
+ color: $osd_fg_color;
|
||||
+ background-color: $osd_bg_color;
|
||||
+ border-radius: 5px;
|
||||
+ padding: 3px;
|
||||
+ }
|
||||
+
|
||||
.app-well-app-running-dot { //running apps indicator
|
||||
width: 10px; height: 3px;
|
||||
background-color: $selected_bg_color;
|
||||
@@ -1801,7 +1827,12 @@ StScrollBar {
|
||||
.login-dialog-banner { color: darken($osd_fg_color,10%); }
|
||||
.login-dialog-button-box { spacing: 5px; }
|
||||
.login-dialog-message-warning { color: $warning_color; }
|
||||
- .login-dialog-message-hint { padding-top: 0; padding-bottom: 20px; }
|
||||
+ .login-dialog-message-hint, .login-dialog-message {
|
||||
+ color: darken($osd_fg_color, 20%);
|
||||
+ padding-top: 0;
|
||||
+ padding-bottom: 20px;
|
||||
+ min-height: 2.75em;
|
||||
+ }
|
||||
.login-dialog-user-selection-box { padding: 100px 0px; }
|
||||
.login-dialog-not-listed-label {
|
||||
padding-left: 2px;
|
||||
@@ -1856,6 +1887,10 @@ StScrollBar {
|
||||
padding-bottom: 12px;
|
||||
spacing: 8px;
|
||||
width: 23em;
|
||||
+ .login-dialog-timed-login-indicator {
|
||||
+ height: 2px;
|
||||
+ background-color: darken($fg_color,40%);
|
||||
+ }
|
||||
}
|
||||
|
||||
.login-dialog-prompt-label {
|
||||
--
|
||||
2.21.0
|
||||
|
33
SOURCES/0001-apps-menu-Add-missing-chain-up.patch
Normal file
33
SOURCES/0001-apps-menu-Add-missing-chain-up.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From 0bbeadadc41128b2be1f2b56c60b5a7a671d40da Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Thu, 27 Jun 2019 03:57:53 +0200
|
||||
Subject: [PATCH] apps-menu: Add missing chain-up
|
||||
|
||||
PanelMenu.Button is a bit weird in that it also "contains" its parent
|
||||
actor. That container is supposed to be destroyed with the button, but
|
||||
as we currently don't chain up to the parent class' _onDestroy(), we
|
||||
leave behind an empty container every time the extension is disabled.
|
||||
|
||||
Fix this by adding the missing chain-up.
|
||||
|
||||
https://gitlab.gnome.org/GNOME/gnome-shell-extensions/merge_requests/75
|
||||
---
|
||||
extensions/apps-menu/extension.js | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/extensions/apps-menu/extension.js b/extensions/apps-menu/extension.js
|
||||
index b9e7111..9803cc1 100644
|
||||
--- a/extensions/apps-menu/extension.js
|
||||
+++ b/extensions/apps-menu/extension.js
|
||||
@@ -433,6 +433,8 @@ class ApplicationsButton extends PanelMenu.Button {
|
||||
}
|
||||
|
||||
_onDestroy() {
|
||||
+ super._onDestroy();
|
||||
+
|
||||
Main.overview.disconnect(this._showingId);
|
||||
Main.overview.disconnect(this._hidingId);
|
||||
appSys.disconnect(this._installedChangedId);
|
||||
--
|
||||
2.21.0
|
||||
|
40
SOURCES/0001-apps-menu-Explicitly-set-label_actor.patch
Normal file
40
SOURCES/0001-apps-menu-Explicitly-set-label_actor.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 52ee25effa3debb21307e33ac223cf48ac7bc57a Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Thu, 17 Mar 2016 17:15:38 +0100
|
||||
Subject: [PATCH] apps-menu: Explicitly set label_actor
|
||||
|
||||
For some reason orca fails to pick up the label of category items,
|
||||
so set the label_actor explicitly as workaround.
|
||||
---
|
||||
extensions/apps-menu/extension.js | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/extensions/apps-menu/extension.js b/extensions/apps-menu/extension.js
|
||||
index d62e3d7..cc399c6 100644
|
||||
--- a/extensions/apps-menu/extension.js
|
||||
+++ b/extensions/apps-menu/extension.js
|
||||
@@ -29,7 +29,9 @@ class ActivitiesMenuItem extends PopupMenu.PopupBaseMenuItem {
|
||||
constructor(button) {
|
||||
super();
|
||||
this._button = button;
|
||||
- this.actor.add_child(new St.Label({ text: _('Activities Overview') }));
|
||||
+ let label = new St.Label({ text: _('Activities Overview') });
|
||||
+ this.actor.add_child(label);
|
||||
+ this.actor.label_actor = label;
|
||||
}
|
||||
|
||||
activate(event) {
|
||||
@@ -120,7 +122,9 @@ class CategoryMenuItem extends PopupMenu.PopupBaseMenuItem {
|
||||
else
|
||||
name = _('Favorites');
|
||||
|
||||
- this.actor.add_child(new St.Label({ text: name }));
|
||||
+ let label = new St.Label({ text: name });
|
||||
+ this.actor.add_child(label);
|
||||
+ this.actor.label_actor = label;
|
||||
this.actor.connect('motion-event', this._onMotionEvent.bind(this));
|
||||
}
|
||||
|
||||
--
|
||||
2.21.0
|
||||
|
@ -0,0 +1,32 @@
|
||||
From 3e3634b59455da0cbae1de4af0ce5cf97be8b80d Mon Sep 17 00:00:00 2001
|
||||
From: Ray Strode <rstrode@redhat.com>
|
||||
Date: Tue, 21 Jan 2014 16:48:17 -0500
|
||||
Subject: [PATCH] apps-menu: add logo icon to Applications menu
|
||||
|
||||
Brand requested it.
|
||||
---
|
||||
extensions/apps-menu/extension.js | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
diff --git a/extensions/apps-menu/extension.js b/extensions/apps-menu/extension.js
|
||||
index d7ba570..d62e3d7 100644
|
||||
--- a/extensions/apps-menu/extension.js
|
||||
+++ b/extensions/apps-menu/extension.js
|
||||
@@ -390,6 +390,14 @@ class ApplicationsButton extends PanelMenu.Button {
|
||||
|
||||
let hbox = new St.BoxLayout({ style_class: 'panel-status-menu-box' });
|
||||
|
||||
+ let iconFile = Gio.File.new_for_path(
|
||||
+ '/usr/share/icons/hicolor/scalable/apps/start-here.svg');
|
||||
+ this._icon = new St.Icon({
|
||||
+ gicon: new Gio.FileIcon({ file: iconFile }),
|
||||
+ style_class: 'panel-logo-icon'
|
||||
+ });
|
||||
+ hbox.add_actor(this._icon);
|
||||
+
|
||||
this._label = new St.Label({
|
||||
text: _('Applications'),
|
||||
y_expand: true,
|
||||
--
|
||||
2.21.0
|
||||
|
208
SOURCES/0001-dashToDock-Handle-no-overview-case.patch
Normal file
208
SOURCES/0001-dashToDock-Handle-no-overview-case.patch
Normal file
@ -0,0 +1,208 @@
|
||||
From 3c62051c0a154ae987bb0126e8adb6cd86aa69a2 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Mon, 24 Feb 2020 16:17:05 +0100
|
||||
Subject: [PATCH] dashToDock: Handle no-overview case
|
||||
|
||||
There is no longer an overview in GNOME Classic, so in order to be
|
||||
used in that environment, the extension must deal with that case.
|
||||
---
|
||||
extensions/dash-to-dock/docking.js | 122 ++++++++++++++++-------------
|
||||
1 file changed, 68 insertions(+), 54 deletions(-)
|
||||
|
||||
diff --git a/extensions/dash-to-dock/docking.js b/extensions/dash-to-dock/docking.js
|
||||
index d35094b..2b8353a 100644
|
||||
--- a/extensions/dash-to-dock/docking.js
|
||||
+++ b/extensions/dash-to-dock/docking.js
|
||||
@@ -233,7 +233,7 @@ var DockedDash = class DashToDock {
|
||||
// Create a new dash object
|
||||
this.dash = new MyDash.MyDash(this._settings, this._remoteModel, this._monitorIndex);
|
||||
|
||||
- if (!this._settings.get_boolean('show-show-apps-button'))
|
||||
+ if (Main.overview.isDummy || !this._settings.get_boolean('show-show-apps-button'))
|
||||
this.dash.hideShowAppsButton();
|
||||
|
||||
// Create the main actor and the containers for sliding in and out and
|
||||
@@ -272,45 +272,11 @@ var DockedDash = class DashToDock {
|
||||
this.dash.actor.add_constraint(this.constrainSize);
|
||||
|
||||
this._signalsHandler.add([
|
||||
- Main.overview,
|
||||
- 'item-drag-begin',
|
||||
- this._onDragStart.bind(this)
|
||||
- ], [
|
||||
- Main.overview,
|
||||
- 'item-drag-end',
|
||||
- this._onDragEnd.bind(this)
|
||||
- ], [
|
||||
- Main.overview,
|
||||
- 'item-drag-cancelled',
|
||||
- this._onDragEnd.bind(this)
|
||||
- ], [
|
||||
// update when workarea changes, for instance if other extensions modify the struts
|
||||
//(like moving th panel at the bottom)
|
||||
global.display,
|
||||
'workareas-changed',
|
||||
this._resetPosition.bind(this)
|
||||
- ], [
|
||||
- Main.overview,
|
||||
- 'showing',
|
||||
- this._onOverviewShowing.bind(this)
|
||||
- ], [
|
||||
- Main.overview,
|
||||
- 'hiding',
|
||||
- this._onOverviewHiding.bind(this)
|
||||
- ], [
|
||||
- // Hide on appview
|
||||
- Main.overview.viewSelector,
|
||||
- 'page-changed',
|
||||
- this._pageChanged.bind(this)
|
||||
- ], [
|
||||
- Main.overview.viewSelector,
|
||||
- 'page-empty',
|
||||
- this._onPageEmpty.bind(this)
|
||||
- ], [
|
||||
- // Ensure the ShowAppsButton status is kept in sync
|
||||
- Main.overview.viewSelector._showAppsButton,
|
||||
- 'notify::checked',
|
||||
- this._syncShowAppsButtonToggled.bind(this)
|
||||
], [
|
||||
global.display,
|
||||
'in-fullscreen-changed',
|
||||
@@ -325,15 +291,6 @@ var DockedDash = class DashToDock {
|
||||
this.dash,
|
||||
'icon-size-changed',
|
||||
() => { Main.overview.dashIconSize = this.dash.iconSize; }
|
||||
- ], [
|
||||
- // This duplicate the similar signal which is in owerview.js.
|
||||
- // Being connected and thus executed later this effectively
|
||||
- // overwrite any attempt to use the size of the default dash
|
||||
- //which given the customization is usually much smaller.
|
||||
- // I can't easily disconnect the original signal
|
||||
- Main.overview._controls.dash,
|
||||
- 'icon-size-changed',
|
||||
- () => { Main.overview.dashIconSize = this.dash.iconSize; }
|
||||
], [
|
||||
// sync hover after a popupmenu is closed
|
||||
this.dash,
|
||||
@@ -341,6 +298,53 @@ var DockedDash = class DashToDock {
|
||||
() => { this._box.sync_hover() }
|
||||
]);
|
||||
|
||||
+ if (!Main.overview.isDummy) {
|
||||
+ this._signalsHandler.add([
|
||||
+ Main.overview,
|
||||
+ 'item-drag-begin',
|
||||
+ this._onDragStart.bind(this)
|
||||
+ ], [
|
||||
+ Main.overview,
|
||||
+ 'item-drag-end',
|
||||
+ this._onDragEnd.bind(this)
|
||||
+ ], [
|
||||
+ Main.overview,
|
||||
+ 'item-drag-cancelled',
|
||||
+ this._onDragEnd.bind(this)
|
||||
+ ], [
|
||||
+ Main.overview,
|
||||
+ 'showing',
|
||||
+ this._onOverviewShowing.bind(this)
|
||||
+ ], [
|
||||
+ Main.overview,
|
||||
+ 'hiding',
|
||||
+ this._onOverviewHiding.bind(this)
|
||||
+ ], [
|
||||
+ // Hide on appview
|
||||
+ Main.overview.viewSelector,
|
||||
+ 'page-changed',
|
||||
+ this._pageChanged.bind(this)
|
||||
+ ], [
|
||||
+ Main.overview.viewSelector,
|
||||
+ 'page-empty',
|
||||
+ this._onPageEmpty.bind(this)
|
||||
+ ], [
|
||||
+ // Ensure the ShowAppsButton status is kept in sync
|
||||
+ Main.overview.viewSelector._showAppsButton,
|
||||
+ 'notify::checked',
|
||||
+ this._syncShowAppsButtonToggled.bind(this)
|
||||
+ ], [
|
||||
+ // This duplicate the similar signal which is in owerview.js.
|
||||
+ // Being connected and thus executed later this effectively
|
||||
+ // overwrite any attempt to use the size of the default dash
|
||||
+ //which given the customization is usually much smaller.
|
||||
+ // I can't easily disconnect the original signal
|
||||
+ Main.overview._controls.dash,
|
||||
+ 'icon-size-changed',
|
||||
+ () => { Main.overview.dashIconSize = this.dash.iconSize; }
|
||||
+ ]);
|
||||
+ }
|
||||
+
|
||||
this._injectionsHandler = new Utils.InjectionsHandler();
|
||||
this._themeManager = new Theming.ThemeManager(this._settings, this);
|
||||
|
||||
@@ -370,14 +374,17 @@ var DockedDash = class DashToDock {
|
||||
this._dashSpacer = new OverviewControls.DashSpacer();
|
||||
this._dashSpacer.setDashActor(this._box);
|
||||
|
||||
- if (this._position == St.Side.LEFT)
|
||||
- Main.overview._controls._group.insert_child_at_index(this._dashSpacer, this._rtl ? -1 : 0); // insert on first
|
||||
- else if (this._position == St.Side.RIGHT)
|
||||
- Main.overview._controls._group.insert_child_at_index(this._dashSpacer, this._rtl ? 0 : -1); // insert on last
|
||||
- else if (this._position == St.Side.TOP)
|
||||
- Main.overview._overview.insert_child_at_index(this._dashSpacer, 0);
|
||||
- else if (this._position == St.Side.BOTTOM)
|
||||
- Main.overview._overview.insert_child_at_index(this._dashSpacer, -1);
|
||||
+ if (!Main.overview.isDummy) {
|
||||
+ const { _controls, _overview } = Main.overview;
|
||||
+ if (this._position == St.Side.LEFT)
|
||||
+ _controls._group.insert_child_at_index(this._dashSpacer, this._rtl ? -1 : 0); // insert on first
|
||||
+ else if (this._position == St.Side.RIGHT)
|
||||
+ _controls._group.insert_child_at_index(this._dashSpacer, this._rtl ? 0 : -1); // insert on last
|
||||
+ else if (this._position == St.Side.TOP)
|
||||
+ _overview.insert_child_at_index(this._dashSpacer, 0);
|
||||
+ else if (this._position == St.Side.BOTTOM)
|
||||
+ _overview.insert_child_at_index(this._dashSpacer, -1);
|
||||
+ }
|
||||
|
||||
// Add dash container actor and the container to the Chrome.
|
||||
this.actor.set_child(this._slider);
|
||||
@@ -412,7 +419,7 @@ var DockedDash = class DashToDock {
|
||||
|
||||
// Since Gnome 3.8 dragging an app without having opened the overview before cause the attemp to
|
||||
//animate a null target since some variables are not initialized when the viewSelector is created
|
||||
- if (Main.overview.viewSelector._activePage == null)
|
||||
+ if (!Main.overview.isDummy && Main.overview.viewSelector._activePage == null)
|
||||
Main.overview.viewSelector._activePage = Main.overview.viewSelector._workspacesPage;
|
||||
|
||||
this._updateVisibilityMode();
|
||||
@@ -493,7 +500,8 @@ var DockedDash = class DashToDock {
|
||||
this._settings,
|
||||
'changed::show-show-apps-button',
|
||||
() => {
|
||||
- if (this._settings.get_boolean('show-show-apps-button'))
|
||||
+ if (!Main.overview.isDummy &&
|
||||
+ this._settings.get_boolean('show-show-apps-button'))
|
||||
this.dash.showShowAppsButton();
|
||||
else
|
||||
this.dash.hideShowAppsButton();
|
||||
@@ -1681,6 +1689,9 @@ var DockManager = class DashToDock_DockManager {
|
||||
// set stored icon size to the new dash
|
||||
Main.overview.dashIconSize = this._allDocks[0].dash.iconSize;
|
||||
|
||||
+ if (Main.overview.isDummy)
|
||||
+ return;
|
||||
+
|
||||
// Hide usual Dash
|
||||
Main.overview._controls.dash.actor.hide();
|
||||
|
||||
@@ -1707,6 +1718,9 @@ var DockManager = class DashToDock_DockManager {
|
||||
}
|
||||
|
||||
_restoreDash() {
|
||||
+ if (Main.overview.isDummy)
|
||||
+ return;
|
||||
+
|
||||
Main.overview._controls.dash.actor.show();
|
||||
Main.overview._controls.dash.actor.set_width(-1); //reset default dash size
|
||||
// This force the recalculation of the icon size
|
||||
--
|
||||
2.25.0
|
||||
|
31
SOURCES/0001-desktop-icons-Update-Japanese-translation.patch
Normal file
31
SOURCES/0001-desktop-icons-Update-Japanese-translation.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 0a7248c75c084a83852aa3d0e7a36ccebd365b81 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Wed, 27 Jan 2021 11:51:28 +0100
|
||||
Subject: [PATCH] desktop-icons: Update Japanese translation
|
||||
|
||||
---
|
||||
po/ja.po | 7 +------
|
||||
1 file changed, 1 insertion(+), 6 deletions(-)
|
||||
|
||||
diff --git a/po/ja.po b/po/ja.po
|
||||
index df5646d..4d780b9 100644
|
||||
--- a/po/ja.po
|
||||
+++ b/po/ja.po
|
||||
@@ -293,13 +293,8 @@ msgid "Workspace %d"
|
||||
msgstr "ワークスペース %d"
|
||||
|
||||
#: desktopGrid.js:334
|
||||
-#, fuzzy
|
||||
msgid "Display Settings"
|
||||
-msgstr ""
|
||||
-"#-#-#-#-# ja.po (gnome-shell-extensions master) #-#-#-#-#\n"
|
||||
-"ディスプレイ設定\n"
|
||||
-"#-#-#-#-# ja.po (desktop-icons master) #-#-#-#-#\n"
|
||||
-"ディスプレイの設定"
|
||||
+msgstr "ディスプレイ設定"
|
||||
|
||||
#: schemas/org.gnome.shell.extensions.desktop-icons.gschema.xml:11
|
||||
#, fuzzy
|
||||
--
|
||||
2.29.2
|
||||
|
@ -0,0 +1,55 @@
|
||||
From b4eeaf7ea12fa7d9713e80371490d8060396b3cb Mon Sep 17 00:00:00 2001
|
||||
From: Milan Crha <mcrha@redhat.com>
|
||||
Date: Fri, 17 Apr 2020 09:21:42 +0200
|
||||
Subject: [PATCH] window-list: Invalid current mode selected in Preferences
|
||||
|
||||
It seems that gtk+ resets the active radio whenever a new radio button
|
||||
is added into the group, thus rather restore the current mode after
|
||||
the group is fully populated.
|
||||
|
||||
https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/119
|
||||
---
|
||||
extensions/window-list/prefs.js | 9 ++++++++-
|
||||
1 file changed, 8 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/extensions/window-list/prefs.js b/extensions/window-list/prefs.js
|
||||
index 78792b5..17e9799 100644
|
||||
--- a/extensions/window-list/prefs.js
|
||||
+++ b/extensions/window-list/prefs.js
|
||||
@@ -50,6 +50,7 @@ class WindowListPrefsWidget extends Gtk.Grid {
|
||||
};
|
||||
|
||||
let radio = null;
|
||||
+ let currentRadio = null;
|
||||
for (let i = 0; i < modes.length; i++) {
|
||||
let mode = modes[i];
|
||||
let label = modeLabels[mode];
|
||||
@@ -59,18 +60,24 @@ class WindowListPrefsWidget extends Gtk.Grid {
|
||||
}
|
||||
|
||||
radio = new Gtk.RadioButton({
|
||||
- active: currentMode == mode,
|
||||
+ active: !i,
|
||||
label: label,
|
||||
group: radio
|
||||
});
|
||||
grid.add(radio);
|
||||
|
||||
+ if (currentMode === mode)
|
||||
+ currentRadio = radio;
|
||||
+
|
||||
radio.connect('toggled', button => {
|
||||
if (button.active)
|
||||
this._settings.set_string('grouping-mode', mode);
|
||||
});
|
||||
}
|
||||
|
||||
+ if (currentRadio)
|
||||
+ currentRadio.active = true;
|
||||
+
|
||||
let check = new Gtk.CheckButton({
|
||||
label: _('Show on all monitors'),
|
||||
margin_top: 6
|
||||
--
|
||||
2.26.2
|
||||
|
26742
SOURCES/add-extra-extensions.patch
Normal file
26742
SOURCES/add-extra-extensions.patch
Normal file
File diff suppressed because it is too large
Load Diff
27
SOURCES/gnome-classic-wayland.desktop
Normal file
27
SOURCES/gnome-classic-wayland.desktop
Normal file
@ -0,0 +1,27 @@
|
||||
[Desktop Entry]
|
||||
Name[de]=Klassisch (Wayland Anzeige-Server)
|
||||
Name[es]=Clásico (servidor gráfico Wayland)
|
||||
Name[fr]=Classic (serveur affichage Wayland)
|
||||
Name[it]=Classico (server grafico Wayland)
|
||||
Name[ja]=クラシック (Wayland ディスプレイサーバー)
|
||||
Name[ko]=클래식 (Wayland 디스플레이 서버)
|
||||
Name[pt_BR]=Clássico (servidor de exibição Wayland)
|
||||
Name[ru]=Классический (дисплейный сервер Wayland)
|
||||
Name[zh_CN]=经典(Wayland 显现服务器)
|
||||
Name[zh_TW]=經典(Wayland顯示服務器)
|
||||
Name=Classic (Wayland display server)
|
||||
Comment[de]=Diese Sitzung meldet Sie in GNOME Classic an
|
||||
Comment[es]=Esta sesión inicia GNOME clásico
|
||||
Comment[fr]=Cette session vous connnecte à GNOME Classique
|
||||
Comment[it]=Questa sessione si avvia con GNOME classico
|
||||
Comment[ja]=GNOME クラシックモードでログインします
|
||||
Comment[ko]=이 세션을 사용하면 그놈 클래식에 로그인합니다
|
||||
Comment[pt_BR]=Essa sessão se inicia como GNOME Clássico
|
||||
Comment[ru]=Данный сеанс использует классический рабочий стол GNOME
|
||||
Comment[zh_CN]=该会话将登录到“GNOME 经典模式”
|
||||
Comment[zh_TW]=這個作業階段讓您登入 GNOME Classic
|
||||
Comment=This session logs you into GNOME Classic
|
||||
Exec=env GNOME_SHELL_SESSION_MODE=classic gnome-session --session gnome-classic
|
||||
TryExec=gnome-session
|
||||
Type=Application
|
||||
DesktopNames=GNOME-Classic;GNOME;
|
27
SOURCES/gnome-classic.desktop
Normal file
27
SOURCES/gnome-classic.desktop
Normal file
@ -0,0 +1,27 @@
|
||||
[Desktop Entry]
|
||||
Name[de]=Klassisch (X11 Anzeige-Server)
|
||||
Name[es]=Clásico (servidor gráfico X11)
|
||||
Name[fr]=Classic (serveur affichage X11)
|
||||
Name[it]=Classico (server grafico X11)
|
||||
Name[ja]=クラシック (X11 ディスプレイサーバー)
|
||||
Name[ko]=클래식 (X11 디스플레이 서버)
|
||||
Name[pt_BR]=Clássico (servidor de exibição X11)
|
||||
Name[ru]=Классический (дисплейный сервер X11)
|
||||
Name[zh_CN]=经典(X11 显示服务器)
|
||||
Name[zh_TW]=經典(X11顯示服務器)
|
||||
Name=Classic (X11 display server)
|
||||
Comment[de]=Diese Sitzung meldet Sie in GNOME Classic an
|
||||
Comment[es]=Esta sesión inicia GNOME clásico
|
||||
Comment[fr]=Cette session vous connnecte à GNOME Classique
|
||||
Comment[it]=Questa sessione si avvia con GNOME classico
|
||||
Comment[ja]=GNOME クラシックモードでログインします
|
||||
Comment[ko]=이 세션을 사용하면 그놈 클래식에 로그인합니다
|
||||
Comment[pt_BR]=Essa sessão se inicia como GNOME Clássico
|
||||
Comment[ru]=Данный сеанс использует классический рабочий стол GNOME
|
||||
Comment[zh_CN]=该会话将登录到“GNOME 经典模式”
|
||||
Comment[zh_TW]=這個作業階段讓您登入 GNOME Classic
|
||||
Comment=This session logs you into GNOME Classic
|
||||
Exec=env GNOME_SHELL_SESSION_MODE=classic gnome-session --session gnome-classic
|
||||
TryExec=gnome-session
|
||||
Type=Application
|
||||
DesktopNames=GNOME-Classic;GNOME;
|
3270
SOURCES/more-classic-classic-mode.patch
Normal file
3270
SOURCES/more-classic-classic-mode.patch
Normal file
File diff suppressed because it is too large
Load Diff
1311
SOURCES/resurrect-system-monitor.patch
Normal file
1311
SOURCES/resurrect-system-monitor.patch
Normal file
File diff suppressed because it is too large
Load Diff
1025
SPECS/gnome-shell-extensions.spec
Normal file
1025
SPECS/gnome-shell-extensions.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user