import gnome-shell-extensions-3.32.1-27.el8
This commit is contained in:
parent
4746496ff9
commit
c4d161f7aa
@ -1,4 +1,4 @@
|
||||
From 7a6819443c896ce288e420cb9bfebebaade61fdb Mon Sep 17 00:00:00 2001
|
||||
From 2a498fef3ec02d834346b545aeacba0a6224494e Mon Sep 17 00:00:00 2001
|
||||
From: rpm-build <rpm-build>
|
||||
Date: Thu, 28 Jan 2021 00:06:12 +0100
|
||||
Subject: [PATCH] Add gesture-inhibitor extension
|
||||
@ -20,7 +20,7 @@ This extension may disable default GNOME Shell gestures.
|
||||
|
||||
diff --git a/extensions/gesture-inhibitor/extension.js b/extensions/gesture-inhibitor/extension.js
|
||||
new file mode 100644
|
||||
index 0000000..e74ede2
|
||||
index 00000000..e74ede2f
|
||||
--- /dev/null
|
||||
+++ b/extensions/gesture-inhibitor/extension.js
|
||||
@@ -0,0 +1,75 @@
|
||||
@ -101,7 +101,7 @@ index 0000000..e74ede2
|
||||
+}
|
||||
diff --git a/extensions/gesture-inhibitor/meson.build b/extensions/gesture-inhibitor/meson.build
|
||||
new file mode 100644
|
||||
index 0000000..fdad5cc
|
||||
index 00000000..fdad5cc8
|
||||
--- /dev/null
|
||||
+++ b/extensions/gesture-inhibitor/meson.build
|
||||
@@ -0,0 +1,8 @@
|
||||
@ -115,7 +115,7 @@ index 0000000..fdad5cc
|
||||
+extension_schemas += files(metadata_conf.get('gschemaname') + '.gschema.xml')
|
||||
diff --git a/extensions/gesture-inhibitor/metadata.json.in b/extensions/gesture-inhibitor/metadata.json.in
|
||||
new file mode 100644
|
||||
index 0000000..37d6a11
|
||||
index 00000000..37d6a117
|
||||
--- /dev/null
|
||||
+++ b/extensions/gesture-inhibitor/metadata.json.in
|
||||
@@ -0,0 +1,12 @@
|
||||
@ -133,7 +133,7 @@ index 0000000..37d6a11
|
||||
+
|
||||
diff --git a/extensions/gesture-inhibitor/org.gnome.shell.extensions.gesture-inhibitor.gschema.xml b/extensions/gesture-inhibitor/org.gnome.shell.extensions.gesture-inhibitor.gschema.xml
|
||||
new file mode 100644
|
||||
index 0000000..1d67dcc
|
||||
index 00000000..1d67dcc0
|
||||
--- /dev/null
|
||||
+++ b/extensions/gesture-inhibitor/org.gnome.shell.extensions.gesture-inhibitor.gschema.xml
|
||||
@@ -0,0 +1,25 @@
|
||||
@ -164,23 +164,23 @@ index 0000000..1d67dcc
|
||||
+
|
||||
diff --git a/extensions/gesture-inhibitor/stylesheet.css b/extensions/gesture-inhibitor/stylesheet.css
|
||||
new file mode 100644
|
||||
index 0000000..37b93f2
|
||||
index 00000000..37b93f21
|
||||
--- /dev/null
|
||||
+++ b/extensions/gesture-inhibitor/stylesheet.css
|
||||
@@ -0,0 +1 @@
|
||||
+/* Add your custom extension styling here */
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 23bd5ad..9e59729 100644
|
||||
index e163b84d..ba84f8f3 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -54,6 +54,7 @@ all_extensions += [
|
||||
'auto-move-windows',
|
||||
@@ -55,6 +55,7 @@ all_extensions += [
|
||||
'dash-to-dock',
|
||||
'dash-to-panel',
|
||||
'disable-screenshield',
|
||||
+ 'gesture-inhibitor',
|
||||
'native-window-placement',
|
||||
'no-hot-corner',
|
||||
'panel-favorites',
|
||||
--
|
||||
2.29.2
|
||||
2.32.0
|
||||
|
||||
|
@ -0,0 +1,179 @@
|
||||
From b334c8c248f849be996963cdafb1b0b69476bdf1 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@redhat.com>
|
||||
Date: Tue, 2 Nov 2021 09:20:11 +0100
|
||||
Subject: [PATCH] desktop-icons: Fix stuck grab issue with rubber banding
|
||||
|
||||
The desktop icons extension can get into a state where the desktop no longer
|
||||
takes mouse input.
|
||||
|
||||
This happens if a user starts a rubber banding operation and then drags
|
||||
the mouse to somewhere on screen that has a pop up menu, and then pops
|
||||
the menu up.
|
||||
|
||||
This commit addresses the bug by limiting the grab actor to the
|
||||
backgrounds, and by explicitly ending the rubber banding operation
|
||||
when one of the icons own menus is shown.
|
||||
|
||||
One side effect of limiting the grab actor to the backgrounds, is the
|
||||
rubber banding code never gets to see motion outside of the backgrounds
|
||||
anymore. In order to keep drag operations feeling fluid when the user moves
|
||||
toward the edge of the screen, this commit also overrides the
|
||||
grab helpers captured-event handler so those motion events keep coming.
|
||||
|
||||
We also start to end the rubber band if for any reason the grab it had
|
||||
was released.
|
||||
---
|
||||
extensions/desktop-icons/desktopGrid.js | 1 +
|
||||
extensions/desktop-icons/desktopManager.js | 75 ++++++++++++++--------
|
||||
extensions/desktop-icons/fileItem.js | 1 +
|
||||
3 files changed, 49 insertions(+), 28 deletions(-)
|
||||
|
||||
diff --git a/extensions/desktop-icons/desktopGrid.js b/extensions/desktop-icons/desktopGrid.js
|
||||
index 602fa7f..bd27e2a 100644
|
||||
--- a/extensions/desktop-icons/desktopGrid.js
|
||||
+++ b/extensions/desktop-icons/desktopGrid.js
|
||||
@@ -365,6 +365,7 @@ var DesktopGrid = class {
|
||||
}
|
||||
|
||||
_openMenu(x, y) {
|
||||
+ Extension.desktopManager.endRubberBand();
|
||||
Main.layoutManager.setDummyCursorGeometry(x, y, 0, 0);
|
||||
this.actor._desktopBackgroundMenu.open(BoxPointer.PopupAnimation.NONE);
|
||||
/* Since the handler is in the press event it needs to ignore the release event
|
||||
diff --git a/extensions/desktop-icons/desktopManager.js b/extensions/desktop-icons/desktopManager.js
|
||||
index a70cd98..c37e1e7 100644
|
||||
--- a/extensions/desktop-icons/desktopManager.js
|
||||
+++ b/extensions/desktop-icons/desktopManager.js
|
||||
@@ -79,6 +79,7 @@ var DesktopManager = GObject.registerClass({
|
||||
this._queryFileInfoCancellable = null;
|
||||
this._unixMode = null;
|
||||
this._writableByOthers = null;
|
||||
+ this._rubberBandActive = false;
|
||||
|
||||
this._monitorsChangedId = Main.layoutManager.connect('monitors-changed', () => this._recreateDesktopIcons());
|
||||
this._rubberBand = new St.Widget({ style_class: 'rubber-band' });
|
||||
@@ -86,6 +87,20 @@ var DesktopManager = GObject.registerClass({
|
||||
Main.layoutManager._backgroundGroup.add_child(this._rubberBand);
|
||||
this._grabHelper = new GrabHelper.GrabHelper(global.stage);
|
||||
|
||||
+ let origCapturedEvent = this._grabHelper.onCapturedEvent;
|
||||
+ this._grabHelper.onCapturedEvent = (event) => {
|
||||
+ if (event.type() === Clutter.EventType.MOTION) {
|
||||
+ /* We handle motion events from a captured event handler so we
|
||||
+ * we can see motion over actors that are on other parts of the
|
||||
+ * stage.
|
||||
+ */
|
||||
+ this._handleMotion(event);
|
||||
+ return Clutter.EVENT_STOP;
|
||||
+ }
|
||||
+
|
||||
+ return origCapturedEvent.bind(this._grabHelper)(event);
|
||||
+ };
|
||||
+
|
||||
this._addDesktopIcons();
|
||||
this._monitorDesktopFolder();
|
||||
|
||||
@@ -108,30 +123,15 @@ var DesktopManager = GObject.registerClass({
|
||||
this._initRubberBandColor();
|
||||
this._updateRubberBand(x, y);
|
||||
this._rubberBand.show();
|
||||
- this._grabHelper.grab({ actor: global.stage });
|
||||
+ this._rubberBandActive = true;
|
||||
+ this._grabHelper.grab({
|
||||
+ actor: Main.layoutManager._backgroundGroup,
|
||||
+ onUngrab: () => this.endRubberBand(false),
|
||||
+ });
|
||||
Extension.lockActivitiesButton = true;
|
||||
this._stageReleaseEventId = global.stage.connect('button-release-event', (actor, event) => {
|
||||
this.endRubberBand();
|
||||
});
|
||||
- this._rubberBandId = global.stage.connect('motion-event', (actor, event) => {
|
||||
- /* In some cases, when the user starts a rubberband selection and ends it
|
||||
- * (by releasing the left button) over a window instead of doing it over
|
||||
- * the desktop, the stage doesn't receive the "button-release" event.
|
||||
- * This happens currently with, at least, Dash to Dock extension, but
|
||||
- * it probably also happens with other applications or extensions.
|
||||
- * To fix this, we also end the rubberband selection if we detect mouse
|
||||
- * motion in the stage without the left button pressed during a
|
||||
- * rubberband selection.
|
||||
- * */
|
||||
- let button = event.get_state();
|
||||
- if (!(button & Clutter.ModifierType.BUTTON1_MASK)) {
|
||||
- this.endRubberBand();
|
||||
- return;
|
||||
- }
|
||||
- [x, y] = event.get_coords();
|
||||
- this._updateRubberBand(x, y);
|
||||
- this._updateSelection(x, y);
|
||||
- });
|
||||
this._rubberBandTouchId = global.stage.connect('touch-event', (actor, event) => {
|
||||
// Let x11 pointer emulation do the job on X11
|
||||
if (!Meta.is_wayland_compositor())
|
||||
@@ -175,14 +175,37 @@ var DesktopManager = GObject.registerClass({
|
||||
}
|
||||
}
|
||||
|
||||
- endRubberBand() {
|
||||
+ _handleMotion(event) {
|
||||
+ /* In some cases, when the user starts a rubberband selection and ends it
|
||||
+ * (by releasing the left button) over a window instead of doing it over
|
||||
+ * the desktop, the stage doesn't receive the "button-release" event.
|
||||
+ * This happens currently with, at least, Dash to Dock extension, but
|
||||
+ * it probably also happens with other applications or extensions.
|
||||
+ * To fix this, we also end the rubberband selection if we detect mouse
|
||||
+ * motion in the stage without the left button pressed during a
|
||||
+ * rubberband selection.
|
||||
+ * */
|
||||
+ let button = event.get_state();
|
||||
+ if (!(button & Clutter.ModifierType.BUTTON1_MASK)) {
|
||||
+ this.endRubberBand();
|
||||
+ return;
|
||||
+ }
|
||||
+ let [x, y] = event.get_coords();
|
||||
+ this._updateRubberBand(x, y);
|
||||
+ this._updateSelection(x, y);
|
||||
+ }
|
||||
+
|
||||
+ endRubberBand(ungrab=true) {
|
||||
+ if (!this._rubberBandActive)
|
||||
+ return;
|
||||
+
|
||||
+ this._rubberBandActive = false;
|
||||
this._rubberBand.hide();
|
||||
Extension.lockActivitiesButton = false;
|
||||
- this._grabHelper.ungrab();
|
||||
- global.stage.disconnect(this._rubberBandId);
|
||||
+ if (ungrab)
|
||||
+ this._grabHelper.ungrab();
|
||||
global.stage.disconnect(this._rubberBandTouchId);
|
||||
global.stage.disconnect(this._stageReleaseEventId);
|
||||
- this._rubberBandId = 0;
|
||||
this._rubberBandTouchId = 0;
|
||||
this._stageReleaseEventId = 0;
|
||||
|
||||
@@ -760,10 +783,6 @@ var DesktopManager = GObject.registerClass({
|
||||
global.stage.disconnect(this._stageReleaseEventId);
|
||||
this._stageReleaseEventId = 0;
|
||||
|
||||
- if (this._rubberBandId)
|
||||
- global.stage.disconnect(this._rubberBandId);
|
||||
- this._rubberBandId = 0;
|
||||
-
|
||||
if (this._rubberBandTouchId)
|
||||
global.stage.disconnect(this._rubberBandTouchId);
|
||||
this._rubberBandTouchId = 0;
|
||||
diff --git a/extensions/desktop-icons/fileItem.js b/extensions/desktop-icons/fileItem.js
|
||||
index 1cb47e8..90f326d 100644
|
||||
--- a/extensions/desktop-icons/fileItem.js
|
||||
+++ b/extensions/desktop-icons/fileItem.js
|
||||
@@ -676,6 +676,7 @@ var FileItem = class {
|
||||
}
|
||||
|
||||
_onPressButton(actor, event) {
|
||||
+ Extension.desktopManager.endRubberBand();
|
||||
this._updateClickState(event);
|
||||
let button = this._eventButton(event);
|
||||
if (button == 3) {
|
||||
--
|
||||
2.31.1
|
||||
|
@ -0,0 +1,28 @@
|
||||
From 81b5163b43b7d45ca8bc9205476ef67789e283a4 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Mon, 29 Nov 2021 16:48:53 +0100
|
||||
Subject: [PATCH] desktop-icons: Use a single unique name to access nautilus
|
||||
|
||||
... otherwise dbus-daemon will assume that activating one of the
|
||||
services failed, because its executable exits early (after activating
|
||||
the primary instance).
|
||||
---
|
||||
extensions/desktop-icons/dbusUtils.js | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/extensions/desktop-icons/dbusUtils.js b/extensions/desktop-icons/dbusUtils.js
|
||||
index 19fe9878..b44ffa59 100644
|
||||
--- a/extensions/desktop-icons/dbusUtils.js
|
||||
+++ b/extensions/desktop-icons/dbusUtils.js
|
||||
@@ -64,7 +64,7 @@ function init() {
|
||||
|
||||
FreeDesktopFileManagerProxy = new FreeDesktopFileManagerProxyInterface(
|
||||
Gio.DBus.session,
|
||||
- 'org.freedesktop.FileManager1',
|
||||
+ 'org.gnome.Nautilus',
|
||||
'/org/freedesktop/FileManager1',
|
||||
(proxy, error) => {
|
||||
if (error) {
|
||||
--
|
||||
2.33.1
|
||||
|
@ -0,0 +1,41 @@
|
||||
From dfdd10b46d670674d5e0e38f7adcd007f5884822 Mon Sep 17 00:00:00 2001
|
||||
From: rpm-build <rpm-build>
|
||||
Date: Wed, 29 Sep 2021 14:33:25 +0200
|
||||
Subject: [PATCH] gesture-inhibitor: Put a foot down with self-enabling
|
||||
gestures
|
||||
|
||||
If a gesture (unfullscreen, I'm looking at you) controls its 'enabled'
|
||||
property, it will bypass the will of this extension. Make it sure that
|
||||
gestures are forced-off if the extension says so.
|
||||
---
|
||||
extensions/gesture-inhibitor/extension.js | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/extensions/gesture-inhibitor/extension.js b/extensions/gesture-inhibitor/extension.js
|
||||
index e74ede2..66c706e 100644
|
||||
--- a/extensions/gesture-inhibitor/extension.js
|
||||
+++ b/extensions/gesture-inhibitor/extension.js
|
||||
@@ -59,13 +59,19 @@ class Extension {
|
||||
enable() {
|
||||
this._map.forEach(m => {
|
||||
this._settings.bind(m.setting, m.action, 'enabled',
|
||||
- Gio.SettingsBindFlags.DEFAULT);
|
||||
+ Gio.SettingsBindFlags.GET);
|
||||
+ m.handler = m.action.connect('notify::enabled', () => {
|
||||
+ if (m.action.enabled && !this._settings.get_boolean(m.setting))
|
||||
+ m.action.enabled = this._settings.get_boolean(m.setting);
|
||||
+ });
|
||||
});
|
||||
}
|
||||
|
||||
disable() {
|
||||
this._map.forEach(m => {
|
||||
m.action.enabled = true;
|
||||
+ if (m.handler > 0)
|
||||
+ m.action.disconnect(m.handler);
|
||||
});
|
||||
}
|
||||
}
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 131b1b81f8f28bf57d080487e121d332546f1ab1 Mon Sep 17 00:00:00 2001
|
||||
From 8da1760af68496c6073be4d6b3c8266b64347925 Mon Sep 17 00:00:00 2001
|
||||
From: Ray Strode <rstrode@redhat.com>
|
||||
Date: Tue, 24 Aug 2021 15:03:57 -0400
|
||||
Subject: [PATCH] heads-up-display: Add extension for showing persistent heads
|
||||
@ -24,7 +24,7 @@ Subject: [PATCH] heads-up-display: Add extension for showing persistent heads
|
||||
|
||||
diff --git a/extensions/heads-up-display/extension.js b/extensions/heads-up-display/extension.js
|
||||
new file mode 100644
|
||||
index 0000000..e4ef9e8
|
||||
index 00000000..e4ef9e85
|
||||
--- /dev/null
|
||||
+++ b/extensions/heads-up-display/extension.js
|
||||
@@ -0,0 +1,320 @@
|
||||
@ -350,7 +350,7 @@ index 0000000..e4ef9e8
|
||||
+}
|
||||
diff --git a/extensions/heads-up-display/headsUpMessage.js b/extensions/heads-up-display/headsUpMessage.js
|
||||
new file mode 100644
|
||||
index 0000000..d828d8c
|
||||
index 00000000..d828d8c9
|
||||
--- /dev/null
|
||||
+++ b/extensions/heads-up-display/headsUpMessage.js
|
||||
@@ -0,0 +1,150 @@
|
||||
@ -506,7 +506,7 @@ index 0000000..d828d8c
|
||||
+});
|
||||
diff --git a/extensions/heads-up-display/meson.build b/extensions/heads-up-display/meson.build
|
||||
new file mode 100644
|
||||
index 0000000..40c3de0
|
||||
index 00000000..40c3de0a
|
||||
--- /dev/null
|
||||
+++ b/extensions/heads-up-display/meson.build
|
||||
@@ -0,0 +1,8 @@
|
||||
@ -520,7 +520,7 @@ index 0000000..40c3de0
|
||||
+extension_schemas += files(metadata_conf.get('gschemaname') + '.gschema.xml')
|
||||
diff --git a/extensions/heads-up-display/metadata.json.in b/extensions/heads-up-display/metadata.json.in
|
||||
new file mode 100644
|
||||
index 0000000..e7ab71a
|
||||
index 00000000..e7ab71aa
|
||||
--- /dev/null
|
||||
+++ b/extensions/heads-up-display/metadata.json.in
|
||||
@@ -0,0 +1,11 @@
|
||||
@ -537,7 +537,7 @@ index 0000000..e7ab71a
|
||||
+}
|
||||
diff --git a/extensions/heads-up-display/org.gnome.shell.extensions.heads-up-display.gschema.xml b/extensions/heads-up-display/org.gnome.shell.extensions.heads-up-display.gschema.xml
|
||||
new file mode 100644
|
||||
index 0000000..ea1f377
|
||||
index 00000000..ea1f3774
|
||||
--- /dev/null
|
||||
+++ b/extensions/heads-up-display/org.gnome.shell.extensions.heads-up-display.gschema.xml
|
||||
@@ -0,0 +1,54 @@
|
||||
@ -597,7 +597,7 @@ index 0000000..ea1f377
|
||||
+</schemalist>
|
||||
diff --git a/extensions/heads-up-display/prefs.js b/extensions/heads-up-display/prefs.js
|
||||
new file mode 100644
|
||||
index 0000000..b4b6f94
|
||||
index 00000000..b4b6f94c
|
||||
--- /dev/null
|
||||
+++ b/extensions/heads-up-display/prefs.js
|
||||
@@ -0,0 +1,175 @@
|
||||
@ -778,7 +778,7 @@ index 0000000..b4b6f94
|
||||
+}
|
||||
diff --git a/extensions/heads-up-display/stylesheet.css b/extensions/heads-up-display/stylesheet.css
|
||||
new file mode 100644
|
||||
index 0000000..9303446
|
||||
index 00000000..93034469
|
||||
--- /dev/null
|
||||
+++ b/extensions/heads-up-display/stylesheet.css
|
||||
@@ -0,0 +1,32 @@
|
||||
@ -815,37 +815,10 @@ index 0000000..9303446
|
||||
+ text-align: center;
|
||||
+}
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 9e59729..84e161d 100644
|
||||
index ba84f8f3..c5fc86ef 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -17,60 +17,61 @@ modedir = join_paths(shelldir, 'modes')
|
||||
themedir = join_paths(shelldir, 'theme')
|
||||
|
||||
schemadir = join_paths(datadir, 'glib-2.0', 'schemas')
|
||||
sessiondir = join_paths(datadir, 'gnome-session', 'sessions')
|
||||
xsessiondir = join_paths(datadir, 'xsessions')
|
||||
|
||||
js60 = find_program('js60', required: false)
|
||||
|
||||
ver_arr = meson.project_version().split('.')
|
||||
if ver_arr[1].to_int().is_even()
|
||||
shell_version = '@0@.@1@'.format(ver_arr[0], ver_arr[1])
|
||||
else
|
||||
shell_version = '.'.join(ver_arr)
|
||||
endif
|
||||
|
||||
uuid_suffix = '@gnome-shell-extensions.gcampax.github.com'
|
||||
|
||||
classic_extensions = [
|
||||
'apps-menu',
|
||||
'desktop-icons',
|
||||
'horizontal-workspaces',
|
||||
'places-menu',
|
||||
'launch-new-instance',
|
||||
'top-icons',
|
||||
'window-list'
|
||||
]
|
||||
|
||||
@@ -44,6 +44,7 @@ classic_extensions = [
|
||||
default_extensions = classic_extensions
|
||||
default_extensions += [
|
||||
'drive-menu',
|
||||
@ -853,33 +826,6 @@ index 9e59729..84e161d 100644
|
||||
'screenshot-window-sizer',
|
||||
'windowsNavigator',
|
||||
'workspace-indicator'
|
||||
]
|
||||
|
||||
all_extensions = default_extensions
|
||||
all_extensions += [
|
||||
'auto-move-windows',
|
||||
'dash-to-dock',
|
||||
'disable-screenshield',
|
||||
'gesture-inhibitor',
|
||||
'native-window-placement',
|
||||
'no-hot-corner',
|
||||
'panel-favorites',
|
||||
'systemMonitor',
|
||||
'updates-dialog',
|
||||
'user-theme',
|
||||
'window-grouper'
|
||||
]
|
||||
|
||||
enabled_extensions = get_option('enable_extensions')
|
||||
|
||||
if enabled_extensions.length() == 0
|
||||
set = get_option('extension_set')
|
||||
|
||||
if set == 'classic'
|
||||
enabled_extensions += classic_extensions
|
||||
elif set == 'default'
|
||||
enabled_extensions += default_extensions
|
||||
elif set == 'all'
|
||||
--
|
||||
2.27.0
|
||||
2.32.0
|
||||
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -6,7 +6,7 @@
|
||||
|
||||
Name: gnome-shell-extensions
|
||||
Version: 3.32.1
|
||||
Release: 20%{?dist}
|
||||
Release: 27%{?dist}
|
||||
Summary: Modify and extend GNOME Shell functionality and behavior
|
||||
|
||||
Group: User Interface/Desktops
|
||||
@ -46,6 +46,9 @@ Patch0017: desktop-icons-touch-support.patch
|
||||
Patch0018: 0001-Add-gesture-inhibitor-extension.patch
|
||||
Patch0019: 0001-top-icons-Don-t-use-wm_class-as-role.patch
|
||||
Patch0020: 0001-heads-up-display-Add-extension-for-showing-persisten.patch
|
||||
Patch0021: 0001-desktop-icons-Fix-stuck-grab-issue-with-rubber-bandi.patch
|
||||
Patch0022: 0001-gesture-inhibitor-Put-a-foot-down-with-self-enabling.patch
|
||||
Patch0023: 0001-desktop-icons-Use-a-single-unique-name-to-access-nau.patch
|
||||
|
||||
%description
|
||||
GNOME Shell Extensions is a collection of extensions providing additional and
|
||||
@ -54,7 +57,9 @@ optional functionality to GNOME Shell.
|
||||
Enabled extensions:
|
||||
* apps-menu
|
||||
* auto-move-windows
|
||||
* classification-banner
|
||||
* dash-to-dock
|
||||
* dash-to-panel
|
||||
* disable-screenshield
|
||||
* desktop-icons
|
||||
* gesture-inhibitor
|
||||
@ -148,6 +153,16 @@ workspace can be assigned to each application as soon as it creates a window, in
|
||||
a manner configurable with a GSettings key.
|
||||
|
||||
|
||||
%package -n %{pkg_prefix}-classification-banner
|
||||
Summary: Display classification level banner in GNOME Shell
|
||||
Group: User Interface/Desktops
|
||||
License: GPLv2+
|
||||
Requires: %{pkg_prefix}-common = %{version}-%{release}
|
||||
|
||||
%description -n %{pkg_prefix}-classification-banner
|
||||
This GNOME Shell extension adds a banner that displays the classification level.
|
||||
|
||||
|
||||
%package -n %{pkg_prefix}-dash-to-dock
|
||||
Summary: Show the dash outside the activities overview
|
||||
Group: User Interface/Desktops
|
||||
@ -158,6 +173,16 @@ Requires: %{pkg_prefix}-common = %{version}-%{release}
|
||||
This GNOME Shell extension makes the dash available outside the activities overview.
|
||||
|
||||
|
||||
%package -n %{pkg_prefix}-dash-to-panel
|
||||
Summary: Show the dash in the top bar
|
||||
Group: User Interface/Desktops
|
||||
License: GPLv2+
|
||||
Requires: %{pkg_prefix}-common = %{version}-%{release}
|
||||
|
||||
%description -n %{pkg_prefix}-dash-to-panel
|
||||
This GNOME Shell extension makes the dash available in the top bar
|
||||
|
||||
|
||||
%package -n %{pkg_prefix}-disable-screenshield
|
||||
Summary: Disable GNOME Shell screen shield if lock is disabled
|
||||
Group: User Interface/Desktops
|
||||
@ -417,11 +442,21 @@ cp $RPM_SOURCE_DIR/gnome-classic.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions
|
||||
%{_datadir}/gnome-shell/extensions/auto-move-windows*/
|
||||
|
||||
|
||||
%files -n %{pkg_prefix}-classification-banner
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.classification-banner.gschema.xml
|
||||
%{_datadir}/gnome-shell/extensions/classification-banner*/
|
||||
|
||||
|
||||
%files -n %{pkg_prefix}-dash-to-dock
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.dash-to-dock.gschema.xml
|
||||
%{_datadir}/gnome-shell/extensions/dash-to-dock*/
|
||||
|
||||
|
||||
%files -n %{pkg_prefix}-dash-to-panel
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.dash-to-panel.gschema.xml
|
||||
%{_datadir}/gnome-shell/extensions/dash-to-panel*/
|
||||
|
||||
|
||||
%files -n %{pkg_prefix}-disable-screenshield
|
||||
%{_datadir}/gnome-shell/extensions/disable-screenshield*/
|
||||
|
||||
@ -512,6 +547,34 @@ cp $RPM_SOURCE_DIR/gnome-classic.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Dec 14 2021 Florian Müllner <fmuellner@redhat.com> - 3.32.1-27
|
||||
- Keep classification banners on login/lock screen
|
||||
Resolves: #1751336
|
||||
|
||||
* Fri Dec 10 2021 Florian Müllner <fmuellner@redhat.com> - 3.32.1-26
|
||||
- Add classification-banner
|
||||
Resolves: #1751336
|
||||
|
||||
* Mon Nov 29 2021 Florian Müllner <fmuellner@redhat.com> - 3.32.1-25
|
||||
- Fix desktop-icons warning
|
||||
Resolves: #2026622
|
||||
|
||||
* Thu Nov 04 2021 Carlos Garnacho <cgarnach@redhat.com> - 3.32.1-24
|
||||
- Fix gesture inhibitor extension with unfullscreen gesture
|
||||
Resolves: #1988906
|
||||
|
||||
* Tue Nov 02 2021 Jonas Ådahl <jadahl@redhat.com> - 3.32.1-23
|
||||
- Fix stuck grab on desktop-icons
|
||||
Resolves: #1984956
|
||||
|
||||
* Tue Oct 19 2021 Florian Müllner <fmuellner@redhat.com> - 3.32.1-22
|
||||
- Install missing prefs file
|
||||
Related: #1995814
|
||||
|
||||
* Mon Oct 18 2021 Florian Müllner <fmuellner@redhat.com> - 3.32.1-21
|
||||
- Add dash-to-panel
|
||||
Resolves: #1995814
|
||||
|
||||
* Thu Aug 26 2021 Ray Strode <rstrode@redhat.com> - 3.32.1-20
|
||||
- Add extension for displaying heads up message
|
||||
Related: #1651378
|
||||
|
Loading…
Reference in New Issue
Block a user