import gnome-shell-extensions-40.4-1.el9
This commit is contained in:
commit
bb2ef745cb
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/gnome-shell-extensions-40.4.tar.xz
|
1
.gnome-shell-extensions.metadata
Normal file
1
.gnome-shell-extensions.metadata
Normal file
@ -0,0 +1 @@
|
||||
d47290e4787b2f70bf56c0fca4ec450da11c41aa SOURCES/gnome-shell-extensions-40.4.tar.xz
|
32
SOURCES/0001-Include-top-icons-in-classic-session.patch
Normal file
32
SOURCES/0001-Include-top-icons-in-classic-session.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 4d57a258f50ab86506642fe8657e80077e9490fc Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Fri, 23 Feb 2018 16:56:46 +0100
|
||||
Subject: [PATCH] Include top-icons in classic session
|
||||
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index ada6b92..8f01fb3 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -31,6 +31,7 @@ classic_extensions = [
|
||||
'desktop-icons',
|
||||
'places-menu',
|
||||
'launch-new-instance',
|
||||
+ 'top-icons',
|
||||
'window-list'
|
||||
]
|
||||
|
||||
@@ -49,7 +50,6 @@ all_extensions += [
|
||||
'native-window-placement',
|
||||
'panel-favorites',
|
||||
'systemMonitor',
|
||||
- 'top-icons',
|
||||
'updates-dialog',
|
||||
'user-theme'
|
||||
]
|
||||
--
|
||||
2.28.0
|
||||
|
43
SOURCES/0001-Update-style.patch
Normal file
43
SOURCES/0001-Update-style.patch
Normal file
@ -0,0 +1,43 @@
|
||||
From 9ca03a744552c43251523fd23292b243130e1f89 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Mon, 24 May 2021 15:36:04 +0200
|
||||
Subject: [PATCH] Update style
|
||||
|
||||
---
|
||||
data/gnome-shell-sass | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
Submodule data/gnome-shell-sass 9d66f7d..60230f4:
|
||||
diff --git a/data/gnome-shell-sass/widgets/_panel.scss b/data/gnome-shell-sass/widgets/_panel.scss
|
||||
index 1f46507..ad638b2 100644
|
||||
--- a/data/gnome-shell-sass/widgets/_panel.scss
|
||||
+++ b/data/gnome-shell-sass/widgets/_panel.scss
|
||||
@@ -67,6 +67,11 @@ $panel_transition_duration: 250ms; // same as the overview transition duration
|
||||
}
|
||||
}
|
||||
|
||||
+ .panel-logo-icon {
|
||||
+ padding-right: .4em;
|
||||
+ icon-size: 1em;
|
||||
+ }
|
||||
+
|
||||
// status area icons
|
||||
.system-status-icon {
|
||||
icon-size: $base_icon_size;
|
||||
diff --git a/data/gnome-classic.css b/data/gnome-classic.css
|
||||
index 52e5367..3be81e9 100644
|
||||
--- a/data/gnome-classic.css
|
||||
+++ b/data/gnome-classic.css
|
||||
@@ -1234,6 +1234,9 @@ StScrollBar {
|
||||
box-shadow: none; }
|
||||
#panel .panel-button.clock-display:hover .clock, #panel .panel-button.clock-display:active .clock, #panel .panel-button.clock-display:overview .clock, #panel .panel-button.clock-display:focus .clock, #panel .panel-button.clock-display:checked .clock {
|
||||
box-shadow: inset 0 0 0 100px rgba(255, 255, 255, 0.2); }
|
||||
+ #panel .panel-button .panel-logo-icon {
|
||||
+ padding-right: .4em;
|
||||
+ icon-size: 1em; }
|
||||
#panel .panel-button .system-status-icon {
|
||||
icon-size: 1.09em;
|
||||
padding: 5px;
|
||||
--
|
||||
2.28.0
|
||||
|
29
SOURCES/0001-apps-menu-Explicitly-set-label_actor.patch
Normal file
29
SOURCES/0001-apps-menu-Explicitly-set-label_actor.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From 813e1f83a42a0575ab3a5e38b30bcd1437d68652 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Thu, 17 Mar 2016 17:15:38 +0100
|
||||
Subject: [PATCH] apps-menu: Explicitly set label_actor
|
||||
|
||||
For some reason orca fails to pick up the label of category items,
|
||||
so set the label_actor explicitly as workaround.
|
||||
---
|
||||
extensions/apps-menu/extension.js | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/extensions/apps-menu/extension.js b/extensions/apps-menu/extension.js
|
||||
index 17285fd..0215c95 100644
|
||||
--- a/extensions/apps-menu/extension.js
|
||||
+++ b/extensions/apps-menu/extension.js
|
||||
@@ -112,7 +112,9 @@ class CategoryMenuItem extends PopupMenu.PopupBaseMenuItem {
|
||||
else
|
||||
name = _('Favorites');
|
||||
|
||||
- this.add_child(new St.Label({ text: name }));
|
||||
+ const label = new St.Label({ text: name });
|
||||
+ this.add_child(label);
|
||||
+ this.actor.label_actor = label;
|
||||
this.connect('motion-event', this._onMotionEvent.bind(this));
|
||||
this.connect('notify::active', this._onActiveChanged.bind(this));
|
||||
}
|
||||
--
|
||||
2.28.0
|
||||
|
@ -0,0 +1,66 @@
|
||||
From a28e752ac10f9882d33a52189fc237d11d541fed Mon Sep 17 00:00:00 2001
|
||||
From: Ray Strode <rstrode@redhat.com>
|
||||
Date: Tue, 21 Jan 2014 16:48:17 -0500
|
||||
Subject: [PATCH] apps-menu: add logo icon to Applications menu
|
||||
|
||||
Brand requested it.
|
||||
---
|
||||
extensions/apps-menu/extension.js | 22 +++++++++++++++++++++-
|
||||
1 file changed, 21 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/extensions/apps-menu/extension.js b/extensions/apps-menu/extension.js
|
||||
index 6376b524..1b1f01f1 100644
|
||||
--- a/extensions/apps-menu/extension.js
|
||||
+++ b/extensions/apps-menu/extension.js
|
||||
@@ -363,13 +363,24 @@ class ApplicationsButton extends PanelMenu.Button {
|
||||
// role ATK_ROLE_MENU like other elements of the panel.
|
||||
this.accessible_role = Atk.Role.LABEL;
|
||||
|
||||
+ const hbox = new St.BoxLayout({ style_class: 'panel-status-menu-box' });
|
||||
+
|
||||
+ const iconFile = Gio.File.new_for_path(
|
||||
+ '/usr/share/icons/hicolor/scalable/apps/start-here.svg');
|
||||
+ this._icon = new St.Icon({
|
||||
+ gicon: new Gio.FileIcon({ file: iconFile }),
|
||||
+ style_class: 'panel-logo-icon',
|
||||
+ });
|
||||
+ hbox.add_actor(this._icon);
|
||||
+
|
||||
this._label = new St.Label({
|
||||
text: _('Applications'),
|
||||
y_expand: true,
|
||||
y_align: Clutter.ActorAlign.CENTER,
|
||||
});
|
||||
+ hbox.add_actor(this._label);
|
||||
|
||||
- this.add_actor(this._label);
|
||||
+ this.add_actor(hbox);
|
||||
this.name = 'panelApplications';
|
||||
this.label_actor = this._label;
|
||||
|
||||
@@ -403,6 +414,14 @@ class ApplicationsButton extends PanelMenu.Button {
|
||||
this._display();
|
||||
this._installedChangedId = appSys.connect('installed-changed',
|
||||
this._onTreeChanged.bind(this));
|
||||
+ this._sessionUpdatedId = Main.sessionMode.connect('updated',
|
||||
+ this._sessionUpdated.bind(this));
|
||||
+ this._sessionUpdated();
|
||||
+ }
|
||||
+
|
||||
+ _sessionUpdated() {
|
||||
+ this._icon.visible =
|
||||
+ !Main.sessionMode.panel.left.includes('activities');
|
||||
}
|
||||
|
||||
_onTreeChanged() {
|
||||
@@ -428,6 +447,7 @@ class ApplicationsButton extends PanelMenu.Button {
|
||||
|
||||
Main.overview.disconnect(this._showingId);
|
||||
Main.overview.disconnect(this._hidingId);
|
||||
+ Main.sessionMode.disconnect(this._sessionUpdatedId);
|
||||
appSys.disconnect(this._installedChangedId);
|
||||
this._tree.disconnect(this._treeChangedId);
|
||||
this._tree = null;
|
||||
--
|
||||
2.31.1
|
||||
|
29
SOURCES/0001-desktop-icons-Update-Japanese-translation.patch
Normal file
29
SOURCES/0001-desktop-icons-Update-Japanese-translation.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From 3e26797049c9cca7f40ffbe5432e1185ff6deb1e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Wed, 27 Jan 2021 11:51:28 +0100
|
||||
Subject: [PATCH] desktop-icons: Update Japanese translation
|
||||
|
||||
---
|
||||
po/ja.po | 6 +-----
|
||||
1 file changed, 1 insertion(+), 5 deletions(-)
|
||||
|
||||
diff --git a/po/ja.po b/po/ja.po
|
||||
index 8eb7725..ddf1eb7 100644
|
||||
--- a/po/ja.po
|
||||
+++ b/po/ja.po
|
||||
@@ -897,11 +897,7 @@ msgstr "押し込み量 (ピクセル)"
|
||||
#: desktopGrid.js:359
|
||||
#, fuzzy
|
||||
msgid "Display Settings"
|
||||
-msgstr ""
|
||||
-"#-#-#-#-# ja.po (gnome-shell-extensions master) #-#-#-#-#\n"
|
||||
-"ディスプレイ設定\n"
|
||||
-"#-#-#-#-# ja.po (desktop-icons master) #-#-#-#-#\n"
|
||||
-"ディスプレイの設定"
|
||||
+msgstr "ディスプレイ設定"
|
||||
|
||||
#: schemas/org.gnome.shell.extensions.desktop-icons.gschema.xml:11
|
||||
#, fuzzy
|
||||
--
|
||||
2.28.0
|
||||
|
27
SOURCES/0001-top-icons-Don-t-use-wm_class-as-role.patch
Normal file
27
SOURCES/0001-top-icons-Don-t-use-wm_class-as-role.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From ce48dc2f4fba6a7084540df256cb5b3eb0da43da Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Wed, 2 Jun 2021 17:32:21 +0200
|
||||
Subject: [PATCH] top-icons: Don't use wm_class as role
|
||||
|
||||
This prevents adding icons for multiple instances of the same app,
|
||||
which may be desirable in some circumstances.
|
||||
---
|
||||
extensions/top-icons/extension.js | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/extensions/top-icons/extension.js b/extensions/top-icons/extension.js
|
||||
index 79e2f423..3dfba469 100644
|
||||
--- a/extensions/top-icons/extension.js
|
||||
+++ b/extensions/top-icons/extension.js
|
||||
@@ -63,7 +63,7 @@ class SysTray {
|
||||
button.destroy();
|
||||
});
|
||||
|
||||
- let role = wmClass || `${icon}`;
|
||||
+ const role = `${icon}`;
|
||||
Main.panel.addToStatusArea(role, button);
|
||||
}
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
66733
SOURCES/add-extra-extensions.patch
Normal file
66733
SOURCES/add-extra-extensions.patch
Normal file
File diff suppressed because it is too large
Load Diff
231
SOURCES/desktop-icons-40-fixes.patch
Normal file
231
SOURCES/desktop-icons-40-fixes.patch
Normal file
@ -0,0 +1,231 @@
|
||||
From 8f9a1adcb9b8d62f537d53562c8324175310d577 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Wed, 19 May 2021 16:46:59 +0200
|
||||
Subject: [PATCH 1/2] desktop-icons: Revert "Use GTK-Theme CSS for selected
|
||||
file-item and rubberband"
|
||||
|
||||
GtkStyleContext requires a (X11) display connection, which may not
|
||||
be available with xwayland-on-demand. Better use some hardcoded
|
||||
colors than crashing the session.
|
||||
|
||||
This reverts commit 8dc524aa4efd6a3fbad67480bd6c904b0c0c99d6.
|
||||
---
|
||||
extensions/desktop-icons/desktopIconsUtil.js | 11 ----------
|
||||
extensions/desktop-icons/desktopManager.js | 12 -----------
|
||||
extensions/desktop-icons/fileItem.js | 22 ++++----------------
|
||||
extensions/desktop-icons/stylesheet.css | 9 ++++++++
|
||||
4 files changed, 13 insertions(+), 41 deletions(-)
|
||||
|
||||
diff --git a/extensions/desktop-icons/desktopIconsUtil.js b/extensions/desktop-icons/desktopIconsUtil.js
|
||||
index 696c945..57bedc1 100644
|
||||
--- a/extensions/desktop-icons/desktopIconsUtil.js
|
||||
+++ b/extensions/desktop-icons/desktopIconsUtil.js
|
||||
@@ -16,7 +16,6 @@
|
||||
* along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
*/
|
||||
|
||||
-const Gtk = imports.gi.Gtk;
|
||||
const Gio = imports.gi.Gio;
|
||||
const GLib = imports.gi.GLib;
|
||||
const ExtensionUtils = imports.misc.extensionUtils;
|
||||
@@ -114,16 +113,6 @@ function getFileExtensionOffset(filename, isDirectory) {
|
||||
return offset;
|
||||
}
|
||||
|
||||
-function getGtkClassBackgroundColor(classname, state) {
|
||||
- let widget = new Gtk.WidgetPath();
|
||||
- widget.append_type(Gtk.Widget);
|
||||
-
|
||||
- let context = new Gtk.StyleContext();
|
||||
- context.set_path(widget);
|
||||
- context.add_class(classname);
|
||||
- return context.get_background_color(state);
|
||||
-}
|
||||
-
|
||||
// Reference the extension org.gnome.shell.extensions.drive-menu
|
||||
function eject(mount) {
|
||||
let unmountArgs = [
|
||||
diff --git a/extensions/desktop-icons/desktopManager.js b/extensions/desktop-icons/desktopManager.js
|
||||
index 1aad8c6..10e3ce0 100644
|
||||
--- a/extensions/desktop-icons/desktopManager.js
|
||||
+++ b/extensions/desktop-icons/desktopManager.js
|
||||
@@ -16,7 +16,6 @@
|
||||
* along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
*/
|
||||
|
||||
-const Gtk = imports.gi.Gtk;
|
||||
const Clutter = imports.gi.Clutter;
|
||||
const GObject = imports.gi.GObject;
|
||||
const Gio = imports.gi.Gio;
|
||||
@@ -132,7 +131,6 @@ var DesktopManager = GObject.registerClass({
|
||||
startRubberBand(x, y) {
|
||||
this._rubberBandInitialX = x;
|
||||
this._rubberBandInitialY = y;
|
||||
- this._initRubberBandColor();
|
||||
this._updateRubberBand(x, y);
|
||||
this._rubberBand.show();
|
||||
this._grabHelper.grab({ actor: global.stage });
|
||||
@@ -235,16 +233,6 @@ var DesktopManager = GObject.registerClass({
|
||||
this._desktopGrids = {};
|
||||
}
|
||||
|
||||
- /**
|
||||
- * Initialize rubberband color from the GTK rubberband class
|
||||
- * */
|
||||
- _initRubberBandColor() {
|
||||
- let rgba = DesktopIconsUtil.getGtkClassBackgroundColor('rubberband', Gtk.StateFlags.NORMAL);
|
||||
- let background_color =
|
||||
- 'rgba(' + rgba.red * 255 + ', ' + rgba.green * 255 + ', ' + rgba.blue * 255 + ', 0.4)';
|
||||
- this._rubberBand.set_style('background-color: ' + background_color);
|
||||
- }
|
||||
-
|
||||
async _scanFiles() {
|
||||
for (let [fileItem, fileItemHandler] of this._fileItemHandlers)
|
||||
Object.values(fileItemHandler).forEach(id => fileItem.disconnect(id));
|
||||
diff --git a/extensions/desktop-icons/fileItem.js b/extensions/desktop-icons/fileItem.js
|
||||
index 9987e7f..1e8ea89 100644
|
||||
--- a/extensions/desktop-icons/fileItem.js
|
||||
+++ b/extensions/desktop-icons/fileItem.js
|
||||
@@ -16,7 +16,6 @@
|
||||
* along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
*/
|
||||
|
||||
-const Gtk = imports.gi.Gtk;
|
||||
const Clutter = imports.gi.Clutter;
|
||||
const Gio = imports.gi.Gio;
|
||||
const GLib = imports.gi.GLib;
|
||||
@@ -649,17 +648,6 @@ var FileItem = GObject.registerClass({
|
||||
DBusUtils.openFileWithOtherApplication(this.file.get_path());
|
||||
}
|
||||
|
||||
- _getSelectionStyle() {
|
||||
- let rgba = DesktopIconsUtil.getGtkClassBackgroundColor('view', Gtk.StateFlags.SELECTED);
|
||||
- let background_color =
|
||||
- 'rgba(' + rgba.red * 255 + ', ' + rgba.green * 255 + ', ' + rgba.blue * 255 + ', 0.6)';
|
||||
- let border_color =
|
||||
- 'rgba(' + rgba.red * 255 + ', ' + rgba.green * 255 + ', ' + rgba.blue * 255 + ', 0.8)';
|
||||
-
|
||||
- return 'background-color: ' + background_color + ';' +
|
||||
- 'border-color: ' + border_color + ';';
|
||||
- }
|
||||
-
|
||||
get menu() {
|
||||
return this._menu;
|
||||
}
|
||||
@@ -901,12 +889,10 @@ var FileItem = GObject.registerClass({
|
||||
if (isSelected == this._isSelected)
|
||||
return;
|
||||
|
||||
- if (isSelected) {
|
||||
- this._container.set_style(this._getSelectionStyle());
|
||||
- } else {
|
||||
- this._container.set_style('background-color: transparent');
|
||||
- this._container.set_style('border-color: transparent');
|
||||
- }
|
||||
+ if (isSelected)
|
||||
+ this._container.add_style_pseudo_class('selected');
|
||||
+ else
|
||||
+ this._container.remove_style_pseudo_class('selected');
|
||||
|
||||
this._isSelected = isSelected;
|
||||
}
|
||||
diff --git a/extensions/desktop-icons/stylesheet.css b/extensions/desktop-icons/stylesheet.css
|
||||
index 61b4ce8..4fd31c3 100644
|
||||
--- a/extensions/desktop-icons/stylesheet.css
|
||||
+++ b/extensions/desktop-icons/stylesheet.css
|
||||
@@ -8,6 +8,15 @@
|
||||
background-color: rgba(238, 238, 238, 0.2);
|
||||
}
|
||||
|
||||
+.file-item:selected {
|
||||
+ background-color: rgba(74, 144, 217, 0.6);
|
||||
+ border-color: rgba(74, 144, 217, 0.8);
|
||||
+}
|
||||
+
|
||||
+.rubber-band {
|
||||
+ background-color: rgba(74, 144, 238, 0.4);
|
||||
+}
|
||||
+
|
||||
.name-label {
|
||||
text-shadow: 1px 1px black;
|
||||
color: white;
|
||||
--
|
||||
2.28.0
|
||||
|
||||
|
||||
From 7f31b7697d3bacf53d5d37cb34642d82ea109a52 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Fri, 21 May 2021 00:50:52 +0200
|
||||
Subject: [PATCH 2/2] desktop-icons: Port prefs to GTK4
|
||||
|
||||
... for compatibility with GNOME 40.
|
||||
---
|
||||
extensions/desktop-icons/prefs.js | 32 ++++++++++++++++++-------------
|
||||
1 file changed, 19 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/extensions/desktop-icons/prefs.js b/extensions/desktop-icons/prefs.js
|
||||
index 890bcdb..c390aa8 100644
|
||||
--- a/extensions/desktop-icons/prefs.js
|
||||
+++ b/extensions/desktop-icons/prefs.js
|
||||
@@ -98,23 +98,29 @@ function get_schema(schema) {
|
||||
|
||||
function buildPrefsWidget() {
|
||||
initTranslations();
|
||||
- let frame = new Gtk.Box({ orientation: Gtk.Orientation.VERTICAL, border_width: 10, spacing: 10 });
|
||||
-
|
||||
- frame.add(buildSelector('icon-size', _("Size for the desktop icons"), { 'small': _("Small"), 'standard': _("Standard"), 'large': _("Large") }));
|
||||
- frame.add(buildSwitcher('show-home', _("Show the personal folder in the desktop")));
|
||||
- frame.add(buildSwitcher('show-trash', _("Show the trash icon in the desktop")));
|
||||
- frame.add(buildSwitcher('show-mount', _("Show mounted drives in the desktop")));
|
||||
- frame.show_all();
|
||||
+ let frame = new Gtk.Box({
|
||||
+ orientation: Gtk.Orientation.VERTICAL,
|
||||
+ margin_top: 10,
|
||||
+ margin_bottom: 10,
|
||||
+ margin_start: 10,
|
||||
+ margin_end: 10,
|
||||
+ spacing: 10,
|
||||
+ });
|
||||
+
|
||||
+ frame.append(buildSelector('icon-size', _("Size for the desktop icons"), { 'small': _("Small"), 'standard': _("Standard"), 'large': _("Large") }));
|
||||
+ frame.append(buildSwitcher('show-home', _("Show the personal folder in the desktop")));
|
||||
+ frame.append(buildSwitcher('show-trash', _("Show the trash icon in the desktop")));
|
||||
+ frame.append(buildSwitcher('show-mount', _("Show mounted drives in the desktop")));
|
||||
return frame;
|
||||
}
|
||||
|
||||
function buildSwitcher(key, labelText) {
|
||||
let hbox = new Gtk.Box({ orientation: Gtk.Orientation.HORIZONTAL, spacing: 10 });
|
||||
- let label = new Gtk.Label({ label: labelText, xalign: 0 });
|
||||
+ let label = new Gtk.Label({ label: labelText, xalign: 0, hexpand: true });
|
||||
let switcher = new Gtk.Switch({ active: settings.get_boolean(key) });
|
||||
settings.bind(key, switcher, 'active', 3);
|
||||
- hbox.pack_start(label, true, true, 0);
|
||||
- hbox.add(switcher);
|
||||
+ hbox.append(label);
|
||||
+ hbox.append(switcher);
|
||||
return hbox;
|
||||
}
|
||||
|
||||
@@ -131,15 +137,15 @@ function buildSelector(key, labelText, elements) {
|
||||
listStore.set (iter, [0, 1], [visibleText, val]);
|
||||
}
|
||||
let hbox = new Gtk.Box({ orientation: Gtk.Orientation.HORIZONTAL, spacing: 10 });
|
||||
- let label = new Gtk.Label({ label: labelText, xalign: 0 });
|
||||
+ let label = new Gtk.Label({ label: labelText, xalign: 0, hexpand: true });
|
||||
let combo = new Gtk.ComboBox({model: listStore});
|
||||
let rendererText = new Gtk.CellRendererText();
|
||||
combo.pack_start (rendererText, false);
|
||||
combo.add_attribute (rendererText, 'text', 0);
|
||||
combo.set_id_column(1);
|
||||
settings.bind(key, combo, 'active-id', 3);
|
||||
- hbox.pack_start(label, true, true, 0);
|
||||
- hbox.add(combo);
|
||||
+ hbox.append(label);
|
||||
+ hbox.append(combo);
|
||||
return hbox;
|
||||
}
|
||||
|
||||
--
|
||||
2.28.0
|
||||
|
1551
SOURCES/resurrect-system-monitor.patch
Normal file
1551
SOURCES/resurrect-system-monitor.patch
Normal file
File diff suppressed because it is too large
Load Diff
1005
SPECS/gnome-shell-extensions.spec
Normal file
1005
SPECS/gnome-shell-extensions.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user