Update to 40.5

Resolves: #2031654
This commit is contained in:
Florian Müllner 2021-12-13 18:50:42 +01:00
parent 94826d1b0f
commit 5bbecb74eb
5 changed files with 17 additions and 82 deletions

1
.gitignore vendored
View File

@ -148,3 +148,4 @@
/gnome-shell-extensions-40.2.tar.xz /gnome-shell-extensions-40.2.tar.xz
/gnome-shell-extensions-40.3.tar.xz /gnome-shell-extensions-40.3.tar.xz
/gnome-shell-extensions-40.4.tar.xz /gnome-shell-extensions-40.4.tar.xz
/gnome-shell-extensions-40.5.tar.xz

View File

@ -1,38 +0,0 @@
From b2f2e37590baa44bbdd1e776b9f5b7a3cea3ae1d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Fri, 26 Nov 2021 20:01:40 +0100
Subject: [PATCH] window-list: Fix OSK
The reveal animation moved from Main.layoutManager.keyboardBox to
the keyboard itself, so instead of applying an additional translation
for the bottom panel, we override the translation that would reveal
the keyboard (and thus prevent it from showing altogether).
Fix this by moving our translation to the keyboardBox instead.
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/199>
---
extensions/window-list/extension.js | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index f7ecd190..8bca68c2 100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -918,11 +918,8 @@ class WindowList extends St.Widget {
}
_updateKeyboardAnchor() {
- if (!Main.keyboard.keyboardActor)
- return;
-
- let translationY = Main.overview.visible ? 0 : this.height;
- Main.keyboard.keyboardActor.translation_y = -translationY;
+ const translationY = Main.overview.visible ? 0 : this.height;
+ Main.layoutManager.keyboardBox.translation_y = -translationY;
}
_onAppStateChanged(appSys, app) {
--
2.33.1

View File

@ -1,39 +1,8 @@
From a79d2afb2d6119ae3a4d1eba020d6c35b3fece23 Mon Sep 17 00:00:00 2001 From 1692d4a91d95fecd5642b0c92bc2c5b0dbcb4184 Mon Sep 17 00:00:00 2001
From: Neal Gompa <ngompa@fedoraproject.org>
Date: Fri, 29 Oct 2021 09:33:06 -0400
Subject: [PATCH 1/2] classic: Add X-GNOME-SessionRegisters
GDM has supported sessions registering with it for a few years now so
it can know when to shut down the greeter. Having the GNOME Classic
session declare that it will register itself allows GDM to avoid
executing a fallback codepath.
This has been supported with the regular GNOME session for a while,
and this session was likely forgotten about when it was added there.
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/195>
---
data/gnome-classic.desktop.in | 1 +
1 file changed, 1 insertion(+)
diff --git a/data/gnome-classic.desktop.in b/data/gnome-classic.desktop.in
index 5df6821..13da2b5 100644
--- a/data/gnome-classic.desktop.in
+++ b/data/gnome-classic.desktop.in
@@ -5,3 +5,4 @@ Exec=env GNOME_SHELL_SESSION_MODE=classic gnome-session
TryExec=gnome-session
Type=Application
DesktopNames=GNOME-Classic;GNOME;
+X-GDM-SessionRegisters=true
--
2.33.1
From eb517c851777067087c3bf067c2baf10dcaf4128 Mon Sep 17 00:00:00 2001
From: Neal Gompa <ngompa@fedoraproject.org> From: Neal Gompa <ngompa@fedoraproject.org>
Date: Fri, 29 Oct 2021 09:37:33 -0400 Date: Fri, 29 Oct 2021 09:37:33 -0400
Subject: [PATCH 2/2] classic: Install the session for Wayland and ship Subject: [PATCH] classic: Install the session for Wayland and ship override
override sessions sessions
The regular GNOME session ships with three options: The regular GNOME session ships with three options:
@ -61,7 +30,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
diff --git a/data/gnome-classic-wayland.desktop.in b/data/gnome-classic-wayland.desktop.in diff --git a/data/gnome-classic-wayland.desktop.in b/data/gnome-classic-wayland.desktop.in
new file mode 100644 new file mode 100644
index 0000000..7287c68 index 00000000..7287c689
--- /dev/null --- /dev/null
+++ b/data/gnome-classic-wayland.desktop.in +++ b/data/gnome-classic-wayland.desktop.in
@@ -0,0 +1,8 @@ @@ -0,0 +1,8 @@
@ -75,7 +44,7 @@ index 0000000..7287c68
+X-GDM-SessionRegisters=true +X-GDM-SessionRegisters=true
diff --git a/data/gnome-classic-xorg.desktop.in b/data/gnome-classic-xorg.desktop.in diff --git a/data/gnome-classic-xorg.desktop.in b/data/gnome-classic-xorg.desktop.in
new file mode 100644 new file mode 100644
index 0000000..5fb338a index 00000000..5fb338a1
--- /dev/null --- /dev/null
+++ b/data/gnome-classic-xorg.desktop.in +++ b/data/gnome-classic-xorg.desktop.in
@@ -0,0 +1,8 @@ @@ -0,0 +1,8 @@
@ -88,7 +57,7 @@ index 0000000..5fb338a
+DesktopNames=GNOME-Classic;GNOME; +DesktopNames=GNOME-Classic;GNOME;
+X-GDM-SessionRegisters=true +X-GDM-SessionRegisters=true
diff --git a/data/meson.build b/data/meson.build diff --git a/data/meson.build b/data/meson.build
index 27f4287..47fe798 100644 index 27f42872..47fe798e 100644
--- a/data/meson.build --- a/data/meson.build
+++ b/data/meson.build +++ b/data/meson.build
@@ -1,12 +1,34 @@ @@ -1,12 +1,34 @@
@ -136,7 +105,7 @@ index 27f4287..47fe798 100644
classic_uuids = [] classic_uuids = []
foreach e : classic_extensions foreach e : classic_extensions
diff --git a/meson.build b/meson.build diff --git a/meson.build b/meson.build
index 8f2afda..33006b3 100644 index dda3ddac..ea8a859d 100644
--- a/meson.build --- a/meson.build
+++ b/meson.build +++ b/meson.build
@@ -20,6 +20,7 @@ themedir = join_paths(shelldir, 'theme') @@ -20,6 +20,7 @@ themedir = join_paths(shelldir, 'theme')
@ -147,7 +116,7 @@ index 8f2afda..33006b3 100644
ver_arr = meson.project_version().split('.') ver_arr = meson.project_version().split('.')
shell_version = ver_arr[0] shell_version = ver_arr[0]
@@ -83,6 +84,10 @@ endforeach @@ -90,6 +91,10 @@ endforeach
if classic_mode_enabled if classic_mode_enabled
subdir('data') subdir('data')
@ -160,7 +129,7 @@ index 8f2afda..33006b3 100644
subdir('extensions') subdir('extensions')
diff --git a/meson/session-post-install.py b/meson/session-post-install.py diff --git a/meson/session-post-install.py b/meson/session-post-install.py
new file mode 100755 new file mode 100755
index 0000000..36abe5e index 00000000..36abe5e4
--- /dev/null --- /dev/null
+++ b/meson/session-post-install.py +++ b/meson/session-post-install.py
@@ -0,0 +1,20 @@ @@ -0,0 +1,20 @@

View File

@ -6,8 +6,8 @@
%global tarball_version %%(echo %{version} | tr '~' '.') %global tarball_version %%(echo %{version} | tr '~' '.')
Name: gnome-shell-extensions Name: gnome-shell-extensions
Version: 40.4 Version: 40.5
Release: 8%{?dist} Release: 1%{?dist}
Summary: Modify and extend GNOME Shell functionality and behavior Summary: Modify and extend GNOME Shell functionality and behavior
License: GPLv2+ License: GPLv2+
@ -33,7 +33,6 @@ Patch010: 0001-heads-up-display-Add-extension-for-showing-persisten.patch
Patch011: 0001-Add-gesture-inhibitor-extension.patch Patch011: 0001-Add-gesture-inhibitor-extension.patch
Patch012: gnome-classic-wayland.patch Patch012: gnome-classic-wayland.patch
Patch013: 0001-desktop-icons-Fix-stuck-grab-issue-with-rubber-bandi.patch Patch013: 0001-desktop-icons-Fix-stuck-grab-issue-with-rubber-bandi.patch
Patch014: 0001-window-list-Fix-OSK.patch
%description %description
GNOME Shell Extensions is a collection of extensions providing additional and GNOME Shell Extensions is a collection of extensions providing additional and
@ -390,6 +389,10 @@ workspaces.
%changelog %changelog
* Mon Dec 13 2021 Florian Müllner <fmuellner@redhat.com> - 40.5-1
- Update to 40.5
Resolves: #2031654
* Tue Nov 30 2021 Florian Müllner <fmuellner@redhat.com> - 40.4-8 * Tue Nov 30 2021 Florian Müllner <fmuellner@redhat.com> - 40.4-8
- Fix on-screen keyboard when showing window-list - Fix on-screen keyboard when showing window-list
Resolves: #2019866 Resolves: #2019866

View File

@ -1 +1 @@
SHA512 (gnome-shell-extensions-40.4.tar.xz) = 79f087c9fbc7764241751441190819b3e768530257ffe3a7b39b1004f8997de9c8ea381338ec0544a39b8cc6866137d315e56f3f058c9b66a9ed566ec40712ef SHA512 (gnome-shell-extensions-40.5.tar.xz) = aa25f9ae307f168b8d6fff729547f5753d28eb19171dcbd66faa302851c5f270c2a5060a26df322eba74c7e7901a9b5e762044f3e7fd53345ed0f4bb5aefab72