Fix classification-banner preferences
Resolves: ##2031186
This commit is contained in:
parent
707bbed079
commit
15e44cc273
@ -66732,7 +66732,7 @@ index 14e60ccb..4bdf7154 100644
|
||||
2.33.1
|
||||
|
||||
|
||||
From 54f40756727d8dde3a265cd5ede1d599a15b9c55 Mon Sep 17 00:00:00 2001
|
||||
From d1d06e1ad24b0ddb3745bd08c4ecd6ef1cfbd4c7 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Thu, 2 Dec 2021 19:39:50 +0100
|
||||
Subject: [PATCH 6/6] Add classification-banner
|
||||
@ -66743,10 +66743,10 @@ Subject: [PATCH 6/6] Add classification-banner
|
||||
extensions/classification-banner/meson.build | 8 +
|
||||
.../classification-banner/metadata.json.in | 10 +
|
||||
...tensions.classification-banner.gschema.xml | 29 +++
|
||||
extensions/classification-banner/prefs.js | 196 +++++++++++++++++
|
||||
extensions/classification-banner/prefs.js | 197 +++++++++++++++++
|
||||
.../classification-banner/stylesheet.css | 3 +
|
||||
meson.build | 1 +
|
||||
8 files changed, 618 insertions(+)
|
||||
8 files changed, 619 insertions(+)
|
||||
create mode 100644 extensions/classification-banner/adwShim.js
|
||||
create mode 100644 extensions/classification-banner/extension.js
|
||||
create mode 100644 extensions/classification-banner/meson.build
|
||||
@ -67205,15 +67205,16 @@ index 00000000..0314ef60
|
||||
+</schemalist>
|
||||
diff --git a/extensions/classification-banner/prefs.js b/extensions/classification-banner/prefs.js
|
||||
new file mode 100644
|
||||
index 00000000..30b879fc
|
||||
index 00000000..a5dd8af1
|
||||
--- /dev/null
|
||||
+++ b/extensions/classification-banner/prefs.js
|
||||
@@ -0,0 +1,196 @@
|
||||
@@ -0,0 +1,197 @@
|
||||
+/* exported init buildPrefsWidget */
|
||||
+const { Gdk, Gio, GObject, Gtk } = imports.gi;
|
||||
+
|
||||
+const ExtensionUtils = imports.misc.extensionUtils;
|
||||
+const _ = ExtensionUtils.gettext;
|
||||
+const Gettext = imports.gettext.domain('gnome-shell-extensions');
|
||||
+const _ = Gettext.gettext;
|
||||
+
|
||||
+const Me = ExtensionUtils.getCurrentExtension();
|
||||
+const Adw = Me.imports.adwShim;
|
||||
|
@ -7,7 +7,7 @@
|
||||
|
||||
Name: gnome-shell-extensions
|
||||
Version: 40.5
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Modify and extend GNOME Shell functionality and behavior
|
||||
|
||||
License: GPLv2+
|
||||
@ -405,6 +405,10 @@ workspaces.
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Dec 14 2021 Florian Müllner <fmuellner@redhat.com> - 40.5-3
|
||||
- Fix classification-banner preferences
|
||||
Resolves: #2031186
|
||||
|
||||
* Tue Dec 14 2021 Florian Müllner <fmuellner@redhat.com> - 40.5-2
|
||||
- Add classification-banner
|
||||
Resolves: #2031186
|
||||
|
Loading…
Reference in New Issue
Block a user