- Update to 2.13.92
- Add patch from CVS HEAD to maintain compatibility with version 2.13.91
This commit is contained in:
parent
8ca38b6f55
commit
b9e659847f
88
gnome-session-2.13.92-user-share.patch
Normal file
88
gnome-session-2.13.92-user-share.patch
Normal file
@ -0,0 +1,88 @@
|
||||
--- gnome-session-2.13.92/gnome-session/main.c.user-share 2006-02-22 11:31:10.000000000 -0500
|
||||
+++ gnome-session-2.13.92/gnome-session/main.c 2006-02-28 13:42:42.000000000 -0500
|
||||
@@ -46,6 +46,7 @@
|
||||
#include "gsm-sound.h"
|
||||
#include "gsm-gsd.h"
|
||||
#include "gsm-keyring.h"
|
||||
+#include "gsm-user-share.h"
|
||||
#include "gsm-xrandr.h"
|
||||
#include "gsm-at-startup.h"
|
||||
#include "gsm-remote-desktop.h"
|
||||
@@ -485,6 +486,8 @@
|
||||
|
||||
gsm_sound_login ();
|
||||
|
||||
+ gdm_user_share_start ();
|
||||
+
|
||||
gsm_remote_desktop_start ();
|
||||
|
||||
if (splashing)
|
||||
--- /dev/null 2006-02-28 12:23:07.427962250 -0500
|
||||
+++ gnome-session-2.13.92/gnome-session/gsm-user-share.c 2006-02-28 13:40:38.000000000 -0500
|
||||
@@ -0,0 +1,38 @@
|
||||
+#include <config.h>
|
||||
+
|
||||
+#include <glib.h>
|
||||
+#include <gconf/gconf-client.h>
|
||||
+
|
||||
+#include "gsm-user-share.h"
|
||||
+
|
||||
+#define FILE_SHARING_ENABLED "/desktop/gnome/file_sharing/enabled"
|
||||
+
|
||||
+void
|
||||
+gsm_user_share_start (void)
|
||||
+{
|
||||
+ GConfClient *client;
|
||||
+ gboolean enabled;
|
||||
+ char *argv[2];
|
||||
+ int i;
|
||||
+
|
||||
+ client = gconf_client_get_default ();
|
||||
+ enabled = gconf_client_get_bool (client,
|
||||
+ FILE_SHARING_ENABLED,
|
||||
+ NULL);
|
||||
+ g_object_unref (client);
|
||||
+
|
||||
+ if (enabled) {
|
||||
+ i = 0;
|
||||
+ argv[i++] = LIBEXECDIR"/gnome-user-share";
|
||||
+ argv[i++] = NULL;
|
||||
+
|
||||
+ g_spawn_async (NULL,
|
||||
+ argv,
|
||||
+ NULL,
|
||||
+ G_SPAWN_STDOUT_TO_DEV_NULL | G_SPAWN_STDERR_TO_DEV_NULL,
|
||||
+ NULL,
|
||||
+ NULL,
|
||||
+ NULL,
|
||||
+ NULL);
|
||||
+ }
|
||||
+}
|
||||
--- /dev/null 2006-02-28 12:23:07.427962250 -0500
|
||||
+++ gnome-session-2.13.92/gnome-session/gsm-user-share.h 2006-02-28 13:40:38.000000000 -0500
|
||||
@@ -0,0 +1,6 @@
|
||||
+#ifndef GSM_USER_SHARE_H
|
||||
+#define GSM_USER_SHARE_H
|
||||
+
|
||||
+void gsm_user_share_start (void);
|
||||
+
|
||||
+#endif /* GSM_USER_SHARE_H */
|
||||
--- gnome-session-2.13.92/gnome-session/Makefile.am.user-share 2005-01-10 11:36:40.000000000 -0500
|
||||
+++ gnome-session-2.13.92/gnome-session/Makefile.am 2006-02-28 13:40:38.000000000 -0500
|
||||
@@ -23,6 +23,7 @@
|
||||
-DPREFIX=\""$(prefix)"\" \
|
||||
-DSYSCONFDIR=\""$(sysconfdir)"\" \
|
||||
-DLIBDIR=\""$(libdir)"\" \
|
||||
+ -DLIBEXECDIR=\""$(libexecdir)"\" \
|
||||
-DDATADIR=\""$(datadir)"\" \
|
||||
$(NULL)
|
||||
|
||||
@@ -93,6 +94,8 @@
|
||||
gsm-xrandr.h \
|
||||
gsm-keyring.c \
|
||||
gsm-keyring.h \
|
||||
+ gsm-user-share.c \
|
||||
+ gsm-user-share.h \
|
||||
gsm-gsd.c \
|
||||
gsm-gsd.h \
|
||||
gsm-protocol.c \
|
@ -12,8 +12,8 @@
|
||||
|
||||
Summary: GNOME session manager
|
||||
Name: gnome-session
|
||||
Version: 2.13.91
|
||||
Release: 2
|
||||
Version: 2.13.92
|
||||
Release: 1
|
||||
URL: http://www.gnome.org
|
||||
Source0: %{name}-%{version}.tar.bz2
|
||||
Source1: redhat-default-session
|
||||
@ -45,11 +45,12 @@ Patch3: gnome-session-2.0.5-dithering.patch
|
||||
## http://bugzilla.gnome.org/show_bug.cgi?id=106450
|
||||
Patch6: gnome-session-2.9.4-gnome-common.patch
|
||||
# Launch gnome-user-share on login if enabled
|
||||
Patch7: gnome-session-user-share.patch
|
||||
Patch7: gnome-session-2.13.92-user-share.patch
|
||||
# do shaped window for splash screen
|
||||
Patch8: gnome-session-2.12.0-shaped.patch
|
||||
# too much crashing
|
||||
Patch9: gnome-session-2.13.4-no-crashes.patch
|
||||
Patch10: gnome-session-2.13.92-preserve-backward-compat.patch
|
||||
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: pango-devel >= %{pango_version}
|
||||
@ -80,7 +81,7 @@ GNOME components and handles logout and saving the session.
|
||||
%patch7 -p0 -b .user-share
|
||||
%patch8 -p1 -b .shaped
|
||||
%patch9 -p1 -b .no-crashes
|
||||
|
||||
%patch10 -p1 -b .preserve-backward-compat
|
||||
%build
|
||||
|
||||
#workaround broken perl-XML-Parser on 64bit arches
|
||||
@ -155,6 +156,11 @@ done
|
||||
%{_sysconfdir}/xdg/autostart
|
||||
|
||||
%changelog
|
||||
* Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
|
||||
- Update to 2.13.92
|
||||
- Add patch from CVS HEAD to maintain compatibility with
|
||||
version 2.13.91
|
||||
|
||||
* Thu Feb 23 2006 Ray Strode <rstrode@redhat.com> - 2.13.91-2
|
||||
- take ownership of autostart dir (bug 182335)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user