This commit is contained in:
Matthias Clasen 2010-08-06 20:25:44 -04:00
parent 25df28c404
commit a005df456f
5 changed files with 59 additions and 103 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
gnome-session-2.31.2.tar.bz2
gnome-session-2.31.6.tar.bz2

View File

@ -1,42 +1,26 @@
From 62efd61f95a5985f2dff7e109944e23354b00547 Mon Sep 17 00:00:00 2001
From: William Jon McCann <jmccann@redhat.com>
Date: Thu, 1 Oct 2009 02:18:56 -0400
Subject: [PATCH] Add ability to perform actions after a period of idleness
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=597030
---
configure.in | 2 +
data/gnome-session.schemas.in.in | 30 +++
gnome-session/gsm-manager.c | 394 ++++++++++++++++++++++++++++++++++++--
gnome-session/gsm-presence.c | 12 ++
gnome-session/main.c | 3 +
5 files changed, 428 insertions(+), 13 deletions(-)
diff --git a/configure.in b/configure.in
index 79466c9..4c5e133 100644
--- a/configure.in
+++ b/configure.in
@@ -42,6 +42,7 @@ LIBGNOMEUI_REQUIRED=2.2.0
GTK_REQUIRED=2.14.0
diff -up gnome-session-2.31.6/configure.in.max-idle gnome-session-2.31.6/configure.in
--- gnome-session-2.31.6/configure.in.max-idle 2010-08-04 07:35:41.000000000 -0400
+++ gnome-session-2.31.6/configure.in 2010-08-06 20:18:07.157048001 -0400
@@ -50,6 +50,7 @@ AC_MSG_RESULT([$with_gtk])
GLIB_REQUIRED=2.16.0
DBUS_GLIB_REQUIRED=0.76
DEVKIT_POWER_REQUIRED=008
UPOWER_REQUIRED=0.9.0
+LIBNOTIFY_REQUIRED=0.4.3
dnl ====================================================================
dnl Dependency Checks
@@ -54,6 +55,7 @@ PKG_CHECK_MODULES(GNOME_SESSION,
gtk+-2.0 >= $GTK_REQUIRED
case "$with_gtk" in
2.0) GTK_API_VERSION=2.0
@@ -71,6 +72,7 @@ PKG_CHECK_MODULES(GNOME_SESSION,
gtk+-$GTK_API_VERSION >= $GTK_REQUIRED
dbus-glib-1 >= $DBUS_GLIB_REQUIRED
devkit-power-gobject >= $DEVKIT_POWER_REQUIRED
upower-glib >= $UPOWER_REQUIRED
+ libnotify >= $LIBNOTIFY_REQUIRED
)
PKG_CHECK_MODULES(SESSION_PROPERTIES,
diff --git a/data/gnome-session.schemas.in.in b/data/gnome-session.schemas.in.in
index 2cd5e2d..f87e6c3 100644
--- a/data/gnome-session.schemas.in.in
+++ b/data/gnome-session.schemas.in.in
@@ -61,6 +61,36 @@
diff -up gnome-session-2.31.6/data/gnome-session.schemas.in.in.max-idle gnome-session-2.31.6/data/gnome-session.schemas.in.in
--- gnome-session-2.31.6/data/gnome-session.schemas.in.in.max-idle 2010-08-04 07:22:30.000000000 -0400
+++ gnome-session-2.31.6/data/gnome-session.schemas.in.in 2010-08-06 20:06:05.274048002 -0400
@@ -39,6 +39,36 @@
</locale>
</schema>
<schema>
@ -73,14 +57,13 @@ index 2cd5e2d..f87e6c3 100644
<key>/schemas/desktop/gnome/session/default_session</key>
<applyto>/desktop/gnome/session/default_session</applyto>
<owner>gnome</owner>
diff --git a/gnome-session/gsm-manager.c b/gnome-session/gsm-manager.c
index 49fefe6..417f353 100644
--- a/gnome-session/gsm-manager.c
+++ b/gnome-session/gsm-manager.c
diff -up gnome-session-2.31.6/gnome-session/gsm-manager.c.max-idle gnome-session-2.31.6/gnome-session/gsm-manager.c
--- gnome-session-2.31.6/gnome-session/gsm-manager.c.max-idle 2010-07-15 08:53:08.000000000 -0400
+++ gnome-session-2.31.6/gnome-session/gsm-manager.c 2010-08-06 20:06:05.278048002 -0400
@@ -39,6 +39,7 @@
#include <dbus/dbus-glib-lowlevel.h>
#include <devkit-power-gobject/devicekit-power.h>
#include <upower.h>
+#include <libnotify/notify.h>
#include <gtk/gtk.h> /* for logout dialog */
@ -137,7 +120,7 @@ index 49fefe6..417f353 100644
static void gsm_manager_class_init (GsmManagerClass *klass);
static void gsm_manager_init (GsmManager *manager);
static void gsm_manager_finalize (GObject *object);
@@ -2147,6 +2172,19 @@ gsm_manager_dispose (GObject *object)
@@ -2141,6 +2166,19 @@ gsm_manager_dispose (GObject *object)
g_debug ("GsmManager: disposing manager");
@ -157,7 +140,7 @@ index 49fefe6..417f353 100644
if (manager->priv->clients != NULL) {
g_signal_handlers_disconnect_by_func (manager->priv->clients,
on_store_client_added,
@@ -2343,6 +2381,321 @@ load_idle_delay_from_gconf (GsmManager *manager)
@@ -2337,6 +2375,321 @@ load_idle_delay_from_gconf (GsmManager *
}
static void
@ -479,7 +462,7 @@ index 49fefe6..417f353 100644
on_gconf_key_changed (GConfClient *client,
guint cnxn_id,
GConfEntry *entry,
@@ -2370,6 +2723,32 @@ on_gconf_key_changed (GConfClient *client,
@@ -2364,6 +2717,32 @@ on_gconf_key_changed (GConfClient *clien
} else {
invalid_type_warning (key);
}
@ -512,7 +495,7 @@ index 49fefe6..417f353 100644
} else if (strcmp (key, KEY_LOCK_DISABLE) == 0) {
if (value->type == GCONF_VALUE_BOOL) {
gboolean disabled;
@@ -2407,6 +2786,7 @@ on_presence_status_changed (GsmPresence *presence,
@@ -2401,6 +2780,7 @@ on_presence_status_changed (GsmPresence
consolekit = gsm_get_consolekit ();
gsm_consolekit_set_session_idle (consolekit,
(status == GSM_PRESENCE_STATUS_IDLE));
@ -520,7 +503,7 @@ index 49fefe6..417f353 100644
}
static void
@@ -2457,6 +2837,7 @@ gsm_manager_init (GsmManager *manager)
@@ -2451,6 +2831,7 @@ gsm_manager_init (GsmManager *manager)
NULL, NULL);
load_idle_delay_from_gconf (manager);
@ -528,7 +511,7 @@ index 49fefe6..417f353 100644
}
static void
@@ -2763,19 +3144,6 @@ request_hibernate (GsmManager *manager)
@@ -2757,19 +3138,6 @@ request_hibernate (GsmManager *manager)
gtk_widget_show (manager->priv->inhibit_dialog);
}
@ -548,10 +531,9 @@ index 49fefe6..417f353 100644
static void
request_switch_user (GsmManager *manager)
{
diff --git a/gnome-session/gsm-presence.c b/gnome-session/gsm-presence.c
index c3918de..40f123f 100644
--- a/gnome-session/gsm-presence.c
+++ b/gnome-session/gsm-presence.c
diff -up gnome-session-2.31.6/gnome-session/gsm-presence.c.max-idle gnome-session-2.31.6/gnome-session/gsm-presence.c
--- gnome-session-2.31.6/gnome-session/gsm-presence.c.max-idle 2010-02-09 08:22:01.000000000 -0500
+++ gnome-session-2.31.6/gnome-session/gsm-presence.c 2010-08-06 20:06:05.281048002 -0400
@@ -66,6 +66,7 @@ enum {
PROP_STATUS_TEXT,
PROP_IDLE_ENABLED,
@ -560,7 +542,7 @@ index c3918de..40f123f 100644
};
@@ -187,6 +188,7 @@ on_screensaver_active_changed (DBusGProxy *proxy,
@@ -187,6 +188,7 @@ on_screensaver_active_changed (DBusGProx
presence->priv->screensaver_active = is_active;
reset_idle_watch (presence);
set_session_idle (presence, is_active);
@ -568,7 +550,7 @@ index c3918de..40f123f 100644
}
}
@@ -439,6 +441,9 @@ gsm_presence_get_property (GObject *object,
@@ -439,6 +441,9 @@ gsm_presence_get_property (GObject *o
case PROP_IDLE_TIMEOUT:
g_value_set_uint (value, self->priv->idle_timeout);
break;
@ -578,7 +560,7 @@ index c3918de..40f123f 100644
default:
G_OBJECT_WARN_INVALID_PROPERTY_ID (object, prop_id, pspec);
break;
@@ -532,6 +537,13 @@ gsm_presence_class_init (GsmPresenceClass *klass)
@@ -532,6 +537,13 @@ gsm_presence_class_init (GsmPresenceClas
G_MAXINT,
300000,
G_PARAM_READWRITE | G_PARAM_CONSTRUCT));
@ -592,10 +574,9 @@ index c3918de..40f123f 100644
dbus_g_object_type_install_info (GSM_TYPE_PRESENCE, &dbus_glib_gsm_presence_object_info);
dbus_g_error_domain_register (GSM_PRESENCE_ERROR, NULL, GSM_PRESENCE_TYPE_ERROR);
diff --git a/gnome-session/main.c b/gnome-session/main.c
index 87d46ae..90e0dce 100644
--- a/gnome-session/main.c
+++ b/gnome-session/main.c
diff -up gnome-session-2.31.6/gnome-session/main.c.max-idle gnome-session-2.31.6/gnome-session/main.c
--- gnome-session-2.31.6/gnome-session/main.c.max-idle 2010-03-29 19:46:51.000000000 -0400
+++ gnome-session-2.31.6/gnome-session/main.c 2010-08-06 20:06:05.282048002 -0400
@@ -36,6 +36,7 @@
#include <dbus/dbus-glib.h>
#include <dbus/dbus-glib-bindings.h>
@ -604,7 +585,7 @@ index 87d46ae..90e0dce 100644
#include "gdm-signal-handler.h"
#include "gdm-log.h"
@@ -467,6 +468,8 @@ main (int argc, char **argv)
@@ -471,6 +472,8 @@ main (int argc, char **argv)
exit (1);
}
@ -613,6 +594,3 @@ index 87d46ae..90e0dce 100644
gdm_log_init ();
gdm_log_set_debug (debug);
--
1.6.5.rc2

View File

@ -9,8 +9,8 @@
Summary: GNOME session manager
Name: gnome-session
Version: 2.31.2
Release: 2%{?dist}
Version: 2.31.6
Release: 1%{?dist}
URL: http://www.gnome.org
#VCS: git:git://git.gnome.org/gnome-session
Source0: http://download.gnome.org/sources/gnome-session/2.31/%{name}-%{version}.tar.bz2
@ -182,6 +182,9 @@ fi
%changelog
* Fri Aug 6 2010 Matthias Clasen <mclasen@redhat.com> - 2.31.6-1
- Update to 2.31.6
* Thu Jul 8 2010 Matthias Clasen <mclasen@redhat.com> - 2.31.2-2
- Require dconf

View File

@ -1,26 +1,6 @@
From 04bfd175f1284576d9ddf51e13f073dc50f18f83 Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Fri, 15 Jan 2010 12:52:50 -0500
Subject: [PATCH] Nag users when they try to log in as root
Root login does not work very well, in general.
PolicyKit, IRC, and other random things just don't
function right when run as root. This commit adds
a nag screen to warn the user that they might not
have a good experience.
https://bugzilla.gnome.org/show_bug.cgi?id=607094
---
data/gnome-session.schemas.in.in | 11 ++++++
gnome-session/gsm-manager.c | 22 +++++++++++++
gnome-session/gsm-util.c | 64 ++++++++++++++++++++++++++++++++++++++
gnome-session/gsm-util.h | 3 ++
4 files changed, 100 insertions(+), 0 deletions(-)
diff --git a/data/gnome-session.schemas.in.in b/data/gnome-session.schemas.in.in
index 2cd5e2d..146319f 100644
--- a/data/gnome-session.schemas.in.in
+++ b/data/gnome-session.schemas.in.in
diff -up gnome-session-2.31.6/data/gnome-session.schemas.in.in.nag-root-user gnome-session-2.31.6/data/gnome-session.schemas.in.in
--- gnome-session-2.31.6/data/gnome-session.schemas.in.in.nag-root-user 2010-08-06 20:18:36.000000000 -0400
+++ gnome-session-2.31.6/data/gnome-session.schemas.in.in 2010-08-06 20:24:53.215048000 -0400
@@ -3,6 +3,17 @@
<schemalist>
@ -36,14 +16,13 @@ index 2cd5e2d..146319f 100644
+ </locale>
+ </schema>
+ <schema>
<key>/schemas/apps/gnome-session/options/show_splash_screen</key>
<applyto>/apps/gnome-session/options/show_splash_screen</applyto>
<key>/schemas/apps/gnome-session/options/auto_save_session</key>
<applyto>/apps/gnome-session/options/auto_save_session</applyto>
<owner>gnome</owner>
diff --git a/gnome-session/gsm-manager.c b/gnome-session/gsm-manager.c
index 49fefe6..6fbd312 100644
--- a/gnome-session/gsm-manager.c
+++ b/gnome-session/gsm-manager.c
@@ -85,6 +85,8 @@
diff -up gnome-session-2.31.6/gnome-session/gsm-manager.c.nag-root-user gnome-session-2.31.6/gnome-session/gsm-manager.c
--- gnome-session-2.31.6/gnome-session/gsm-manager.c.nag-root-user 2010-08-06 20:18:36.308048001 -0400
+++ gnome-session-2.31.6/gnome-session/gsm-manager.c 2010-08-06 20:18:36.333048001 -0400
@@ -92,6 +92,8 @@
#define KEY_SLEEP_LOCK "/apps/gnome-screensaver/lock_enabled"
@ -52,7 +31,7 @@ index 49fefe6..6fbd312 100644
#define IS_STRING_EMPTY(x) ((x)==NULL||(x)[0]=='\0')
typedef enum
@@ -467,6 +469,26 @@ end_phase (GsmManager *manager)
@@ -492,6 +494,26 @@ end_phase (GsmManager *manager)
manager->priv->phase_timeout_id = 0;
}
@ -79,10 +58,9 @@ index 49fefe6..6fbd312 100644
switch (manager->priv->phase) {
case GSM_MANAGER_PHASE_STARTUP:
case GSM_MANAGER_PHASE_INITIALIZATION:
diff --git a/gnome-session/gsm-util.c b/gnome-session/gsm-util.c
index d139b95..b60d994 100644
--- a/gnome-session/gsm-util.c
+++ b/gnome-session/gsm-util.c
diff -up gnome-session-2.31.6/gnome-session/gsm-util.c.nag-root-user gnome-session-2.31.6/gnome-session/gsm-util.c
--- gnome-session-2.31.6/gnome-session/gsm-util.c.nag-root-user 2010-02-09 08:22:01.000000000 -0500
+++ gnome-session-2.31.6/gnome-session/gsm-util.c 2010-08-06 20:18:36.338048001 -0400
@@ -35,6 +35,7 @@
#include <dbus/dbus-glib.h>
@ -161,11 +139,10 @@ index d139b95..b60d994 100644
* gsm_util_generate_startup_id:
*
* Generates a new SM client ID.
diff --git a/gnome-session/gsm-util.h b/gnome-session/gsm-util.h
index b67a4ab..f7318a7 100644
--- a/gnome-session/gsm-util.h
+++ b/gnome-session/gsm-util.h
@@ -41,6 +41,9 @@ gboolean gsm_util_text_is_blank (const char *str);
diff -up gnome-session-2.31.6/gnome-session/gsm-util.h.nag-root-user gnome-session-2.31.6/gnome-session/gsm-util.h
--- gnome-session-2.31.6/gnome-session/gsm-util.h.nag-root-user 2010-02-09 08:22:01.000000000 -0500
+++ gnome-session-2.31.6/gnome-session/gsm-util.h 2010-08-06 20:18:36.340048001 -0400
@@ -41,6 +41,9 @@ gboolean gsm_util_text_is_blank
void gsm_util_init_error (gboolean fatal,
const char *format, ...);
@ -175,6 +152,3 @@ index b67a4ab..f7318a7 100644
char * gsm_util_generate_startup_id (void);
--
1.6.5.3

View File

@ -1 +1 @@
4f223cebb440666aca09d852f07f241a gnome-session-2.31.2.tar.bz2
1fda5f2b9d797773cbabc920df6d52cc gnome-session-2.31.6.tar.bz2