2.23.6
This commit is contained in:
parent
912bd53874
commit
8cfbfcbd00
@ -1,12 +0,0 @@
|
|||||||
diff -up gnome-session-2.23.4.1/capplet/commands.c.escape gnome-session-2.23.4.1/capplet/commands.c
|
|
||||||
--- gnome-session-2.23.4.1/capplet/commands.c.escape 2008-07-08 13:40:02.000000000 -0400
|
|
||||||
+++ gnome-session-2.23.4.1/capplet/commands.c 2008-07-08 13:40:15.000000000 -0400
|
|
||||||
@@ -788,7 +788,7 @@ char *
|
|
||||||
spc_command_get_app_description (const char *name,
|
|
||||||
const char *comment)
|
|
||||||
{
|
|
||||||
- return g_strdup_printf ("<b>%s</b>\n%s", name,
|
|
||||||
+ return g_markup_printf_escaped ("<b>%s</b>\n%s", name,
|
|
||||||
(!gsm_util_text_is_blank (comment) ?
|
|
||||||
comment : _("No description")));
|
|
||||||
}
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up gnome-session-2.23.5/gnome-session/gsm-autostart-app.c.gerror-crash gnome-session-2.23.5/gnome-session/gsm-autostart-app.c
|
|
||||||
--- gnome-session-2.23.5/gnome-session/gsm-autostart-app.c.gerror-crash 2008-07-24 19:31:29.000000000 -0400
|
|
||||||
+++ gnome-session-2.23.5/gnome-session/gsm-autostart-app.c 2008-07-24 19:33:00.000000000 -0400
|
|
||||||
@@ -156,6 +156,8 @@ gsm_autostart_app_set_desktop_filename (
|
|
||||||
|
|
||||||
g_debug ("GsmAutostartApp: setting desktop filename to %s", desktop_filename);
|
|
||||||
|
|
||||||
+ error = NULL;
|
|
||||||
+
|
|
||||||
if (app->priv->desktop_file != NULL) {
|
|
||||||
egg_desktop_file_free (app->priv->desktop_file);
|
|
||||||
app->priv->desktop_file = NULL;
|
|
@ -1,70 +0,0 @@
|
|||||||
--- gnome-session-2.19.4/gnome-session/gsm-at-startup.c.timeout 2007-06-17 18:21:51.000000000 -0400
|
|
||||||
+++ gnome-session-2.19.4/gnome-session/gsm-at-startup.c 2007-06-19 14:21:30.000000000 -0400
|
|
||||||
@@ -10,67 +10,14 @@
|
|
||||||
#include <gdk/gdkx.h>
|
|
||||||
#include <gconf/gconf-client.h>
|
|
||||||
|
|
||||||
-static Atom AT_SPI_IOR;
|
|
||||||
-
|
|
||||||
-static GdkFilterReturn
|
|
||||||
-gsm_assistive_filter_watch (GdkXEvent *xevent, GdkEvent *event, gpointer data){
|
|
||||||
- XEvent *xev = (XEvent *)xevent;
|
|
||||||
- gint tid = *(gint *)data;
|
|
||||||
-
|
|
||||||
- if (xev->xany.type == PropertyNotify &&
|
|
||||||
- xev->xproperty.atom == AT_SPI_IOR)
|
|
||||||
- {
|
|
||||||
- g_source_remove (tid);
|
|
||||||
- gtk_main_quit ();
|
|
||||||
-
|
|
||||||
- return GDK_FILTER_REMOVE;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
- return GDK_FILTER_CONTINUE;
|
|
||||||
-}
|
|
||||||
-
|
|
||||||
-static void
|
|
||||||
-gsm_assistive_error_dialog (void)
|
|
||||||
-{
|
|
||||||
- GtkWidget *dialog = gtk_message_dialog_new (NULL,
|
|
||||||
- GTK_DIALOG_MODAL,
|
|
||||||
- GTK_MESSAGE_ERROR,
|
|
||||||
- GTK_BUTTONS_OK,
|
|
||||||
- _("Assistive technology support has been requested for this session, but the accessibility registry was not found. Please ensure that the AT-SPI package is installed. Your session has been started without assistive technology support."));
|
|
||||||
- gtk_dialog_run (GTK_DIALOG (dialog));
|
|
||||||
- gtk_widget_destroy (dialog);
|
|
||||||
-}
|
|
||||||
-
|
|
||||||
-static gboolean
|
|
||||||
-gsm_assistive_filter_timeout (gpointer data)
|
|
||||||
-{
|
|
||||||
- gsm_assistive_error_dialog ();
|
|
||||||
-
|
|
||||||
- gtk_main_quit ();
|
|
||||||
-
|
|
||||||
- return FALSE;
|
|
||||||
-}
|
|
||||||
-
|
|
||||||
void
|
|
||||||
gsm_assistive_registry_start (void)
|
|
||||||
{
|
|
||||||
- GdkWindow *w = gdk_get_default_root_window ();
|
|
||||||
gchar *command;
|
|
||||||
- guint tid;
|
|
||||||
|
|
||||||
- if (!AT_SPI_IOR)
|
|
||||||
- AT_SPI_IOR = XInternAtom (GDK_DISPLAY (), "AT_SPI_IOR", False);
|
|
||||||
-
|
|
||||||
command = g_strdup (AT_SPI_REGISTRYD_DIR "/at-spi-registryd");
|
|
||||||
|
|
||||||
- gdk_window_set_events (w, GDK_PROPERTY_CHANGE_MASK);
|
|
||||||
gsm_exec_command_line_async (command, NULL);
|
|
||||||
- gdk_window_add_filter (w, gsm_assistive_filter_watch, &tid);
|
|
||||||
- tid = g_timeout_add_seconds (5, gsm_assistive_filter_timeout, NULL);
|
|
||||||
-
|
|
||||||
- gtk_main ();
|
|
||||||
-
|
|
||||||
- gdk_window_remove_filter (w, gsm_assistive_filter_watch, &tid);
|
|
||||||
|
|
||||||
g_free (command);
|
|
||||||
}
|
|
@ -1,43 +0,0 @@
|
|||||||
--- gnome-session-2.23.5/data/gnome-session.schemas.in.window-manager 2008-07-27 11:33:01.000000000 -0400
|
|
||||||
+++ gnome-session-2.23.5/data/gnome-session.schemas.in 2008-07-28 16:06:46.000000000 -0400
|
|
||||||
@@ -2,6 +2,17 @@
|
|
||||||
<gconfschemafile>
|
|
||||||
<schemalist>
|
|
||||||
<schema>
|
|
||||||
+ <key>/schemas/apps/gnome-session/rh/window_manager</key>
|
|
||||||
+ <applyto>/apps/gnome-session/rh/window_manager</applyto>
|
|
||||||
+ <owner>gnome</owner>
|
|
||||||
+ <type>string</type>
|
|
||||||
+ <default>metacity</default>
|
|
||||||
+ <locale name="C">
|
|
||||||
+ <short>Window Manager to start</short>
|
|
||||||
+ <long>The Window manager that gnome-session will start. Valid values are "metacity" and "compiz".</long>
|
|
||||||
+ </locale>
|
|
||||||
+ </schema>
|
|
||||||
+ <schema>
|
|
||||||
<key>/schemas/apps/gnome-session/options/show_splash_screen</key>
|
|
||||||
<applyto>/apps/gnome-session/options/show_splash_screen</applyto>
|
|
||||||
<owner>gnome</owner>
|
|
||||||
--- gnome-session-2.23.5/data/gnome-wm.window-manager 2008-06-13 16:00:53.000000000 -0400
|
|
||||||
+++ gnome-session-2.23.5/data/gnome-wm 2008-07-28 16:03:10.000000000 -0400
|
|
||||||
@@ -3,7 +3,9 @@
|
|
||||||
# The user can specify his prefered WM by setting the WINDOW_MANAGER
|
|
||||||
# environment variable.
|
|
||||||
#
|
|
||||||
-# If this is not set, we search a list of known windowmanagers and use
|
|
||||||
+# If this is not set, we check the /apps/gnome-session/rh/window_manager key
|
|
||||||
+# and go off that. finally, if all else fails we search a list of known
|
|
||||||
+# windowmanagers and use
|
|
||||||
# the first one that is found in the users's PATH
|
|
||||||
#
|
|
||||||
|
|
||||||
@@ -38,6 +40,9 @@
|
|
||||||
done
|
|
||||||
|
|
||||||
# WINDOW_MANAGER overrides all
|
|
||||||
+if [ -z "$WINDOW_MANAGER" ] ; then
|
|
||||||
+ WINDOW_MANAGER=$(gconftool-2 --get /apps/gnome-session/rh/window_manager)
|
|
||||||
+fi
|
|
||||||
|
|
||||||
if [ -z "$WINDOW_MANAGER" ] ; then
|
|
||||||
# Create a list of window manager we can handle, trying to only use the
|
|
@ -1,15 +0,0 @@
|
|||||||
--- gnome-session-2.23.5/gnome-session/gsm-manager.c.orig 2008-07-21 15:50:16.000000000 -0400
|
|
||||||
+++ gnome-session-2.23.5/gnome-session/gsm-manager.c 2008-07-21 15:51:18.000000000 -0400
|
|
||||||
@@ -1612,7 +1612,11 @@
|
|
||||||
continue;
|
|
||||||
}
|
|
||||||
|
|
||||||
- desktop_file = g_strdup_printf ("%s.desktop", (char *) a->data);
|
|
||||||
+ if (strcmp (a->data, "nautilus") == 0) {
|
|
||||||
+ desktop_file = g_strdup ("gnome-nautilus.desktop");
|
|
||||||
+ } else {
|
|
||||||
+ desktop_file = g_strdup_printf ("%s.desktop", (char *) a->data);
|
|
||||||
+ }
|
|
||||||
|
|
||||||
g_debug ("GsmManager: Looking for: %s", desktop_file);
|
|
||||||
|
|
@ -1,116 +0,0 @@
|
|||||||
Index: gsm-sound.c
|
|
||||||
===================================================================
|
|
||||||
--- gsm-sound.c (revision 4557)
|
|
||||||
+++ gsm-sound.c (working copy)
|
|
||||||
@@ -9,8 +9,7 @@
|
|
||||||
#endif
|
|
||||||
#include "util.h"
|
|
||||||
|
|
||||||
-#include <libgnome/gnome-sound.h>
|
|
||||||
-#include <libgnome/gnome-triggers.h>
|
|
||||||
+#include <libgnome/libgnome.h>
|
|
||||||
|
|
||||||
#define ENABLE_SOUND_KEY "/desktop/gnome/sound/enable_esd"
|
|
||||||
#define ENABLE_EVENT_SOUNDS_KEY "/desktop/gnome/sound/event_sounds"
|
|
||||||
@@ -138,10 +137,81 @@
|
|
||||||
#endif
|
|
||||||
}
|
|
||||||
|
|
||||||
+static char *
|
|
||||||
+get_filename_from_string (const char *string)
|
|
||||||
+{
|
|
||||||
+ if (string[0] != '/')
|
|
||||||
+ {
|
|
||||||
+ return gnome_program_locate_file (NULL, GNOME_FILE_DOMAIN_SOUND, string,
|
|
||||||
+ TRUE, NULL);
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ return g_strdup (string);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static char *
|
|
||||||
+get_filename_for_sound_from_keyfile (const char *name, const char *soundlist_file)
|
|
||||||
+{
|
|
||||||
+ GKeyFile *keyfile;
|
|
||||||
+ char *sound;
|
|
||||||
+
|
|
||||||
+ keyfile = g_key_file_new ();
|
|
||||||
+
|
|
||||||
+ if (g_key_file_load_from_file (keyfile, soundlist_file, G_KEY_FILE_NONE, NULL) == FALSE)
|
|
||||||
+ {
|
|
||||||
+ g_key_file_free (keyfile);
|
|
||||||
+ return NULL;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ sound = g_key_file_get_string (keyfile, name, "file", NULL);
|
|
||||||
+ g_key_file_free (keyfile);
|
|
||||||
+ if (sound != NULL)
|
|
||||||
+ {
|
|
||||||
+ char *res;
|
|
||||||
+
|
|
||||||
+ res = get_filename_from_string (sound);
|
|
||||||
+ if (res != NULL)
|
|
||||||
+ {
|
|
||||||
+ g_free (sound);
|
|
||||||
+ return res;
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+ g_free (sound);
|
|
||||||
+
|
|
||||||
+ return NULL;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static char *
|
|
||||||
+get_filename_for_sound (const char *name)
|
|
||||||
+{
|
|
||||||
+ char *soundlist, *sound;
|
|
||||||
+
|
|
||||||
+ /* Try to load the user configuration first */
|
|
||||||
+ soundlist = g_build_filename (g_get_home_dir(), ".gnome2", "sound",
|
|
||||||
+ "events", "gnome-2.soundlist", NULL);
|
|
||||||
+ sound = get_filename_for_sound_from_keyfile (name, soundlist);
|
|
||||||
+ g_free (soundlist);
|
|
||||||
+ if (sound != NULL)
|
|
||||||
+ return sound;
|
|
||||||
+
|
|
||||||
+ soundlist = g_build_filename (SYSCONFDIR, "sound", "events", "gnome-2.soundlist", NULL);
|
|
||||||
+ sound = get_filename_for_sound_from_keyfile (name, soundlist);
|
|
||||||
+ g_free (soundlist);
|
|
||||||
+
|
|
||||||
+ return sound;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
static void
|
|
||||||
play_sound_event (const char *name)
|
|
||||||
{
|
|
||||||
- gnome_triggers_do (NULL, NULL, "gnome-2", name, NULL);
|
|
||||||
+ char *sound;
|
|
||||||
+
|
|
||||||
+ sound = get_filename_for_sound (name);
|
|
||||||
+ if (sound != NULL)
|
|
||||||
+ {
|
|
||||||
+ gnome_sound_play (sound);
|
|
||||||
+ g_free (sound);
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
void
|
|
||||||
Index: Makefile.am
|
|
||||||
===================================================================
|
|
||||||
--- Makefile.am (revision 4557)
|
|
||||||
+++ Makefile.am (working copy)
|
|
||||||
@@ -16,12 +16,12 @@
|
|
||||||
-DDEFAULTDIR="\"$(defaultdir)\"" \
|
|
||||||
-DESD_SERVER="\"$(ESD_SERVER)\"" \
|
|
||||||
-DAT_SPI_REGISTRYD_DIR="\"$(AT_SPI_REGISTRYD_DIR)\"" \
|
|
||||||
- -DTIME_UTILITY="\"$(TIME_UTILITY)\""
|
|
||||||
+ -DTIME_UTILITY="\"$(TIME_UTILITY)\"" \
|
|
||||||
+ -DSYSCONFDIR=\""$(sysconfdir)"\"
|
|
||||||
|
|
||||||
# Used by the GNOME_PROGRAM_STANDARD_PROPERTIES macros
|
|
||||||
STANDARD_PROPERTIES_CFLAGS = \
|
|
||||||
-DPREFIX=\""$(prefix)"\" \
|
|
||||||
- -DSYSCONFDIR=\""$(sysconfdir)"\" \
|
|
||||||
-DLIBDIR=\""$(libdir)"\" \
|
|
||||||
-DDATADIR=\""$(datadir)"\" \
|
|
||||||
$(NULL)
|
|
@ -12,7 +12,7 @@
|
|||||||
Summary: GNOME session manager
|
Summary: GNOME session manager
|
||||||
Name: gnome-session
|
Name: gnome-session
|
||||||
Version: 2.23.6
|
Version: 2.23.6
|
||||||
Release: 0.2008.07.30.1%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://www.gnome.org
|
URL: http://www.gnome.org
|
||||||
Source0: http://download.gnome.org/sources/gnome-session/2.23/%{name}-%{version}.tar.bz2
|
Source0: http://download.gnome.org/sources/gnome-session/2.23/%{name}-%{version}.tar.bz2
|
||||||
Source1: redhat-default-session
|
Source1: redhat-default-session
|
||||||
@ -33,14 +33,6 @@ Requires: dbus-x11
|
|||||||
## we conflict with gdm that contains the GNOME gdm xsession
|
## we conflict with gdm that contains the GNOME gdm xsession
|
||||||
Conflicts: gdm < 1:2.6.0.8-5
|
Conflicts: gdm < 1:2.6.0.8-5
|
||||||
|
|
||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=350848
|
|
||||||
# The gconf bits weren't accepted upstream, so we'll
|
|
||||||
# need to figure something out here
|
|
||||||
Patch13: gnome-session-2.23.5-window-manager.patch
|
|
||||||
|
|
||||||
# FIXME does this still apply ?
|
|
||||||
#Patch20: gnome-session-2.19.4-atspi-timeout.patch
|
|
||||||
|
|
||||||
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
|
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
|
||||||
BuildRequires: gtk2-devel >= %{gtk2_version}
|
BuildRequires: gtk2-devel >= %{gtk2_version}
|
||||||
BuildRequires: dbus-devel >= %{dbus_version}
|
BuildRequires: dbus-devel >= %{dbus_version}
|
||||||
@ -79,9 +71,6 @@ GNOME components and handles logout and saving the session.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch13 -p1 -b .window-manager
|
|
||||||
#%patch20 -p1 -b .timeout
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
#workaround broken perl-XML-Parser on 64bit arches
|
#workaround broken perl-XML-Parser on 64bit arches
|
||||||
@ -175,6 +164,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 5 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.6-1
|
||||||
|
- Update to 2.23.6
|
||||||
|
|
||||||
* Wed Jul 30 2008 Jon McCann <jmccann@redhat.com> - 2.23.6.0.2008.07.30.1
|
* Wed Jul 30 2008 Jon McCann <jmccann@redhat.com> - 2.23.6.0.2008.07.30.1
|
||||||
- New snapshot from DBus branch
|
- New snapshot from DBus branch
|
||||||
|
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
diff -up gnome-session-2.23.4.1/gnome-session/logout-dialog.c.icon-names gnome-session-2.23.4.1/gnome-session/logout-dialog.c
|
|
||||||
--- gnome-session-2.23.4.1/gnome-session/logout-dialog.c.icon-names 2008-07-09 16:12:41.000000000 -0400
|
|
||||||
+++ gnome-session-2.23.4.1/gnome-session/logout-dialog.c 2008-07-09 16:13:10.000000000 -0400
|
|
||||||
@@ -41,8 +41,8 @@
|
|
||||||
|
|
||||||
#define AUTOMATIC_ACTION_TIMEOUT 60
|
|
||||||
|
|
||||||
-#define GSM_ICON_LOGOUT "gnome-logout"
|
|
||||||
-#define GSM_ICON_SHUTDOWN "gnome-shutdown"
|
|
||||||
+#define GSM_ICON_LOGOUT "system-log-out"
|
|
||||||
+#define GSM_ICON_SHUTDOWN "system-shutdown"
|
|
||||||
|
|
||||||
struct _GsmLogoutDialogPrivate
|
|
||||||
{
|
|
@ -1,29 +0,0 @@
|
|||||||
diff -up gnome-session-2.23.2.2/gnome-session/session.c.legacy-crash gnome-session-2.23.2.2/gnome-session/session.c
|
|
||||||
--- gnome-session-2.23.2.2/gnome-session/session.c.legacy-crash 2008-05-15 19:46:02.000000000 -0400
|
|
||||||
+++ gnome-session-2.23.2.2/gnome-session/session.c 2008-05-15 19:47:48.000000000 -0400
|
|
||||||
@@ -152,8 +152,13 @@ out:
|
|
||||||
static void
|
|
||||||
append_app (GsmSession *session, GsmApp *app)
|
|
||||||
{
|
|
||||||
- const char *basename = gsm_app_get_basename (app);
|
|
||||||
- GsmApp *dup = g_hash_table_lookup (session->apps_by_name, basename);
|
|
||||||
+ const char *basename;
|
|
||||||
+ GsmApp *dup = NULL;
|
|
||||||
+
|
|
||||||
+ basename = gsm_app_get_basename (app);
|
|
||||||
+
|
|
||||||
+ if (basename)
|
|
||||||
+ dup = g_hash_table_lookup (session->apps_by_name, basename);
|
|
||||||
|
|
||||||
if (dup)
|
|
||||||
{
|
|
||||||
@@ -163,7 +168,8 @@ append_app (GsmSession *session, GsmApp
|
|
||||||
}
|
|
||||||
|
|
||||||
session->apps = g_slist_append (session->apps, app);
|
|
||||||
- g_hash_table_insert (session->apps_by_name, g_strdup (basename), app);
|
|
||||||
+ if (basename)
|
|
||||||
+ g_hash_table_insert (session->apps_by_name, g_strdup (basename), app);
|
|
||||||
}
|
|
||||||
|
|
||||||
static void
|
|
Loading…
Reference in New Issue
Block a user