update patches

This commit is contained in:
Matthias Clasen 2008-01-15 14:33:20 +00:00
parent b35899cb56
commit 61e3c35c31
11 changed files with 58 additions and 613 deletions

View File

@ -1 +1 @@
gnome-session-2.20.2.tar.bz2
gnome-session-2.21.5.tar.bz2

View File

@ -1,20 +0,0 @@
--- gnome-session-2.0.5/gnome-session/splash-widget.c.dithering 2002-08-28 12:47:42.000000000 -0400
+++ gnome-session-2.0.5/gnome-session/splash-widget.c 2002-08-28 12:48:10.000000000 -0400
@@ -163,7 +163,7 @@
exposed.y - si->position.y,
exposed.x, exposed.y,
exposed.width, exposed.height,
- GDK_RGB_DITHER_NORMAL,
+ GDK_RGB_DITHER_MAX,
exposed.x, exposed.y);
}
@@ -245,7 +245,7 @@
sw->background, GDK_DRAWABLE (pm),
widget->style->black_gc,
0, 0, 0, 0, width, height,
- GDK_RGB_DITHER_NORMAL,
+ GDK_RGB_DITHER_MAX,
0, 0);
gdk_window_set_back_pixmap (

View File

@ -1,11 +0,0 @@
--- gnome-session-2.0.5/gnome-session/gsm-sound.c.login 2002-07-12 10:02:06.000000000 +0100
+++ gnome-session-2.0.5/gnome-session/gsm-sound.c 2002-08-23 14:53:08.000000000 +0100
@@ -66,7 +66,7 @@
if (!(sample_file && *sample_file))
{
g_free (sample_file);
- return FALSE;
+ return TRUE; /* Don't fall back to system sound. */
}
sample_id = esd_sample_getid (gnome_sound_connection_get (), "gnome-2/login");

View File

@ -1,120 +0,0 @@
--- gnome-session-2.12.0/gnome-session/splash-widget.h.shaped 2005-08-08 03:35:13.000000000 -0400
+++ gnome-session-2.12.0/gnome-session/splash-widget.h 2006-01-12 02:19:59.000000000 -0500
@@ -36,7 +36,6 @@
GnomeIconTheme *icon_theme;
GdkPixbuf *background;
- GdkPixmap *bg_pixmap;
GList *icons;
PangoLayout *layout;
PangoAttribute *font_size_attr;
@@ -66,13 +65,13 @@
#define SPLASH_BASE_HEIGHT 220
/* offset from bottom of label & font */
-#define SPLASH_LABEL_V_OFFSET 3
+#define SPLASH_LABEL_V_OFFSET 79
#define SPLASH_LABEL_FONT_SIZE 8
/* icon border, spacing, offset from bottom and initial size */
-#define SPLASH_ICON_BORDER 8
+#define SPLASH_ICON_BORDER 78
#define SPLASH_ICON_SPACING 4
-#define SPLASH_ICON_V_OFFSET 14
+#define SPLASH_ICON_V_OFFSET 90
#define SPLASH_BASE_ICON_SIZE 36
#define SPLASH_BASE_ICON_ROWS 1
--- gnome-session-2.12.0/gnome-session/splash-widget.c.shaped 2006-01-12 02:19:59.000000000 -0500
+++ gnome-session-2.12.0/gnome-session/splash-widget.c 2006-01-12 02:22:28.000000000 -0500
@@ -137,16 +137,6 @@
if (!GTK_WIDGET_DRAWABLE (widget))
return FALSE;
- if (gdk_rectangle_intersect (
- &event->area, &sw->image_bounds, &exposed))
- gdk_draw_drawable (
- GDK_DRAWABLE (widget->window),
- widget->style->black_gc,
- GDK_DRAWABLE (sw->bg_pixmap),
- exposed.x, exposed.y,
- exposed.x, exposed.y,
- exposed.width, exposed.height);
-
for (l = sw->icons; l; l = l->next) {
SplashIcon *si = l->data;
@@ -221,33 +211,42 @@
static void
splash_widget_realize (GtkWidget *widget)
{
- GdkPixmap *pm;
SplashWidget *sw = (SplashWidget *) widget;
GNOME_CALL_PARENT (GTK_WIDGET_CLASS, realize, (widget));
if (sw->background && widget->window) {
- int width, height;
+ GdkPixmap *pixmap;
+ GdkBitmap *mask;
+ GdkColormap *colormap;
- width = gdk_pixbuf_get_width (sw->background);
- height = gdk_pixbuf_get_height (sw->background);
+ pixmap = NULL;
+ mask = NULL;
- pm = gdk_pixmap_new (
- widget->window,
- width, height,
- gdk_drawable_get_visual (widget->window)->depth);
+ colormap = gtk_widget_get_colormap (widget);
+ gdk_pixbuf_render_pixmap_and_mask_for_colormap (sw->background,
+ colormap,
+ &pixmap, &mask,
+ 125);
- if (pm) {
- gdk_pixbuf_render_to_drawable (
- sw->background, GDK_DRAWABLE (pm),
- widget->style->black_gc,
- 0, 0, 0, 0, width, height,
- GDK_RGB_DITHER_MAX,
- 0, 0);
-
- gdk_window_set_back_pixmap (
- widget->window, pm, FALSE);
- sw->bg_pixmap = pm;
+ if (pixmap) {
+ GtkStyle *style;
+
+ style = gtk_style_copy (widget->style);
+ style->bg_pixmap[GTK_STATE_NORMAL] = pixmap;
+
+ gtk_widget_set_style (widget, style);
+ g_object_unref (style);
+
+ if (mask) {
+ gdk_window_shape_combine_mask (widget->window,
+ mask, 0, 0);
+
+ g_object_unref (mask);
+ }
+
+ gtk_style_set_background (widget->style, widget->window,
+ GTK_STATE_NORMAL);
}
}
}
@@ -257,11 +256,6 @@
{
SplashWidget *sw = (SplashWidget *) widget;
- if (sw->bg_pixmap) {
- g_object_unref (sw->bg_pixmap);
- sw->bg_pixmap = NULL;
- }
-
GNOME_CALL_PARENT (GTK_WIDGET_CLASS, unrealize, (widget));
}

View File

@ -1,191 +0,0 @@
--- gnome-session-2.15.91/gnome-session/startup-programs.c.desensitize-invalid-buttons 2006-08-14 13:59:45.000000000 -0400
+++ gnome-session-2.15.91/gnome-session/startup-programs.c 2006-08-14 14:01:23.000000000 -0400
@@ -22,6 +22,7 @@
#include <config.h>
#include <ctype.h>
#include <stdlib.h>
+#include <unistd.h>
#include <glib/gstdio.h>
#include <gnome.h>
#include <libgnome/gnome-desktop-item.h>
@@ -541,6 +542,48 @@ startup_list_delete (GSList **sl, GtkTre
spc_write_state ();
}
+gboolean
+startup_list_can_edit (GSList **sl, GtkTreeModel *model, GtkTreeSelection *sel)
+{
+ ManualClient *client;
+ GtkTreeIter iter;
+ char *path, *basename;
+ const char * const * system_dirs;
+ int i;
+ gboolean can_edit = TRUE;
+
+ if (!gtk_tree_selection_get_selected (sel, NULL, &iter)) return FALSE;
+
+ gtk_tree_model_get (model, &iter, 0, &client, -1);
+
+ if (g_file_test (client->desktop_file, G_FILE_TEST_EXISTS) &&
+ access (client->desktop_file, W_OK) != 0)
+ return FALSE;
+
+ basename = g_path_get_basename (client->desktop_file);
+
+ system_dirs = g_get_system_data_dirs ();
+ for (i = 0; system_dirs[i] != NULL && can_edit; i++)
+ {
+ path = g_build_filename (system_dirs[i], "gnome", "autostart", basename, NULL);
+ if (g_file_test (path, G_FILE_TEST_EXISTS) && access (path, W_OK) != 0)
+ can_edit = FALSE;
+ g_free (path);
+ }
+
+ system_dirs = g_get_system_config_dirs ();
+ for (i = 0; system_dirs[i] != NULL && can_edit; i++)
+ {
+ path = g_build_filename (system_dirs[i], "autostart", basename, NULL);
+ if (g_file_test (path, G_FILE_TEST_EXISTS) && access (path, W_OK) != 0)
+ can_edit = FALSE;
+ g_free (path);
+ }
+
+ g_free (basename);
+ return can_edit;
+}
+
/* Check if the selected client can be enabled */
gboolean
startup_list_can_enable (GSList **sl, GtkTreeModel *model, GtkTreeSelection *sel)
--- gnome-session-2.15.91/gnome-session/session-properties-capplet.c.desensitize-invalid-buttons 2006-08-14 14:02:21.000000000 -0400
+++ gnome-session-2.15.91/gnome-session/session-properties-capplet.c 2006-08-14 14:15:57.000000000 -0400
@@ -91,16 +91,14 @@ static void saved_sessions (GtkWidget *w
#define SESSION_STOCK_EDIT "session-stock-edit"
static void
-selection_changed_cb (GtkTreeSelection *selection, GtkTreeView *view)
+session_selection_changed_cb (GtkTreeSelection *selection, GtkTreeView *view)
{
gboolean sel;
GtkWidget *edit_button;
GtkWidget *delete_button;
- GtkWidget *enable_button;
edit_button = g_object_get_data (G_OBJECT (view), "edit");
delete_button = g_object_get_data (G_OBJECT (view), "delete");
- enable_button = g_object_get_data (G_OBJECT (view), "enable");
sel = gtk_tree_selection_get_selected (selection, NULL, NULL);
@@ -109,29 +107,56 @@ selection_changed_cb (GtkTreeSelection *
if (delete_button)
gtk_widget_set_sensitive (delete_button, sel);
+}
+
+static void
+startup_selection_changed_cb (GtkTreeSelection *selection, GtkTreeView *view)
+{
+ gboolean sel, can_edit;
+ GtkWidget *edit_button;
+ GtkWidget *delete_button;
+ GtkWidget *enable_button;
- if (enable_button)
+ edit_button = g_object_get_data (G_OBJECT (view), "edit");
+ delete_button = g_object_get_data (G_OBJECT (view), "delete");
+ enable_button = g_object_get_data (G_OBJECT (view), "enable");
+
+ if (!edit_button || !delete_button || !enable_button)
+ return;
+
+ sel = gtk_tree_selection_get_selected (selection, NULL, NULL);
+ can_edit = startup_list_can_edit (&startup_list, startup_store, startup_sel);
+
+ if (sel && can_edit)
+ {
+ gtk_widget_set_sensitive (edit_button, TRUE);
+ gtk_widget_set_sensitive (delete_button, TRUE);
+ }
+ else
{
- if (sel)
+ gtk_widget_set_sensitive (edit_button, FALSE);
+ gtk_widget_set_sensitive (delete_button, FALSE);
+ }
+
+ if (sel)
+ {
+ if (startup_list_can_enable (&startup_list, startup_store, startup_sel))
{
- if (startup_list_can_enable (&startup_list, startup_store, startup_sel))
- {
- gtk_button_set_label (GTK_BUTTON (enable_button), _("Enable"));
- gtk_button_set_image (GTK_BUTTON (enable_button),
- gtk_image_new_from_stock (GTK_STOCK_YES, GTK_ICON_SIZE_BUTTON));
- }
- else
- {
- gtk_button_set_label (GTK_BUTTON (enable_button), _("Disable"));
- gtk_button_set_image (GTK_BUTTON (enable_button),
- gtk_image_new_from_stock (GTK_STOCK_NO, GTK_ICON_SIZE_BUTTON));
- }
-
- gtk_widget_set_sensitive (enable_button, TRUE);
+ gtk_button_set_label (GTK_BUTTON (enable_button), _("Enable"));
+ gtk_button_set_image (GTK_BUTTON (enable_button),
+ gtk_image_new_from_stock (GTK_STOCK_YES, GTK_ICON_SIZE_BUTTON));
}
else
- gtk_widget_set_sensitive (enable_button, FALSE);
+ {
+ gtk_button_set_label (GTK_BUTTON (enable_button), _("Disable"));
+ gtk_button_set_image (GTK_BUTTON (enable_button),
+ gtk_image_new_from_stock (GTK_STOCK_NO, GTK_ICON_SIZE_BUTTON));
+ }
+
+ gtk_widget_set_sensitive (enable_button, TRUE);
}
+ else
+ gtk_widget_set_sensitive (enable_button, FALSE);
}
static void
@@ -345,7 +370,7 @@ capplet_build (void)
GTK_WIDGET (sessions_view));
sessions_sel = gtk_tree_view_get_selection (sessions_view);
gtk_tree_selection_set_mode (sessions_sel, GTK_SELECTION_SINGLE);
- g_signal_connect (G_OBJECT (sessions_sel), "changed", (GCallback) selection_changed_cb, sessions_view);
+ g_signal_connect (G_OBJECT (sessions_sel), "changed", (GCallback) session_selection_changed_cb, sessions_view);
renderer = gtk_cell_renderer_text_new ();
column = gtk_tree_view_column_new_with_attributes (_("Session Name"), renderer, "text", 0, NULL);
gtk_tree_view_append_column (sessions_view, column);
@@ -433,7 +458,7 @@ capplet_build (void)
GTK_WIDGET (startup_view));
startup_sel = gtk_tree_view_get_selection (startup_view);
gtk_tree_selection_set_mode (startup_sel, GTK_SELECTION_SINGLE);
- g_signal_connect (G_OBJECT (startup_sel), "changed", (GCallback) selection_changed_cb, startup_view);
+ g_signal_connect (G_OBJECT (startup_sel), "changed", (GCallback) startup_selection_changed_cb, startup_view);
renderer = gtk_cell_renderer_text_new ();
column = gtk_tree_view_column_new_with_attributes (_("Command"), renderer, "text", 2, NULL);
gtk_tree_view_append_column (startup_view, column);
@@ -604,7 +629,7 @@ enable_startup_cb (void)
else
startup_list_disable (&startup_list, startup_store, startup_sel);
- selection_changed_cb (startup_sel, startup_view);
+ startup_selection_changed_cb (startup_sel, startup_view);
}
static void
--- gnome-session-2.15.91/gnome-session/session-properties-capplet.h.desensitize-invalid-buttons 2006-08-14 14:01:51.000000000 -0400
+++ gnome-session-2.15.91/gnome-session/session-properties-capplet.h 2006-08-14 14:02:09.000000000 -0400
@@ -34,6 +34,8 @@ void startup_list_edit_dialog (GSList **
void startup_list_delete (GSList **sl,
GtkTreeModel *model, GtkTreeSelection *sel);
+gboolean startup_list_can_edit (GSList **sl, GtkTreeModel *model, GtkTreeSelection *sel);
+
gboolean startup_list_can_enable (GSList **sl, GtkTreeModel *model, GtkTreeSelection *sel);
void startup_list_enable (GSList **sl, GtkTreeModel *model, GtkTreeSelection *sel);
void startup_list_disable (GSList **sl, GtkTreeModel *model, GtkTreeSelection *sel);

View File

@ -1,120 +0,0 @@
--- gnome-session-2.12.0/gnome-session/splash-widget.h.shaped 2005-08-08 03:35:13.000000000 -0400
+++ gnome-session-2.12.0/gnome-session/splash-widget.h 2006-01-12 02:19:59.000000000 -0500
@@ -36,7 +36,6 @@
GnomeIconTheme *icon_theme;
GdkPixbuf *background;
- GdkPixmap *bg_pixmap;
GList *icons;
PangoLayout *layout;
PangoAttribute *font_size_attr;
@@ -66,13 +65,13 @@
#define SPLASH_BASE_HEIGHT 220
/* offset from bottom of label & font */
-#define SPLASH_LABEL_V_OFFSET 3
+#define SPLASH_LABEL_V_OFFSET 18
#define SPLASH_LABEL_FONT_SIZE 8
/* icon border, spacing, offset from bottom and initial size */
-#define SPLASH_ICON_BORDER 8
+#define SPLASH_ICON_BORDER 26
#define SPLASH_ICON_SPACING 4
-#define SPLASH_ICON_V_OFFSET 14
+#define SPLASH_ICON_V_OFFSET 28
#define SPLASH_BASE_ICON_SIZE 36
#define SPLASH_BASE_ICON_ROWS 1
--- gnome-session-2.12.0/gnome-session/splash-widget.c.shaped 2006-01-12 02:19:59.000000000 -0500
+++ gnome-session-2.12.0/gnome-session/splash-widget.c 2006-01-12 02:22:28.000000000 -0500
@@ -137,16 +137,6 @@
if (!GTK_WIDGET_DRAWABLE (widget))
return FALSE;
- if (gdk_rectangle_intersect (
- &event->area, &sw->image_bounds, &exposed))
- gdk_draw_drawable (
- GDK_DRAWABLE (widget->window),
- widget->style->black_gc,
- GDK_DRAWABLE (sw->bg_pixmap),
- exposed.x, exposed.y,
- exposed.x, exposed.y,
- exposed.width, exposed.height);
-
for (l = sw->icons; l; l = l->next) {
SplashIcon *si = l->data;
@@ -221,33 +211,42 @@
static void
splash_widget_realize (GtkWidget *widget)
{
- GdkPixmap *pm;
SplashWidget *sw = (SplashWidget *) widget;
GNOME_CALL_PARENT (GTK_WIDGET_CLASS, realize, (widget));
if (sw->background && widget->window) {
- int width, height;
+ GdkPixmap *pixmap;
+ GdkBitmap *mask;
+ GdkColormap *colormap;
- width = gdk_pixbuf_get_width (sw->background);
- height = gdk_pixbuf_get_height (sw->background);
+ pixmap = NULL;
+ mask = NULL;
- pm = gdk_pixmap_new (
- widget->window,
- width, height,
- gdk_drawable_get_visual (widget->window)->depth);
+ colormap = gtk_widget_get_colormap (widget);
+ gdk_pixbuf_render_pixmap_and_mask_for_colormap (sw->background,
+ colormap,
+ &pixmap, &mask,
+ 125);
- if (pm) {
- gdk_pixbuf_render_to_drawable (
- sw->background, GDK_DRAWABLE (pm),
- widget->style->black_gc,
- 0, 0, 0, 0, width, height,
- GDK_RGB_DITHER_MAX,
- 0, 0);
-
- gdk_window_set_back_pixmap (
- widget->window, pm, FALSE);
- sw->bg_pixmap = pm;
+ if (pixmap) {
+ GtkStyle *style;
+
+ style = gtk_style_copy (widget->style);
+ style->bg_pixmap[GTK_STATE_NORMAL] = pixmap;
+
+ gtk_widget_set_style (widget, style);
+ g_object_unref (style);
+
+ if (mask) {
+ gdk_window_shape_combine_mask (widget->window,
+ mask, 0, 0);
+
+ g_object_unref (mask);
+ }
+
+ gtk_style_set_background (widget->style, widget->window,
+ GTK_STATE_NORMAL);
}
}
}
@@ -257,11 +256,6 @@
{
SplashWidget *sw = (SplashWidget *) widget;
- if (sw->bg_pixmap) {
- g_object_unref (sw->bg_pixmap);
- sw->bg_pixmap = NULL;
- }
-
GNOME_CALL_PARENT (GTK_WIDGET_CLASS, unrealize, (widget));
}

View File

@ -1,89 +0,0 @@
--- gnome-session-2.17.2/gnome-session/gsm-proxy.c.http-proxy 2006-11-27 00:36:17.000000000 -0500
+++ gnome-session-2.17.2/gnome-session/gsm-proxy.c 2006-11-27 00:36:47.000000000 -0500
@@ -38,7 +38,7 @@ gsm_set_up_legacy_proxy_environment (voi
{
static gboolean run_before = FALSE;
gboolean use_proxy, use_authentication;
- char *host, *user_name, *password, *http_proxy;
+ char *host, *http_proxy;
gint port;
GConfClient *gconf_client;
@@ -62,52 +62,34 @@ gsm_set_up_legacy_proxy_environment (voi
return;
}
+ use_authentication = gconf_client_get_bool (gconf_client, HTTP_PROXY_AUTHENTICATION_KEY, NULL);
+
+ /* we don't bother if a username/password are set since keeping the password
+ * in an environment variable has security ramifications
+ */
+ if (use_authentication)
+ {
+ g_unsetenv ("http_proxy");
+ return;
+ }
+
host = gconf_client_get_string (gconf_client, HTTP_PROXY_HOST_KEY, NULL);
if (host == NULL || host[0] == '\0')
{
+ g_free (host);
g_unsetenv ("http_proxy");
return;
}
port = gconf_client_get_int (gconf_client, HTTP_PROXY_PORT_KEY, NULL);
- use_authentication = gconf_client_get_bool (gconf_client, HTTP_PROXY_AUTHENTICATION_KEY, NULL);
-
- user_name = NULL;
- password = NULL;
- if (use_authentication)
- {
- user_name = gconf_client_get_string (gconf_client, HTTP_PROXY_USER_NAME_KEY,
- NULL);
- if (user_name != NULL && user_name[0] == '\0')
- {
- g_free (user_name);
- user_name = NULL;
- }
- else
- password = gconf_client_get_string (gconf_client, HTTP_PROXY_PASSWORD_KEY,
- NULL);
- }
-
if (port <= 0)
- http_proxy = g_strdup_printf ("http://%s%s%s%s%s",
- user_name != NULL? user_name : "",
- user_name != NULL && password != NULL? "@" : "",
- user_name != NULL && password != NULL? password : "",
- user_name != NULL? ":" : "",
- host);
+ http_proxy = g_strdup_printf ("http://%s", host);
else
- http_proxy = g_strdup_printf ("http://%s%s%s%s%s:%d",
- user_name != NULL? user_name : "",
- user_name != NULL && password != NULL? "@" : "",
- user_name != NULL && password != NULL? password : "",
- user_name != NULL? ":" : "",
- host, port);
+ http_proxy = g_strdup_printf ("http://%s:%d", host, port);
g_setenv ("http_proxy", http_proxy, TRUE);
g_free (http_proxy);
- g_free (password);
- g_free (user_name);
g_free (host);
}
--- gnome-session-2.17.2/gnome-session/headers.h.http-proxy 2006-10-26 21:19:45.000000000 -0400
+++ gnome-session-2.17.2/gnome-session/headers.h 2006-11-27 00:36:47.000000000 -0500
@@ -78,8 +78,6 @@
#define HTTP_PROXY_PREFIX "/system/http_proxy"
#define HTTP_PROXY_KEY HTTP_PROXY_PREFIX "/use_http_proxy"
#define HTTP_PROXY_AUTHENTICATION_KEY HTTP_PROXY_PREFIX "/use_authentication"
-#define HTTP_PROXY_USER_NAME_KEY HTTP_PROXY_PREFIX "/authentication_user"
-#define HTTP_PROXY_PASSWORD_KEY HTTP_PROXY_PREFIX "/authentication_password"
#define HTTP_PROXY_HOST_KEY HTTP_PROXY_PREFIX "/host"
#define HTTP_PROXY_PORT_KEY HTTP_PROXY_PREFIX "/port"

View File

@ -1,24 +1,36 @@
--- gnome-session-2.13.92/gnome-session/main.c.user-share 2006-02-22 11:31:10.000000000 -0500
+++ gnome-session-2.13.92/gnome-session/main.c 2006-02-28 13:42:42.000000000 -0500
@@ -46,6 +46,7 @@
#include "gsm-sound.h"
#include "gsm-gsd.h"
#include "gsm-keyring.h"
+#include "gsm-user-share.h"
#include "gsm-xrandr.h"
#include "gsm-at-startup.h"
#include "gsm-remote-desktop.h"
@@ -485,6 +486,8 @@
gsm_sound_login ();
+ gsm_user_share_start ();
diff -up /dev/null gnome-session-2.21.5/gnome-session/gsm-user-share.h
--- /dev/null 2008-01-15 08:30:50.560008905 -0500
+++ gnome-session-2.21.5/gnome-session/gsm-user-share.h 2008-01-15 09:14:18.000000000 -0500
@@ -0,0 +1,6 @@
+#ifndef GSM_USER_SHARE_H
+#define GSM_USER_SHARE_H
+
gsm_remote_desktop_start ();
+void gsm_user_share_start (void);
+
+#endif /* GSM_USER_SHARE_H */
diff -up gnome-session-2.21.5/gnome-session/Makefile.am.user-share gnome-session-2.21.5/gnome-session/Makefile.am
--- gnome-session-2.21.5/gnome-session/Makefile.am.user-share 2008-01-14 17:42:46.000000000 -0500
+++ gnome-session-2.21.5/gnome-session/Makefile.am 2008-01-15 09:14:18.000000000 -0500
@@ -23,6 +23,7 @@ STANDARD_PROPERTIES_CFLAGS =
-DPREFIX=\""$(prefix)"\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DLIBDIR=\""$(libdir)"\" \
+ -DLIBEXECDIR=\""$(libexecdir)"\" \
-DDATADIR=\""$(datadir)"\" \
$(NULL)
if (splashing)
--- /dev/null 2006-02-28 12:23:07.427962250 -0500
+++ gnome-session-2.13.92/gnome-session/gsm-user-share.c 2006-02-28 13:40:38.000000000 -0500
@@ -82,6 +83,8 @@ gnome_session_SOURCES = \
gsm-dbus.h \
gsm-keyring.c \
gsm-keyring.h \
+ gsm-user-share.c \
+ gsm-user-share.h \
gsm-gsd.c \
gsm-gsd.h \
gsm-protocol.c \
diff -up /dev/null gnome-session-2.21.5/gnome-session/gsm-user-share.c
--- /dev/null 2008-01-15 08:30:50.560008905 -0500
+++ gnome-session-2.21.5/gnome-session/gsm-user-share.c 2008-01-15 09:14:18.000000000 -0500
@@ -0,0 +1,38 @@
+#include <config.h>
+
@ -58,31 +70,23 @@
+ NULL);
+ }
+}
--- /dev/null 2006-02-28 12:23:07.427962250 -0500
+++ gnome-session-2.13.92/gnome-session/gsm-user-share.h 2006-02-28 13:40:38.000000000 -0500
@@ -0,0 +1,6 @@
+#ifndef GSM_USER_SHARE_H
+#define GSM_USER_SHARE_H
+
+void gsm_user_share_start (void);
+
+#endif /* GSM_USER_SHARE_H */
--- gnome-session-2.13.92/gnome-session/Makefile.am.user-share 2005-01-10 11:36:40.000000000 -0500
+++ gnome-session-2.13.92/gnome-session/Makefile.am 2006-02-28 13:40:38.000000000 -0500
@@ -23,6 +23,7 @@
-DPREFIX=\""$(prefix)"\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DLIBDIR=\""$(libdir)"\" \
+ -DLIBEXECDIR=\""$(libexecdir)"\" \
-DDATADIR=\""$(datadir)"\" \
$(NULL)
diff -up gnome-session-2.21.5/gnome-session/main.c.user-share gnome-session-2.21.5/gnome-session/main.c
--- gnome-session-2.21.5/gnome-session/main.c.user-share 2008-01-14 18:21:52.000000000 -0500
+++ gnome-session-2.21.5/gnome-session/main.c 2008-01-15 09:24:53.000000000 -0500
@@ -51,6 +51,7 @@
#include "gsm-sound.h"
#include "gsm-gsd.h"
#include "gsm-keyring.h"
+#include "gsm-user-share.h"
#include "gsm-at-startup.h"
#include "gsm-remote-desktop.h"
@@ -93,6 +94,8 @@
gsm-xrandr.h \
gsm-keyring.c \
gsm-keyring.h \
+ gsm-user-share.c \
+ gsm-user-share.h \
gsm-gsd.c \
gsm-gsd.h \
gsm-protocol.c \
@@ -778,6 +779,8 @@ main (int argc, char *argv[])
gsm_sound_login ();
+ gsm_user_share_start ();
+
gsm_remote_desktop_start ();
if (splashing)

View File

@ -1,11 +0,0 @@
--- gnome-session-2.9.4/configure.in.gnome-common 2005-02-02 16:31:39.000000000 -0500
+++ gnome-session-2.9.4/configure.in 2005-02-02 16:31:59.000000000 -0500
@@ -18,8 +18,6 @@
dnl make sure we keep ACLOCAL_FLAGS around for maintainer builds to work
AC_SUBST(ACLOCAL_AMFLAGS, "\${ACLOCAL_FLAGS}")
-GNOME_COMPILE_WARNINGS(yes)
-
AC_ARG_ENABLE(deprecations,
[AC_HELP_STRING([--enable-deprecations],
[warn about deprecated usages [default=no]])],,

View File

@ -11,10 +11,10 @@
Summary: GNOME session manager
Name: gnome-session
Version: 2.20.2
Version: 2.21.5
Release: 1%{?dist}
URL: http://www.gnome.org
Source0: http://download.gnome.org/sources/gnome-session/2.20/%{name}-%{version}.tar.bz2
Source0: http://download.gnome.org/sources/gnome-session/2.21/%{name}-%{version}.tar.bz2
Source1: redhat-default-session
Source2: gnome.desktop
License: GPLv2+
@ -43,7 +43,7 @@ Patch1: gnome-session-2.2.2-icons.patch
Patch2: gnome-session-enable-sound-by-default.patch
# Launch gnome-user-share on login if enabled
Patch7: gnome-session-2.13.92-user-share.patch
Patch7: gnome-session-2.21.5-user-share.patch
# too much crashing
Patch9: gnome-session-2.13.4-no-crashes.patch
@ -192,6 +192,9 @@ fi
%doc %{_datadir}/man/man*/*
%changelog
* Tue Jan 15 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.5-1
- Update to 2.21.5
* Tue Nov 27 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.2-1
- Update to 2.20.2 (translation updates)

View File

@ -1 +1 @@
4dba25eb6ddb1a25d70fe3107ce23ed8 gnome-session-2.20.2.tar.bz2
8f044122c0ecd071fa3d56bc83ef52fe gnome-session-2.21.5.tar.bz2