Update to 3.4.1

... and dropped upstreamed
0001-Fix-some-problems-in-the-systemd-code.patch
This commit is contained in:
Kalev Lember 2012-04-16 22:46:05 +03:00
parent 75e7919ab6
commit 4b53c2d9f8
4 changed files with 9 additions and 73 deletions

1
.gitignore vendored
View File

@ -26,3 +26,4 @@ gnome-session-2.31.6.tar.bz2
/gnome-session-3.3.90.tar.xz
/gnome-session-3.3.92.tar.xz
/gnome-session-3.4.0.tar.xz
/gnome-session-3.4.1.tar.xz

View File

@ -1,66 +0,0 @@
From 5dc795f32bf7eae5c12d36cd289cf9b9f6438255 Mon Sep 17 00:00:00 2001
From: Matthias Clasen <mclasen@redhat.com>
Date: Thu, 5 Apr 2012 22:00:17 -0400
Subject: [PATCH] Fix some problems in the systemd code
The stop and restart functions forgot to pass the manager
object down, and then tried to emit signals on a NULL
object. Also, we were unreffing a variant that was NULL
half the time. Don't do that.
Fixes the problem where a poweroff request in the presence
of multiple user sessions leads to a PolicyKit dialog that
comes back every time it is canceled.
https://bugzilla.gnome.org/show_bug.cgi?id=673619
---
gnome-session/gsm-systemd.c | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/gnome-session/gsm-systemd.c b/gnome-session/gsm-systemd.c
index 5bf64b0..0907bfb 100644
--- a/gnome-session/gsm-systemd.c
+++ b/gnome-session/gsm-systemd.c
@@ -208,9 +208,8 @@ restart_done (GObject *source,
g_error_free (error);
} else {
emit_restart_complete (manager, NULL);
+ g_variant_unref (res);
}
-
- g_variant_unref (res);
}
static void
@@ -225,7 +224,7 @@ gsm_systemd_attempt_restart (GsmSystem *system)
G_MAXINT,
NULL,
restart_done,
- NULL);
+ manager);
}
static void
@@ -246,9 +245,8 @@ stop_done (GObject *source,
g_error_free (error);
} else {
emit_stop_complete (manager, NULL);
+ g_variant_unref (res);
}
-
- g_variant_unref (res);
}
static void
@@ -263,7 +261,7 @@ gsm_systemd_attempt_stop (GsmSystem *system)
G_MAXINT,
NULL,
stop_done,
- NULL);
+ manager);
}
static void
--
1.7.9.3

View File

@ -2,19 +2,17 @@
Summary: GNOME session manager
Name: gnome-session
Version: 3.4.0
Release: 2%{?dist}
Version: 3.4.1
Release: 1%{?dist}
URL: http://www.gnome.org
#VCS: git:git://git.gnome.org/gnome-session
Source0: http://download.gnome.org/sources/gnome-session/3.3/%{name}-%{version}.tar.xz
Source0: http://download.gnome.org/sources/gnome-session/3.4/%{name}-%{version}.tar.xz
Source1: gnome-authentication-agent.desktop
Source2: gnome.desktop
Patch0: gnome-session-3.3.1-llvmpipe.patch
# Blacklist NV30: https://bugzilla.redhat.com/show_bug.cgi?id=745202
Patch1: gnome-session-3.3.92-nv30.patch
# https://bugzilla.gnome.org/show_bug.cgi?id=673619
Patch2: 0001-Fix-some-problems-in-the-systemd-code.patch
License: GPLv2+
Group: User Interface/Desktops
@ -84,7 +82,6 @@ Desktop file to add GNOME to display manager session menu.
%setup -q
%patch0 -p1 -b .llvmpipe
%patch1 -p1 -b .nv30
%patch2 -p1 -b .systemd
echo "ACLOCAL_AMFLAGS = -I m4" >> Makefile.am
@ -160,6 +157,10 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
%{_datadir}/glib-2.0/schemas/org.gnome.SessionManager.gschema.xml
%changelog
* Tue Apr 17 2012 Kalev Lember <kalevlember@gmail.com> - 3.4.1-1
- Update to 3.4.1
- Dropped upstreamed systemd patch
* Thu Apr 5 2012 Matthias Clasen <mclasen@redhat.com> - 3.4.0-2
- Fix a looping PolicyKit dialog on shutdown

View File

@ -1 +1 @@
5e4551f3c6dae7ab476a53fad5cfd955 gnome-session-3.4.0.tar.xz
993ade4c005ec47d7992ab971177bad9 gnome-session-3.4.1.tar.xz