import gnome-session-3.28.1-6.el8
This commit is contained in:
commit
1075ea96bb
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/gnome-session-3.28.1.tar.xz
|
1
.gnome-session.metadata
Normal file
1
.gnome-session.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
3233201cc82fa736997ddee7e54cb7f61c9d0074 SOURCES/gnome-session-3.28.1.tar.xz
|
@ -0,0 +1,75 @@
|
|||||||
|
From 687ec347d2fa0bca227e3a583a3a47f9bbc10bb0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adam Jackson <ajax@redhat.com>
|
||||||
|
Date: Tue, 4 Oct 2016 13:15:39 -0400
|
||||||
|
Subject: [PATCH] check-accelerated-gles: Use eglGetPlatformDisplay{,EXT}
|
||||||
|
|
||||||
|
eglGetDisplay forces the implementation to guess, and in general it
|
||||||
|
can't guess correctly. Be explicit.
|
||||||
|
|
||||||
|
Signed-off-by: Adam Jackson <ajax@redhat.com>
|
||||||
|
---
|
||||||
|
.../gnome-session-check-accelerated-gles-helper.c | 36 +++++++++++++++++++++-
|
||||||
|
1 file changed, 35 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/tools/gnome-session-check-accelerated-gles-helper.c b/tools/gnome-session-check-accelerated-gles-helper.c
|
||||||
|
index 2a38d9e..472d1ad 100644
|
||||||
|
--- a/tools/gnome-session-check-accelerated-gles-helper.c
|
||||||
|
+++ b/tools/gnome-session-check-accelerated-gles-helper.c
|
||||||
|
@@ -34,11 +34,43 @@
|
||||||
|
#include <GLES2/gl2.h>
|
||||||
|
#include <GLES2/gl2ext.h>
|
||||||
|
#include <EGL/egl.h>
|
||||||
|
+#include <EGL/eglext.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#include "gnome-session-check-accelerated-common.h"
|
||||||
|
|
||||||
|
#ifdef GDK_WINDOWING_X11
|
||||||
|
+static EGLDisplay
|
||||||
|
+get_display (void *native)
|
||||||
|
+{
|
||||||
|
+ EGLDisplay dpy = NULL;
|
||||||
|
+ const char *client_exts = eglQueryString (NULL, EGL_EXTENSIONS);
|
||||||
|
+
|
||||||
|
+ if (g_strstr_len (client_exts, -1, "EGL_KHR_platform_base")) {
|
||||||
|
+ PFNEGLGETPLATFORMDISPLAYEXTPROC get_platform_display =
|
||||||
|
+ (void *) eglGetProcAddress ("eglGetPlatformDisplay");
|
||||||
|
+
|
||||||
|
+ if (get_platform_display)
|
||||||
|
+ dpy = get_platform_display (EGL_PLATFORM_X11_KHR, native, NULL);
|
||||||
|
+
|
||||||
|
+ if (dpy)
|
||||||
|
+ return dpy;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ if (g_strstr_len (client_exts, -1, "EGL_EXT_platform_base")) {
|
||||||
|
+ PFNEGLGETPLATFORMDISPLAYEXTPROC get_platform_display =
|
||||||
|
+ (void *) eglGetProcAddress ("eglGetPlatformDisplayEXT");
|
||||||
|
+
|
||||||
|
+ if (get_platform_display)
|
||||||
|
+ dpy = get_platform_display (EGL_PLATFORM_X11_KHR, native, NULL);
|
||||||
|
+
|
||||||
|
+ if (dpy)
|
||||||
|
+ return dpy;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ return eglGetDisplay ((EGLNativeDisplayType) native);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
static char *
|
||||||
|
get_gles_renderer (void)
|
||||||
|
{
|
||||||
|
@@ -67,7 +99,9 @@ get_gles_renderer (void)
|
||||||
|
gdk_error_trap_push ();
|
||||||
|
|
||||||
|
display = GDK_DISPLAY_XDISPLAY (gdk_display_get_default ());
|
||||||
|
- egl_dpy = eglGetDisplay (display);
|
||||||
|
+
|
||||||
|
+ egl_dpy = get_display (display);
|
||||||
|
+
|
||||||
|
if (!egl_dpy) {
|
||||||
|
g_warning ("eglGetDisplay() failed");
|
||||||
|
goto out;
|
||||||
|
--
|
||||||
|
2.9.3
|
||||||
|
|
12
SOURCES/gnome-session-3.3.92-nv30.patch
Normal file
12
SOURCES/gnome-session-3.3.92-nv30.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
--- gnome-session/data/hardware-compatibility 2012-03-21 16:30:06.269104695 -0700
|
||||||
|
+++ gnome-session/data/hardware-compatibility.new 2012-03-22 23:26:37.201967075 -0700
|
||||||
|
@@ -19,6 +19,9 @@
|
||||||
|
-Mesa DRI R[12]00[^[:digit:]]
|
||||||
|
-Mesa DRI R[12]00$
|
||||||
|
|
||||||
|
+# NV30 family on Nouveau: https://bugzilla.redhat.com/show_bug.cgi?id=745202
|
||||||
|
+-Gallium .* on NV3[0-9A-F]$
|
||||||
|
+
|
||||||
|
# Old Mesa software GL renderer
|
||||||
|
-software rasterizer
|
||||||
|
|
12
SOURCES/gnome-session-3.6.2-swrast.patch
Normal file
12
SOURCES/gnome-session-3.6.2-swrast.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up gnome-session-3.6.2/data/hardware-compatibility.jx gnome-session-3.6.2/data/hardware-compatibility
|
||||||
|
--- gnome-session-3.6.2/data/hardware-compatibility.jx 2012-12-10 12:43:06.000000000 -0500
|
||||||
|
+++ gnome-session-3.6.2/data/hardware-compatibility 2012-12-10 12:43:50.424352484 -0500
|
||||||
|
@@ -23,7 +23,7 @@
|
||||||
|
-Gallium .* on NV3[0-9A-F]$
|
||||||
|
|
||||||
|
# Old Mesa software GL renderer
|
||||||
|
--software rasterizer
|
||||||
|
+#software rasterizer
|
||||||
|
|
||||||
|
# Gallium has softpipe; we explicitly enable llvmpipe
|
||||||
|
-softpipe
|
27
SOURCES/gnome-xorg.desktop
Normal file
27
SOURCES/gnome-xorg.desktop
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Name[de]=Standard (X11 Anzeige-Server) unter Xorg
|
||||||
|
Name[es]=Estándar (servidor gráfico X11) en Xorg
|
||||||
|
Name[fr]=Standard (serveur affichage X11) sur Xorg
|
||||||
|
Name[it]=Standard (server grafico X11) su Xorg
|
||||||
|
Name[ja]=Xorg 上でのスタンダード (X11 ディスプレイサーバー)
|
||||||
|
Name[ko]=Xorg 스탠다드 (X11 디스플레이 서버)
|
||||||
|
Name[pt_BR]=Padrão (servidor de exibição X11) no Xorg
|
||||||
|
Name[ru]=Стандартный (дисплейный сервер X11) на Xorg
|
||||||
|
Name[zh_CN]=Xorg 标准(X11 显示服务器)
|
||||||
|
Name[zh_TW]=Xorg上的標準(X11顯示服務器)
|
||||||
|
Name=Standard (X11 display server) on Xorg
|
||||||
|
Comment[de]=Diese Sitzung meldet Sie bei GNOME an
|
||||||
|
Comment[es]=Esta sesión accede a GNOME
|
||||||
|
Comment[fr]=Cette session vous connecte dans GNOME
|
||||||
|
Comment[it]=Questa sessione esegue l'accesso in GNOME
|
||||||
|
Comment[ja]=このセッションで GNOME にログインします
|
||||||
|
Comment[ko]=이 세션을 사용하면 그놈에 로그인합니다
|
||||||
|
Comment[pt_BR]=Essa sessão o leva ao GNOME
|
||||||
|
Comment[ru]=Этот сеанс позволяет вам войти в GNOME
|
||||||
|
Comment[zh_CN]=此会话将您登录到 GNOME
|
||||||
|
Comment[zh_TW]=這個工作階段讓您登入 GNOME
|
||||||
|
Comment=This session logs you into GNOME
|
||||||
|
Exec=gnome-session
|
||||||
|
TryExec=gnome-session
|
||||||
|
Type=Application
|
||||||
|
DesktopNames=GNOME
|
27
SOURCES/gnome.desktop
Normal file
27
SOURCES/gnome.desktop
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Name[de]=Standard (Wayland Anzeige-Server)
|
||||||
|
Name[es]=Estándar (servidor gráfico Wayland)
|
||||||
|
Name[fr]=Standard (serveur affichage Wayland)
|
||||||
|
Name[it]=Standard (server grafico Wayland)
|
||||||
|
Name[ja]=スタンダード (Wayland ディスプレイサーバー)
|
||||||
|
Name[ko]=스탠다드 (Wayland 디스플레이 서버)
|
||||||
|
Name[pt_BR]=Padrão (servidor de exibição Wayland)
|
||||||
|
Name[ru]=Стандартный (дисплейный сервер Wayland)
|
||||||
|
Name[zh_CN]=标准(Wayland 显示服务器)
|
||||||
|
Name[zh_TW]=標準(Wayland顯示服務器)
|
||||||
|
Name=Standard (Wayland display server)
|
||||||
|
Comment[de]=Diese Sitzung meldet Sie bei GNOME an
|
||||||
|
Comment[es]=Esta sesión accede a GNOME
|
||||||
|
Comment[fr]=Cette session vous connecte dans GNOME
|
||||||
|
Comment[it]=Questa sessione esegue l'accesso in GNOME
|
||||||
|
Comment[ja]=このセッションで GNOME にログインします
|
||||||
|
Comment[ko]=이 세션을 사용하면 그놈에 로그인합니다
|
||||||
|
Comment[pt_BR]=Essa sessão o leva ao GNOME
|
||||||
|
Comment[ru]=Этот сеанс позволяет вам войти в GNOME
|
||||||
|
Comment[zh_CN]=此会话将您登录到 GNOME
|
||||||
|
Comment[zh_TW]=這個工作階段讓您登入 GNOME
|
||||||
|
Comment=This session logs you into GNOME
|
||||||
|
Exec=gnome-session
|
||||||
|
TryExec=gnome-session
|
||||||
|
Type=Application
|
||||||
|
DesktopNames=GNOME
|
1483
SPECS/gnome-session.spec
Normal file
1483
SPECS/gnome-session.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user