Remove patch fuzz 2 and drop two upstreamed patches
These two were being totally misapplied due to patch fuzz 2 ...
This commit is contained in:
parent
9de8a298de
commit
0259b130a2
@ -1,36 +0,0 @@
|
||||
From f1424cd84dc3488922c91a918d9a4f5bdbfb2756 Mon Sep 17 00:00:00 2001
|
||||
From: Matthias Clasen <mclasen@redhat.com>
|
||||
Date: Fri, 6 Mar 2015 18:13:40 -0500
|
||||
Subject: [PATCH] Fix SessionIsActive property
|
||||
|
||||
GsmSystemd emits its cold-plug notify::active signal out of
|
||||
init(), giving GsmManager no chance to connect its signal handler
|
||||
in time to catch the initial emission. And even if we did,
|
||||
the GsmManager handler can only operate once the skeleton object
|
||||
exists.
|
||||
Therefore, do our own cold-plug after creating the skeleton.
|
||||
|
||||
This is fallout from the GDBus port.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=745762
|
||||
---
|
||||
gnome-session/gsm-manager.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/gnome-session/gsm-manager.c b/gnome-session/gsm-manager.c
|
||||
index 775873f..70ef94f 100644
|
||||
--- a/gnome-session/gsm-manager.c
|
||||
+++ b/gnome-session/gsm-manager.c
|
||||
@@ -3210,6 +3210,9 @@ register_manager (GsmManager *manager)
|
||||
manager->priv->connection = connection;
|
||||
manager->priv->skeleton = skeleton;
|
||||
|
||||
+ /* cold-plug SessionIsActive */
|
||||
+ on_gsm_system_active_changed (manager->priv->system, NULL, manager);
|
||||
+
|
||||
return TRUE;
|
||||
}
|
||||
|
||||
--
|
||||
2.3.1
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 6bda8ba424d2dbd2441d9a7e6553608dceaa8454 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Thu, 18 Oct 2012 16:53:12 +0200
|
||||
Subject: [PATCH] main: Set XDG_MENU_PREFIX
|
||||
|
||||
---
|
||||
gnome-session/main.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/gnome-session/main.c b/gnome-session/main.c
|
||||
index 1903381..147daec 100644
|
||||
--- a/gnome-session/main.c
|
||||
+++ b/gnome-session/main.c
|
||||
@@ -347,6 +347,11 @@ main (int argc, char **argv)
|
||||
*/
|
||||
gsm_util_setenv ("GNOME_DESKTOP_SESSION_ID", "this-is-deprecated");
|
||||
|
||||
+ /* We want to use the GNOME menus which has the designed categories,
|
||||
+ * not the legacy redhat-menus.
|
||||
+ */
|
||||
+ gsm_util_setenv ("XDG_MENU_PREFIX", "gnome-");
|
||||
+
|
||||
client_store = gsm_store_new ();
|
||||
|
||||
xsmp_server = gsm_xsmp_server_new (client_store);
|
||||
--
|
||||
1.7.12.1
|
||||
|
@ -8,5 +8,5 @@ diff -up gnome-session-3.6.2/data/hardware-compatibility.jx gnome-session-3.6.2/
|
||||
--software rasterizer
|
||||
+#software rasterizer
|
||||
|
||||
# Gallium has softpipe and llvmpipe
|
||||
# Gallium has softpipe; we explicitly enable llvmpipe
|
||||
-softpipe
|
||||
|
@ -1,7 +1,6 @@
|
||||
%global _changelog_trimtime %(date +%s -d "1 year ago")
|
||||
|
||||
%define po_package gnome-session-3.0
|
||||
%define _default_patch_fuzz 2
|
||||
|
||||
%if 0%{?fedora}
|
||||
%else
|
||||
@ -18,12 +17,8 @@ Source0: http://download.gnome.org/sources/gnome-session/3.15/%{name}-%{version}
|
||||
|
||||
# Blacklist NV30: https://bugzilla.redhat.com/show_bug.cgi?id=745202
|
||||
Patch1: gnome-session-3.3.92-nv30.patch
|
||||
Patch2: 0001-main-Set-XDG_MENU_PREFIX.patch
|
||||
Patch3: gnome-session-3.6.2-swrast.patch
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=745762
|
||||
Patch4: 0001-Fix-SessionIsActive-property.patch
|
||||
|
||||
License: GPLv2+
|
||||
Group: User Interface/Desktops
|
||||
|
||||
@ -90,9 +85,7 @@ Desktop file to add GNOME on wayland to display manager session menu.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .nv30
|
||||
%patch2 -p1 -b .set-xdg-menu-prefix
|
||||
%patch3 -p1 -b .swrast
|
||||
%patch4 -p1 -b .session-is-active
|
||||
|
||||
echo "ACLOCAL_AMFLAGS = -I m4" >> Makefile.am
|
||||
|
||||
@ -152,6 +145,7 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
|
||||
%changelog
|
||||
* Wed Mar 18 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.92-1
|
||||
- Update to 3.15.92
|
||||
- Remove patch fuzz 2 and drop two upstreamed patches
|
||||
|
||||
* Sat Mar 07 2015 Bastien Nocera <bnocera@redhat.com> 3.15.90-2
|
||||
- Fix SessionIsActive property thereby fixing screens not going to sleep
|
||||
|
Loading…
Reference in New Issue
Block a user