Auto sync2gitlab import of gnome-remote-desktop-0.1.8-3.el8.src.rpm
This commit is contained in:
parent
76436d229f
commit
6d835941be
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
/gnome-remote-desktop-0.1.8.tar.xz
|
52
0001-stream-log-a-warning-on-error.patch
Normal file
52
0001-stream-log-a-warning-on-error.patch
Normal file
@ -0,0 +1,52 @@
|
||||
From 7670167e578eb5c6e032cff38112edf85df142ee Mon Sep 17 00:00:00 2001
|
||||
From: Wim Taymans <wtaymans@redhat.com>
|
||||
Date: Tue, 16 Jun 2020 11:44:52 +0200
|
||||
Subject: [PATCH 1/2] stream: log a warning on error
|
||||
|
||||
When we get an invalid buffer or we can't mmap() it, log a warning
|
||||
and exit instead of carying on with invalid pointers and segfault.
|
||||
---
|
||||
src/grd-vnc-pipewire-stream.c | 15 ++++++++++++---
|
||||
1 file changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/grd-vnc-pipewire-stream.c b/src/grd-vnc-pipewire-stream.c
|
||||
index 261292a..91fb0a1 100644
|
||||
--- a/src/grd-vnc-pipewire-stream.c
|
||||
+++ b/src/grd-vnc-pipewire-stream.c
|
||||
@@ -323,14 +323,18 @@ process_buffer (GrdVncPipeWireStream *stream,
|
||||
|
||||
if (buffer->datas[0].chunk->size == 0)
|
||||
{
|
||||
- size = 0;
|
||||
- map = NULL;
|
||||
- src_data = NULL;
|
||||
+ g_warning ("Received empty buffer");
|
||||
+ return NULL;
|
||||
}
|
||||
else if (buffer->datas[0].type == SPA_DATA_MemFd)
|
||||
{
|
||||
size = buffer->datas[0].maxsize + buffer->datas[0].mapoffset;
|
||||
map = mmap (NULL, size, PROT_READ, MAP_PRIVATE, buffer->datas[0].fd, 0);
|
||||
+ if (map == MAP_FAILED)
|
||||
+ {
|
||||
+ g_warning ("Failed to mmap buffer: %s", g_strerror (errno));
|
||||
+ return NULL;
|
||||
+ }
|
||||
src_data = SPA_MEMBER (map, buffer->datas[0].mapoffset, uint8_t);
|
||||
}
|
||||
else if (buffer->datas[0].type == SPA_DATA_DmaBuf)
|
||||
@@ -341,6 +345,11 @@ process_buffer (GrdVncPipeWireStream *stream,
|
||||
size = buffer->datas[0].maxsize + buffer->datas[0].mapoffset;
|
||||
|
||||
map = mmap (NULL, size, PROT_READ, MAP_PRIVATE, fd, 0);
|
||||
+ if (map == MAP_FAILED)
|
||||
+ {
|
||||
+ g_warning ("Failed to mmap DMA buffer: %s", g_strerror (errno));
|
||||
+ return NULL;
|
||||
+ }
|
||||
sync_dma_buf (fd, DMA_BUF_SYNC_START);
|
||||
|
||||
src_data = SPA_MEMBER (map, buffer->datas[0].mapoffset, uint8_t);
|
||||
--
|
||||
2.26.2
|
||||
|
73
0001-vnc-pipewire-stream-Handle-stride-mismatch.patch
Normal file
73
0001-vnc-pipewire-stream-Handle-stride-mismatch.patch
Normal file
@ -0,0 +1,73 @@
|
||||
From 78c5bcb181fe2b0b9fc17eea696feac8b504df54 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
||||
Date: Thu, 7 May 2020 15:48:22 +0200
|
||||
Subject: [PATCH] vnc/pipewire-stream: Handle stride mismatch
|
||||
|
||||
The VNC server framebuffer assumes a particular stride; but there is no
|
||||
guarantee that we'll get the same from PipeWire. Handle this gracefully
|
||||
by coping row by row instead of the whole buffer.
|
||||
---
|
||||
src/grd-vnc-pipewire-stream.c | 23 +++++++++++++++--------
|
||||
1 file changed, 15 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/src/grd-vnc-pipewire-stream.c b/src/grd-vnc-pipewire-stream.c
|
||||
index 88c07be..261292a 100644
|
||||
--- a/src/grd-vnc-pipewire-stream.c
|
||||
+++ b/src/grd-vnc-pipewire-stream.c
|
||||
@@ -187,8 +187,6 @@ on_stream_param_changed (void *user_data,
|
||||
struct spa_pod_builder pod_builder;
|
||||
int width;
|
||||
int height;
|
||||
- int stride;
|
||||
- int size;
|
||||
const struct spa_pod *params[3];
|
||||
|
||||
if (!format || id != SPA_PARAM_Format)
|
||||
@@ -203,14 +201,9 @@ on_stream_param_changed (void *user_data,
|
||||
|
||||
grd_session_vnc_queue_resize_framebuffer (stream->session, width, height);
|
||||
|
||||
- stride = grd_session_vnc_get_framebuffer_stride (stream->session);
|
||||
- size = stride * height;
|
||||
-
|
||||
params[0] = spa_pod_builder_add_object (
|
||||
&pod_builder,
|
||||
SPA_TYPE_OBJECT_ParamBuffers, SPA_PARAM_Buffers,
|
||||
- SPA_PARAM_BUFFERS_size, SPA_POD_Int (size),
|
||||
- SPA_PARAM_BUFFERS_stride, SPA_POD_Int (stride),
|
||||
SPA_PARAM_BUFFERS_buffers, SPA_POD_CHOICE_RANGE_Int (8, 1, 8),
|
||||
0);
|
||||
|
||||
@@ -319,6 +312,10 @@ process_buffer (GrdVncPipeWireStream *stream,
|
||||
size_t size;
|
||||
uint8_t *map;
|
||||
void *src_data;
|
||||
+ int src_stride;
|
||||
+ int dst_stride;
|
||||
+ int height;
|
||||
+ int y;
|
||||
struct spa_meta_cursor *spa_meta_cursor;
|
||||
g_autofree GrdVncFrame *frame = NULL;
|
||||
|
||||
@@ -359,7 +356,17 @@ process_buffer (GrdVncPipeWireStream *stream,
|
||||
return NULL;
|
||||
}
|
||||
|
||||
- frame->data = g_memdup (src_data, buffer->datas[0].maxsize);
|
||||
+ src_stride = buffer->datas[0].chunk->stride;
|
||||
+ dst_stride = grd_session_vnc_get_framebuffer_stride (stream->session);
|
||||
+ height = stream->spa_format.size.height;
|
||||
+
|
||||
+ frame->data = g_malloc (height * dst_stride);
|
||||
+ for (y = 0; y < height; y++)
|
||||
+ {
|
||||
+ memcpy (((uint8_t *) frame->data) + y * dst_stride,
|
||||
+ ((uint8_t *) src_data) + y * src_stride,
|
||||
+ dst_stride);
|
||||
+ }
|
||||
|
||||
if (map)
|
||||
{
|
||||
--
|
||||
2.26.2
|
||||
|
25
0001-vnc-pipewire-stream-Remove-assert.patch
Normal file
25
0001-vnc-pipewire-stream-Remove-assert.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 240d8694fbcdeb020e7f9c0f8f292a4679b88b30 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
||||
Date: Thu, 18 Jun 2020 13:14:04 +0200
|
||||
Subject: [PATCH] vnc/pipewire-stream: Remove assert
|
||||
|
||||
Handle lack of frames gracefully.
|
||||
---
|
||||
src/grd-vnc-pipewire-stream.c | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/src/grd-vnc-pipewire-stream.c b/src/grd-vnc-pipewire-stream.c
|
||||
index ee8ad5d..a3f5fb6 100644
|
||||
--- a/src/grd-vnc-pipewire-stream.c
|
||||
+++ b/src/grd-vnc-pipewire-stream.c
|
||||
@@ -463,7 +463,6 @@ on_stream_process (void *user_data)
|
||||
|
||||
frame = process_buffer (stream, buffer->buffer);
|
||||
|
||||
- g_assert (frame);
|
||||
g_mutex_lock (&stream->frame_mutex);
|
||||
if (stream->pending_frame)
|
||||
{
|
||||
--
|
||||
2.26.2
|
||||
|
@ -0,0 +1,62 @@
|
||||
From f3efe25a5cb173bc63b380619b8673cd5ba99f6f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
||||
Date: Thu, 18 Jun 2020 11:35:44 +0200
|
||||
Subject: [PATCH 2/2] vnc/pipewire-stream: Only try to copy frame pixels if
|
||||
there are any
|
||||
|
||||
The producer might send empty frames with only cursor metadata, and in
|
||||
this case we shouldn't try to copy any pixels, as there are no.
|
||||
---
|
||||
src/grd-vnc-pipewire-stream.c | 28 ++++++++++++++++------------
|
||||
1 file changed, 16 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/src/grd-vnc-pipewire-stream.c b/src/grd-vnc-pipewire-stream.c
|
||||
index 91fb0a1..ee8ad5d 100644
|
||||
--- a/src/grd-vnc-pipewire-stream.c
|
||||
+++ b/src/grd-vnc-pipewire-stream.c
|
||||
@@ -312,9 +312,6 @@ process_buffer (GrdVncPipeWireStream *stream,
|
||||
size_t size;
|
||||
uint8_t *map;
|
||||
void *src_data;
|
||||
- int src_stride;
|
||||
- int dst_stride;
|
||||
- int height;
|
||||
int y;
|
||||
struct spa_meta_cursor *spa_meta_cursor;
|
||||
g_autofree GrdVncFrame *frame = NULL;
|
||||
@@ -365,16 +362,23 @@ process_buffer (GrdVncPipeWireStream *stream,
|
||||
return NULL;
|
||||
}
|
||||
|
||||
- src_stride = buffer->datas[0].chunk->stride;
|
||||
- dst_stride = grd_session_vnc_get_framebuffer_stride (stream->session);
|
||||
- height = stream->spa_format.size.height;
|
||||
-
|
||||
- frame->data = g_malloc (height * dst_stride);
|
||||
- for (y = 0; y < height; y++)
|
||||
+ if (src_data)
|
||||
{
|
||||
- memcpy (((uint8_t *) frame->data) + y * dst_stride,
|
||||
- ((uint8_t *) src_data) + y * src_stride,
|
||||
- dst_stride);
|
||||
+ int src_stride;
|
||||
+ int dst_stride;
|
||||
+ int height;
|
||||
+
|
||||
+ src_stride = buffer->datas[0].chunk->stride;
|
||||
+ dst_stride = grd_session_vnc_get_framebuffer_stride (stream->session);
|
||||
+ height = stream->spa_format.size.height;
|
||||
+
|
||||
+ frame->data = g_malloc (height * dst_stride);
|
||||
+ for (y = 0; y < height; y++)
|
||||
+ {
|
||||
+ memcpy (((uint8_t *) frame->data) + y * dst_stride,
|
||||
+ ((uint8_t *) src_data) + y * src_stride,
|
||||
+ dst_stride);
|
||||
+ }
|
||||
}
|
||||
|
||||
if (map)
|
||||
--
|
||||
2.26.2
|
||||
|
1532
anon-tls-support.patch
Normal file
1532
anon-tls-support.patch
Normal file
File diff suppressed because it is too large
Load Diff
127
cursor-only-frame-fixes.patch
Normal file
127
cursor-only-frame-fixes.patch
Normal file
@ -0,0 +1,127 @@
|
||||
From f97b689c5c67cee36025a7b0a9210deb8b373b03 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
||||
Date: Fri, 3 Jul 2020 17:03:52 +0200
|
||||
Subject: [PATCH 1/3] session-vnc: Add API to flush
|
||||
|
||||
When no damage is to be reported, but e.g. cursor moved, we need to
|
||||
flush, so add API to make this possible.
|
||||
|
||||
(cherry picked from commit 25e61a7ed3631687aed4310824e7810088e63b37)
|
||||
---
|
||||
src/grd-session-vnc.c | 6 ++++++
|
||||
src/grd-session-vnc.h | 2 ++
|
||||
2 files changed, 8 insertions(+)
|
||||
|
||||
diff --git a/src/grd-session-vnc.c b/src/grd-session-vnc.c
|
||||
index 9fcbb69..7950d1e 100644
|
||||
--- a/src/grd-session-vnc.c
|
||||
+++ b/src/grd-session-vnc.c
|
||||
@@ -179,6 +179,12 @@ grd_session_vnc_take_buffer (GrdSessionVnc *session_vnc,
|
||||
rfbProcessEvents (session_vnc->rfb_screen, 0);
|
||||
}
|
||||
|
||||
+void
|
||||
+grd_session_vnc_flush (GrdSessionVnc *session_vnc)
|
||||
+{
|
||||
+ rfbProcessEvents (session_vnc->rfb_screen, 0);
|
||||
+}
|
||||
+
|
||||
void
|
||||
grd_session_vnc_set_cursor (GrdSessionVnc *session_vnc,
|
||||
rfbCursorPtr rfb_cursor)
|
||||
diff --git a/src/grd-session-vnc.h b/src/grd-session-vnc.h
|
||||
index 294860e..a065857 100644
|
||||
--- a/src/grd-session-vnc.h
|
||||
+++ b/src/grd-session-vnc.h
|
||||
@@ -49,6 +49,8 @@ void grd_session_vnc_queue_resize_framebuffer (GrdSessionVnc *session_vnc,
|
||||
void grd_session_vnc_take_buffer (GrdSessionVnc *session_vnc,
|
||||
void *data);
|
||||
|
||||
+void grd_session_vnc_flush (GrdSessionVnc *session_vnc);
|
||||
+
|
||||
void grd_session_vnc_set_cursor (GrdSessionVnc *session_vnc,
|
||||
rfbCursorPtr rfb_cursor);
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
||||
|
||||
From 8a050b66be76d73725ac7665295160ab6c40b0f5 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
||||
Date: Fri, 3 Jul 2020 17:12:58 +0200
|
||||
Subject: [PATCH 2/3] vnc-pipewire-stream: Properly process cursor-change-only
|
||||
frames
|
||||
|
||||
Such frames will have the buffer data size set to 0, as it is empty, but
|
||||
may contain metadata carrying the cursor update.
|
||||
|
||||
(cherry picked from commit c04762a450ea9a21730db26c296c1283e121dc08)
|
||||
---
|
||||
src/grd-vnc-pipewire-stream.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/grd-vnc-pipewire-stream.c b/src/grd-vnc-pipewire-stream.c
|
||||
index a3f5fb6..7519377 100644
|
||||
--- a/src/grd-vnc-pipewire-stream.c
|
||||
+++ b/src/grd-vnc-pipewire-stream.c
|
||||
@@ -312,7 +312,6 @@ process_buffer (GrdVncPipeWireStream *stream,
|
||||
size_t size;
|
||||
uint8_t *map;
|
||||
void *src_data;
|
||||
- int y;
|
||||
struct spa_meta_cursor *spa_meta_cursor;
|
||||
g_autofree GrdVncFrame *frame = NULL;
|
||||
|
||||
@@ -320,8 +319,8 @@ process_buffer (GrdVncPipeWireStream *stream,
|
||||
|
||||
if (buffer->datas[0].chunk->size == 0)
|
||||
{
|
||||
- g_warning ("Received empty buffer");
|
||||
- return NULL;
|
||||
+ map = NULL;
|
||||
+ src_data = NULL;
|
||||
}
|
||||
else if (buffer->datas[0].type == SPA_DATA_MemFd)
|
||||
{
|
||||
@@ -367,6 +366,7 @@ process_buffer (GrdVncPipeWireStream *stream,
|
||||
int src_stride;
|
||||
int dst_stride;
|
||||
int height;
|
||||
+ int y;
|
||||
|
||||
src_stride = buffer->datas[0].chunk->stride;
|
||||
dst_stride = grd_session_vnc_get_framebuffer_stride (stream->session);
|
||||
--
|
||||
2.26.2
|
||||
|
||||
|
||||
From eac6368d8411c586007df8b1a2d85df3da1b55c5 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
||||
Date: Fri, 3 Jul 2020 17:13:58 +0200
|
||||
Subject: [PATCH 3/3] vnc-pipewire-stream: Flush connection if no new pixel
|
||||
buffer
|
||||
|
||||
Otherwise we'll wait on input until we flush out our new cursor move
|
||||
only output.
|
||||
|
||||
(cherry picked from commit 3394e34c3c502d63636bb852c062855c46736a6f)
|
||||
---
|
||||
src/grd-vnc-pipewire-stream.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/grd-vnc-pipewire-stream.c b/src/grd-vnc-pipewire-stream.c
|
||||
index 7519377..791b71d 100644
|
||||
--- a/src/grd-vnc-pipewire-stream.c
|
||||
+++ b/src/grd-vnc-pipewire-stream.c
|
||||
@@ -299,6 +299,8 @@ do_render (struct spa_loop *loop,
|
||||
|
||||
if (frame->data)
|
||||
grd_session_vnc_take_buffer (stream->session, frame->data);
|
||||
+ else
|
||||
+ grd_session_vnc_flush (stream->session);
|
||||
|
||||
g_free (frame);
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
141
gnome-remote-desktop.spec
Normal file
141
gnome-remote-desktop.spec
Normal file
@ -0,0 +1,141 @@
|
||||
%global systemd_unit gnome-remote-desktop.service
|
||||
|
||||
Name: gnome-remote-desktop
|
||||
Version: 0.1.8
|
||||
Release: 3%{?dist}
|
||||
Summary: GNOME Remote Desktop screen share service
|
||||
|
||||
License: GPLv2+
|
||||
URL: https://gitlab.gnome.org/jadahl/gnome-remote-desktop
|
||||
Source0: https://gitlab.gnome.org/jadahl/gnome-remote-desktop/uploads/20e4965351cdbd8dc32ff9801e884b91/gnome-remote-desktop-0.1.8.tar.xz
|
||||
|
||||
# Fix black screen on Wayland
|
||||
Patch1: 0001-vnc-pipewire-stream-Handle-stride-mismatch.patch
|
||||
|
||||
# Anon TLS encryption support
|
||||
Patch2: anon-tls-support.patch
|
||||
|
||||
# Don't crash on metadata only buffers (#1847062)
|
||||
Patch3: 0001-stream-log-a-warning-on-error.patch
|
||||
Patch4: 0002-vnc-pipewire-stream-Only-try-to-copy-frame-pixels-if.patch
|
||||
Patch5: 0001-vnc-pipewire-stream-Remove-assert.patch
|
||||
|
||||
# Cursor only frame fixes (#1837406)
|
||||
Patch6: cursor-only-frame-fixes.patch
|
||||
|
||||
BuildRequires: git
|
||||
BuildRequires: gcc
|
||||
BuildRequires: meson >= 0.36.0
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: pkgconfig(glib-2.0) >= 2.32
|
||||
BuildRequires: pkgconfig(gio-unix-2.0) >= 2.32
|
||||
BuildRequires: pkgconfig(libpipewire-0.3) >= 0.3.4
|
||||
BuildRequires: pkgconfig(libvncserver) >= 0.9.11-7
|
||||
BuildRequires: pkgconfig(libsecret-1)
|
||||
BuildRequires: pkgconfig(libnotify)
|
||||
BuildRequires: pkgconfig(gnutls)
|
||||
BuildRequires: python3-devel
|
||||
|
||||
%{?systemd_requires}
|
||||
BuildRequires: systemd
|
||||
|
||||
Requires: pipewire >= 0.3.4
|
||||
|
||||
%description
|
||||
GNOME Remote Desktop is a remote desktop and screen sharing service for the
|
||||
GNOME desktop environment.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -S git
|
||||
|
||||
|
||||
%build
|
||||
%meson
|
||||
%meson_build
|
||||
|
||||
|
||||
%install
|
||||
%meson_install
|
||||
|
||||
|
||||
%post
|
||||
%systemd_user_post %{systemd_unit}
|
||||
|
||||
|
||||
%preun
|
||||
%systemd_user_preun %{systemd_unit}
|
||||
|
||||
|
||||
%postun
|
||||
%systemd_user_postun_with_restart %{systemd_unit}
|
||||
|
||||
|
||||
%files
|
||||
%license COPYING
|
||||
%doc README
|
||||
%{_libexecdir}/gnome-remote-desktop-daemon
|
||||
%{_userunitdir}/gnome-remote-desktop.service
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.desktop.remote-desktop.gschema.xml
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.desktop.remote-desktop.enums.xml
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jul 15 2020 Jonas Ådahl <jadahl@redhat.com> - 0.1.8-3
|
||||
- Backport cursor only frame fixes
|
||||
Related: #1837406
|
||||
|
||||
* Thu Jun 18 2020 Jonas Ådahl <jadahl@redhat.com> - 0.1.8-2
|
||||
- Don't crash on metadata only buffers
|
||||
Resolves: #1847062
|
||||
|
||||
* Wed May 20 2020 Jonas Ådahl <jadahl@redhat.com> - 0.1.8-1
|
||||
- Rebase to 0.1.8
|
||||
Resolves: #1837406
|
||||
|
||||
* Wed Nov 27 2019 Jonas Ådahl <jadahl@redhat.com> - 0.1.6-8
|
||||
- Update patch to handle older libvncserver at build time
|
||||
Resolves: #1684729
|
||||
|
||||
* Wed Nov 27 2019 Jonas Ådahl <jadahl@redhat.com> - 0.1.6-7
|
||||
- Handle auth settings changes
|
||||
Resolves: #1684729
|
||||
|
||||
* Wed Nov 27 2019 Jonas Ådahl <jadahl@redhat.com> - 0.1.6-6
|
||||
- Fix initial black content issue
|
||||
Resolves: #1765448
|
||||
|
||||
* Thu May 30 2019 Tomáš Popela <tpopela@redhat.com> - 0.1.6-5
|
||||
- Bump the version to make gating happy - that's bug 1681618
|
||||
- Resolves: rhbz#1713330
|
||||
|
||||
* Fri May 24 2019 Jonas Ådahl <jadahl@redhat.com> - 0.1.6-4
|
||||
- Backport password override test helper (rhbz#1713330)
|
||||
|
||||
* Thu Jan 3 2019 Jonas Ådahl <jadahl@redhat.com> - 0.1.6-3
|
||||
- Backport various fixes (rhbz#1659118)
|
||||
|
||||
* Mon Oct 1 2018 Jonas Ådahl <jadahl@redhat.com> - 0.1.6-2
|
||||
- Don't crash when PipeWire disconnects (rhbz#1627469)
|
||||
|
||||
* Tue Aug 7 2018 Jonas Ådahl <jadahl@redhat.com> - 0.1.6
|
||||
- Update to 0.1.6
|
||||
- Apply ANON-TLS patch
|
||||
- Depend on pipewire 0.2.2
|
||||
|
||||
* Tue Aug 29 2017 Jonas Ådahl <jadahl@redhat.com> - 0.1.2-3
|
||||
- Use %%autosetup
|
||||
- Install licence file
|
||||
|
||||
* Tue Aug 22 2017 Jonas Ådahl <jadahl@redhat.com> - 0.1.2-2
|
||||
- Remove gschema compilation step as that had been deprecated
|
||||
|
||||
* Mon Aug 21 2017 Jonas Ådahl <jadahl@redhat.com> - 0.1.2-1
|
||||
- Update to 0.1.2
|
||||
- Changed tabs to spaces
|
||||
- Added systemd user macros
|
||||
- Install to correct systemd user unit directory
|
||||
- Compile gsettings schemas after install and uninstall
|
||||
|
||||
* Mon Aug 21 2017 Jonas Ådahl <jadahl@redhat.com> - 0.1.1-1
|
||||
- First packaged version
|
Loading…
Reference in New Issue
Block a user