Update to 3.1.1

This commit is contained in:
Bastien Nocera 2011-07-01 15:34:44 +01:00
parent 0c1fb5f52d
commit 3e7332b848
6 changed files with 11 additions and 102 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/gnome-online-accounts-3.1.0.tar.bz2
/gnome-online-accounts-3.1.1.tar.xz

View File

@ -1,35 +0,0 @@
From 0a2bf065882fa3bf823a2483c6b6f93195a08922 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Mon, 13 Jun 2011 16:31:11 +0100
Subject: [PATCH] Don't version the panel plugin
---
src/panel/Makefile.am | 6 ++++--
1 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/src/panel/Makefile.am b/src/panel/Makefile.am
index 4383b3d..2de2865 100644
--- a/src/panel/Makefile.am
+++ b/src/panel/Makefile.am
@@ -30,14 +30,16 @@ libgoa_panel_la_CFLAGS = \
$(GNOME_CONTROL_CENTER_CFLAGS) \
$(NULL)
-libgoa_panel_la_LDFLAGS = \
- `pkg-config --libs webkitgtk-3.0` \
+libgoa_panel_la_LDFLAGS = \
+ -avoid-version -no-undefined \
+ -export-symbols-regex '^g_io_module_(load|unload)'
$(NULL)
libgoa_panel_la_LIBADD = \
$(GLIB_LIBS) \
$(GTK_LIBS) \
$(GNOME_CONTROL_CENTER_LIBS) \
+ $(WEBKITGTK_LIBS) \
$(top_builddir)/src/goa/libgoa-1.0.la \
$(top_builddir)/src/goabackend/libgoa-backend-1.0.la \
$(NULL)
--
1.7.5.4

View File

@ -1,25 +0,0 @@
From 8533fa59904527b942365f8c07984c332619ee7a Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Mon, 13 Jun 2011 18:36:13 +0100
Subject: [PATCH] Fix .desktop file's validity
---
data/goa-prefs.desktop.in | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/data/goa-prefs.desktop.in b/data/goa-prefs.desktop.in
index 1a72c4f..78fe531 100644
--- a/data/goa-prefs.desktop.in
+++ b/data/goa-prefs.desktop.in
@@ -5,7 +5,7 @@ Icon=goa-panel
Exec=gnome-control-center goa
Terminal=false
Type=Application
-Categories=Settings;X-GNOME-Settings-Panel;X-GNOME-PersonalSettings
+Categories=Settings;X-GNOME-Settings-Panel;X-GNOME-PersonalSettings;
StartupNotify=true
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=goa
--
1.7.5.4

View File

@ -1,25 +0,0 @@
From 73f48d4e296d131e2944b909bc961942fd5ac447 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Tue, 14 Jun 2011 10:05:17 +0100
Subject: [PATCH] Fix panel UI file loading
---
src/panel/goapanel.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/src/panel/goapanel.c b/src/panel/goapanel.c
index 005e6d4..9dfc0a3 100644
--- a/src/panel/goapanel.c
+++ b/src/panel/goapanel.c
@@ -104,7 +104,7 @@ goa_panel_init (GoaPanel *panel)
panel->builder = gtk_builder_new ();
error = NULL;
if (gtk_builder_add_from_file (panel->builder,
- PACKAGE_DATA_DIR "/goa/goapanel.ui",
+ PACKAGE_DATA_DIR "/gnome-online-accounts/goapanel.ui",
&error) == 0)
{
goa_warning ("Error loading UI file: %s (%s, %d)",
--
1.7.5.4

View File

@ -1,23 +1,20 @@
Name: gnome-online-accounts
Version: 3.1.0
Release: 3%{?dist}
Version: 3.1.1
Release: 1%{?dist}
Summary: Provide online accounts information
Group: System Environment/Libraries
License: LGPLv2+
URL: http://people.freedesktop.org/~david/gnome-online-accounts-3.1.0/
Source0: http://people.freedesktop.org/~david/%{name}-%{version}.tar.bz2
Source0: http://people.freedesktop.org/~david/%{name}-%{version}.tar.xz
BuildRequires: gtk3-devel glib2-devel
BuildRequires: control-center-devel gobject-introspection-devel
BuildRequires: gnome-common automake autoconf libtool intltool
BuildRequires: gobject-introspection-devel
BuildRequires: gtk-doc
BuildRequires: webkitgtk3-devel json-glib-devel libgnome-keyring-devel
BuildRequires: libnotify-devel rest-devel
Patch0: 0001-Don-t-version-the-panel-plugin.patch
Patch1: 0001-Fix-.desktop-file-s-validity.patch
Patch2: 0001-Fix-panel-UI-file-loading.patch
# For autoreconf, if needed
# BuildRequires: gnome-common automake autoconf libtool intltool
%description
gnome-online-accounts provides interfaces so applications and
@ -36,16 +33,11 @@ files for developing applications that use gnome-online-accounts.
%prep
%setup -q
%patch0 -p1 -b .version
%patch1 -p1 -b .desktop
%patch2 -p1 -b .ui-file
autoreconf -f
%build
%configure --disable-static --enable-gtk-doc
make %{?_smp_mflags}
%install
make install DESTDIR=$RPM_BUILD_ROOT
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la $RPM_BUILD_ROOT/%{_libdir}/control-center-1/panels/*.la
@ -67,14 +59,12 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%files
%defattr(-,root,root,-)
%doc NEWS COPYING
%{_libdir}/control-center-1/panels/libgoa-panel.so
%{_libdir}/girepository-1.0/Goa-1.0.typelib
%{_libdir}/libgoa-1.0.so.0
%{_libdir}/libgoa-1.0.so.0.0.0
%{_libdir}/libgoa-backend-1.0.so.0
%{_libdir}/libgoa-backend-1.0.so.0.0.0
%{_prefix}/libexec/goa-daemon
%{_datadir}/applications/goa-prefs.desktop
%{_datadir}/dbus-1/services/org.gnome.OnlineAccounts.service
%{_datadir}/gnome-online-accounts/goapanel.ui
%{_datadir}/icons/hicolor/*/apps/goa-*.png
@ -91,6 +81,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_datadir}/gtk-doc/html/goa/
%changelog
* Fri Jul 01 2011 Bastien Nocera <bnocera@redhat.com> 3.1.1-1
- Update to 3.1.1
* Tue Jun 14 2011 Bastien Nocera <bnocera@redhat.com> 3.1.0-3
- Add more necessary patches

View File

@ -1 +1 @@
a98926706647d142175a0bcaf0e40fe9 gnome-online-accounts-3.1.0.tar.bz2
abbbbb5d05a58b18d5d1108ddf06ffb7 gnome-online-accounts-3.1.1.tar.xz