Update to new webkitgtk-2.1.90 API
This commit is contained in:
parent
7760426d1f
commit
18de632739
67
0001-Update-to-new-webkitgtk-2.1.90-API.patch
Normal file
67
0001-Update-to-new-webkitgtk-2.1.90-API.patch
Normal file
@ -0,0 +1,67 @@
|
||||
From f5119db95aab7e97a30aca646833bcd72d4ba51f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Se=C3=A1n=20de=20B=C3=BArca?= <leftmostcat@gmail.com>
|
||||
Date: Wed, 28 Aug 2013 11:02:30 -0600
|
||||
Subject: [PATCH] Update to new webkitgtk-2.1.90 API
|
||||
|
||||
Fixes: https://bugzilla.gnome.org/707006
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
src/goabackend/goaflickrprovider.c | 4 ++--
|
||||
src/goabackend/goagoogleprovider.c | 6 +++---
|
||||
3 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index bb7bb11..436a96a 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -91,7 +91,7 @@ PKG_CHECK_MODULES(GTK, [gtk+-3.0 >= 3.5.1])
|
||||
AC_SUBST(GTK_CFLAGS)
|
||||
AC_SUBST(GTK_LIBS)
|
||||
|
||||
-PKG_CHECK_MODULES(WEBKIT_GTK, [webkitgtk-3.0])
|
||||
+PKG_CHECK_MODULES(WEBKIT_GTK, [webkitgtk-3.0 >= 2.1.90])
|
||||
AC_SUBST(WEBKIT_GTK_CFLAGS)
|
||||
AC_SUBST(WEBKIT_GTK_LIBS)
|
||||
|
||||
diff --git a/src/goabackend/goaflickrprovider.c b/src/goabackend/goaflickrprovider.c
|
||||
index 66396ba..7505482 100644
|
||||
--- a/src/goabackend/goaflickrprovider.c
|
||||
+++ b/src/goabackend/goaflickrprovider.c
|
||||
@@ -285,8 +285,8 @@ is_deny_node (GoaOAuthProvider *provider, WebKitDOMNode *node)
|
||||
if (!WEBKIT_DOM_IS_HTML_ANCHOR_ELEMENT (node))
|
||||
goto out;
|
||||
|
||||
- element = WEBKIT_DOM_HTML_ELEMENT (node);
|
||||
- id = webkit_dom_html_element_get_id (element);
|
||||
+ element = WEBKIT_DOM_ELEMENT (node);
|
||||
+ id = webkit_dom_element_get_id (element);
|
||||
if (g_strcmp0 (id, "auth-disallow") != 0)
|
||||
goto out;
|
||||
|
||||
diff --git a/src/goabackend/goagoogleprovider.c b/src/goabackend/goagoogleprovider.c
|
||||
index ef28cf6..cee9d96 100644
|
||||
--- a/src/goabackend/goagoogleprovider.c
|
||||
+++ b/src/goabackend/goagoogleprovider.c
|
||||
@@ -270,8 +270,8 @@ is_deny_node (GoaOAuth2Provider *provider, WebKitDOMNode *node)
|
||||
if (!WEBKIT_DOM_IS_HTML_BUTTON_ELEMENT (node))
|
||||
goto out;
|
||||
|
||||
- element = WEBKIT_DOM_HTML_ELEMENT (node);
|
||||
- id = webkit_dom_html_element_get_id (element);
|
||||
+ element = WEBKIT_DOM_ELEMENT (node);
|
||||
+ id = webkit_dom_element_get_id (element);
|
||||
if (g_strcmp0 (id, "submit_deny_access") != 0)
|
||||
goto out;
|
||||
|
||||
@@ -300,7 +300,7 @@ is_identity_node (GoaOAuth2Provider *provider, WebKitDOMHTMLInputElement *elemen
|
||||
if (g_strcmp0 (element_type, "email") != 0)
|
||||
goto out;
|
||||
|
||||
- id = webkit_dom_html_element_get_id (WEBKIT_DOM_HTML_ELEMENT (element));
|
||||
+ id = webkit_dom_element_get_id (WEBKIT_DOM_ELEMENT (element));
|
||||
if (g_strcmp0 (id, "Email") != 0)
|
||||
goto out;
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,12 +1,13 @@
|
||||
Name: gnome-online-accounts
|
||||
Version: 3.9.90
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Single sign-on framework for GNOME
|
||||
|
||||
Group: System Environment/Libraries
|
||||
License: LGPLv2+
|
||||
URL: https://live.gnome.org/GnomeOnlineAccounts
|
||||
Source0: http://download.gnome.org/sources/gnome-online-accounts/3.9/%{name}-%{version}.tar.xz
|
||||
Patch0: 0001-Update-to-new-webkitgtk-2.1.90-API.patch
|
||||
|
||||
BuildRequires: gcr-devel
|
||||
BuildRequires: glib2-devel >= 2.35
|
||||
@ -41,6 +42,7 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .webkitgtk-2.1.90
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -112,6 +114,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_libdir}/goa-1.0/include
|
||||
|
||||
%changelog
|
||||
* Thu Aug 29 2013 Kalev Lember <kalevlember@gmail.com> - 3.9.90-2
|
||||
- Update to new webkitgtk-2.1.90 API
|
||||
|
||||
* Thu Aug 22 2013 Debarshi Ray <rishi@fedoraproject.org> - 3.9.90-1
|
||||
- Update to 3.9.90
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user