Fix typos in last patch
This commit is contained in:
parent
1c506c5e9a
commit
c93b840f9c
@ -1,4 +1,4 @@
|
||||
From 75e759aa88e75d55b956bd531509306f50e6fcc2 Mon Sep 17 00:00:00 2001
|
||||
From c99306e0efcf3113d592bc963b4dfac6504b724d Mon Sep 17 00:00:00 2001
|
||||
From: Ray Strode <rstrode@redhat.com>
|
||||
Date: Thu, 15 Apr 2021 14:43:17 -0400
|
||||
Subject: [PATCH 4/4] wip! Better support libxklavier
|
||||
@ -12,10 +12,10 @@ stays in sync with X server state.
|
||||
compositor/kiosk-input-source-group.c | 17 +
|
||||
compositor/kiosk-input-source-group.h | 5 +-
|
||||
compositor/kiosk-input-sources-manager.c | 142 ++++++
|
||||
compositor/kiosk-x-keyboard-manager.c | 578 +++++++++++++++++++++++
|
||||
compositor/kiosk-x-keyboard-manager.c | 579 +++++++++++++++++++++++
|
||||
compositor/kiosk-x-keyboard-manager.h | 22 +
|
||||
meson.build | 1 +
|
||||
6 files changed, 764 insertions(+), 1 deletion(-)
|
||||
6 files changed, 765 insertions(+), 1 deletion(-)
|
||||
create mode 100644 compositor/kiosk-x-keyboard-manager.c
|
||||
create mode 100644 compositor/kiosk-x-keyboard-manager.h
|
||||
|
||||
@ -566,10 +566,10 @@ index 4b4ef62..c6c8c91 100644
|
||||
}
|
||||
diff --git a/compositor/kiosk-x-keyboard-manager.c b/compositor/kiosk-x-keyboard-manager.c
|
||||
new file mode 100644
|
||||
index 0000000..23c3de3
|
||||
index 0000000..d5c64fb
|
||||
--- /dev/null
|
||||
+++ b/compositor/kiosk-x-keyboard-manager.c
|
||||
@@ -0,0 +1,578 @@
|
||||
@@ -0,0 +1,579 @@
|
||||
+#include "config.h"
|
||||
+#include "kiosk-x-keyboard-manager.h"
|
||||
+
|
||||
@ -777,13 +777,13 @@ index 0000000..23c3de3
|
||||
+static void
|
||||
+kiosk_x_keyboard_manager_disallow_layout_selection (KioskXKeyboardManager *self)
|
||||
+{
|
||||
+ self->disallow_layout_selection = FALSE;
|
||||
+ self->disallow_layout_selection = TRUE;
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
+kiosk_x_keyboard_manager_allow_layout_selection (KioskXKeyboardManager *self)
|
||||
+{
|
||||
+ self->disallow_layout_selection = TRUE;
|
||||
+ self->disallow_layout_selection = FALSE;
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
@ -855,6 +855,8 @@ index 0000000..23c3de3
|
||||
+ OPTIONS
|
||||
+ } property_value_index;
|
||||
+
|
||||
+ kiosk_x_keyboard_manager_allow_layout_selection (self);
|
||||
+
|
||||
+ g_debug ("KioskXKeyboardManager: Reading active keyboard layouts from X server");
|
||||
+
|
||||
+ status = XGetWindowProperty (self->x_server_display,
|
||||
@ -945,8 +947,6 @@ index 0000000..23c3de3
|
||||
+ kiosk_x_keyboard_manager_read_current_layout_index (self);
|
||||
+ g_object_thaw_notify (G_OBJECT (self));
|
||||
+
|
||||
+ kiosk_x_keyboard_manager_allow_layout_selection (self);
|
||||
+
|
||||
+ return TRUE;
|
||||
+}
|
||||
+
|
||||
@ -995,7 +995,7 @@ index 0000000..23c3de3
|
||||
+
|
||||
+ /* We block layout index changes until we have a chance to figure out what the new layouts are
|
||||
+ */
|
||||
+ kiosk_x_keyboard_manager_diallow_layout_selection (self);
|
||||
+ kiosk_x_keyboard_manager_disallow_layout_selection (self);
|
||||
+
|
||||
+ kiosk_gobject_utils_queue_defer_callback (G_OBJECT (self),
|
||||
+ "[kiosk-input-sources-manager] on_x_server_xkb_rules_names_data_changed",
|
||||
@ -1017,6 +1017,7 @@ index 0000000..23c3de3
|
||||
+ return;
|
||||
+ }
|
||||
+ if (self->disallow_layout_selection) {
|
||||
+ g_debug ("KioskXKeyboardManager: Ignoring layout change request to group %lu", layout_index);
|
||||
+ return;
|
||||
+ }
|
||||
+ g_debug ("KioskXKeyboardManager: Approving keyboard group change to group %lu", layout_index);
|
||||
|
Loading…
Reference in New Issue
Block a user