2.20.2
This commit is contained in:
parent
32a77f6fc7
commit
b7123d7dc1
@ -1 +1 @@
|
|||||||
gnome-keyring-2.20.1.tar.bz2
|
gnome-keyring-2.20.2.tar.bz2
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- gnome-keyring-0.5.2/gnome-keyring.c.nullfix 2006-08-23 16:31:47.000000000 -0400
|
|
||||||
+++ gnome-keyring-0.5.2/gnome-keyring.c 2006-08-23 16:32:25.000000000 -0400
|
|
||||||
@@ -2483,7 +2483,7 @@
|
|
||||||
GnomeKeyringResult result;
|
|
||||||
GList *found;
|
|
||||||
|
|
||||||
- out_list = NULL;
|
|
||||||
+ *out_list = NULL;
|
|
||||||
attributes = make_attribute_list_for_network_password (user,
|
|
||||||
domain,
|
|
||||||
server,
|
|
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: A framework for managing user passwords and other secrets
|
Summary: A framework for managing user passwords and other secrets
|
||||||
Name: gnome-keyring
|
Name: gnome-keyring
|
||||||
Version: 2.20.1
|
Version: 2.20.2
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://download.gnome.org/sources/gnome-keyring/2.20/gnome-keyring-%{version}.tar.bz2
|
Source: http://download.gnome.org/sources/gnome-keyring/2.20/gnome-keyring-%{version}.tar.bz2
|
||||||
@ -111,6 +111,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 26 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.2-1
|
||||||
|
- Update to 2.20.2
|
||||||
|
|
||||||
* Sun Nov 11 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.1-4
|
* Sun Nov 11 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.1-4
|
||||||
- Don't ship a .la file (#370531)
|
- Don't ship a .la file (#370531)
|
||||||
|
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up gnome-keyring-2.19.6/daemon/gnome-keyring-daemon-ops.c.init-retval gnome-keyring-2.19.6/daemon/gnome-keyring-daemon-ops.c
|
|
||||||
--- gnome-keyring-2.19.6/daemon/gnome-keyring-daemon-ops.c.init-retval 2007-07-30 13:26:41.000000000 -0400
|
|
||||||
+++ gnome-keyring-2.19.6/daemon/gnome-keyring-daemon-ops.c 2007-07-30 13:27:12.000000000 -0400
|
|
||||||
@@ -1495,7 +1495,7 @@ op_get_item_info (GkrBuffer *packet, Gkr
|
|
||||||
GkrKeyringItem *item;
|
|
||||||
GnomeKeyringOpCode opcode;
|
|
||||||
guint32 item_id, flags;
|
|
||||||
- gboolean ret;
|
|
||||||
+ gboolean ret = TRUE;
|
|
||||||
GnomeKeyringResult res;
|
|
||||||
|
|
||||||
if (!gnome_keyring_proto_decode_get_item_info (packet, &opcode, &keyring_name,
|
|
37
pam.patch
37
pam.patch
@ -1,37 +0,0 @@
|
|||||||
diff -up gnome-keyring-2.19.6.1/configure.in.pam gnome-keyring-2.19.6.1/configure.in
|
|
||||||
--- gnome-keyring-2.19.6.1/configure.in.pam 2007-07-30 13:41:08.000000000 -0400
|
|
||||||
+++ gnome-keyring-2.19.6.1/configure.in 2007-07-30 20:15:38.000000000 -0400
|
|
||||||
@@ -231,25 +231,20 @@ AC_ARG_ENABLE(pam,
|
|
||||||
AC_HELP_STRING([--disable-pam],
|
|
||||||
[Build GNOME keyring PAM helper]))
|
|
||||||
|
|
||||||
+
|
|
||||||
if test "$enable_pam" != "no"; then
|
|
||||||
AC_CHECK_HEADER(security/pam_modules.h, have_pam=yes, have_pam=no)
|
|
||||||
if test "$enable_pam" = "yes" -a "$have_pam" = "no"; then
|
|
||||||
AC_MSG_ERROR(The PAM headers are missing)
|
|
||||||
fi
|
|
||||||
-
|
|
||||||
- case "$host" in
|
|
||||||
- *-redhat-linux-gnu)
|
|
||||||
- PAM_DEST_DIR="/lib/security"
|
|
||||||
- ;;
|
|
||||||
- *-*-linux*)
|
|
||||||
- PAM_DEST_DIR="\$(prefix)/../lib/security"
|
|
||||||
- ;;
|
|
||||||
- *)
|
|
||||||
- PAM_DEST_DIR="/usr/lib"
|
|
||||||
- ;;
|
|
||||||
- esac
|
|
||||||
- AC_SUBST(PAM_DEST_DIR)
|
|
||||||
fi
|
|
||||||
+
|
|
||||||
+AC_ARG_WITH([pam-dir],
|
|
||||||
+ [AC_HELP_STRING([--with-pam-dir=DIR],
|
|
||||||
+ [directory to install pam modules in])],
|
|
||||||
+ [], [with_pam_dir="/usr/lib"])
|
|
||||||
+PAM_DEST_DIR="$with_pam_dir"
|
|
||||||
+AC_SUBST(PAM_DEST_DIR)
|
|
||||||
|
|
||||||
AM_CONDITIONAL(WITH_PAM, test "$have_pam" = "yes")
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user