update pam patch
This commit is contained in:
parent
9d8571d1b2
commit
771850ea75
@ -7,6 +7,7 @@ Release: 1%{?dist}
|
|||||||
License: GPL/LGPL
|
License: GPL/LGPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://download.gnome.org/sources/gnome-keyring/2.19/gnome-keyring-%{version}.tar.bz2
|
Source: http://download.gnome.org/sources/gnome-keyring/2.19/gnome-keyring-%{version}.tar.bz2
|
||||||
|
Patch0: pam.patch
|
||||||
URL: http://www.gnome.org
|
URL: http://www.gnome.org
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: gtk2-devel >= %{gtk2_version}
|
BuildRequires: gtk2-devel >= %{gtk2_version}
|
||||||
@ -54,6 +55,7 @@ and start the keyring daemon.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n gnome-keyring-%{version}
|
%setup -q -n gnome-keyring-%{version}
|
||||||
|
%patch0 -p1 -b .pam
|
||||||
|
|
||||||
%build
|
%build
|
||||||
aclocal
|
aclocal
|
||||||
|
37
pam.patch
37
pam.patch
@ -1,31 +1,22 @@
|
|||||||
diff -up gnome-keyring-2.19.6/pam/Makefile.am.pam gnome-keyring-2.19.6/pam/Makefile.am
|
diff -up gnome-keyring-2.19.6.1/configure.in.pam gnome-keyring-2.19.6.1/configure.in
|
||||||
--- gnome-keyring-2.19.6/pam/Makefile.am.pam 2007-07-21 22:01:42.000000000 -0400
|
--- gnome-keyring-2.19.6.1/configure.in.pam 2007-07-30 13:41:08.000000000 -0400
|
||||||
+++ gnome-keyring-2.19.6/pam/Makefile.am 2007-07-27 18:31:40.000000000 -0400
|
+++ gnome-keyring-2.19.6.1/configure.in 2007-07-30 20:15:38.000000000 -0400
|
||||||
@@ -17,9 +17,10 @@ pam_gnome_keyring_la_LIBADD = \
|
@@ -231,25 +231,20 @@ AC_ARG_ENABLE(pam,
|
||||||
pam_gnome_keyring_la_LDFLAGS = -module -avoid-version
|
AC_HELP_STRING([--disable-pam],
|
||||||
|
[Build GNOME keyring PAM helper]))
|
||||||
|
|
||||||
install-pam: install
|
+
|
||||||
- cp $(DESTDIR)$(libdir)/pam_gnome_keyring.so $(PAM_DEST_DIR)/
|
if test "$enable_pam" != "no"; then
|
||||||
- $(LN_S) -f pam_gnome_keyring.so $(PAM_DEST_DIR)/pam_gnome_keyring_auth.so
|
AC_CHECK_HEADER(security/pam_modules.h, have_pam=yes, have_pam=no)
|
||||||
- $(LN_S) -f pam_gnome_keyring.so $(PAM_DEST_DIR)/pam_gnome_keyring_session.so
|
|
||||||
+ $(mkinstalldirs) $(DESTDIR)$(PAM_DEST_DIR)
|
|
||||||
+ cp $(DESTDIR)$(libdir)/pam_gnome_keyring.so $(DESTDIR)$(PAM_DEST_DIR)
|
|
||||||
+ pushd $(DESTDIR)$(PAM_DEST_DIR); $(LN_S) -f pam_gnome_keyring.so pam_gnome_keyring_auth.so; popd
|
|
||||||
+ pushd $(DESTDIR)$(PAM_DEST_DIR); $(LN_S) -f pam_gnome_keyring.so pam_gnome_keyring_session.so; popd
|
|
||||||
|
|
||||||
uninstall-pam:
|
|
||||||
rm -f $(PAM_DEST_DIR)/pam_gnome_keyring.so
|
|
||||||
diff -up gnome-keyring-2.19.6/configure.in.pam gnome-keyring-2.19.6/configure.in
|
|
||||||
--- gnome-keyring-2.19.6/configure.in.pam 2007-07-24 23:05:32.000000000 -0400
|
|
||||||
+++ gnome-keyring-2.19.6/configure.in 2007-07-27 18:31:52.000000000 -0400
|
|
||||||
@@ -236,18 +236,15 @@ if test "$enable_pam" != "no"; then
|
|
||||||
if test "$enable_pam" = "yes" -a "$have_pam" = "no"; then
|
if test "$enable_pam" = "yes" -a "$have_pam" = "no"; then
|
||||||
AC_MSG_ERROR(The PAM headers are missing)
|
AC_MSG_ERROR(The PAM headers are missing)
|
||||||
fi
|
fi
|
||||||
-
|
-
|
||||||
- case "$host" in
|
- case "$host" in
|
||||||
|
- *-redhat-linux-gnu)
|
||||||
|
- PAM_DEST_DIR="/lib/security"
|
||||||
|
- ;;
|
||||||
- *-*-linux*)
|
- *-*-linux*)
|
||||||
- # See also <configure-flags> in pam_mount.xml.
|
|
||||||
- PAM_DEST_DIR="\$(prefix)/../lib/security"
|
- PAM_DEST_DIR="\$(prefix)/../lib/security"
|
||||||
- ;;
|
- ;;
|
||||||
- *)
|
- *)
|
||||||
@ -33,8 +24,7 @@ diff -up gnome-keyring-2.19.6/configure.in.pam gnome-keyring-2.19.6/configure.in
|
|||||||
- ;;
|
- ;;
|
||||||
- esac
|
- esac
|
||||||
- AC_SUBST(PAM_DEST_DIR)
|
- AC_SUBST(PAM_DEST_DIR)
|
||||||
-fi
|
fi
|
||||||
+fi
|
|
||||||
+
|
+
|
||||||
+AC_ARG_WITH([pam-dir],
|
+AC_ARG_WITH([pam-dir],
|
||||||
+ [AC_HELP_STRING([--with-pam-dir=DIR],
|
+ [AC_HELP_STRING([--with-pam-dir=DIR],
|
||||||
@ -42,7 +32,6 @@ diff -up gnome-keyring-2.19.6/configure.in.pam gnome-keyring-2.19.6/configure.in
|
|||||||
+ [], [with_pam_dir="/usr/lib"])
|
+ [], [with_pam_dir="/usr/lib"])
|
||||||
+PAM_DEST_DIR="$with_pam_dir"
|
+PAM_DEST_DIR="$with_pam_dir"
|
||||||
+AC_SUBST(PAM_DEST_DIR)
|
+AC_SUBST(PAM_DEST_DIR)
|
||||||
+
|
|
||||||
|
|
||||||
AM_CONDITIONAL(WITH_PAM, test "$have_pam" = "yes")
|
AM_CONDITIONAL(WITH_PAM, test "$have_pam" = "yes")
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user