151 lines
5.1 KiB
Diff
151 lines
5.1 KiB
Diff
From 58251548ef5835d1c1ce464fd4e8c29d99c1b343 Mon Sep 17 00:00:00 2001
|
|
From: Ray Strode <rstrode@redhat.com>
|
|
Date: Tue, 15 Aug 2023 10:53:41 -0400
|
|
Subject: [PATCH 1/7] gnome-initial-setup: Bump GLib required version to 2.70
|
|
|
|
This gives us GStrvBuilder
|
|
---
|
|
gnome-initial-setup/meson.build | 2 +-
|
|
meson.build | 4 ++--
|
|
2 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/gnome-initial-setup/meson.build b/gnome-initial-setup/meson.build
|
|
index a6a014d1..d0ad5ff8 100644
|
|
--- a/gnome-initial-setup/meson.build
|
|
+++ b/gnome-initial-setup/meson.build
|
|
@@ -25,61 +25,61 @@ sources += [
|
|
'gis-driver.h',
|
|
'gis-keyring.h'
|
|
]
|
|
|
|
geocode_glib_2_dep = dependency(
|
|
'geocode-glib-2.0',
|
|
fallback: ['geocode-glib', 'geocode_glib_dep'],
|
|
default_options: [
|
|
'enable-gtk-doc=false',
|
|
'enable-installed-tests=false',
|
|
'enable-introspection=false',
|
|
'soup2=false',
|
|
],
|
|
)
|
|
|
|
gweather_dep = dependency('gweather4')
|
|
|
|
subdir('pages')
|
|
|
|
dependencies = [
|
|
dependency ('libnm', version: '>= 1.2'),
|
|
dependency ('libnma-gtk4', version: '>= 1.0'),
|
|
dependency ('polkit-gobject-1', version: '>= 0.103'),
|
|
dependency ('accountsservice'),
|
|
geocode_glib_2_dep,
|
|
dependency ('gnome-desktop-4'),
|
|
dependency ('gsettings-desktop-schemas', version: '>= 3.37.1'),
|
|
dependency ('fontconfig'),
|
|
dependency ('goa-1.0'),
|
|
dependency ('gtk4', version: '>= 4.6'),
|
|
- dependency ('glib-2.0', version: '>= 2.63.1'),
|
|
+ dependency ('glib-2.0', version: '>= 2.70.0'),
|
|
dependency ('gio-unix-2.0', version: '>= 2.53.0'),
|
|
dependency ('gdm', version: '>= 3.8.3'),
|
|
gweather_dep,
|
|
dependency ('libgeoclue-2.0', version: '>= 2.3.1'),
|
|
cc.find_library('m', required: false),
|
|
dependency ('pango', version: '>= 1.32.5'),
|
|
dependency ('json-glib-1.0'),
|
|
dependency ('krb5'),
|
|
dependency ('libsecret-1', version: '>= 0.18.8'),
|
|
dependency ('pwquality'),
|
|
dependency ('rest-1.0'),
|
|
ibus_dep,
|
|
libmalcontent_dep,
|
|
libmalcontent_ui_dep,
|
|
libadwaita_dep,
|
|
webkitgtk_dep
|
|
]
|
|
|
|
executable(
|
|
'gnome-initial-setup',
|
|
sources,
|
|
include_directories: config_h_dir,
|
|
dependencies: dependencies,
|
|
install: true,
|
|
install_dir: get_option('libexecdir')
|
|
)
|
|
|
|
executable(
|
|
'gnome-initial-setup-copy-worker',
|
|
['gnome-initial-setup-copy-worker.c'],
|
|
diff --git a/meson.build b/meson.build
|
|
index a1057988..28cf7998 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -3,62 +3,62 @@ project('gnome-initial-setup',
|
|
version: '45.beta',
|
|
license: 'GPL-2.0-or-later',
|
|
meson_version: '>= 0.53.0',
|
|
)
|
|
|
|
cc = meson.get_compiler('c')
|
|
gnome = import('gnome')
|
|
i18n = import('i18n')
|
|
|
|
prefix = get_option('prefix')
|
|
po_dir = join_paths(meson.current_source_dir(), 'po')
|
|
bin_dir = join_paths(prefix, get_option('bindir'))
|
|
data_dir = join_paths(prefix, get_option('datadir'))
|
|
locale_dir = join_paths(prefix, get_option('localedir'))
|
|
libexec_dir = join_paths(prefix, get_option('libexecdir'))
|
|
sysconf_dir = join_paths(prefix, get_option('sysconfdir'))
|
|
pkgdata_dir = join_paths(data_dir, meson.project_name())
|
|
pkgsysconf_dir = join_paths(sysconf_dir, meson.project_name())
|
|
|
|
conf = configuration_data()
|
|
conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
|
|
conf.set_quoted('GNOMELOCALEDIR', locale_dir)
|
|
conf.set_quoted('PKGDATADIR', pkgdata_dir)
|
|
conf.set_quoted('DATADIR', data_dir)
|
|
conf.set_quoted('PKGSYSCONFDIR', pkgsysconf_dir)
|
|
conf.set_quoted('SYSCONFDIR', sysconf_dir)
|
|
conf.set_quoted('LIBEXECDIR', libexec_dir)
|
|
conf.set('SECRET_API_SUBJECT_TO_CHANGE', true)
|
|
conf.set_quoted('G_LOG_DOMAIN', 'InitialSetup')
|
|
conf.set('G_LOG_USE_STRUCTURED', true)
|
|
-conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_2_64')
|
|
-conf.set('GLIB_VERSION_MAX_ALLOWED', 'GLIB_VERSION_2_64')
|
|
+conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_2_70')
|
|
+conf.set('GLIB_VERSION_MAX_ALLOWED', 'GLIB_VERSION_2_70')
|
|
|
|
enable_systemd = get_option('systemd')
|
|
if enable_systemd
|
|
systemd_dep = dependency('systemd', version: '>= 242', required: false)
|
|
assert(systemd_dep.found(), 'Systemd support explicitly required, but systemd not found')
|
|
|
|
systemd_userunitdir = systemd_dep.get_variable(pkgconfig: 'systemduserunitdir',
|
|
pkgconfig_define: ['prefix', prefix])
|
|
systemd_sysusersdir = systemd_dep.get_variable(pkgconfig: 'sysusersdir',
|
|
pkgconfig_define: ['prefix', prefix])
|
|
endif
|
|
|
|
vendor_conf_file = get_option('vendor-conf-file')
|
|
if vendor_conf_file != ''
|
|
conf.set_quoted('VENDOR_CONF_FILE', vendor_conf_file)
|
|
endif
|
|
|
|
# Needed for the 'keyboard' page
|
|
ibus_dep = dependency ('ibus-1.0',
|
|
version: '>= 1.4.99',
|
|
required: get_option('ibus'))
|
|
have_ibus = ibus_dep.found()
|
|
conf.set('HAVE_IBUS', have_ibus)
|
|
|
|
# Check for libadwaita before malcontent-ui, otherwise Meson may search and
|
|
# find an older version of libadwaita in the host system, cache it, and fail
|
|
# to fallback to a submodule.
|
|
libadwaita_dep = dependency(
|
|
'libadwaita-1',
|
|
version: '>= 1.2.alpha',
|
|
--
|
|
2.41.0.rc2
|
|
|