Update to 3.34.0
This commit is contained in:
parent
3349ea73d8
commit
ba6c451940
1
.gitignore
vendored
1
.gitignore
vendored
@ -64,3 +64,4 @@
|
|||||||
/gnome-initial-setup-3.33.4.tar.xz
|
/gnome-initial-setup-3.33.4.tar.xz
|
||||||
/gnome-initial-setup-3.33.91.tar.xz
|
/gnome-initial-setup-3.33.91.tar.xz
|
||||||
/gnome-initial-setup-3.33.92.tar.xz
|
/gnome-initial-setup-3.33.92.tar.xz
|
||||||
|
/gnome-initial-setup-3.34.0.tar.xz
|
||||||
|
@ -1,137 +0,0 @@
|
|||||||
From bb0b9a3763f5648ab69a7c417f8e83021539580c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Benjamin Berg <bberg@redhat.com>
|
|
||||||
Date: Wed, 4 Sep 2019 13:24:58 +0200
|
|
||||||
Subject: [PATCH 1/2] data: Always install .wants symlinks
|
|
||||||
|
|
||||||
The services should always be enabled after installation. Install the
|
|
||||||
.wants symlinks rather than relying on them being enabled by the package
|
|
||||||
post installation script or system administrator.
|
|
||||||
---
|
|
||||||
...gnome-initial-setup-copy-worker.service.in | 3 --
|
|
||||||
...gnome-initial-setup-first-login.service.in | 3 --
|
|
||||||
data/gnome-initial-setup.service.in | 3 --
|
|
||||||
data/gnome-welcome-tour.service.in | 3 --
|
|
||||||
data/meson-add-wants.sh | 30 +++++++++++++++++++
|
|
||||||
data/meson.build | 18 ++++++-----
|
|
||||||
6 files changed, 41 insertions(+), 19 deletions(-)
|
|
||||||
create mode 100755 data/meson-add-wants.sh
|
|
||||||
|
|
||||||
diff --git a/data/gnome-initial-setup-copy-worker.service.in b/data/gnome-initial-setup-copy-worker.service.in
|
|
||||||
index df43c39..9b411d0 100644
|
|
||||||
--- a/data/gnome-initial-setup-copy-worker.service.in
|
|
||||||
+++ b/data/gnome-initial-setup-copy-worker.service.in
|
|
||||||
@@ -10,6 +10,3 @@ ConditionPathExists=!%E/gnome-initial-setup-done
|
|
||||||
Type=simple
|
|
||||||
ExecStart=@libexecdir@/gnome-initial-setup-copy-worker
|
|
||||||
Restart=no
|
|
||||||
-
|
|
||||||
-[Install]
|
|
||||||
-WantedBy=gnome-session.target
|
|
||||||
diff --git a/data/gnome-initial-setup-first-login.service.in b/data/gnome-initial-setup-first-login.service.in
|
|
||||||
index 7c7f50d..302753b 100644
|
|
||||||
--- a/data/gnome-initial-setup-first-login.service.in
|
|
||||||
+++ b/data/gnome-initial-setup-first-login.service.in
|
|
||||||
@@ -14,6 +14,3 @@ ConditionPathExists=!%E/gnome-initial-setup-done
|
|
||||||
Type=oneshot
|
|
||||||
ExecStart=@libexecdir@/gnome-initial-setup --existing-user
|
|
||||||
Restart=no
|
|
||||||
-
|
|
||||||
-[Install]
|
|
||||||
-WantedBy=gnome-session.target
|
|
||||||
diff --git a/data/gnome-initial-setup.service.in b/data/gnome-initial-setup.service.in
|
|
||||||
index ea91d69..bb0af2e 100644
|
|
||||||
--- a/data/gnome-initial-setup.service.in
|
|
||||||
+++ b/data/gnome-initial-setup.service.in
|
|
||||||
@@ -11,6 +11,3 @@ Type=simple
|
|
||||||
ExecStart=@libexecdir@/gnome-initial-setup
|
|
||||||
ExecStopPost=-@libexecdir@/gnome-session-ctl --shutdown
|
|
||||||
Restart=no
|
|
||||||
-
|
|
||||||
-[Install]
|
|
||||||
-WantedBy=gnome-session@gnome-initial-setup.target
|
|
||||||
diff --git a/data/gnome-welcome-tour.service.in b/data/gnome-welcome-tour.service.in
|
|
||||||
index 2315540..d958630 100644
|
|
||||||
--- a/data/gnome-welcome-tour.service.in
|
|
||||||
+++ b/data/gnome-welcome-tour.service.in
|
|
||||||
@@ -10,6 +10,3 @@ ConditionPathExists=%E/run-welcome-tour
|
|
||||||
Type=simple
|
|
||||||
ExecStart=@libexecdir@/gnome-welcome-tour
|
|
||||||
Restart=no
|
|
||||||
-
|
|
||||||
-[Install]
|
|
||||||
-WantedBy=gnome-session.target
|
|
||||||
diff --git a/data/meson-add-wants.sh b/data/meson-add-wants.sh
|
|
||||||
new file mode 100755
|
|
||||||
index 0000000..c33d1b4
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/data/meson-add-wants.sh
|
|
||||||
@@ -0,0 +1,30 @@
|
|
||||||
+#!/bin/sh
|
|
||||||
+set -eu
|
|
||||||
+
|
|
||||||
+# Script copied from systemd
|
|
||||||
+
|
|
||||||
+unitdir="$1"
|
|
||||||
+target="$2"
|
|
||||||
+unit="$3"
|
|
||||||
+
|
|
||||||
+case "$target" in
|
|
||||||
+ */?*) # a path, but not just a slash at the end
|
|
||||||
+ dir="${DESTDIR:-}${target}"
|
|
||||||
+ ;;
|
|
||||||
+ *)
|
|
||||||
+ dir="${DESTDIR:-}${unitdir}/${target}"
|
|
||||||
+ ;;
|
|
||||||
+esac
|
|
||||||
+
|
|
||||||
+unitpath="${DESTDIR:-}${unitdir}/${unit}"
|
|
||||||
+
|
|
||||||
+case "$target" in
|
|
||||||
+ */)
|
|
||||||
+ mkdir -vp -m 0755 "$dir"
|
|
||||||
+ ;;
|
|
||||||
+ *)
|
|
||||||
+ mkdir -vp -m 0755 "$(dirname "$dir")"
|
|
||||||
+ ;;
|
|
||||||
+esac
|
|
||||||
+
|
|
||||||
+ln -vfs --relative "$unitpath" "$dir"
|
|
||||||
diff --git a/data/meson.build b/data/meson.build
|
|
||||||
index 9aa79bf..19e3643 100644
|
|
||||||
--- a/data/meson.build
|
|
||||||
+++ b/data/meson.build
|
|
||||||
@@ -42,20 +42,24 @@ if enable_systemd
|
|
||||||
unitconf = configuration_data()
|
|
||||||
unitconf.set('libexecdir', libexec_dir)
|
|
||||||
|
|
||||||
- unit_files = [
|
|
||||||
- 'gnome-initial-setup.service',
|
|
||||||
- 'gnome-initial-setup-first-login.service',
|
|
||||||
- 'gnome-initial-setup-copy-worker.service',
|
|
||||||
- 'gnome-welcome-tour.service'
|
|
||||||
- ]
|
|
||||||
+ unit_files = {
|
|
||||||
+ 'gnome-initial-setup.service' : [ 'gnome-session@gnome-initial-setup.target.wants/' ],
|
|
||||||
+ 'gnome-initial-setup-first-login.service' : [ 'gnome-session.target.wants/' ],
|
|
||||||
+ 'gnome-initial-setup-copy-worker.service' : [ 'gnome-session.target.wants/' ],
|
|
||||||
+ 'gnome-welcome-tour.service' : [ 'gnome-session.target.wants/' ],
|
|
||||||
+ }
|
|
||||||
|
|
||||||
- foreach unit: unit_files
|
|
||||||
+ foreach unit, wants: unit_files
|
|
||||||
configure_file(
|
|
||||||
input: unit + '.in',
|
|
||||||
output: unit,
|
|
||||||
configuration: unitconf,
|
|
||||||
install_dir: systemd_userunitdir
|
|
||||||
)
|
|
||||||
+
|
|
||||||
+ foreach target: wants
|
|
||||||
+ meson.add_install_script('meson-add-wants.sh', systemd_userunitdir, target, unit)
|
|
||||||
+ endforeach
|
|
||||||
endforeach
|
|
||||||
endif
|
|
||||||
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
@ -1,25 +0,0 @@
|
|||||||
From a1308201e22578d0522d77caa3dbe4043b6e2952 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Benjamin Berg <bberg@redhat.com>
|
|
||||||
Date: Wed, 4 Sep 2019 11:50:56 +0200
|
|
||||||
Subject: [PATCH 2/2] data: Flag gnome-initial-setup.desktop as being systemd
|
|
||||||
managed
|
|
||||||
|
|
||||||
When using systemd to manage the gnome-session, gnome-initial-setup will
|
|
||||||
be launched that way. So set the appropriate flag so that gnome-session
|
|
||||||
will not try to launch the service itself.
|
|
||||||
---
|
|
||||||
data/gnome-initial-setup.desktop.in.in | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/data/gnome-initial-setup.desktop.in.in b/data/gnome-initial-setup.desktop.in.in
|
|
||||||
index 6db7765..cad2fe7 100644
|
|
||||||
--- a/data/gnome-initial-setup.desktop.in.in
|
|
||||||
+++ b/data/gnome-initial-setup.desktop.in.in
|
|
||||||
@@ -13,3 +13,4 @@ X-GNOME-Bugzilla-Bugzilla=GNOME
|
|
||||||
X-GNOME-Bugzilla-Product=gnome-initial-setup
|
|
||||||
X-GNOME-Bugzilla-Component=general
|
|
||||||
X-GNOME-Bugzilla-Version=unknown
|
|
||||||
+X-GNOME-HiddenUnderSystemd=@systemd_hidden@
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
@ -5,8 +5,8 @@
|
|||||||
%global geoclue_version 2.3.1
|
%global geoclue_version 2.3.1
|
||||||
|
|
||||||
Name: gnome-initial-setup
|
Name: gnome-initial-setup
|
||||||
Version: 3.33.92
|
Version: 3.34.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Bootstrapping your OS
|
Summary: Bootstrapping your OS
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -15,9 +15,6 @@ Source0: https://download.gnome.org/sources/%{name}/3.30/%{name}-%{versio
|
|||||||
Source1: vendor.conf
|
Source1: vendor.conf
|
||||||
Patch0: honor-firstboot-disabled.patch
|
Patch0: honor-firstboot-disabled.patch
|
||||||
|
|
||||||
Patch10: 0001-data-Always-install-.wants-symlinks.patch
|
|
||||||
Patch11: 0002-data-Flag-gnome-initial-setup.desktop-as-being-syste.patch
|
|
||||||
|
|
||||||
BuildRequires: meson
|
BuildRequires: meson
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: git
|
BuildRequires: git
|
||||||
@ -112,6 +109,9 @@ useradd -rM -d /run/gnome-initial-setup/ -s /sbin/nologin %{name} &>/dev/null ||
|
|||||||
%{_datadir}/gnome-initial-setup/vendor.conf
|
%{_datadir}/gnome-initial-setup/vendor.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 09 2019 Kalev Lember <klember@redhat.com> - 3.34.0-1
|
||||||
|
- Update to 3.34.0
|
||||||
|
|
||||||
* Wed Sep 04 2019 Benjamin Berg <bberg@redhat.com> - 3.33.92-2
|
* Wed Sep 04 2019 Benjamin Berg <bberg@redhat.com> - 3.33.92-2
|
||||||
- Include upstream patches to fix systemd support
|
- Include upstream patches to fix systemd support
|
||||||
https://gitlab.gnome.org/GNOME/gnome-initial-setup/merge_requests/58
|
https://gitlab.gnome.org/GNOME/gnome-initial-setup/merge_requests/58
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gnome-initial-setup-3.33.92.tar.xz) = 220ec72a89f233bb7706eb84d29ff6d33542f6772171549a636d81c1f568fec1de9ec2af8a6efa161d47518c65c081832ef4ac51e8ae6ad10f80717ee7247648
|
SHA512 (gnome-initial-setup-3.34.0.tar.xz) = 8274ed750deac848df10f8108f999cb174665698adecb381524a3c24ec7817060960951f7844d1f15aa2e0153fc0c9b11ce73cc02e09006da84a46af1d3e7c12
|
||||||
|
Loading…
Reference in New Issue
Block a user