Update to 3.32.0
This commit is contained in:
parent
9f4179c009
commit
9e7a4512e1
@ -5,8 +5,8 @@
|
||||
%global geoclue_version 2.3.1
|
||||
|
||||
Name: gnome-initial-setup
|
||||
Version: 3.30.0
|
||||
Release: 2%{?dist}
|
||||
Version: 3.32.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Bootstrapping your OS
|
||||
|
||||
License: GPLv2+
|
||||
@ -15,9 +15,10 @@ Source0: https://download.gnome.org/sources/%{name}/3.30/%{name}-%{versio
|
||||
Source1: vendor.conf
|
||||
Patch0: honor-firstboot-disabled.patch
|
||||
|
||||
BuildRequires: meson
|
||||
BuildRequires: git
|
||||
BuildRequires: krb5-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: intltool
|
||||
BuildRequires: libpwquality-devel
|
||||
BuildRequires: pkgconfig(libnm) >= %{nm_version}
|
||||
BuildRequires: pkgconfig(libnma) >= %{nma_version}
|
||||
@ -45,8 +46,6 @@ BuildRequires: ibus-devel
|
||||
BuildRequires: rest-devel
|
||||
BuildRequires: polkit-devel
|
||||
BuildRequires: libsecret-devel
|
||||
# Needed to run autoreconf, for patches that touch autotools bits
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: gnome-common
|
||||
|
||||
# gnome-initial-setup is being run by gdm
|
||||
@ -70,16 +69,11 @@ you through configuring it. It is integrated with gdm.
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
# patches touch am files
|
||||
autoreconf -i
|
||||
%configure \
|
||||
--enable-software-sources \
|
||||
--with-vendor-conf-file=%{_datadir}/gnome-initial-setup/vendor.conf
|
||||
make %{?_smp_mflags}
|
||||
%meson -Dsoftware-sources=enabled -Dvendor-conf-file=%{_datadir}/gnome-initial-setup/vendor.conf
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
%make_install
|
||||
find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
||||
%meson_install
|
||||
|
||||
# Desktop file does not (and probably will not) ever validate, as it uses
|
||||
# an absolute path /tmp/-style trigger to determine whether to autostart.
|
||||
@ -116,6 +110,9 @@ useradd -rM -d /run/gnome-initial-setup/ -s /sbin/nologin %{name} &>/dev/null ||
|
||||
%{_datadir}/gnome-initial-setup/vendor.conf
|
||||
|
||||
%changelog
|
||||
* Thu Apr 04 2019 Ray Strode <rstrode@redhat.com> - 3.32.0-1
|
||||
- Update to 3.32.0
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.30.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
|
@ -13,24 +13,10 @@ that but more might be added in the future.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=777707
|
||||
---
|
||||
gnome-initial-setup/Makefile.am | 3 +-
|
||||
meson.build | 2 ++
|
||||
gnome-initial-setup/gnome-initial-setup.c | 34 +++++++++++++++++++++++
|
||||
2 files changed, 36 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gnome-initial-setup/Makefile.am b/gnome-initial-setup/Makefile.am
|
||||
index 6b6d5fb..e6a3e10 100644
|
||||
--- a/gnome-initial-setup/Makefile.am
|
||||
+++ b/gnome-initial-setup/Makefile.am
|
||||
@@ -12,7 +12,8 @@ AM_CPPFLAGS = \
|
||||
-DUIDIR="\"$(uidir)\"" \
|
||||
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
|
||||
-DLIBLOCALEDIR=\""$(prefix)/lib/locale"\" \
|
||||
- -DDATADIR=\""$(datadir)"\"
|
||||
+ -DDATADIR=\""$(datadir)"\" \
|
||||
+ -DSYSCONFDIR=\""$(sysconfdir)"\"
|
||||
|
||||
libexec_PROGRAMS = gnome-initial-setup gnome-initial-setup-copy-worker
|
||||
|
||||
diff --git a/gnome-initial-setup/gnome-initial-setup.c b/gnome-initial-setup/gnome-initial-setup.c
|
||||
index 414ea94..989827b 100644
|
||||
--- a/gnome-initial-setup/gnome-initial-setup.c
|
||||
@ -86,3 +72,71 @@ index 414ea94..989827b 100644
|
||||
--
|
||||
2.19.0.rc0
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 4950bed..6e91f2b 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -1,59 +1,61 @@
|
||||
project('gnome-initial-setup',
|
||||
['c'],
|
||||
version: '3.32.0',
|
||||
license: 'GPLv2',
|
||||
meson_version: '>= 0.47.0',
|
||||
)
|
||||
|
||||
cc = meson.get_compiler('c')
|
||||
gnome = import('gnome')
|
||||
i18n = import('i18n')
|
||||
|
||||
prefix = get_option('prefix')
|
||||
po_dir = join_paths(meson.source_root(), 'po')
|
||||
+sysconf_dir = join_paths(prefix, get_option('sysconfdir'))
|
||||
data_dir = join_paths(prefix, get_option('datadir'))
|
||||
locale_dir = join_paths(prefix, get_option('localedir'))
|
||||
libexec_dir = join_paths(prefix, get_option('libexecdir'))
|
||||
source_root = join_paths(meson.source_root(), 'gnome-initial-setup')
|
||||
pkgdata_dir = join_paths(prefix, meson.project_name())
|
||||
|
||||
vendor_conf_file = get_option('vendor-conf-file')
|
||||
if vendor_conf_file == ''
|
||||
vendor_conf_file = join_paths(data_dir, 'gnome-initial-setup', 'vendor.conf')
|
||||
endif
|
||||
|
||||
conf = configuration_data()
|
||||
conf.set_quoted('VENDOR_CONF_FILE', vendor_conf_file)
|
||||
conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
|
||||
conf.set_quoted('GNOMELOCALEDIR', locale_dir)
|
||||
conf.set_quoted('PKGDATADIR', pkgdata_dir)
|
||||
+conf.set_quoted('SYSCONFDIR', sysconf_dir)
|
||||
conf.set('ENABLE_REGION_PAGE', get_option('region-page'))
|
||||
conf.set('SECRET_API_SUBJECT_TO_CHANGE', true)
|
||||
|
||||
# Needed for the 'account' page
|
||||
cheese_dep = dependency ('cheese',
|
||||
version: '>= 3.3.5',
|
||||
required: get_option('cheese'))
|
||||
cheese_gtk_dep = dependency ('cheese-gtk',
|
||||
version: '>= 3.3.5',
|
||||
required: get_option('cheese'))
|
||||
conf.set('HAVE_CHEESE', cheese_dep.found() and cheese_gtk_dep.found())
|
||||
|
||||
# Needed for the 'software' page
|
||||
pkgkit_dep = dependency ('packagekit-glib2',
|
||||
version: '>= 1.1.4',
|
||||
required: get_option('software-sources'))
|
||||
conf.set('ENABLE_SOFTWARE_SOURCES', pkgkit_dep.found())
|
||||
|
||||
# Needed for the 'keyboard' page
|
||||
ibus_dep = dependency ('ibus-1.0',
|
||||
version: '>= 1.4.99',
|
||||
required: get_option('ibus'))
|
||||
conf.set('HAVE_IBUS', ibus_dep.found())
|
||||
|
||||
configure_file(output: 'config.h',
|
||||
configuration: conf)
|
||||
config_h_dir = include_directories('.')
|
||||
|
||||
subdir('data')
|
||||
subdir('gnome-initial-setup')
|
||||
--
|
||||
2.20.1
|
||||
|
Loading…
Reference in New Issue
Block a user