Update to 3.37.92
- Drop upstreamed honor-firstboot-disabled.patch
This commit is contained in:
parent
06289d6ba0
commit
94f403a3bd
1
.gitignore
vendored
1
.gitignore
vendored
@ -78,3 +78,4 @@
|
||||
/gnome-initial-setup-3.37.3.tar.xz
|
||||
/gnome-initial-setup-3.37.91.tar.xz
|
||||
/gnome-initial-setup-3.37.91.1.tar.xz
|
||||
/gnome-initial-setup-3.37.92.tar.xz
|
||||
|
@ -5,16 +5,14 @@
|
||||
%global geoclue_version 2.3.1
|
||||
|
||||
Name: gnome-initial-setup
|
||||
Version: 3.37.91.1
|
||||
Release: 2%{?dist}
|
||||
Version: 3.37.92
|
||||
Release: 1%{?dist}
|
||||
Summary: Bootstrapping your OS
|
||||
|
||||
License: GPLv2+
|
||||
URL: https://wiki.gnome.org/Design/OS/InitialSetup
|
||||
Source0: https://download.gnome.org/sources/%{name}/3.37/%{name}-%{version}.tar.xz
|
||||
Source1: vendor.conf
|
||||
# https://gitlab.gnome.org/GNOME/gnome-initial-setup/-/merge_requests/101
|
||||
Patch0: honor-firstboot-disabled.patch
|
||||
|
||||
BuildRequires: meson
|
||||
BuildRequires: gcc
|
||||
@ -111,6 +109,10 @@ useradd -rM -d /run/gnome-initial-setup/ -s /sbin/nologin %{name} &>/dev/null ||
|
||||
%{_datadir}/gnome-initial-setup/vendor.conf
|
||||
|
||||
%changelog
|
||||
* Sun Sep 06 2020 Kalev Lember <klember@redhat.com> - 3.37.92-1
|
||||
- Update to 3.37.92
|
||||
- Drop upstreamed honor-firstboot-disabled.patch
|
||||
|
||||
* Thu Aug 27 2020 Kalev Lember <klember@redhat.com> - 3.37.91.1-2
|
||||
- Require new gnome-tour package (#1873206)
|
||||
|
||||
|
@ -1,80 +0,0 @@
|
||||
From 538a8fa09a02f682496f98bda8f4f4a5566eee86 Mon Sep 17 00:00:00 2001
|
||||
From: Rui Matos <tiagomatos@gmail.com>
|
||||
Date: Mon, 23 Jan 2017 19:42:44 +0100
|
||||
Subject: [PATCH] Exit gracefully if we are disabled systemwide
|
||||
|
||||
Sysadmins might want to disable any kind of initial setup for their
|
||||
users, perhaps because they pre-configure their environments. We
|
||||
should provide an easy way to do it.
|
||||
|
||||
At least the anaconda installer provides an option to skip any kind
|
||||
post-install setup tools so, for now we're only adding support for
|
||||
that but more might be added in the future.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=777707
|
||||
---
|
||||
gnome-initial-setup/gnome-initial-setup.c | 28 +++++++++++++++++++++++
|
||||
meson.build | 1 +
|
||||
2 files changed, 29 insertions(+)
|
||||
|
||||
diff --git a/gnome-initial-setup/gnome-initial-setup.c b/gnome-initial-setup/gnome-initial-setup.c
|
||||
index 107be55..0ab987a 100644
|
||||
--- a/gnome-initial-setup/gnome-initial-setup.c
|
||||
+++ b/gnome-initial-setup/gnome-initial-setup.c
|
||||
@@ -240,6 +240,24 @@ get_mode (void)
|
||||
return GIS_DRIVER_MODE_NEW_USER;
|
||||
}
|
||||
|
||||
+static gboolean
|
||||
+initial_setup_disabled_by_anaconda (void)
|
||||
+{
|
||||
+ const gchar *file_name = SYSCONFDIR "/sysconfig/anaconda";
|
||||
+ g_autoptr(GError) error = NULL;
|
||||
+ g_autoptr(GKeyFile) key_file = g_key_file_new ();
|
||||
+
|
||||
+ if (!g_key_file_load_from_file (key_file, file_name, G_KEY_FILE_NONE, &error)) {
|
||||
+ if (!g_error_matches (error, G_FILE_ERROR, G_FILE_ERROR_NOENT) &&
|
||||
+ !g_error_matches (error, G_KEY_FILE_ERROR, G_KEY_FILE_ERROR_NOT_FOUND)) {
|
||||
+ g_warning ("Could not read %s: %s", file_name, error->message);
|
||||
+ }
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+
|
||||
+ return g_key_file_get_boolean (key_file, "General", "post_install_tools_disabled", NULL);
|
||||
+}
|
||||
+
|
||||
int
|
||||
main (int argc, char *argv[])
|
||||
{
|
||||
@@ -289,6 +307,16 @@ main (int argc, char *argv[])
|
||||
gis_ensure_login_keyring ();
|
||||
|
||||
driver = gis_driver_new (mode);
|
||||
+
|
||||
+ /* We only do this in existing-user mode, because if gdm launches us
|
||||
+ * in new-user mode and we just exit, gdm's special g-i-s session
|
||||
+ * never terminates. */
|
||||
+ if (initial_setup_disabled_by_anaconda () &&
|
||||
+ mode == GIS_DRIVER_MODE_EXISTING_USER) {
|
||||
+ gis_ensure_stamp_files (driver);
|
||||
+ exit (EXIT_SUCCESS);
|
||||
+ }
|
||||
+
|
||||
g_signal_connect (driver, "rebuild-pages", G_CALLBACK (rebuild_pages_cb), NULL);
|
||||
status = g_application_run (G_APPLICATION (driver), argc, argv);
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 0fd952f..13986ac 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -25,6 +25,7 @@ conf.set_quoted('GNOMELOCALEDIR', locale_dir)
|
||||
conf.set_quoted('PKGDATADIR', pkgdata_dir)
|
||||
conf.set_quoted('DATADIR', data_dir)
|
||||
conf.set_quoted('PKGSYSCONFDIR', pkgsysconf_dir)
|
||||
+conf.set_quoted('SYSCONFDIR', sysconf_dir)
|
||||
conf.set('SECRET_API_SUBJECT_TO_CHANGE', true)
|
||||
conf.set_quoted('G_LOG_DOMAIN', 'InitialSetup')
|
||||
conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_2_64')
|
||||
--
|
||||
2.26.2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gnome-initial-setup-3.37.91.1.tar.xz) = a05eb6c7f588c465da9243cb080cf047bc162a4657b52162a12232fa38d27781d7590fb6442960e8d40b50b585183930ac901849d0473bd88b61e3eb62916b40
|
||||
SHA512 (gnome-initial-setup-3.37.92.tar.xz) = 2807cc226a786367a30b498bb25093016852807620e1ee762182c0079768d624bef260f36947834ec6a847a87465ca8c2310a2c780e1505c5246ec7d54411e84
|
||||
|
Loading…
Reference in New Issue
Block a user