Update to 3.32.1
This commit is contained in:
parent
f2887d7104
commit
1ed65bdb52
1
.gitignore
vendored
1
.gitignore
vendored
@ -59,3 +59,4 @@
|
|||||||
/gnome-initial-setup-3.29.92.tar.xz
|
/gnome-initial-setup-3.29.92.tar.xz
|
||||||
/gnome-initial-setup-3.30.0.tar.xz
|
/gnome-initial-setup-3.30.0.tar.xz
|
||||||
/gnome-initial-setup-3.32.0.tar.xz
|
/gnome-initial-setup-3.32.0.tar.xz
|
||||||
|
/gnome-initial-setup-3.32.1.tar.xz
|
||||||
|
@ -5,7 +5,7 @@
|
|||||||
%global geoclue_version 2.3.1
|
%global geoclue_version 2.3.1
|
||||||
|
|
||||||
Name: gnome-initial-setup
|
Name: gnome-initial-setup
|
||||||
Version: 3.32.0
|
Version: 3.32.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Bootstrapping your OS
|
Summary: Bootstrapping your OS
|
||||||
|
|
||||||
@ -110,6 +110,9 @@ useradd -rM -d /run/gnome-initial-setup/ -s /sbin/nologin %{name} &>/dev/null ||
|
|||||||
%{_datadir}/gnome-initial-setup/vendor.conf
|
%{_datadir}/gnome-initial-setup/vendor.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Apr 06 2019 Kalev Lember <klember@redhat.com> - 3.32.1-1
|
||||||
|
- Update to 3.32.1
|
||||||
|
|
||||||
* Thu Apr 04 2019 Ray Strode <rstrode@redhat.com> - 3.32.0-1
|
* Thu Apr 04 2019 Ray Strode <rstrode@redhat.com> - 3.32.0-1
|
||||||
- Update to 3.32.0
|
- Update to 3.32.0
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From cfa7925f70ec44a976f6d0426133e3b8ba589142 Mon Sep 17 00:00:00 2001
|
From 56ee7759794f8b455563f795837df256bf35c193 Mon Sep 17 00:00:00 2001
|
||||||
From: Rui Matos <tiagomatos@gmail.com>
|
From: Rui Matos <tiagomatos@gmail.com>
|
||||||
Date: Mon, 23 Jan 2017 19:42:44 +0100
|
Date: Mon, 23 Jan 2017 19:42:44 +0100
|
||||||
Subject: [PATCH] Exit gracefully if we are disabled systemwide
|
Subject: [PATCH] Exit gracefully if we are disabled systemwide
|
||||||
@ -13,15 +13,15 @@ that but more might be added in the future.
|
|||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=777707
|
https://bugzilla.gnome.org/show_bug.cgi?id=777707
|
||||||
---
|
---
|
||||||
meson.build | 2 ++
|
|
||||||
gnome-initial-setup/gnome-initial-setup.c | 34 +++++++++++++++++++++++
|
gnome-initial-setup/gnome-initial-setup.c | 34 +++++++++++++++++++++++
|
||||||
2 files changed, 36 insertions(+), 1 deletion(-)
|
meson.build | 2 ++
|
||||||
|
2 files changed, 36 insertions(+)
|
||||||
|
|
||||||
diff --git a/gnome-initial-setup/gnome-initial-setup.c b/gnome-initial-setup/gnome-initial-setup.c
|
diff --git a/gnome-initial-setup/gnome-initial-setup.c b/gnome-initial-setup/gnome-initial-setup.c
|
||||||
index 414ea94..989827b 100644
|
index e2136de..280bd53 100644
|
||||||
--- a/gnome-initial-setup/gnome-initial-setup.c
|
--- a/gnome-initial-setup/gnome-initial-setup.c
|
||||||
+++ b/gnome-initial-setup/gnome-initial-setup.c
|
+++ b/gnome-initial-setup/gnome-initial-setup.c
|
||||||
@@ -247,6 +247,31 @@ get_mode (void)
|
@@ -246,6 +246,31 @@ get_mode (void)
|
||||||
return GIS_DRIVER_MODE_NEW_USER;
|
return GIS_DRIVER_MODE_NEW_USER;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -53,7 +53,7 @@ index 414ea94..989827b 100644
|
|||||||
int
|
int
|
||||||
main (int argc, char *argv[])
|
main (int argc, char *argv[])
|
||||||
{
|
{
|
||||||
@@ -281,6 +306,15 @@ main (int argc, char *argv[])
|
@@ -280,6 +305,15 @@ main (int argc, char *argv[])
|
||||||
skipped_pages = g_ptr_array_new_with_free_func ((GDestroyNotify) gtk_widget_destroy);
|
skipped_pages = g_ptr_array_new_with_free_func ((GDestroyNotify) gtk_widget_destroy);
|
||||||
mode = get_mode ();
|
mode = get_mode ();
|
||||||
|
|
||||||
@ -69,74 +69,26 @@ index 414ea94..989827b 100644
|
|||||||
/* When we are running as the gnome-initial-setup user we
|
/* When we are running as the gnome-initial-setup user we
|
||||||
* dont have a normal user session and need to initialize
|
* dont have a normal user session and need to initialize
|
||||||
* the keyring manually so that we can pass the credentials
|
* the keyring manually so that we can pass the credentials
|
||||||
--
|
|
||||||
2.19.0.rc0
|
|
||||||
|
|
||||||
diff --git a/meson.build b/meson.build
|
diff --git a/meson.build b/meson.build
|
||||||
index 4950bed..6e91f2b 100644
|
index 7b41505..8bf84db 100644
|
||||||
--- a/meson.build
|
--- a/meson.build
|
||||||
+++ b/meson.build
|
+++ b/meson.build
|
||||||
@@ -1,59 +1,61 @@
|
@@ -11,6 +11,7 @@ i18n = import('i18n')
|
||||||
project('gnome-initial-setup',
|
|
||||||
['c'],
|
|
||||||
version: '3.32.0',
|
|
||||||
license: 'GPLv2',
|
|
||||||
meson_version: '>= 0.47.0',
|
|
||||||
)
|
|
||||||
|
|
||||||
cc = meson.get_compiler('c')
|
|
||||||
gnome = import('gnome')
|
|
||||||
i18n = import('i18n')
|
|
||||||
|
|
||||||
prefix = get_option('prefix')
|
prefix = get_option('prefix')
|
||||||
po_dir = join_paths(meson.source_root(), 'po')
|
po_dir = join_paths(meson.source_root(), 'po')
|
||||||
+sysconf_dir = join_paths(prefix, get_option('sysconfdir'))
|
+sysconf_dir = join_paths(prefix, get_option('sysconfdir'))
|
||||||
data_dir = join_paths(prefix, get_option('datadir'))
|
data_dir = join_paths(prefix, get_option('datadir'))
|
||||||
locale_dir = join_paths(prefix, get_option('localedir'))
|
locale_dir = join_paths(prefix, get_option('localedir'))
|
||||||
libexec_dir = join_paths(prefix, get_option('libexecdir'))
|
libexec_dir = join_paths(prefix, get_option('libexecdir'))
|
||||||
source_root = join_paths(meson.source_root(), 'gnome-initial-setup')
|
@@ -27,6 +28,7 @@ conf.set_quoted('VENDOR_CONF_FILE', vendor_conf_file)
|
||||||
pkgdata_dir = join_paths(prefix, meson.project_name())
|
|
||||||
|
|
||||||
vendor_conf_file = get_option('vendor-conf-file')
|
|
||||||
if vendor_conf_file == ''
|
|
||||||
vendor_conf_file = join_paths(data_dir, 'gnome-initial-setup', 'vendor.conf')
|
|
||||||
endif
|
|
||||||
|
|
||||||
conf = configuration_data()
|
|
||||||
conf.set_quoted('VENDOR_CONF_FILE', vendor_conf_file)
|
|
||||||
conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
|
conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
|
||||||
conf.set_quoted('GNOMELOCALEDIR', locale_dir)
|
conf.set_quoted('GNOMELOCALEDIR', locale_dir)
|
||||||
conf.set_quoted('PKGDATADIR', pkgdata_dir)
|
conf.set_quoted('PKGDATADIR', pkgdata_dir)
|
||||||
+conf.set_quoted('SYSCONFDIR', sysconf_dir)
|
+conf.set_quoted('SYSCONFDIR', sysconf_dir)
|
||||||
conf.set('ENABLE_REGION_PAGE', get_option('region-page'))
|
conf.set('ENABLE_REGION_PAGE', get_option('region-page'))
|
||||||
conf.set('SECRET_API_SUBJECT_TO_CHANGE', true)
|
conf.set('SECRET_API_SUBJECT_TO_CHANGE', true)
|
||||||
|
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
||||||
# Needed for the 'account' page
|
|
||||||
cheese_dep = dependency ('cheese',
|
|
||||||
version: '>= 3.3.5',
|
|
||||||
required: get_option('cheese'))
|
|
||||||
cheese_gtk_dep = dependency ('cheese-gtk',
|
|
||||||
version: '>= 3.3.5',
|
|
||||||
required: get_option('cheese'))
|
|
||||||
conf.set('HAVE_CHEESE', cheese_dep.found() and cheese_gtk_dep.found())
|
|
||||||
|
|
||||||
# Needed for the 'software' page
|
|
||||||
pkgkit_dep = dependency ('packagekit-glib2',
|
|
||||||
version: '>= 1.1.4',
|
|
||||||
required: get_option('software-sources'))
|
|
||||||
conf.set('ENABLE_SOFTWARE_SOURCES', pkgkit_dep.found())
|
|
||||||
|
|
||||||
# Needed for the 'keyboard' page
|
|
||||||
ibus_dep = dependency ('ibus-1.0',
|
|
||||||
version: '>= 1.4.99',
|
|
||||||
required: get_option('ibus'))
|
|
||||||
conf.set('HAVE_IBUS', ibus_dep.found())
|
|
||||||
|
|
||||||
configure_file(output: 'config.h',
|
|
||||||
configuration: conf)
|
|
||||||
config_h_dir = include_directories('.')
|
|
||||||
|
|
||||||
subdir('data')
|
|
||||||
subdir('gnome-initial-setup')
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gnome-initial-setup-3.32.0.tar.xz) = d5940da93d0185710aac6310af97b9b34d8349de2bf3d9c26ee71275f6cd730bac880028db0e279b771a987a00b67f43aa83301477828d687309d5125f7968bf
|
SHA512 (gnome-initial-setup-3.32.1.tar.xz) = da50473d1dac4d9adaa3bd862d9dd5eaefe30c707411b8b65765d79b584267e10b21cbd91d533baa51d616db54831db4a96581f00f7814984a53234b948d0f13
|
||||||
|
Loading…
Reference in New Issue
Block a user